Project

General

Profile

feature request #3836

Implement modifiers and modifying text for Description Elements in TaxEditor

Added by Andreas Müller almost 6 years ago. Updated 6 months ago.

Status:
Resolved
Priority:
Priority14
Category:
taxeditor
Target version:
Start date:
Due date:
% Done:

70%

Severity:
normal

Description

but not for TextData as we expect that TextData will handle modifiers with its text.

see also #3746

Only the recommended modifiers should be shown for the given feature (Feature.recommendedModifierEnumeration)


Related issues

Related to Edit - feature request #3746: Implement time period scope for description elements in TaxEditor Closed 10/30/2013
Related to Edit - feature request #3747: Check if time period is handled correctly for description elements in data portals Closed 12/18/2015
Related to Edit - feature request #8144: Check if modifiers and modifyingText is handled correctly for description elements in data portals New 12/18/2015
Related to Edit - feature request #8226: make modifiers for description elements configurable Resolved 04/08/2019
Related to Edit - feature request #8236: [DISCUSS] Should recommended modifiers also hold for DescriptionElements New 04/10/2019

Associated revisions

Revision 7dc9bbbb (diff)
Added by Katja Luther 7 months ago

ref #3836: add modifier to description elements

Revision fe4a6e83 (diff)
Added by Katja Luther 7 months ago

ref #3836: add the modifier vocabulary to the combobox

Revision 77d90448 (diff)
Added by Katja Luther 6 months ago

ref #3836: add only recommended modifiers to modifier combo

Revision 5f352a56 (diff)
Added by Katja Luther 6 months ago

ref #3836: show modifier part only if recommended modifier voc exist

Revision aef87bc3 (diff)
Added by Katja Luther 6 months ago

ref #3836: minor

Revision 77658c00 (diff)
Added by Katja Luther 6 months ago

ref #3836: minor

Revision 7ca8076a (diff)
Added by Katja Luther 6 months ago

ref #3836: show always freetext modifier field

Revision 04f8f2b1 (diff)
Added by Katja Luther 6 months ago

ref #3836: fix modifier section for stateData/statistical measurement

History

#1 Updated by Andreas Müller over 1 year ago

  • Description updated (diff)
  • Assignee changed from Cherian Mathew to Katja Luther
  • Target version changed from TaxEditor Next Major Release to Unassigned CDM tickets

#2 Updated by Andreas Müller over 1 year ago

  • Private changed from Yes to No

#3 Updated by Andreas Müller over 1 year ago

  • Related to feature request #3746: Implement time period scope for description elements in TaxEditor added

#4 Updated by Andreas Müller over 1 year ago

  • Related to feature request #3747: Check if time period is handled correctly for description elements in data portals added

#5 Updated by Andreas Kohlbecker 8 months ago

  • Subject changed from Implement modifiers and modifying text for Description Elements to Implement modifiers and modifying text for Description Elements in TaxEditor

#6 Updated by Andreas Kohlbecker 8 months ago

  • Related to feature request #8144: Check if modifiers and modifyingText is handled correctly for description elements in data portals added

#7 Updated by Andreas Müller 8 months ago

  • Target version changed from Unassigned CDM tickets to Release 5.6

As we have decided to check for old unimplemented model issues in this version I add it to current milestone. But we may discuss if this makes sense.

#8 Updated by Katja Luther 8 months ago

  • Priority changed from New to Priority14

#9 Updated by Katja Luther 7 months ago

  • Status changed from New to Resolved
  • Assignee changed from Katja Luther to Andreas Müller

This is implemented now, please review

#10 Updated by Andreas Müller 7 months ago

  • Assignee changed from Andreas Müller to Patrick Plitzner

please do first review on nightly

#11 Updated by Patrick Plitzner 7 months ago

  • Assignee changed from Patrick Plitzner to Andreas Müller

Tested on nightly:

  • Created a specimen description element and set modifier and Modifying text
  • Closed and re-opened, re-connected and everything was stored correctly
  • TextData like e.g. citation do not have modifiers

#12 Updated by Andreas Müller 6 months ago

  • Description updated (diff)
  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Katja Luther

Only the recommended modifiers should be shown for the given feature (Feature.recommendedModifierEnumeration) - sorry this requirement was missing in the initial description.

Also for some reason when editing a feature in term editor currently it is not possible to edit the recommended modifiers. Patrick, is this maybe a regression from additivity?

#13 Updated by Andreas Müller 6 months ago

We may also discuss if the modifiers should only be shown if the recommended modifier enumeration is not empty.

Also we may want to make modifers configurable (show only if switched on) as some projects may consider them as not necessary.

But these might be issues of a new ticket.

#14 Updated by Katja Luther 6 months ago

Andreas Müller wrote:

Only the recommended modifiers should be shown for the given feature (Feature.recommendedModifierEnumeration) - sorry this requirement was missing in the initial description.

Also for some reason when editing a feature in term editor currently it is not possible to edit the recommended modifiers. Patrick, is this maybe a regression from additivity?

This is only possible for categorical data and quantitative data and for these the drop down is filled with the recommended modifiers, if no recommended modifiers exist all modifiers from Vocabulary Modifier are loaded.

#15 Updated by Katja Luther 6 months ago

Andreas Müller wrote:

We may also discuss if the modifiers should only be shown if the recommended modifier enumeration is not empty.

Also we may want to make modifers configurable (show only if switched on) as some projects may consider them as not necessary.

But these might be issues of a new ticket.

created new ticket #8226

#16 Updated by Katja Luther 6 months ago

#17 Updated by Katja Luther 6 months ago

  • Status changed from Feedback to Resolved
  • Assignee changed from Katja Luther to Andreas Müller

for description elements only the recommended modifiers are shown. configurability is moved to a new ticket.

#18 Updated by Katja Luther 6 months ago

  • % Done changed from 0 to 70

#19 Updated by Andreas Müller 6 months ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Katja Luther

Katja Luther wrote:

Andreas Müller wrote:

Only the recommended modifiers should be shown for the given feature (Feature.recommendedModifierEnumeration) - sorry this requirement was missing in the initial description.

Also for some reason when editing a feature in term editor currently it is not possible to edit the recommended modifiers. Patrick, is this maybe a regression from additivity?

This is only possible for categorical data and quantitative data and for these the drop down is filled with the recommended modifiers, if no recommended modifiers exist all modifiers from Vocabulary Modifier are loaded.

Hmm, this needs to be discussed. CategoricalData and QuantitativeData have extra modifiers in StateData and StatisticalMeasurmentValue. Maybe therefore only they allow to define the recommended enumerations currently. However, for the DescriptionElements either all (except text data) or none should evaluate the enumeration.
But definetely IF we evaluate the enumeration an empty list should be handled as NO modifier available and not as All modifiers. This is because there are too many different modifier types which may not match at all.

Not sure how we handle this for this release now. We need to discuss if we need 2 different modifier enumerations for catergorical+quantitative data or if we can use the same enumeration for both places.
As we havn't really time to discuss this until release I suggeset to hide the field until we have decided. Can you open a ticket to decide how to handle the modifier enumerationsß

#20 Updated by Katja Luther 6 months ago

now the modifier section is shown only if the feature has recommended modifier voc, so it is hided for all features it is not possible to add recommended modifier vocabularies.

#21 Updated by Katja Luther 6 months ago

  • Status changed from Feedback to Resolved
  • Assignee changed from Katja Luther to Andreas Müller

#22 Updated by Andreas Müller 6 months ago

  • Related to feature request #8236: [DISCUSS] Should recommended modifiers also hold for DescriptionElements added

#23 Updated by Andreas Müller 6 months ago

The discussion on recommended modifiers I moved to #8236.

#24 Updated by Andreas Müller 6 months ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Katja Luther

Katja Luther wrote:

now the modifier section is shown only if the feature has recommended modifier voc, so it is hided for all features it is not possible to add recommended modifier vocabularies.

Only the structured modifiers may need to be hidden. The freetext modifier (modifying text) is vocabulary independent and therefore can always be shown (except for configuration via preferences that it should not be shown for UI simplification)

#25 Updated by Katja Luther 6 months ago

  • Status changed from Feedback to Resolved
  • Assignee changed from Katja Luther to Andreas Müller

Andreas Müller wrote:

Katja Luther wrote:

now the modifier section is shown only if the feature has recommended modifier voc, so it is hided for all features it is not possible to add recommended modifier vocabularies.

Only the structured modifiers may need to be hidden. The freetext modifier (modifying text) is vocabulary independent and therefore can always be shown (except for configuration via preferences that it should not be shown for UI simplification)

this is implemented now.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)