Project

General

Profile

task #3603

Remove creation of dummy DefinedTerm when creating new Term related entities

Added by Cherian Mathew over 5 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Priority14
Category:
taxeditor
Target version:
Start date:
07/24/2013
Due date:
% Done:

100%

Severity:
normal

Description

When new Term related entities are created within the Editor, a dummy Defined Term is created. Currently this problem affects,

  • Scope section of the DetailsViewer for a Description

  • ScopeRestrictedSection of the DetailsViewer for a Polytomous Key not enabled

  • ModifierSection

  • ModifierEditorInput used as the input object for modifier term editor

It needs to be investigated why this dummy defined term is created and potentially remove it, since terms should not be created automatically.

see also #5280

Associated revisions

Revision 9dfd3706 (diff)
Added by Patrick Plitzner almost 2 years ago

fix #3603 Avoid creation of dummy DefinedTerm

History

#1 Updated by Cherian Mathew over 5 years ago

  • Status changed from New to In Progress

Dummy creation now removed . Define Terms are now created with specific TermTypes.

#2 Updated by Cherian Mathew almost 5 years ago

  • Status changed from In Progress to Resolved
  • Assignee changed from c.mathew - to Andreas Müller
  • Target version changed from TaxEditor CDM 3.3 to TaxEditor RELEASE 3.3.0

#3 Updated by Andreas Müller almost 5 years ago

  • Assignee changed from Andreas Müller to c.mathew -
  • Target version deleted (TaxEditor RELEASE 3.3.0)

Scope section of the DetailsViewer for a Description

When I try to create ANY scope here I always get a red screen. So there is still something wrong

didn't test 3 and 4 (where are these to be found in the Editor) and 2 (because not available)

#4 Updated by Andreas Kohlbecker over 4 years ago

  • Target version deleted ()

no release 3.3.1 of the taxeditor so I am moving all tickets to the next milestone 3.3.2

#5 Updated by Cherian Mathew about 4 years ago

  • Target version deleted (TaxEditor RELEASE 3.4.0)

Moving tickets to 3.4.1 milestone

#6 Updated by Cherian Mathew over 3 years ago

  • Target version deleted ()

Moving tickets that were auto assigned to me to the unassigned milestone

#7 Updated by Andreas Müller about 3 years ago

  • Assignee changed from c.mathew - to p.plitzner -

Patrick, could you have a look on this.

#8 Updated by Andreas Müller over 2 years ago

  • Target version changed from Unassigned CDM tickets to Release 4.1
  • Priority changed from New to Priority14

#9 Updated by Patrick Plitzner almost 2 years ago

  • Description updated (diff)
  • Status changed from Resolved to Closed
  • % Done changed from 0 to 100

I could not reproduce any error so I guess this is fixed.

#10 Updated by Patrick Plitzner almost 2 years ago

  • Status changed from Closed to In Progress
  • Target version changed from Release 4.1 to Release 4.6

Reopened because although there are no errors dummy terms are still created

#11 Updated by Patrick Plitzner almost 2 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 100 to 50

#12 Updated by Patrick Plitzner almost 2 years ago

  • Assignee changed from Patrick Plitzner to Andreas Müller
  • % Done changed from 50 to 100

#13 Updated by Andreas Müller almost 2 years ago

  • Status changed from Resolved to Closed
  • Assignee changed from Andreas Müller to Patrick Plitzner

Still don't find ModifierSection and ModifierEditorInput. But for the first 2 (PK scope is enabled now) it works as expected.
So we can close the ticket I think.

#14 Updated by Andreas Müller almost 2 years ago

  • Private changed from Yes to No

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)