Project

General

Profile

feature request #3580

Write permission error with temporary cdmserver echache dir

Added by Cherian Mathew over 6 years ago. Updated almost 3 years ago.

Status:
Duplicate
Priority:
Priority11
Assignee:
Cherian Mathew
Category:
cdmlib-remote
Target version:
-
Start date:
07/03/2013
Due date:
% Done:

0%

Severity:
critical
Tags:

Description

The setting for the ehcache found in ehcache.xml (http://dev.e-taxonomy.eu/trac/browser/trunk/cdmlib/cdmlib-remote/src/main/resources/eu/etaxonomy/cdm/remote/ehcache.xml) points to the os tmp folder. This cache folder is created whenever a spring configuration instance is launched and can cause problems when these configurations are running under different users. e.g.

  • in the case of developers running the cdmserver (which launches the configuration for user 'cdm') and an instance of the Editor (which also tries to launch the configuration for the os user)

  • in the case of ulteo where multiple users are running Editors (each of which launch spring configurations trying to write to /tmp/cdm-server-ehcache)


potentially a duplicate of #2939


Related issues

Duplicates Edit - bug #2939: ehcache diskStore conflict? Closed 06/29/2012

History

#1 Updated by Cherian Mathew over 6 years ago

Changed cache folder in settings to user.home/.cdm-server-echache (r18309). Not sure if this causes other problems, but it should fix the problem with Ulteo which is urgent . The fix needs approval from Andreas K. before the next release.

#2 Updated by Cherian Mathew over 6 years ago

  • Status changed from New to In Progress

Hot fix done for cdmlib release 3.2.2. Editor (release 3.2.2) rebuilt with this version of cdmlib and deployed to the download dir as well as installed on ulteo.

#3 Updated by Cherian Mathew over 6 years ago

  • Target version set to cdmlib RELEASE 3.2.3

#4 Updated by Andreas Kohlbecker over 6 years ago

there is a older related ticket on the ehcache file store location: #2939, possibly a duplicate?

#5 Updated by Andreas Kohlbecker almost 6 years ago

  • Target version changed from cdmlib RELEASE 3.3.0 to cdmlib RELEASE 3.3.1

moving unresolved tickets to next release milestone due release of version 3.3

#6 Updated by Cherian Mathew almost 5 years ago

Seems to be fixed. Can we close this ?

#7 Updated by Andreas Kohlbecker almost 5 years ago

Replying to c.mathew:

Changed cache folder in settings to user.home/.cdm-server-echache (r18309). Not sure if this causes other problems, but it should fix the problem with Ulteo which is urgent . The fix needs approval from Andreas K. before the next release.

1.) I think your solution is ok especially with the future in mind. Currently we still could run into conflicts when we start a cdm-server and taxeditor in parallel, but from the time on when the remoting editor is finished we would no longer have this problem.

2.) However one concern remains: In a cdmserver, we have multilpe instances each with different data, so each of these instances needs to use a different cache and thus the instances should not share the same cache files. Thererfore in /.cdm-server-echache each instance should have it's own subfolder.

#8 Updated by Andreas Kohlbecker over 4 years ago

  • Target version changed from cdmlib RELEASE 3.5.0 to cdmlib RELEASE 3.5.1

moving tickets to next milestone

#9 Updated by Andreas Müller over 4 years ago

  • Target version changed from cdmlib RELEASE 3.5.1 to cdmlib RELEASE 3.5.2

move open 3.5.1 tickets to next milestone after release

#10 Updated by Katja Luther over 4 years ago

  • Target version deleted (cdmlib RELEASE 3.5.2)

#11 Updated by Andreas Müller over 4 years ago

  • Target version set to cdmlib - Reviewed Next Major Release
  • Priority changed from New to Priority11

#12 Updated by Andreas Kohlbecker almost 3 years ago

  • Related to bug #2939: ehcache diskStore conflict? added

#13 Updated by Andreas Kohlbecker almost 3 years ago

  • Tags set to ehcache
  • Description updated (diff)
  • Private changed from Yes to No

#14 Updated by Andreas Kohlbecker almost 3 years ago

  • Duplicates bug #2939: ehcache diskStore conflict? added

#15 Updated by Andreas Kohlbecker almost 3 years ago

  • Related to deleted (bug #2939: ehcache diskStore conflict?)

#16 Updated by Andreas Kohlbecker almost 3 years ago

  • Status changed from In Progress to Duplicate
  • Target version deleted (Reviewed Next Major Release)

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)