Project

General

Profile

bug #3276

NPE for "Move Elements" context menu option

Added by Patrick Plitzner almost 6 years ago. Updated about 2 months ago.

Status:
Closed
Priority:
Highest
Assignee:
Category:
taxeditor
Target version:
Start date:
01/21/2013
Due date:
% Done:

100%

Severity:
normal
Found in Version:

Description

  1. Add a description to a taxon

  2. Add a specimen to that description

  3. Expand the specimen

  4. Open the context menu of its child object via right click

  5. Select "Move Elements"

  6. Press "Cancel" in the upcoming dialog window

An NullPointerException will occur at DescriptionServiceImpl.moveDescriptionElementsToDescription().

I attached the error log.

move_elements_error_log.log View (9.82 KB) Patrick Plitzner, 01/21/2013 04:32 PM

move_elements.png View (22.6 KB) Patrick Plitzner, 01/21/2013 04:33 PM

picture930-1.png View (27.1 KB) Patrick Plitzner, 10/05/2018 09:17 AM

Associated revisions

Revision 90f49fe4 (diff)
Added by Katja Luther 3 months ago

fix #3276: avoid exception when moving unpersisted facts

Revision feef82e2 (diff)
Added by Katja Luther 2 months ago

ref #3276:move fact should be displayed only for facts

Revision bd0c87e3 (diff)
Added by Katja Luther 2 months ago

ref #3276:minor

History

#1 Updated by Patrick Plitzner almost 6 years ago

  • Category changed from cdmlib to taxeditor
  • Target version set to TaxEditor Next Major Release

#2 Updated by Andreas Müller over 2 years ago

  • Assignee changed from Andreas Müller to k.luther -
  • Target version changed from TaxEditor Next Major Release to Unassigned CDM tickets

Is this still an open issue?

#3 Updated by Andreas Müller 3 months ago

  • Description updated (diff)
  • Priority changed from New to Highest
  • Target version changed from Unassigned CDM tickets to Release 5.4

#4 Updated by Katja Luther 3 months ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 50

#5 Updated by Katja Luther 3 months ago

  • Assignee changed from Katja Luther to Patrick Plitzner

please review

#6 Updated by Patrick Plitzner 2 months ago

  • File picture930-1.png View added
  • Status changed from Resolved to Feedback
  • Assignee changed from Patrick Plitzner to Katja Luther

I could not reproduce this exception how described above but there is another one.

Now there is also the context menu option to move the factual data when right-clicked on an element

)

By the way, the tooltips for both options seem to be swapped.

steps to reproduce:

  1. Open context menu for description element
  2. Select "Move Factual Data to Other Taxon"
  3. Select any other taxon and click ok
!ENTRY org.eclipse.ui 4 0 2018-10-05 09:14:09.583
!MESSAGE This is an unexpected error.
Please contact EDIT Support (EditSupport@bgbm.org) with the error trace below (click on the 'Details' button).
!STACK 0
java.lang.Exception: login : admin
editor version : 5.4.0.qualifier
server : localhost (localhost-dev)
schema version : 5.0.0.0.20180514
os : Linux 4.15.0-36-generic amd64
java : 1.8.0_121
org.eclipse.swt.SWTException: Failed to execute runnable (java.lang.NullPointerException)
    at org.eclipse.swt.SWT.error(SWT.java:4533)
    at org.eclipse.swt.SWT.error(SWT.java:4448)
    at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:185)
    at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:4536)
    at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:4154)
    at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$4.run(PartRenderingEngine.java:1121)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
    at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1022)
    at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:150)
    at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:693)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
    at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:610)
    at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:148)
    at eu.etaxonomy.taxeditor.Application.start(Application.java:24)
    at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1519)
    at org.eclipse.equinox.launcher.Main.main(Main.java:1492)
Caused by: java.lang.NullPointerException
    at eu.etaxonomy.taxeditor.editor.view.descriptive.operation.MoveDescriptionToOtherTaxonOperation.execute(MoveDescriptionToOtherTaxonOperation.java:79)
    at eu.etaxonomy.taxeditor.model.AbstractUtility.lambda$3(AbstractUtility.java:141)
    at org.eclipse.ui.internal.UILockListener.doPendingWork(UILockListener.java:162)
    at org.eclipse.ui.internal.UISynchronizer$3.run(UISynchronizer.java:154)
    at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
    at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:182)
    ... 24 more

#7 Updated by Katja Luther 2 months ago

The NPE I could not reproduce. The menu entry for move factual data is displayed only for descritions, now.
Why the tooltip was swapped (only in english, in german I could not reproduce), I don't know because there is no tooltip defined for these menu items.

#8 Updated by Patrick Plitzner 2 months ago

  • Status changed from Feedback to Closed
  • % Done changed from 50 to 100

works fine

#9 Updated by Andreas Müller about 2 months ago

  • Private changed from Yes to No

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)