Project

General

Profile

Actions

bug #10504

closed

NPE when saving deduplication in bulkeditor

Added by Katja Luther about 2 months ago. Updated about 1 month ago.

Status:
Closed
Priority:
New
Assignee:
Category:
taxeditor
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Severity:
normal
Found in Version:

Description

mail AM:

Beim deduplizieren

last remote service : https://api.cybertaxonomy.org:443/euromed/remoting/common.service
last remote method : getDbSchemaVersion
last remote request client time : 2024-05-22T08:22:54.752
last remote request response header time : Wed, 22 May 2024 06:22:51 GMT
client error time : 2024-05-22T08:22:56.868
login : admin
editor version : 5.42.0
server : api.cybertaxonomy.org (cybertaxonomy.org) / euromed
schema version : 5.40.1.0.20230829
os : Windows Server 2019 10.0 amd64
java : 1.8.0_371
org.eclipse.e4.core.di.InjectionException: org.eclipse.core.runtime.AssertionFailedException: null argument:
            at org.eclipse.e4.core.internal.di.MethodRequestor.execute(MethodRequestor.java:65)
            at org.eclipse.e4.core.internal.di.InjectorImpl.invokeUsingClass(InjectorImpl.java:282)
            at org.eclipse.e4.core.internal.di.InjectorImpl.invoke(InjectorImpl.java:247)
            at org.eclipse.e4.core.contexts.ContextInjectionFactory.invoke(ContextInjectionFactory.java:90)
            at org.eclipse.e4.ui.internal.workbench.PartServiceSaveHandler.save(PartServiceSaveHandler.java:57)
            at org.eclipse.ui.internal.WorkbenchWindow$7.save(WorkbenchWindow.java:594)
            at org.eclipse.e4.ui.internal.workbench.PartServiceImpl.savePart(PartServiceImpl.java:1390)
            at eu.etaxonomy.taxeditor.workbench.SaveHandler.execute(SaveHandler.java:42)
            at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
            at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
            at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
            at java.lang.reflect.Method.invoke(Method.java:498)
            at org.eclipse.e4.core.internal.di.MethodRequestor.execute(MethodRequestor.java:55)
            at org.eclipse.e4.core.internal.di.InjectorImpl.invokeUsingClass(InjectorImpl.java:282)
            at org.eclipse.e4.core.internal.di.InjectorImpl.invoke(InjectorImpl.java:264)
            at org.eclipse.e4.core.contexts.ContextInjectionFactory.invoke(ContextInjectionFactory.java:132)
            at org.eclipse.e4.core.commands.internal.HandlerServiceHandler.execute(HandlerServiceHandler.java:152)
            at org.eclipse.core.commands.Command.executeWithChecks(Command.java:494)
            at org.eclipse.core.commands.ParameterizedCommand.executeWithChecks(ParameterizedCommand.java:488)
            at org.eclipse.e4.core.commands.internal.HandlerServiceImpl.executeHandler(HandlerServiceImpl.java:210)
            at org.eclipse.e4.ui.workbench.renderers.swt.HandledContributionItem.executeItem(HandledContributionItem.java:433)
            at org.eclipse.e4.ui.workbench.renderers.swt.AbstractContributionItem.handleWidgetSelection(AbstractContributionItem.java:454)
            at org.eclipse.e4.ui.workbench.renderers.swt.AbstractContributionItem$3.handleEvent(AbstractContributionItem.java:482)
            at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
            at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4418)
            at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1079)
            at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4236)
            at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3824)
            at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$4.run(PartRenderingEngine.java:1121)
            at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
            at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1022)
            at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:150)
            at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:693)
            at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
            at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:610)
            at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:148)
            at eu.etaxonomy.taxeditor.Application.start(Application.java:20)
            at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
            at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
            at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
            at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
            at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
            at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
            at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
            at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
            at java.lang.reflect.Method.invoke(Method.java:498)
            at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673)
            at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610)
            at org.eclipse.equinox.launcher.Main.run(Main.java:1519)
Caused by: org.eclipse.core.runtime.AssertionFailedException: null argument:
            at org.eclipse.core.runtime.Assert.isNotNull(Assert.java:85)
            at org.eclipse.core.runtime.Assert.isNotNull(Assert.java:73)
            at org.eclipse.jface.viewers.StructuredSelection.<init>(StructuredSelection.java:74)
            at eu.etaxonomy.taxeditor.bulkeditor.e4.BulkEditor.getLastSelection(BulkEditor.java:176)
            at eu.etaxonomy.taxeditor.bulkeditor.e4.BulkEditor.save(BulkEditor.java:135)
            at eu.etaxonomy.taxeditor.bulkeditor.e4.BulkEditor.save(BulkEditor.java:131)
            at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
            at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
            at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
            at java.lang.reflect.Method.invoke(Method.java:498)
            at org.eclipse.e4.core.internal.di.MethodRequestor.execute(MethodRequestor.java:55)
            ... 48 more
Actions #1

Updated by Katja Luther about 2 months ago

  • Category set to taxeditor
  • Status changed from New to Resolved
  • Assignee changed from Katja Luther to Andreas Müller

This is fixed, please review.

Actions #2

Updated by Andreas Müller about 2 months ago

  • Status changed from Resolved to Closed
  • Assignee changed from Andreas Müller to Katja Luther
  • % Done changed from 0 to 100

Code looks ok. As I don't how this is reproducable I can not test. Close ticket.

Actions #3

Updated by Andreas Müller about 1 month ago

  • Target version changed from Release 5.47 to Release 5.43
Actions

Also available in: Atom PDF