Project

General

Profile

Actions

bug #10497

closed

Specific epithet list is not limited to epithets existing for the genus (was: Vaadin selected epithet is gone when a record is re-opened)

Added by Wolf-Henning Kusber 3 months ago. Updated about 1 month ago.

Status:
Closed
Priority:
Highest
Category:
cdm-vaadin
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Severity:
critical
Found in Version:

Description

Show case: Vaadin Test (Problem in Release)
Micrasterias truncata f. montanica Levanets & Janse van Vuuren (in preparation)
If the record is reopened, the species epithet "truncata" is gone, saving is not possible and selection of the species epithet is not possible, too. However, cancle closes the record.

The problem is: I open this record to select a already available infraspecific name.
I can select the name, here
Micrasterias truncata f. elevata Prescott

But I cannot save this name relation, because (see above), when I cancle the record, the name relation is not saved.


Files

species_gone.PNG (80.4 KB) species_gone.PNG Wolf-Henning Kusber, 04/25/2024 08:36 PM
clipboard-202405231553-zxgdt.png (10.6 KB) clipboard-202405231553-zxgdt.png Andreas Müller, 05/23/2024 03:53 PM

Related issues

Related to EDIT - bug #10506: Hidden fields are saved in taxon name registration editor NewWolf-Henning Kusber

Actions
Actions #1

Updated by Andreas Müller 2 months ago

  • Target version changed from Unassigned CDM tickets to Release 5.47
Actions #2

Updated by Andreas Müller 2 months ago

  • Status changed from New to In Progress
  • Assignee changed from Andreas Müller to Wolf-Henning Kusber

I can't reproduce this. Can you give a bit more input on what exactly you did?

From where did you "open this record to select a already available infraspecific name"?

And how is Micrasterias truncata f. montanica Levanets & Janse van Vuuren related to Micrasterias truncata f. elevata Prescott?
I can't see that there should be a "name relation" so what do you mean with "name relation" in "But I cannot save this name relation, because (see above), when I cancle the record, the name relation is not saved."?

Actions #3

Updated by Wolf-Henning Kusber about 2 months ago

  • Assignee changed from Wolf-Henning Kusber to Andreas Müller

The procedure:
new taxon, variety or forma

  1. Select a genus name
  2. Select a speciens name
  3. Type in the third epithet
  4. save No problems

ToDo: e.g. add a page number to the name

  1. Goto Reference or List
  2. Open (I called it reopen because the name had been already saved)
  3. In Vaadin the name opens The saved genus name is visible, the saved final epithet is visible The previously saved selected species epithet in NOT VISIBLE (in the screenshot, the species epithet is visible (left side) before reopening the form, but gone when the form is open) This makes the name a incomplete entry
  4. As it is a incomplete entry, it cannot be saved. To be saved it needs the previously selected species epithet, but it is neither visible nor selectable. Thus, I only can quit Vaadin, open the TaxEditor and add the previously saved species epithet again. This bug is critical for users.
Actions #4

Updated by Andreas Müller about 2 months ago

This can still not be reproduced. But I tested the data on test. There does not exist (and as it looks like never existed) a species Micrasterias truncata. So the question is how you could create the 2 formas "Micrasterias truncata f. montanica Levanets & Janse van Vuuren" and "Micrasterias truncata f. elevata Prescott" as it should not be possible to create a forma without the according species.

Once you add the species editing the forma (infraspecies) should be possible again.

Actions #5

Updated by Wolf-Henning Kusber about 2 months ago

  • Assignee changed from Wolf-Henning Kusber to Andreas Müller

Thanks,

I selected Micrasterias for the genus
I selected "truncata" for the species. This epithet was selectable, but not for the genus. But this is also a problem.
We have e.g. Gracilaria truncata in the system

Actions #6

Updated by Andreas Müller about 2 months ago

  • Status changed from Feedback to In Progress

Wolf-Henning Kusber wrote in #note-5:

Thanks,

I selected Micrasterias for the genus
I selected "truncata" for the species. This epithet was selectable, but not for the genus. But this is also a problem.
We have e.g. Gracilaria truncata in the system

But the specific epithet dropdown only allows selecting for the sp.epis for the given genus (at least for me). So how could you select truncata?

Ahh, now I realize how you probably did this. You selected Gracilaria as genus, then you selected truncata as specific epi, then you changed(!) the genus (and the specific epi was still there!). This is I why asked for the exact workflow what you did.

So the real problem is that changing the genus name does not empty the specific epithet if this is not available under the new genus. Correct?

Actions #7

Updated by Andreas Müller about 2 months ago

When first selecting the rank the specific epi field is filled with all existing specific epis. I guess this is unwanted behaviour. The dropbox should fill only after the genus has been selected (or at least should refill once the genus is selected and if necessary should remove the prior selected value in case it is not in the list).

Interesting is, that when first selecting the genus before selecting the rank and then selecting the rank the specific epi dropbox is filled correctly with the existing epis for the given rank only.

However, though I tried to debug at many places, until now I can't find the place where to add a value change listener to the genus dropdown.
Maybe comparing with the rank selection field may help.

Actions #8

Updated by Wolf-Henning Kusber about 2 months ago

Okay, once more (Production and Test)

Databasing a new species:
Select "Species"
Submitter selects a genus name from the list (if not available a new genus is databased and used)
Submitter types in the species epithet (Vaadin behaviour: if exactly this epithet is already in the system, a duplicate is saved and marked as duplicate.

Databasing a new variety:
Select "Variety"
Submitter selects a genus name from the list
Submitter selects a species name from the list (independently from its linkage with the genus name selected)
Submitter types in the third=final epithet
Submitter saves the name.
As the name seems to be saved correctly and the full name is displayed in the List (see screen shot), the submitter have the impression that the name was correctly saved. Here an allert would be useful that this name cannot be saved. Alternatively just species epithets linked to the selected genus name might be selectable.

When the Name is reopened the species epithet is missing, this is completely unexpected for the submitter.

Actions #9

Updated by Andreas Müller about 2 months ago

  • Subject changed from Vaadin selected epithet is gone when a record is re-opened to Specific epithet list is not limited to epithets existing for the genus (was: Vaadin selected epithet is gone when a record is re-opened)

@WHK: as you mentioned already in note-5 "I selected "truncata" for the species. This epithet was selectable, but not for the genus. But this is also a problem ." and I mentioned in note-6 and -7 the real problem is the fact that when selecting a genus the species list is not always updated in a way that it shows only those specific epithets that exist for the given genus. This bug results in the creation of infraspecific names for which no "species parent" exists in the databases.

The originally observed problem ("selected epithet is gone when a record is re-opened") is only a follow-up problem due to the dirty data created before.

Actions #10

Updated by Andreas Müller about 2 months ago

  • Related to bug #10506: Hidden fields are saved in taxon name registration editor added
Actions #11

Updated by Andreas Müller about 2 months ago

  • Status changed from In Progress to Resolved
  • Assignee changed from Andreas Müller to Wolf-Henning Kusber
  • % Done changed from 30 to 70

Should be fixed and can be reviewed. A related ticket was created #10506

Actions #12

Updated by Andreas Müller about 1 month ago

  • Target version changed from Release 5.47 to Release 5.43
Actions #13

Updated by Wolf-Henning Kusber about 1 month ago

  • Assignee changed from Wolf-Henning Kusber to Andreas Müller
  • % Done changed from 70 to 100

Tested with Test system (2024-06-04): The system behaves as expected, many thanks. Ticket can be closed.

Problem solved: only available species epithets of the selected genus can be selected when an infraspecific name should be entered.
Problem solved: If a not available species epithet is typed in, no save is possible and a warning appears
Problem solved: If a species epithet is not available, it can be entered as new under the selected genus.

Actions #14

Updated by Andreas Müller about 1 month ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF