Project

General

Profile

Actions

bug #10495

closed

NPE when uncheck all languages in common name preference

Added by Katja Luther 3 months ago. Updated about 1 month ago.

Status:
Closed
Priority:
Highest
Assignee:
Category:
taxeditor
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Severity:
normal
Found in Version:
Tags:

Description

mail WB:

Hallo,

ich wollte die Spracheinstellungen für Common Names ändern und habe mich erinnert, dass man irgendwie mit dem ganz rechten Knopf hier

alles abwählen kann. Nach click kam der Fehler unten.

Ich weiß nicht, ob das zusammenhängt, aber vorher habe ich die serverseitige Sprache auf Spanisch geändert, das hatte ich im September noch nicht gemacht.

HG
W

last remote service : http://132.248.13.83:8080/cdmserver/cdm_flora_mexico/remoting/term.service
last remote method : getDbSchemaVersion
last remote request client time : 2024-04-19T13:08:27.753
last remote request response header time : Fri, 19 Apr 2024 19:08:27 GMT
client error time : 2024-04-19T13:09:56.38
login : w.berendsohn
editor version : 5.42.0
server : 132.248.13.83 (Mexico) / cdm_flora_mexico
schema version : 5.40.1.0.20230829
os : Windows 10 10.0 amd64
java : 1.8.0_401
java.lang.ArrayIndexOutOfBoundsException: 0
                at eu.etaxonomy.taxeditor.preference.wizard.CheckBoxTreeComposite.widgetSelected(CheckBoxTreeComposite.java:291)
                at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:249)
                at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
                at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4418)
                at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1079)
                at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4236)
                at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3824)
                at org.eclipse.jface.window.Window.runEventLoop(Window.java:818)
                at org.eclipse.jface.window.Window.open(Window.java:794)
                at eu.etaxonomy.taxeditor.workbench.handler.OpenAdminPreferencesHandler.execute(OpenAdminPreferencesHandler.java:126)
                at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
                at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
                at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
                at java.lang.reflect.Method.invoke(Unknown Source)
                at org.eclipse.e4.core.internal.di.MethodRequestor.execute(MethodRequestor.java:55)
                at org.eclipse.e4.core.internal.di.InjectorImpl.invokeUsingClass(InjectorImpl.java:282)
                at org.eclipse.e4.core.internal.di.InjectorImpl.invoke(InjectorImpl.java:264)
                at org.eclipse.e4.core.contexts.ContextInjectionFactory.invoke(ContextInjectionFactory.java:132)
                at org.eclipse.e4.core.commands.internal.HandlerServiceHandler.execute(HandlerServiceHandler.java:152)
                at org.eclipse.core.commands.Command.executeWithChecks(Command.java:494)
                at org.eclipse.core.commands.ParameterizedCommand.executeWithChecks(ParameterizedCommand.java:488)
                at org.eclipse.e4.core.commands.internal.HandlerServiceImpl.executeHandler(HandlerServiceImpl.java:210)
                at org.eclipse.e4.ui.workbench.renderers.swt.HandledContributionItem.executeItem(HandledContributionItem.java:433)
                at org.eclipse.e4.ui.workbench.renderers.swt.AbstractContributionItem.handleWidgetSelection(AbstractContributionItem.java:454)
                at org.eclipse.e4.ui.workbench.renderers.swt.AbstractContributionItem$3.handleEvent(AbstractContributionItem.java:482)
                at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
                at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4418)
                at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1079)
                at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4236)
                at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3824)
                at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$4.run(PartRenderingEngine.java:1121)
                at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
                at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1022)
                at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:150)
                at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:693)
                at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
                at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:610)
                at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:148)
                at eu.etaxonomy.taxeditor.Application.start(Application.java:20)
                at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
                at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
                at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
                at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
                at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
                at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
                at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
                at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
                at java.lang.reflect.Method.invoke(Unknown Source)
                at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673)
                at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610)
                at org.eclipse.equinox.launcher.Main.run(Main.java:1519)

Files

uncheck.png (465 Bytes) uncheck.png Katja Luther, 04/22/2024 01:48 PM
Actions #1

Updated by Katja Luther 3 months ago

  • Category set to taxeditor
  • Assignee set to Katja Luther
  • Target version changed from Unassigned CDM tickets to Release 5.47

Could not reproduce, but added an additional check to avoid NPE.

Actions #2

Updated by Andreas Müller 3 months ago

  • Priority changed from New to Highest
Actions #3

Updated by Katja Luther about 2 months ago

  • Status changed from New to Resolved
  • Assignee changed from Katja Luther to Andreas Müller

This should be fixed, please review.

Actions #4

Updated by Andreas Müller about 2 months ago

  • Tags set to i18n
  • Status changed from Resolved to Closed
  • Assignee changed from Andreas Müller to Katja Luther
  • % Done changed from 0 to 100

This is difficult to test for me as I do not know if I can reproduce the state that lead to the bug.

However, as I can't reproduce despite of some testing I guess the it is fixed. If it happens again let's reopen.

Actions #5

Updated by Andreas Müller about 1 month ago

  • Target version changed from Release 5.47 to Release 5.43
Actions

Also available in: Atom PDF