Project

General

Profile

Actions

bug #10389

closed

NPE in Character Matrix for some quantitative data cells

Added by Katja Luther 11 months ago. Updated 11 months ago.

Status:
Closed
Priority:
New
Assignee:
Category:
taxeditor
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Severity:
normal
Found in Version:
Tags:

Description

mail KK:

1) In the character matrix of Centaurea there are some fields of quantitative characters for which I added values and they are grayed out and non editable.
This is the error I am getting:

last remote service : https://api.cybertaxonomy.org:443/flora-greece/remoting/common.service
last remote method : getDbSchemaVersion
last remote request client time : 2023-08-31T12:36:48.899
last remote request response header time : Thu, 31 Aug 2023 10:36:48 GMT
client error time : 2023-08-31T12:37:03.321
login : k.koutroumpa
editor version : 5.39.0
server : api.cybertaxonomy.org (cybertaxonomy.org) / flora-greece
schema version : 5.38.0.0.20230510
os : Windows 10 10.0 amd64
java : 1.8.0_201
java.lang.NullPointerException

mail AM:

last remote service : https://api.cybertaxonomy.org:443/flora-greece-bupleurum/remoting/term.service
last remote method : getDbSchemaVersion
last remote request client time : 2023-08-31T13:42:37.922
last remote request response header time : Thu, 31 Aug 2023 11:42:38 GMT
client error time : 2023-08-31T13:43:41.614
login : admin
editor version : 5.39.0
server : api.cybertaxonomy.org (cybertaxonomy.org) / flora-greece-bupleurum
schema version : 5.38.0.0.20230510
os : Windows Server 2019 10.0 amd64
java : 1.8.0_371
java.lang.NullPointerException
            at eu.etaxonomy.taxeditor.editor.descriptiveDataSet.matrix.CharacterMatrix$1.getText(CharacterMatrix.java:304)
            at org.eclipse.nebula.widgets.nattable.tooltip.NatTableContentTooltip.shouldCreateToolTip(NatTableContentTooltip.java:169)
            at org.eclipse.jface.window.ToolTip.toolTipCreate(ToolTip.java:326)
            at org.eclipse.jface.window.ToolTip.access$2(ToolTip.java:325)
            at org.eclipse.jface.window.ToolTip$ToolTipOwnerControlListener.handleEvent(ToolTip.java:606)
            at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
            at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4418)
            at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1079)
            at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4236)
            at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3824)
            at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$4.run(PartRenderingEngine.java:1121)
            at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
            at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1022)
            at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:150)
            at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:693)
            at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
            at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:610)
            at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:148)
            at eu.etaxonomy.taxeditor.Application.start(Application.java:20)
            at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
            at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
            at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
            at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
            at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
            at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
            at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
            at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
            at java.lang.reflect.Method.invoke(Method.java:498)
            at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673)
            at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610)
            at org.eclipse.equinox.launcher.Main.run(Main.java:1519)
Actions #1

Updated by Katja Luther 11 months ago

  • Status changed from New to Resolved
  • Assignee changed from Katja Luther to Andreas Müller
  • % Done changed from 0 to 70

This should be fixed, please review.

Actions #2

Updated by Andreas Müller 11 months ago

Can you leave a message in which cases this issue appeared? It is difficult to review without knowing how to reproduce the original bug.

Actions #3

Updated by Konstantina Koutroumpa 11 months ago

In the character matrix the grayed out fields for the specimen B 10 0138866 are: 1) basal leaves - leaves length [mm], 2) involucre - inner involucral bracts width [mm], 3) involucre - middle involucral bracts - middle involucral bracts length [mm], and 4) involucre - middle involucral bracts - middle involucral bracts width [mm]

Actions #4

Updated by Konstantina Koutroumpa 11 months ago

Reviewed it in the test server and the issue is fixed.

Actions #5

Updated by Andreas Müller 11 months ago

  • Tags set to additivity
  • Status changed from Resolved to Closed
  • % Done changed from 70 to 100

I guess we can close this ticket.

Actions #6

Updated by Andreas Müller 11 months ago

  • Assignee changed from Andreas Müller to Katja Luther
Actions

Also available in: Atom PDF