Project

General

Profile

Actions

bug #10375

closed

Distribution status combo box does not always show correct Spanish value

Added by Andreas Müller 12 months ago. Updated 11 months ago.

Status:
Closed
Priority:
Highest
Assignee:
Category:
taxeditor
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Severity:
normal
Found in Version:
Tags:

Description

MR:

Beim "Distribution status" stimmt etwas nicht. Wenn ich den TaxEditor aufmache, sind die Kategorien auf Englisch und Spanisch gemischt:

Wenn ich dann in den "Local Preferences" auf Spanisch wechsele, kommt das folgende Resultat:

Wenn ich daraufhin den TaxEditor zu- und wieder aufmache, kommt wieder das obere Fenster.

WGB:

Beim ersten Fall dachte ich, es hätte vielleicht mit fehlenden Übersetzungen zu tun. Dabei ist mir erstmal aufgefallen, dass die engl. Übersetzung scheinbar veraschwunden war:

Wenn ich dann aber nochmal Englisch auswähle, erscheint der englische Wert:

Da sind also vermutlich mehrere Sachen nicht in Ordnung.


Files

clipboard-202307241740-2djqq.png (37.6 KB) clipboard-202307241740-2djqq.png Andreas Müller, 07/24/2023 05:40 PM
clipboard-202307241740-3dnpb.png (27.7 KB) clipboard-202307241740-3dnpb.png Andreas Müller, 07/24/2023 05:40 PM
clipboard-202307241741-n5hds.png (80 KB) clipboard-202307241741-n5hds.png Andreas Müller, 07/24/2023 05:41 PM
clipboard-202307241741-lrnxb.png (39.6 KB) clipboard-202307241741-lrnxb.png Andreas Müller, 07/24/2023 05:41 PM

Related issues

Related to EDIT - bug #10374: Editing Spanish only term does not workClosedKatja Luther

Actions
Related to EDIT - bug #10305: Add DB preference for term languageClosedKatja Luther

Actions
Actions #1

Updated by Andreas Müller 12 months ago

I could not reproduce the mixed version and the version with only 2 entries, but I could reproduce that the English version is shown (for all records) though Spanish is choosen in the preferences.

As a workaround it worked to switch in preference to English and back to Spanish (no need to save in between). Afterwards the status was shown correctly (but not anymore after TaxEditor restart).

So it looks like the term language preferences is not evaluated correctly at TaxEditor start up.

Actions #2

Updated by Andreas Müller 12 months ago

  • Related to bug #10374: Editing Spanish only term does not work added
Actions #3

Updated by Andreas Müller 12 months ago

See also #10374 for very similar (but not same) issues.

Actions #4

Updated by Andreas Müller 12 months ago

  • Related to bug #10305: Add DB preference for term language added
Actions #5

Updated by Katja Luther 11 months ago

  • Status changed from New to Resolved
  • Assignee changed from Katja Luther to Andreas Müller

This seems to be fixed with the changes for #10374 and #10305 and the changes in term combo. Please review.

Actions #6

Updated by Katja Luther 11 months ago

  • % Done changed from 0 to 60
Actions #7

Updated by Andreas Müller 11 months ago

Katja Luther wrote in #note-5:

This seems to be fixed with the changes for #10374 and #10305 and the changes in term combo. Please review.

Are the changes in term combo related to a ticket? If not can you add the commits here? Or is this the already added commit 904e2f00 ?

Actions #8

Updated by Andreas Müller 11 months ago

  • % Done changed from 60 to 70
Actions #9

Updated by Andreas Müller 11 months ago

  • Target version changed from Release 5.49 to Release 5.40
Actions #10

Updated by Andreas Müller 11 months ago

  • Status changed from Resolved to Closed
  • Assignee changed from Andreas Müller to Katja Luther
  • % Done changed from 70 to 100

Seems to be fixed and can be closed.

Actions

Also available in: Atom PDF