Project

General

Profile

Actions

bug #10374

closed

Editing Spanish only term does not work

Added by Andreas Müller 12 months ago. Updated 11 months ago.

Status:
Closed
Priority:
Highest
Assignee:
Category:
taxeditor
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Severity:
normal
Found in Version:
Tags:

Description

WGB+MR:

2) Der Text von zwei Kategorien in "Estatus de taxón" ist nicht ganz richtig:
(B) Estatus dudoso: La delimitación de l taxón la especie todavía no se ha investigado con detalle.
(C) No se trata de una entidad monofilética: Se requiere más investigación.

Ich kann die Änderung nicht speichern:

Ich speichere, aber wenn ich den Fokus ändere, springt auch das Detail wieder zum alten Label zurück.
Das gleiche gilt auch für die Streichung bei (C).


Files

clipboard-202307241651-gwlfv.png (47.6 KB) clipboard-202307241651-gwlfv.png Andreas Müller, 07/24/2023 04:51 PM
clipboard-202307241655-j7xjo.png (15.4 KB) clipboard-202307241655-j7xjo.png Andreas Müller, 07/24/2023 04:55 PM
clipboard-202307241700-j823h.png (14.5 KB) clipboard-202307241700-j823h.png Andreas Müller, 07/24/2023 05:00 PM
clipboard-202307241702-b3zut.png (1.89 KB) clipboard-202307241702-b3zut.png Andreas Müller, 07/24/2023 05:02 PM
clipboard-202307241704-8mqey.png (13 KB) clipboard-202307241704-8mqey.png Andreas Müller, 07/24/2023 05:04 PM
clipboard-202307241707-h1pzi.png (9.39 KB) clipboard-202307241707-h1pzi.png Andreas Müller, 07/24/2023 05:07 PM
clipboard-202307241710-dm7g3.png (1.89 KB) clipboard-202307241710-dm7g3.png Andreas Müller, 07/24/2023 05:10 PM

Related issues

Related to EDIT - bug #10375: Distribution status combo box does not always show correct Spanish valueClosedKatja Luther

Actions
Related to EDIT - bug #10305: Add DB preference for term languageClosedKatja Luther

Actions
Actions #1

Updated by Andreas Müller 12 months ago

  • Description updated (diff)
Actions #2

Updated by Andreas Müller 12 months ago

AM:

The problem is that the TaxEditor shows the Spanish version in both the details view as well as the translation editor:

In the details view you can switch to English:

... and you can see that the changes made to Spanish were saved in the English translation but the label still shows the Spanish version:

Also in the DB you can see that the changes were appied to English, not Spanish, though made when Spanish was selected:

Note: the term titleCache was updated correctly

SELECT dtb.id termId, dtb.titleCache termTitleCache, l.titleCache language, r.label RepresentationLabel 
FROM DefinedTermBase dtb LEFT JOIN DefinedTermBase_Representation MN ON dtb.id = MN.DefinedTermBase_id
LEFT JOIN Representation r ON r.id = MN.representations_id
LEFT JOIN DefinedTermBase l ON l.id = r.language_id
WHERE dtb.titleCache LIKE '(B) La del%'
Actions #3

Updated by Andreas Müller 12 months ago

The term can be changed if actively choosing Spanish after first selecting English:

I could also edit the term correctly in translation editor by first choosing English on the left side and Spanish on the right side and then editing Spanish.

All the above test were made with term language set to "English" in the local preferences (there are no DB preferences for term language yet).
But also switching to Spanish in the preferences had the same result (at least in details view, did not test translation editor).

Actions #4

Updated by Andreas Müller 12 months ago

Please also note that the section label in details view is not updated correctly even if the term editor shows the correct data. See above screenshot.

Also note that data needs to be cleaned up in DB after fixing this ticket.

Actions #5

Updated by Andreas Müller 12 months ago

  • Priority changed from New to Highest
Actions #6

Updated by Andreas Müller 12 months ago

  • Related to bug #10375: Distribution status combo box does not always show correct Spanish value added
Actions #7

Updated by Andreas Müller 12 months ago

  • Related to bug #10305: Add DB preference for term language added
Actions #8

Updated by Katja Luther 11 months ago

Currently the translation wizard saves only the "target" representation, that means only the representation on the right hand side. I think the original idea was that the "standard" representation is edited in details view and the translation wizard is used only for the translations.
But the main problem is that editing the text fields of the source representation results (sometimes?) in editing the right hand side representation. As a first implementation I disabled the source representation. When opening the translation wizard, the right hand side is empty and the language for the new translation has to be selected before anything can be entered. In the former implementation the first language was shown in the language selection combo but to edit the representation it still needed to be reselected or another language had to be selected.

Actions #9

Updated by Katja Luther 11 months ago

Andreas Müller wrote in #note-4:

Please also note that the section label in details view is not updated correctly even if the term editor shows the correct data. See above screenshot.

Also note that data needs to be cleaned up in DB after fixing this ticket.

The section label shows always the same as the entry in the term editor, this is the representation of the term language.

Actions #10

Updated by Katja Luther 11 months ago

  • Status changed from New to Resolved
  • Assignee changed from Katja Luther to Andreas Müller

With the last changes it is possible to edit the existing representations in details view and adding/editing translations in the translation wizard. Terms with only one representation also a representation differing from the term language can be edited in the details view.

Please have a look whether this implementation covers all user needs.

Actions #11

Updated by Andreas Müller 11 months ago

  • Target version changed from Release 5.49 to Release 5.40
Actions #12

Updated by Andreas Müller 11 months ago

  • % Done changed from 0 to 70
Actions #13

Updated by Andreas Müller 11 months ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Katja Luther
  • % Done changed from 70 to 90

The problem is now that editing a non-default language representation is also possible in the details view. Also saving these changes is (sometimes) successful though yesterday I got a DuplicateEntry exception when doing so.
Going back and force with the focus does not show the changes.

However, as the language model will change in the near future I suggest to keep this as it is as it generally works and non-default language editing is mostly done by advanced users if at all. So we shouldn't spend too much time with it now.

Generally the problem described in the description of this ticket seems to be fixed. So maybe we close this ticket and create a new one with lower priority for the remaining issues.

Actions #14

Updated by Andreas Müller 11 months ago

  • Status changed from Feedback to Closed
  • % Done changed from 90 to 100

We decided not to fix the above as the language model is changing any way. And also this is not strictly part of this ticket as it was like this before.

Actions

Also available in: Atom PDF