Project

General

Profile

Actions

feature request #10335

closed

Allow editing supplemental data for TermNodes

Added by Andreas Müller about 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
Highest
Assignee:
Category:
taxeditor
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Severity:
normal
Tags:

Description

See #10320

Required for adding markers to fallback areas (distributions)


Related issues

Related to EDIT - feature request #10320: MakeTermRelationBase annotatableClosedAndreas Müller

Actions
Related to EDIT - feature request #9502: Implement subarea preference rule and fallback areas for areas with complex hierarchyResolvedAndreas Müller

Actions
Related to EDIT - feature request #9503: Handle term tree of areas and distribution status for distributionInfo in dataportalClosedKatja Luther

Actions
Related to EDIT - feature request #10323: Preference for IUCN status list statesIn ProgressKatja Luther

Actions
Related to EDIT - feature request #10353: Implement supplemental data editing for term treesNewKatja Luther

Actions
Actions #1

Updated by Andreas Müller about 1 year ago

Actions #2

Updated by Andreas Müller about 1 year ago

  • Description updated (diff)
Actions #3

Updated by Andreas Müller about 1 year ago

  • Priority changed from New to Highest
Actions #4

Updated by Andreas Müller about 1 year ago

  • Related to feature request #9502: Implement subarea preference rule and fallback areas for areas with complex hierarchy added
Actions #5

Updated by Andreas Müller about 1 year ago

  • Related to feature request #9503: Handle term tree of areas and distribution status for distributionInfo in dataportal added
Actions #6

Updated by Andreas Müller about 1 year ago

  • Target version changed from Release 5.49 to Release 5.38
Actions #7

Updated by Andreas Müller about 1 year ago

Actions #8

Updated by Katja Luther about 1 year ago

  • Status changed from New to Resolved
  • Assignee changed from Katja Luther to Andreas Müller
  • % Done changed from 0 to 50

This should be solved, please review.

Actions #9

Updated by Andreas Müller about 1 year ago

Remove does not yet seem to work.

Actions #10

Updated by Andreas Müller about 1 year ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Katja Luther

Also it would be nice to show id and uuid as usually for supplemental data.

Actions #11

Updated by Katja Luther about 1 year ago

  • Status changed from Feedback to Resolved
  • Assignee changed from Katja Luther to Andreas Müller

The UUID and id are shown now and remove works as well.

Actions #12

Updated by Andreas Müller about 1 year ago

There is an NPE when selecting no annotation type

java.lang.NullPointerException
    at eu.etaxonomy.taxeditor.ui.section.supplemental.AnnotationDtoElement.handleEvent(AnnotationDtoElement.java:72)
    at eu.etaxonomy.taxeditor.ui.section.AbstractEntityCollectionElement.propertyChange(AbstractEntityCollectionElement.java:168)
    at eu.etaxonomy.taxeditor.ui.element.AbstractCdmFormElement.firePropertyChangeEvent(AbstractCdmFormElement.java:238)
    at eu.etaxonomy.taxeditor.ui.combo.term.TermComboElement.widgetSelected(TermComboElement.java:402)
    at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:249)

I tried to fix this on release brunch

Actions #13

Updated by Andreas Müller about 1 year ago

  • % Done changed from 50 to 70
Actions #14

Updated by Andreas Müller about 1 year ago

The first time when I removed an annotation and a marker with the same "save" only the annotation was removed. But I couldn't reproduce this.

Actions #15

Updated by Andreas Müller about 1 year ago

There is still an NPE in TermNodeDto. I tried to fix.

Caused by: java.lang.NullPointerException
    at eu.etaxonomy.cdm.persistence.dto.TermNodeDto.fromNode(TermNodeDto.java:91)
    at eu.etaxonomy.cdm.persistence.dto.TermNodeDto.fromNode(TermNodeDto.java:72)
    at eu.etaxonomy.cdm.persistence.dto.TermTreeDto.termTreeDtoListFrom(TermTreeDto.java:158)
Actions #16

Updated by Andreas Müller about 1 year ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Katja Luther

Now, no NPE is thrown anymore, but when I store an annotation with no type the text is not shown after reloading the term node. It looks like this is an issue of loading as the data is stored in the database as far as I can see.

Actions #17

Updated by Andreas Müller about 1 year ago

I tested with rem_conf_am/Areatree "Mein Tree"/Land2 => there is an annotation without type which has "Hallo empty3" as text stored in the DB.

Actions #18

Updated by Andreas Müller about 1 year ago

Andreas Müller wrote in #note-16:

Now, no NPE is thrown anymore, but when I store an annotation with no type the text is not shown after reloading the term node. It looks like this is an issue of loading as the data is stored in the database as far as I can see.

Can you have a look on this?

Actions #19

Updated by Katja Luther about 1 year ago

  • Status changed from Feedback to Resolved
  • Assignee changed from Katja Luther to Andreas Müller
Actions #20

Updated by Katja Luther about 1 year ago

Andreas Müller wrote in #note-18:

Andreas Müller wrote in #note-16:

Now, no NPE is thrown anymore, but when I store an annotation with no type the text is not shown after reloading the term node. It looks like this is an issue of loading as the data is stored in the database as far as I can see.

Can you have a look on this?

This is fixed

Actions #21

Updated by Andreas Müller about 1 year ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Katja Luther

Unfortunately still open as the NPE fix was accidentally reverted.

Actions #22

Updated by Katja Luther about 1 year ago

  • Status changed from Feedback to Resolved

The last commit was reverted, so I think now the ticket should be fixed.

Actions #23

Updated by Andreas Müller about 1 year ago

Actions #24

Updated by Andreas Müller about 1 year ago

Actions #25

Updated by Andreas Müller about 1 year ago

Actions #26

Updated by Andreas Müller about 1 year ago

  • Status changed from Resolved to Feedback
  • % Done changed from 70 to 80

Editing now fully works. Only the created/updated information is still missing.

Actions #27

Updated by Katja Luther about 1 year ago

  • Status changed from Feedback to Resolved
  • Assignee changed from Katja Luther to Andreas Müller

Andreas Müller wrote in #note-26:

Editing now fully works. Only the created/updated information is still missing.

This is available now, so I think we can close this ticket, do you want to have a final look?

Actions #28

Updated by Andreas Müller about 1 year ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Katja Luther

Only created is shown, not updated.

Actions #29

Updated by Katja Luther about 1 year ago

Andreas Müller wrote in #note-28:

Only created is shown, not updated.

this is fixed now.

Actions #30

Updated by Andreas Müller about 1 year ago

  • Status changed from Feedback to Closed
  • % Done changed from 80 to 100
Actions

Also available in: Atom PDF