Project

General

Profile

Actions

bug #10274

closed

Opening a gathering event does not work in ReferencingObjectsView

Added by Andreas Müller over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Priority13
Category:
cdmlib
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Severity:
normal
Found in Version:

Description

still need to check if this is a cdmlib issue.
Happened while trying to open the GE related to team ("Thomas D, Person#0 & Wilks") in Flore du Gabon.

last remote service : https://api.cybertaxonomy.org:443/flore-gabon/remoting/occurrence.service
last remote method : getDbSchemaVersion
last remote request client time : 2023-03-17T12:48:24.322
last remote request response header time : Fri, 17 Mar 2023 11:48:24 GMT
client error time : 2023-03-17T12:48:24.434
login : admin
editor version : 5.35.0
server : api.cybertaxonomy.org (cybertaxonomy.org) / flore-gabon
schema version : 5.35.1.0.20221218
os : Windows Server 2012 R2 6.3 amd64
java : 1.8.0_131
org.eclipse.e4.core.di.InjectionException: java.lang.IllegalArgumentException: Type specified for TypedQuery [eu.etaxonomy.cdm.model.occurrence.FieldUnit] is incompatible with query return type [class eu.etaxonomy.cdm.model.occurrence.SpecimenOrObservationBase]
    at org.eclipse.e4.core.internal.di.MethodRequestor.execute(MethodRequestor.java:65)
    at org.eclipse.e4.core.internal.di.InjectorImpl.invokeUsingClass(InjectorImpl.java:282)
    at org.eclipse.e4.core.internal.di.InjectorImpl.invokeUsingClass(InjectorImpl.java:288)
    at org.eclipse.e4.core.internal.di.InjectorImpl.invoke(InjectorImpl.java:264)
    at org.eclipse.e4.core.contexts.ContextInjectionFactory.invoke(ContextInjectionFactory.java:132)
    ... at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1519)
Caused by: java.lang.IllegalArgumentException: Type specified for TypedQuery [eu.etaxonomy.cdm.model.occurrence.FieldUnit] is incompatible with query return type [class eu.etaxonomy.cdm.model.occurrence.SpecimenOrObservationBase]
    at org.hibernate.internal.AbstractSharedSessionContract.resultClassChecking(AbstractSharedSessionContract.java:869)
    at org.hibernate.internal.AbstractSharedSessionContract.createQuery(AbstractSharedSessionContract.java:826)
    at org.hibernate.internal.AbstractSharedSessionContract.createQuery(AbstractSharedSessionContract.java:114)
    at eu.etaxonomy.cdm.persistence.dao.hibernate.occurrence.OccurrenceDaoHibernateImpl.findFieldUnitsForGatheringEvent(OccurrenceDaoHibernateImpl.java:900)
    at eu.etaxonomy.cdm.api.service.OccurrenceServiceImpl.findFieldUnitsForGatheringEvent(OccurrenceServiceImpl.java:1625)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at org.springframework.aop.support.AopUtils.invokeJoinpointUsingReflection(AopUtils.java:333)
    at org.springframework.aop.framework.ReflectiveMethodInvocation.invokeJoinpoint(ReflectiveMethodInvocation.java:190)
    at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:157)
    at org.springframework.transaction.interceptor.TransactionInterceptor$1.proceedWithInvocation(TransactionInterceptor.java:99)
    at org.springframework.transaction.interceptor.TransactionAspectSupport.invokeWithinTransaction(TransactionAspectSupport.java:283)
    at org.springframework.transaction.interceptor.TransactionInterceptor.invoke(TransactionInterceptor.java:96)
    at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:179)
    at org.springframework.aop.framework.JdkDynamicAopProxy.invoke(JdkDynamicAopProxy.java:213)
    at com.sun.proxy.$Proxy8848.findFieldUnitsForGatheringEvent(Unknown Source)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at org.springframework.aop.support.AopUtils.invokeJoinpointUsingReflection(AopUtils.java:333)
    at org.springframework.aop.framework.ReflectiveMethodInvocation.invokeJoinpoint(ReflectiveMethodInvocation.java:190)
    at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:157)
    at org.springframework.remoting.support.RemoteInvocationTraceInterceptor.invoke(RemoteInvocationTraceInterceptor.java:78)
    at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:179)
    at org.springframework.aop.framework.JdkDynamicAopProxy.invoke(JdkDynamicAopProxy.java:213)
    at com.sun.proxy.$Proxy9005.findFieldUnitsForGatheringEvent(Unknown Source)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at org.springframework.remoting.support.RemoteInvocation.invoke(RemoteInvocation.java:212)
    at eu.etaxonomy.cdm.api.remoting.DebuggingRemoteInvocationExecutor.invoke(DebuggingRemoteInvocationExecutor.java:52)
    at org.springframework.remoting.support.RemoteInvocationBasedExporter.invoke(RemoteInvocationBasedExporter.java:78)
    at org.springframework.remoting.support.RemoteInvocationBasedExporter.invokeAndCreateResult(RemoteInvocationBasedExporter.java:114)
    at org.springframework.remoting.httpinvoker.HttpInvokerServiceExporter.handleRequest(HttpInvokerServiceExporter.java:80)
    at org.springframework.web.servlet.mvc.HttpRequestHandlerAdapter.handle(HttpRequestHandlerAdapter.java:51)
    at org.springframework.web.servlet.DispatcherServlet.doDispatch(DispatcherServlet.java:967)
    at org.springframework.web.servlet.DispatcherServlet.doService(DispatcherServlet.java:901)

    ... 37 more
Actions #1

Updated by Andreas Müller over 1 year ago

  • Description updated (diff)
Actions #2

Updated by Andreas Müller over 1 year ago

The related code seems to be here:

    public List<FieldUnit> findFieldUnitsForGatheringEvent(UUID gatheringEventUuid, Integer limit, Integer start, List<OrderHint> orderHints, List<String> propertyPaths) {
        String queryString = "FROM SpecimenOrObservationBase sob "
                + "WHERE sob.gatheringEvent.uuid = :gatheringEventUuid";

        queryString += orderByClause("sob", orderHints);

        Query<FieldUnit> query = getSession().createQuery(queryString, FieldUnit.class);
        query.setParameter("gatheringEventUuid", gatheringEventUuid);

in OccurrenceDaoHibernateImpl

Actions #3

Updated by Andreas Müller over 1 year ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 70
Actions #4

Updated by Andreas Müller over 1 year ago

  • Subject changed from Opening a gathering does not work in ReferencingObjectsView to Opening a gathering event does not work in ReferencingObjectsView
Actions #5

Updated by Andreas Müller over 1 year ago

  • Priority changed from New to Priority13
Actions #6

Updated by Andreas Müller over 1 year ago

  • Target version changed from Release 5.49 to Release 5.36
Actions #7

Updated by Andreas Müller over 1 year ago

  • Assignee changed from Andreas Müller to Katja Luther

I tested with person "GatheringEvent Tester" in rem_conf_am and it worked. Can you also review?

Actions #8

Updated by Katja Luther over 1 year ago

  • Status changed from Resolved to Closed
  • Assignee changed from Katja Luther to Andreas Müller

works as expected.

Actions #9

Updated by Katja Luther over 1 year ago

  • % Done changed from 70 to 100
Actions

Also available in: Atom PDF