Project

General

Profile

Actions

feature request #10221

closed

Add form to edit the json file with cdmserver info

Added by Katja Luther about 1 year ago. Updated 11 months ago.

Status:
Closed
Priority:
Highest
Assignee:
Category:
taxeditor
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Severity:
normal

Description

For users it is difficult to find and edit the json file to add a new cdm server. Therefore we should have a form in the taxEditor to edit the json file


Files

clipboard-202303240003-okuw5.png (19.3 KB) clipboard-202303240003-okuw5.png Andreas Müller, 03/24/2023 12:03 AM

Related issues

Related to EDIT - task #10205: Update GBIF import to modern json library.ClosedKatja Luther

Actions
Related to EDIT - bug #10287: Remaining issues for Remote Server ViewClosedKatja Luther

Actions
Has duplicate EDIT - feature request #9840: Add the possibility to enter new server DuplicateKatja Luther

Actions
Actions #1

Updated by Andreas Müller about 1 year ago

  • Related to task #10205: Update GBIF import to modern json library. added
Actions #2

Updated by Katja Luther about 1 year ago

  • Status changed from New to In Progress

Added new view and edit and delete handlers, the new creation still does not work.

Actions #3

Updated by Katja Luther about 1 year ago

  • % Done changed from 0 to 40
Actions #4

Updated by Andreas Müller 12 months ago

  • Status changed from In Progress to Resolved

I put this to resolved already so we do not forget it for the release.

Actions #5

Updated by Andreas Müller 12 months ago

Is this for review already?

Actions #6

Updated by Andreas Müller 12 months ago

  • Target version changed from Release 5.44 to Release 5.36
Actions #7

Updated by Katja Luther 12 months ago

  • Assignee changed from Katja Luther to Andreas Müller

please review, the json file is now well formatted as well.

Actions #8

Updated by Andreas Müller 12 months ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Katja Luther
  • % Done changed from 40 to 60

Generally it works. Some minor issues:

  • the table should include the "check cdmlib version" value
  • the default order in the table should be the same as in the form, so first port and then prefix. Currently it is the other way round. This is also according to the order in the resulting URL
  • double click on a line in the table should open the form (same as context menu "edit")
  • for menu "new":
    • the name field should be empty, not "New "
    • the port field should be empty, not "0" (or maybe 8080, if this is the default port we use, not sure) There are so to say two default ports 443 and 8080... so I removed the port.
    • the "check cdmlib version" field should be checked
  • the "check cdmlib version" should have a "(recommended)" behind the checkbox
    • even better would be an additional warning that is shown after uncecking the checkbox saying that this is a dangerous mode as it may lead to incorrect behavior or even data corruption
    • also an idea would be to put it into an "advanced" section that opens only if requested
  • back and next buttons are not needed and should be set invisible if possible
  • maybe we should check if an entry is an exact duplicate of another entry or at least we should check that this does not lead to corruption
    • => I tested now and realized that creating an entry with a name that already exists overrides the existing entry which is dangerous behaviour as it might be unwanted, so we should not allow the creation of a new record with a name that already exists
    • => the override may even not be correctly visible in the table as it is not updated correctly in this case (another record maybe updated, not the one that was overriden)
  • entering a string that is not a number (in the valid borders) to the port field results in an error. A red warning should be shown instead and "Finish" should be disabled.
  • when deleting a record from the table the record is not removed fully but instead an empty record with default values (Name: New, port: 0) is shown => I just see that it is even written to the table, but maybe this default record creation does not happen always this seems to be fixed with the last changes as well
Actions #9

Updated by Katja Luther 12 months ago

  • Assignee changed from Katja Luther to Andreas Müller

I would create a new Ticket and would fix it for the next release. This ticket I would close so that we can do the release today.

Actions #10

Updated by Andreas Müller 11 months ago

  • Assignee changed from Andreas Müller to Katja Luther
Actions #11

Updated by Katja Luther 11 months ago

Andreas Müller wrote in #note-8:

  • when deleting a record from the table the record is not removed fully but instead an empty record with default values (Name: New, port: 0) is shown => I just see that it is even written to the table, but maybe this default record creation does not happen always

This is strange because the standard remove method for maps is used here:

cdmServerMap.remove(remoteServerName);

after this call the map contains the empty entry with key ""

Actions #12

Updated by Katja Luther 11 months ago

Andreas Müller wrote in #note-8:

  • maybe we should check if an entry is an exact duplicate of another entry or at least we should check that this does not lead to corruption
    • => I tested now and realized that creating an entry with a name that already exists overrides the existing entry which is dangerous behaviour as it might be unwanted, so we should not allow the creation of a new record with a name that already exists
    • => the override may even not be correctly visible in the table as it is not updated correctly in this case (another record maybe updated, not the one that was overriden)

I tested several times and it is right that entering the same name as an already existing entry results in an update of this entry but the table is correctly updated.
I will implement a check for the name and maybe we should ask whether the user wants to update the entry or create a new one.

Actions #13

Updated by Katja Luther 11 months ago

Katja Luther wrote in #note-12:

Andreas Müller wrote in #note-8:

  • maybe we should check if an entry is an exact duplicate of another entry or at least we should check that this does not lead to corruption
    • => I tested now and realized that creating an entry with a name that already exists overrides the existing entry which is dangerous behaviour as it might be unwanted, so we should not allow the creation of a new record with a name that already exists
    • => the override may even not be correctly visible in the table as it is not updated correctly in this case (another record maybe updated, not the one that was overriden)

I tested several times and it is right that entering the same name as an already existing entry results in an update of this entry but the table is correctly updated.
I will implement a check for the name and maybe we should ask whether the user wants to update the entry or create a new one.

This is implemented now, if the name already exists, the user gets a suggestion for another name and can decide whether he/she wants to choose this or cancel, then the wizard can be edited again.

Actions #14

Updated by Katja Luther 11 months ago

  • Status changed from Feedback to Resolved
  • Assignee changed from Katja Luther to Andreas Müller

The remaining issues will come to a new ticket.

Actions #15

Updated by Katja Luther 11 months ago

  • Related to bug #10287: Remaining issues for Remote Server View added
Actions #16

Updated by Andreas Müller 11 months ago

The current implementation seems to destroy the order of the entries (at least in some cases):

This may confuse users. Can this be fixed fast?

Actions #17

Updated by Katja Luther 11 months ago

  • Status changed from Feedback to Closed

Andreas Müller wrote in #note-16:

The current implementation seems to destroy the order of the entries (at least in some cases):

This may confuse users. Can this be fixed fast?

moved to follow up ticket, so we can close this ticket

Actions #18

Updated by Katja Luther 11 months ago

  • % Done changed from 60 to 100
Actions #19

Updated by Katja Luther 10 months ago

Actions

Also available in: Atom PDF