Project

General

Profile

Actions

bug #10190

closed

Invalid argument supplied for foreach() in order_fieldUnitDtos_by_date_and_type()

Added by Katja Luther 2 months ago. Updated about 2 months ago.

Status:
Closed
Priority:
New
Assignee:
Category:
cdm-dataportal
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Severity:
normal
Found in Version:

Actions #1

Updated by Katja Luther 2 months ago

  • Description updated (diff)
  • Category set to cdm-dataportal
  • Assignee set to Katja Luther
  • Target version changed from Unassigned CDM tickets to Release 5.36
Actions #2

Updated by Katja Luther 2 months ago

  • Description updated (diff)
Actions #3

Updated by Andreas Müller 2 months ago

  • Target version changed from Release 5.36 to Release 5.35
Actions #4

Updated by Katja Luther 2 months ago

The problem was caused by a NPE when the taxon/name of a determination was not set.

Actions #5

Updated by Katja Luther 2 months ago

  • Status changed from New to Resolved
  • Assignee changed from Katja Luther to Andreas Müller

please review

Actions #6

Updated by Andreas Müller about 2 months ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Katja Luther
  • % Done changed from 0 to 90

Generally this is fixed. The result can be seen on test e.g. at https://test.e-taxonomy.eu/dataportal/preview/cichorieae/cdm_dataportal/taxon/ecb7a76e-694a-4706-b1ab-a2eb334173ff/specimens . (the map is shown strangely here but this might be another issue)

I only shortened the null check a bit to improve readability. This is possible as taxon can't be null here. Please review and if you agree close ticket.

Actions #7

Updated by Andreas Müller about 2 months ago

  • Status changed from Feedback to Closed
  • % Done changed from 90 to 100
Actions

Also available in: Atom PDF