Project

General

Profile

Actions

bug #10137

closed

Compressed table does not show derivates anymore

Added by Andreas Müller over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Highest
Assignee:
Category:
cdm-dataportal
Target version:
Start date:
Due date:
% Done:

90%

Estimated time:
Severity:
critical
Found in Version:

Description

e.g. Campanula polyclada (https://campanula.e-taxonomy.net/cdm_dataportal/taxon/2e3aa801-7307-409c-bd39-d825f5f1e031/specimens) does not show tissue sample, DNA sample, consensu sequence and single read information anymore

It should show the following:


Files

clipboard-202209061247-ngjnp.png (37.9 KB) clipboard-202209061247-ngjnp.png Andreas Müller, 09/06/2022 12:47 PM
clipboard-202209061248-dkxev.png (12.3 KB) clipboard-202209061248-dkxev.png Andreas Müller, 09/06/2022 12:48 PM
Screenshot 2022-09-22 135610.png (29.3 KB) Screenshot 2022-09-22 135610.png Katja Luther, 09/22/2022 01:58 PM
Screenshot 2022-09-22 135327.png (42 KB) Screenshot 2022-09-22 135327.png Katja Luther, 09/22/2022 01:58 PM
Screenshot 2022-09-22 135731.png (51.2 KB) Screenshot 2022-09-22 135731.png Katja Luther, 09/22/2022 01:58 PM
Screenshot 2022-10-05 093216.png (22.9 KB) Screenshot 2022-10-05 093216.png Katja Luther, 10/05/2022 09:33 AM
clipboard-202210120904-kpfgf.png (13.2 KB) clipboard-202210120904-kpfgf.png Andreas Müller, 10/12/2022 09:04 AM

Related issues

Related to EDIT - bug #10179: Show collapse/expand icon in compressed tableNewKatja Luther

Actions
Related to EDIT - bug #10180: Write test for specimen compressed tableNewKatja Luther

Actions
Related to EDIT - bug #10397: Moving a specimen imported via ABCD to a new taxon does not show the specimen on the new taxon page but on the old one ClosedKatja Luther

Actions
Actions #1

Updated by Andreas Müller over 1 year ago

Please also check if type information is still available (I did not check)

Actions #2

Updated by Katja Luther over 1 year ago

At the first view it seems that the dto is not filled correctly.

Actions #3

Updated by Katja Luther over 1 year ago

The derivates column should contain icons for scans, DNA data or character data

see code :

            array(

              'data' => ($sob_dto->hasDna ? $sequence_icon : "") . " "

                . ($sob_dto->hasDetailImage ? $detail_image_icon : "") . " "

                . ($sob_dto->hasCharacterData ? $character_data_icon : ""),

              'class' => array('summary_row_cell', 'summary_row_icon')

            )

if this is not the case, nothing is shown

Actions #4

Updated by Andreas Müller over 1 year ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 20
Actions #5

Updated by Katja Luther over 1 year ago

This seems to be a problem of the derivedUnit or field unit DTO, because the flags hasDNA, hasImage etc are not filled correctly.

Actions #6

Updated by Katja Luther over 1 year ago

The compressed table also shows wrong data:
B 40 0042054 is shown as derivate with determination Gomphonema truncatum Ehrenb.

The correct B40er should be B 40 0041628:


B 40 0042054 has determination Surirella brebissonii Krammer & Lange-Bert.

Actions #7

Updated by Andreas Müller over 1 year ago

Katja Luther wrote in #note-6:

The compressed table also shows wrong data:
B 40 0042054 is shown as derivate with determination Gomphonema truncatum Ehrenb.

This is true. However, it is more or less a known issue and maybe even wanted. The compressed table is not made for complex multi-taxon sample derivation trees. Therefore it can not handle specimen types like material samples well. In such a case it seems to show only the preserved specimen children of a field unit and does not check if they really belong to the taxon as it expects a single taxon field unit. This behavior may be further discussed but it works well for typical higher plant derivation trees, not for algae. For algae the tree representation should be chosen as it is the case in the algae portal.

We may create a new ticket for this issue. This ticket here should only be about the regressions mentioned.

Actions #8

Updated by Andreas Müller over 1 year ago

By the way, more astonishing I find that for on https://portal.cybertaxonomy.org/algaterra-new/cdm_dataportal/taxon/cd5df62c-54dd-46e5-abee-20d119bbb6c5/specimens

Andreas Müller wrote in #note-7:

Katja Luther wrote in #note-6:

The compressed table also shows wrong data:
B 40 0042054 is shown as derivate with determination Gomphonema truncatum Ehrenb.

This is true. However, it is more or less a known issue and maybe even wanted. The compressed table is not made for complex multi-taxon sample derivation trees. Therefore it can not handle specimen types like material samples well. In such a case it seems to show only the preserved specimen children of a field unit and does not check if they really belong to the taxon as it expects a single taxon field unit. This behavior may be further discussed but it works well for typical higher plant derivation trees, not for algae. For algae the tree representation should be chosen as it is the case in the algae portal.

We may create a new ticket for this issue. This ticket here should only be about the regressions mentioned.

But I agree that this could be handled better even with the limited possibilites of the compressed table.

Actions #9

Updated by Katja Luther over 1 year ago

  • Status changed from In Progress to Resolved
  • Assignee changed from Katja Luther to Andreas Müller

I adapted the collection of the derivedUnitDtos and now all informations are shown again. Please have a look. (for example https://int.e-taxonomy.eu/dataportal/integration/reference/cdm_dataportal/taxon/d245083e-3bda-435f-9bb3-bdc2249ff23c/specimens)

Actions #10

Updated by Andreas Müller over 1 year ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Katja Luther
  • % Done changed from 20 to 80

A minor issue: the country column has a right alignent now whereas it had a middle alignement before as you can see from screenshots above. This should be adapted as it does not like nice.

Actions #11

Updated by Andreas Müller over 1 year ago

Generally it works as expected and ticket can be closed if alignment ist fixed.
I added a further derivate to field unit "Germany, Berlin, alt. 165 m, 52°31'1.2"N, 13°21'E (WGS84), 28 Mar 2016, Ehrenberg D047" to check if a specimen that is in the same tree but is not explicitly linked itself or by a parent unit does not show up in the table as it is not expected to show up.
This data change may create test problems in other tests. If so we need to decide how to handle this (delete data again or adapt tests). I started dataportal build.

Actions #12

Updated by Andreas Müller over 1 year ago

The tests did all successfully run in dataportal.
Is there already a test that fails if collection "CBFS" or label "Not linked to taxon" appears somewhere on the page? So explicitly testing that unlinked specimen are not shown.
It is ofcourse not really part of this ticket but could be helpful to avoid something like this during future refactoring.

Actions #13

Updated by Katja Luther over 1 year ago

Andreas Müller wrote in #note-10:

A minor issue: the country column has a right alignent now whereas it had a middle alignement before as you can see from screenshots above. This should be adapted as it does not like nice.

There was nothing changed, this only seems to be different, but there is an "expand column" on the left hand side and the header has no defined alignement and the data columns have centered alignement.

This is the production portal for algaterra-new, there it looks the same:

I will create a new ticket to think about how we can do this in a better way, or we still remove the "expand column", I do not know why it is there, because the expand also works if you click anywhere in the summary row.

Actions #14

Updated by Katja Luther over 1 year ago

Andreas Müller wrote in #note-12:

The tests did all successfully run in dataportal.
Is there already a test that fails if collection "CBFS" or label "Not linked to taxon" appears somewhere on the page? So explicitly testing that unlinked specimen are not shown.
It is ofcourse not really part of this ticket but could be helpful to avoid something like this during future refactoring.

I did not find any tests, but maybe it is easier to write the tests on cdmlib side, and check whether the web service returns the correct specimens.

Actions #15

Updated by Katja Luther over 1 year ago

  • Assignee changed from Katja Luther to Andreas Müller
Actions #16

Updated by Andreas Müller over 1 year ago

Katja Luther wrote in #note-13:

...
I will create a new ticket to think about how we can do this in a better way, or we still remove the "expand column", I do not know why it is there, because the expand also works if you click anywhere in the summary row.

Yes, it works, but you have to know it as a user.
The html says something about an expand icon (and collapse icon):

However, such an icon makes sense but it is not visible. So the new ticket (did you create it already? if yes please add relations to this ticket) should be about making the icons visible.

Actions #17

Updated by Andreas Müller over 1 year ago

Katja Luther wrote in #note-14:

...
I did not find any tests, but maybe it is easier to write the tests on cdmlib side, and check whether the web service returns the correct specimens.

It might be easier but it is not a fully correct integration test. What if we use another method in future then the check in the service layer is of no help.

Actions #18

Updated by Katja Luther over 1 year ago

  • Related to bug #10179: Show collapse/expand icon in compressed table added
Actions #19

Updated by Katja Luther over 1 year ago

  • Related to bug #10180: Write test for specimen compressed table added
Actions #20

Updated by Katja Luther over 1 year ago

  • Status changed from Feedback to Closed

Andreas Müller wrote in #note-17:

Katja Luther wrote in #note-14:

...
I did not find any tests, but maybe it is easier to write the tests on cdmlib side, and check whether the web service returns the correct specimens.

It might be easier but it is not a fully correct integration test. What if we use another method in future then the check in the service layer is of no help.

created a new ticket.

Actions #21

Updated by Andreas Müller 5 months ago

  • Related to bug #10397: Moving a specimen imported via ABCD to a new taxon does not show the specimen on the new taxon page but on the old one added
Actions

Also available in: Atom PDF