Project

General

Profile

Actions

bug #10068

closed

Changing focus to accepted taxon does not work

Added by Katja Luther 8 months ago. Updated 27 days ago.

Status:
Closed
Priority:
Highest
Category:
taxeditor
Target version:
Start date:
Due date:
% Done:

70%

Estimated time:
Severity:
normal
Found in Version:

Description

After opening a the name editor with focus on a synonym, the change of focus to the accepted taxon does not work, respectively not before changing the focus to another synonym and then to the accepted taxon.

mail ERS:

Hallo zusammen,

folgendes ist mir und meinen Studenten aufgefallen:

wenn ich im Taxeditor nach einem Namen suche, der sich als Synonym herausstellt, öffnet sich der Freitexteditor so, dass der gesuchte Name (das Synonym) aktiv ist. Daher werden mir an dieser Stelle keine Faktendaten zum akzeptierten Taxon angezeigt. Die möchte ich aber sehen, weil ich ja klassischerweise nach einem Namen suche, um dann neue Faktendaten (z.B. Verbreitungsdaten) zum akzeptierten Taxon eingeben zu können.

Um das tun zu können, versuche ich jetzt nach der Suche, die erste Zeile im Freitexteditor (das akzeptierte Taxon) zu aktivieren, indem ich mit dem Cursor in die erste Zeile gehe und doppelklicke. An der Stelle vermute ich einen echten bug;
Denn Doppelklicken auf den akzeptierten Namen zeigt überhaupt keine Wirkung. Doppelklicken auf jedes andere Synonym aktiviert dieses, und danach kann auch der akzeptierte Name durch Doppelklicken aktiviert werden. Ich möchte diesen aber gleich im ersten Schritt aktivieren, damit ich sofort Faktendaten eingeben kann. Dieses Verhalten ist auch für die Dateneingabe durch Studenten sehr wichtig.

Könnt ihr das beschriebene Verhalten des Editors nachvollziehen? Ein Beispiel für ein Synonym wäre Evax pygmaea. Faktendaten möchte ich anschließend sofort zum akzeptierten Namen Filago pygmaea eingeben.


Related issues

Related to EDIT - bug #8953: Focus not correctly evaluated for details view when switching between namesResolvedAndreas Müller

Actions
Related to EDIT - bug #10138: Details view is not updated after freetext changeClosedKatja Luther

Actions
Related to EDIT - bug #10186: Problems with session handling in taxeditorClosedKatja Luther

Actions
Actions #1

Updated by Katja Luther 8 months ago

  • Target version changed from Unassigned CDM tickets to Release 5.36
Actions #2

Updated by Katja Luther about 1 month ago

  • Status changed from New to Feedback
  • Assignee changed from Katja Luther to Andreas Müller
  • Target version changed from Release 5.36 to Release 5.35

This issue seems to be solved by #10138 and/or #10186. We can remove the version or set it to the current milestone (5.35).

Actions #3

Updated by Andreas Müller about 1 month ago

  • Assignee changed from Andreas Müller to Katja Luther

Katja Luther wrote in #note-2:

This issue seems to be solved by #10138 and/or #10186. We can remove the version or set it to the current milestone (5.35).

Hmm, I still can reproduce this. It happens only after opening the synonym and first time click (single or double click) on the accepted taxon. Maybe this is related to the fact that the synonym is not really selected (no blue focus) but only shown in the DetailsView.

Actions #4

Updated by Andreas Müller about 1 month ago

  • Related to bug #8953: Focus not correctly evaluated for details view when switching between names added
Actions #5

Updated by Andreas Müller about 1 month ago

  • Related to bug #10138: Details view is not updated after freetext change added
Actions #6

Updated by Andreas Müller about 1 month ago

  • Related to bug #10186: Problems with session handling in taxeditor added
Actions #7

Updated by Katja Luther about 1 month ago

  • Status changed from Feedback to New
  • Target version changed from Release 5.35 to Release 5.36

ok,then we keep it in 5.36

Actions #8

Updated by Andreas Müller about 1 month ago

  • Status changed from New to Resolved
  • Priority changed from New to Highest
  • Target version changed from Release 5.36 to Release 5.35
  • % Done changed from 0 to 70

fixed with commit:a5a95b645c5976. Please review. It also solves the issue that when opening the Taxon Editor the focus is not set / not visible. Was there another ticket for this? I did not find any.

Actions #9

Updated by Katja Luther 27 days ago

  • Status changed from Resolved to Closed
  • Assignee changed from Katja Luther to Andreas Müller

This works now.

Actions

Also available in: Atom PDF