removed plugins that were accidentally checked into version control
authorn.hoffmann <n.hoffmann@localhost>
Wed, 5 Aug 2009 14:56:45 +0000 (14:56 +0000)
committern.hoffmann <n.hoffmann@localhost>
Wed, 5 Aug 2009 14:56:45 +0000 (14:56 +0000)
89 files changed:
.gitattributes
taxeditor-updateSite/artifacts.xml [deleted file]
taxeditor-updateSite/content.xml [deleted file]
taxeditor-updateSite/features/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/META-INF/MANIFEST.MF [deleted file]
taxeditor-updateSite/features/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/feature.xml [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/META-INF/MANIFEST.MF [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/cdmlib-io-2.1src.zip [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/cdmlib-model-2.1.jar [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/cdmlib-model-2.1src.zip [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/cdmlib-persistence-2.1-tests.jar [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/cdmlib-persistence-2.1.jar [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/cdmlib-persistence-2.1src.zip [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/cdmlib-services-2.1.jar [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/cdmlib-services-2.1src.zip [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/cglib-2.1.3.jar [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/commons-collections-3.2.jar [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/commons-logging-1.0.4.jar [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/dom4j-1.6.1.jar [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/ehcache-1.2.3.jar [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/ejb3-persistence.jar [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/h2-1.0.73.jar [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/hibernate-annotations-3.4.0-SNAPSHOT-sources.jar [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/hibernate-annotations-3.4.0-SNAPSHOT.jar [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/hibernate-commons-annotations-3.4.0-SNAPSHOT-sources.jar [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/hibernate-commons-annotations-3.4.0-SNAPSHOT.jar [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/hibernate-core-3.4.0-SNAPSHOT-sources.jar [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/hibernate-core-3.4.0-SNAPSHOT.jar [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/hibernate-envers-3.4.0-SNAPSHOT-sources.jar [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/hibernate-envers-3.4.0-SNAPSHOT.jar [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/hibernate-search-3.1.0.GA-sources.jar [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/hibernate-search-3.1.0.GA.jar [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/hibernate-tools-3.2.0.ga.jar [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/hibernate-validator-3.1.0.GA.jar [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/hsqldb.jar [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/javassist.jar [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/jaxb-api.jar [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/jaxb-impl-2.0.jar [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/jdbc-1.2.jar [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/jdbc2_0-stdext.jar [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/jdom-1.0.jar [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/joda-time-1.5.jar [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/joda-time-hibernate-1.0.jar [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/jsr250-api-1.0.jar [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/jta.jar [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/jtds-1.2.2.jar [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/junit-4.4.jar [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/log4j-1.2.14.jar [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/log4j-1.2.14src.zip [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/lsid-client-1.1.2.jar [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/lsid-server-1.1.2.jar [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/lucene-core-2.4.0.jar [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/lucene-spellchecker-2.4.0.jar [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/mysql-connector-java-3.1.14-bin.jar [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/opencsv-1.8.jar [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/plugin.xml [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/poi-3.1-FINAL.jar [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/postgresql-8.2-504.jdbc4.jar [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/sanselan-0.94-incubator.jar [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/slf4j-api-1.5.2.jar [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/slf4j-log4j12-1.5.2.jar [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/spring-2.5.6.jar [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/spring-agent-2.5.6.jar [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/spring-aop-2.5.6.jar [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/spring-aop-2.5src.zip [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/spring-aspects-2.5.6.jar [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/spring-beans-2.5.6.jar [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/spring-beans-2.5src.zip [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/spring-context-2.5.6.jar [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/spring-context-2.5src.zip [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/spring-context-support-2.5src.zip [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/spring-core-2.5.6.jar [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/spring-core-2.5src.zip [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/spring-jdbc-2.5.6.jar [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/spring-jdbc-2.5src.zip [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/spring-modules-lucene-0.8a.jar [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/spring-orm-2.5.6.jar [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/spring-orm-2.5src.zip [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/spring-security-core-2.0.4-tests.jar [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/spring-security-core-2.0.4.jar [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/spring-test-2.5.6.jar [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/spring-test-2.5src.zip [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/spring-tx-2.5src.zip [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/spring-web-2.5.6.jar [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/spring-webmvc-2.5.6.jar [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/unitils-1.0.jar [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/wsdl4j-1.6.1.jar [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/xercesImpl.jar [deleted file]
taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/xml-apis.jar [deleted file]
taxeditor-updateSite/site.xml

index b456283ba3635d821b237e23bafe48cce6e91a81..d6cfd162b1cc45348c697227c2fb6d5d7e2523bd 100644 (file)
@@ -1157,95 +1157,8 @@ taxeditor-store/src/test/resources/eu/etaxonomy/taxeditor/store/ConcurrentSessio
 taxeditor-store/src/test/resources/log4j.properties -text
 taxeditor-store/src/test/resources/unitils.properties -text
 taxeditor-updateSite/.project -text
-taxeditor-updateSite/artifacts.xml -text
-taxeditor-updateSite/content.xml -text
-taxeditor-updateSite/features/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/META-INF/MANIFEST.MF -text
-taxeditor-updateSite/features/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/feature.xml -text
 taxeditor-updateSite/index.html -text
 taxeditor-updateSite/logs.zip -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/META-INF/MANIFEST.MF -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/cdmlib-io-2.1src.zip -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/cdmlib-model-2.1.jar -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/cdmlib-model-2.1src.zip -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/cdmlib-persistence-2.1-tests.jar -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/cdmlib-persistence-2.1.jar -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/cdmlib-persistence-2.1src.zip -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/cdmlib-services-2.1.jar -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/cdmlib-services-2.1src.zip -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/cglib-2.1.3.jar -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/commons-collections-3.2.jar -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/commons-logging-1.0.4.jar -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/dom4j-1.6.1.jar -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/ehcache-1.2.3.jar -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/ejb3-persistence.jar -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/h2-1.0.73.jar -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/hibernate-annotations-3.4.0-SNAPSHOT-sources.jar -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/hibernate-annotations-3.4.0-SNAPSHOT.jar -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/hibernate-commons-annotations-3.4.0-SNAPSHOT-sources.jar -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/hibernate-commons-annotations-3.4.0-SNAPSHOT.jar -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/hibernate-core-3.4.0-SNAPSHOT-sources.jar -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/hibernate-core-3.4.0-SNAPSHOT.jar -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/hibernate-envers-3.4.0-SNAPSHOT-sources.jar -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/hibernate-envers-3.4.0-SNAPSHOT.jar -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/hibernate-search-3.1.0.GA-sources.jar -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/hibernate-search-3.1.0.GA.jar -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/hibernate-tools-3.2.0.ga.jar -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/hibernate-validator-3.1.0.GA.jar -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/hsqldb.jar -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/javassist.jar -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/jaxb-api.jar -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/jaxb-impl-2.0.jar -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/jdbc-1.2.jar -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/jdbc2_0-stdext.jar -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/jdom-1.0.jar -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/joda-time-1.5.jar -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/joda-time-hibernate-1.0.jar -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/jsr250-api-1.0.jar -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/jta.jar -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/jtds-1.2.2.jar -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/junit-4.4.jar -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/log4j-1.2.14.jar -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/log4j-1.2.14src.zip -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/lsid-client-1.1.2.jar -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/lsid-server-1.1.2.jar -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/lucene-core-2.4.0.jar -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/lucene-spellchecker-2.4.0.jar -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/mysql-connector-java-3.1.14-bin.jar -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/opencsv-1.8.jar -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/plugin.xml -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/poi-3.1-FINAL.jar -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/postgresql-8.2-504.jdbc4.jar -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/sanselan-0.94-incubator.jar -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/slf4j-api-1.5.2.jar -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/slf4j-log4j12-1.5.2.jar -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/spring-2.5.6.jar -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/spring-agent-2.5.6.jar -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/spring-aop-2.5.6.jar -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/spring-aop-2.5src.zip -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/spring-aspects-2.5.6.jar -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/spring-beans-2.5.6.jar -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/spring-beans-2.5src.zip -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/spring-context-2.5.6.jar -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/spring-context-2.5src.zip -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/spring-context-support-2.5src.zip -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/spring-core-2.5.6.jar -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/spring-core-2.5src.zip -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/spring-jdbc-2.5.6.jar -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/spring-jdbc-2.5src.zip -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/spring-modules-lucene-0.8a.jar -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/spring-orm-2.5.6.jar -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/spring-orm-2.5src.zip -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/spring-security-core-2.0.4-tests.jar -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/spring-security-core-2.0.4.jar -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/spring-test-2.5.6.jar -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/spring-test-2.5src.zip -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/spring-tx-2.5src.zip -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/spring-web-2.5.6.jar -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/spring-webmvc-2.5.6.jar -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/unitils-1.0.jar -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/wsdl4j-1.6.1.jar -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/xercesImpl.jar -text
-taxeditor-updateSite/plugins/eu.etaxonomy.cdmLibrary_2.1.0.v20090625-1925/xml-apis.jar -text
 taxeditor-updateSite/site.xml -text
 taxeditor-updateSite/web/site.css -text
 taxeditor-updateSite/web/site.xsl -text
diff --git a/taxeditor-updateSite/artifacts.xml b/taxeditor-updateSite/artifacts.xml
deleted file mode 100644 (file)
index d8dca7b..0000000
+++ /dev/null
@@ -1,713 +0,0 @@
-<?xml version='1.0' encoding='UTF-8'?>\r
-<?artifactRepository class='org.eclipse.equinox.internal.p2.artifact.repository.simple.SimpleArtifactRepository' version='1.0.0'?>\r
-<repository name='file:/Users/nho/Documents/workspace/taxeditor/taxeditor-updateSite/ - artifacts' type='org.eclipse.equinox.p2.artifact.repository.simpleRepository' version='1.0.0'>\r
-  <properties size='2'>\r
-    <property name='p2.compressed' value='false'/>\r
-    <property name='p2.timestamp' value='1247066741761'/>\r
-  </properties>\r
-  <mappings size='3'>\r
-    <rule filter='(&amp; (classifier=osgi.bundle))' output='${repoUrl}/plugins/${id}_${version}.jar'/>\r
-    <rule filter='(&amp; (classifier=binary))' output='${repoUrl}/binary/${id}_${version}'/>\r
-    <rule filter='(&amp; (classifier=org.eclipse.update.feature))' output='${repoUrl}/features/${id}_${version}.jar'/>\r
-  </mappings>\r
-  <artifacts size='102'>\r
-    <artifact classifier='osgi.bundle' id='eu.etaxonomy.taxeditor.navigation' version='2.0.0.v20090617-1416'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='64076'/>\r
-        <property name='download.size' value='64076'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='org.eclipse.update.feature' id='eu.etaxonomy.taxeditor' version='2.0.0.v20090708-1713'>\r
-      <properties size='2'>\r
-        <property name='artifact.size' value='841'/>\r
-        <property name='download.size' value='841'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='org.eclipse.osgi.services' version='3.1.200.v20071203'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='63665'/>\r
-        <property name='download.size' value='63665'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='org.eclipse.ui.carbon' version='4.0.0.I20080610-1200'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='15178'/>\r
-        <property name='download.size' value='15178'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='org.eclipse.update.feature' id='eu.etaxonomy.cdmLibrary' version='2.1.0.v20090612_1250'>\r
-      <properties size='2'>\r
-        <property name='artifact.size' value='760'/>\r
-        <property name='download.size' value='760'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='org.eclipse.equinox.common' version='3.4.0.v20080421-2006'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='94649'/>\r
-        <property name='download.size' value='94649'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='org.eclipse.update.feature' id='eu.etaxonomy.taxeditor.feature.dependencies' version='2.0.0.v200906021611'>\r
-      <properties size='2'>\r
-        <property name='artifact.size' value='1646'/>\r
-        <property name='download.size' value='1646'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='org.eclipse.core.filesystem.win32.x86' version='1.1.0.v20080604-1400'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='16971'/>\r
-        <property name='download.size' value='16971'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='org.eclipse.equinox.security.macosx' version='1.0.0.v20080602-2000'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='13697'/>\r
-        <property name='download.size' value='13697'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='eu.etaxonomy.taxeditor.store' version='2.0.0.v20090701-1323'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='679785'/>\r
-        <property name='download.size' value='679785'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='org.eclipse.core.filebuffers' version='3.4.0.v20080603-2000'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='112005'/>\r
-        <property name='download.size' value='112005'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='org.eclipse.ui.ide' version='3.4.2.M20090127-1700'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='2035254'/>\r
-        <property name='download.size' value='2035254'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='eu.etaxonomy.taxeditor.application' version='2.0.0.v20090708-1713'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='251128'/>\r
-        <property name='download.size' value='251128'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='org.eclipse.core.resources' version='3.4.2.R34x_v20090126'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='700059'/>\r
-        <property name='download.size' value='700059'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='org.eclipse.jface' version='3.4.2.M20090107-0800'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='1041252'/>\r
-        <property name='download.size' value='1041252'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='eu.etaxonomy.taxeditor.navigation' version='2.0.0.v20090603_1757'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='44055'/>\r
-        <property name='download.size' value='44055'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='org.eclipse.core.net' version='1.1.0.I20080604'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='55332'/>\r
-        <property name='download.size' value='55332'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='eu.etaxonomy.cdmLibrary' version='2.1.0.v20090603_1459'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='49295539'/>\r
-        <property name='download.size' value='49295539'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='org.eclipse.ui.views.properties.tabbed' version='3.4.2.M20090127-1700'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='102473'/>\r
-        <property name='download.size' value='102473'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='org.eclipse.core.commands' version='3.4.0.I20080509-2000'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='105794'/>\r
-        <property name='download.size' value='105794'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='org.eclipse.update.feature' id='eu.etaxonomy.cdmLibrary' version='2.1.0.v20090625-1925'>\r
-      <properties size='2'>\r
-        <property name='artifact.size' value='760'/>\r
-        <property name='download.size' value='760'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='org.eclipse.osgi' version='3.4.3.R34x_v20081215-1030'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='997240'/>\r
-        <property name='download.size' value='997240'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='eu.etaxonomy.cdmLibrary' version='2.1.0.v20090625-1925'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='49632730'/>\r
-        <property name='download.size' value='49632730'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='eu.etaxonomy.taxeditor.navigation' version='2.0.0.v20090708-1633'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='74781'/>\r
-        <property name='download.size' value='74781'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='org.eclipse.ui' version='3.4.2.M20090204-0800'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='145333'/>\r
-        <property name='download.size' value='145333'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='org.eclipse.pde.source' version='3.4.0.v20080603'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='13865'/>\r
-        <property name='download.size' value='13865'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='org.eclipse.update.core' version='3.2.202.R34x_v20081128'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='605282'/>\r
-        <property name='download.size' value='605282'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='eu.etaxonomy.taxeditor.application' version='2.0.0.v20090701-1323'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='251130'/>\r
-        <property name='download.size' value='251130'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='eu.etaxonomy.taxeditor.store' version='2.0.0.v20090603_1757'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='635984'/>\r
-        <property name='download.size' value='635984'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='eu.etaxonomy.taxeditor.editor' version='2.0.0.v20090708-1713'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='852196'/>\r
-        <property name='download.size' value='852196'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='org.eclipse.ui.forms' version='3.3.103.v20081027_34x'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='298080'/>\r
-        <property name='download.size' value='298080'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='org.eclipse.core.databinding' version='1.1.1.M20080827-0800b'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='347799'/>\r
-        <property name='download.size' value='347799'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='org.eclipse.ui.navigator' version='3.3.102.M20090127-1700'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='319920'/>\r
-        <property name='download.size' value='319920'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='org.eclipse.equinox.simpleconfigurator' version='1.0.0.v20080604'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='34117'/>\r
-        <property name='download.size' value='34117'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='org.eclipse.equinox.registry' version='3.4.0.v20080516-0950'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='172936'/>\r
-        <property name='download.size' value='172936'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='org.eclipse.text' version='3.4.0.v20080605-1800'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='244646'/>\r
-        <property name='download.size' value='244646'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='org.eclipse.update.feature' id='eu.etaxonomy.cdmLibrary' version='2.1.0.v20090603_1459'>\r
-      <properties size='2'>\r
-        <property name='artifact.size' value='761'/>\r
-        <property name='download.size' value='761'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='eu.etaxonomy.cdmLibrary' version='2.1.0.v20090708-1712'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='70148867'/>\r
-        <property name='download.size' value='70148867'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='eu.etaxonomy.taxeditor.application' version='2.0.0.v20090617-1416'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='251023'/>\r
-        <property name='download.size' value='251023'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='org.eclipse.core.jobs' version='3.4.1.R34x_v20081128'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='82559'/>\r
-        <property name='download.size' value='82559'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='org.eclipse.core.resources.win32.x86' version='3.4.0.v20071204'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='15751'/>\r
-        <property name='download.size' value='15751'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='eu.etaxonomy.cdmLibrary' version='2.1.0.v20090625-1925'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='0'/>\r
-        <property name='download.size' value='0'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='eu.etaxonomy.taxeditor.store' version='2.0.0.v20090708-1713'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='704116'/>\r
-        <property name='download.size' value='704116'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='eu.etaxonomy.taxeditor.navigation' version='2.0.0.v20090701-1323'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='71833'/>\r
-        <property name='download.size' value='71833'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='org.eclipse.update.ui' version='3.2.101.R34x_v20081128'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='510047'/>\r
-        <property name='download.size' value='510047'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='org.eclipse.update.core.win32' version='3.2.100.v20080107'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='85078'/>\r
-        <property name='download.size' value='85078'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='javax.servlet' version='2.4.0.v200806031604'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='107637'/>\r
-        <property name='download.size' value='107637'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='org.junit4' version='4.3.1'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='107603'/>\r
-        <property name='download.size' value='107603'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='eu.etaxonomy.taxeditor.navigation' version='2.0.0.v20090708-1713'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='73251'/>\r
-        <property name='download.size' value='73251'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='org.eclipse.core.variables' version='3.2.100.v20080529-1300'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='31172'/>\r
-        <property name='download.size' value='31172'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='org.eclipse.ant.core' version='3.2.0.v20080529'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='95496'/>\r
-        <property name='download.size' value='95496'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='org.eclipse.swt' version='3.4.2.v3452b'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='15811'/>\r
-        <property name='download.size' value='15811'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='org.eclipse.core.expressions' version='3.4.1.r342_v20081203-0800'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='86182'/>\r
-        <property name='download.size' value='86182'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='org.eclipse.equinox.app' version='1.1.0.v20080421-2006'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='79866'/>\r
-        <property name='download.size' value='79866'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='org.eclipse.update.configurator' version='3.2.201.R34x_v20080819'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='97995'/>\r
-        <property name='download.size' value='97995'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='org.eclipse.ui.workbench' version='3.4.2.M20090127-1700'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='3928086'/>\r
-        <property name='download.size' value='3928086'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='org.eclipse.ui.editors' version='3.4.0.v20080603-2000'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='549393'/>\r
-        <property name='download.size' value='549393'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='org.eclipse.update.feature' id='eu.etaxonomy.taxeditor' version='2.0.0.v20090617-1416'>\r
-      <properties size='2'>\r
-        <property name='artifact.size' value='846'/>\r
-        <property name='download.size' value='846'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='org.eclipse.ui.views' version='3.3.1.M20081112-0800'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='79527'/>\r
-        <property name='download.size' value='79527'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='org.eclipse.core.filesystem' version='1.2.0.v20080604-1400'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='44111'/>\r
-        <property name='download.size' value='44111'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='org.eclipse.equinox.preferences' version='3.2.201.R34x_v20080709'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='104280'/>\r
-        <property name='download.size' value='104280'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='org.eclipse.swt.win32.win32.x86' version='3.4.1.v3452b'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='2123582'/>\r
-        <property name='download.size' value='2123582'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='org.eclipse.update.feature' id='eu.etaxonomy.taxeditor.feature.dependencies' version='2.0.0.v20090617-1416'>\r
-      <properties size='2'>\r
-        <property name='artifact.size' value='1702'/>\r
-        <property name='download.size' value='1702'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='org.eclipse.help' version='3.3.102.v20081014_34x'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='216711'/>\r
-        <property name='download.size' value='216711'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='javax.servlet' version='2.5.0.v200806031605'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='117842'/>\r
-        <property name='download.size' value='117842'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='eu.etaxonomy.taxeditor.editor' version='2.0.0.v20090701-1323'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='822263'/>\r
-        <property name='download.size' value='822263'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='eu.etaxonomy.taxeditor.store' version='2.0.0.v20090701-1323'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='679716'/>\r
-        <property name='download.size' value='679716'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='eu.etaxonomy.taxeditor.editor' version='2.0.0.v20090617-1416'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='804890'/>\r
-        <property name='download.size' value='804890'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='org.eclipse.core.runtime.compatibility.auth' version='3.2.100.v20070502'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='21215'/>\r
-        <property name='download.size' value='21215'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='org.eclipse.core.resources.compatibility' version='3.4.0.v20080604-1400'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='120997'/>\r
-        <property name='download.size' value='120997'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='org.eclipse.update.feature' id='eu.etaxonomy.cdmLibrary' version='2.1.0.v20090708-1712'>\r
-      <properties size='2'>\r
-        <property name='artifact.size' value='760'/>\r
-        <property name='download.size' value='760'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='org.eclipse.core.databinding.beans' version='1.1.1.M20080827-0800a'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='60279'/>\r
-        <property name='download.size' value='60279'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='org.eclipse.core.contenttype' version='3.3.0.v20080604-1400'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='86969'/>\r
-        <property name='download.size' value='86969'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='eu.etaxonomy.taxeditor.application' version='2.0.0.v20090603_1756'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='250950'/>\r
-        <property name='download.size' value='250950'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='org.eclipse.update.feature' id='eu.etaxonomy.cdmLibrary' version='2.1.0.v20090708-1452'>\r
-      <properties size='2'>\r
-        <property name='artifact.size' value='760'/>\r
-        <property name='download.size' value='760'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='org.eclipse.ui.workbench.texteditor' version='3.4.1.r341_v20080827-1100'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='573914'/>\r
-        <property name='download.size' value='573914'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='org.eclipse.swt.carbon.macosx' version='3.4.1.v3452b'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='1852342'/>\r
-        <property name='download.size' value='1852342'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='org.eclipse.core.runtime' version='3.4.0.v20080512'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='69019'/>\r
-        <property name='download.size' value='69019'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='eu.etaxonomy.cdmLibrary' version='2.1.0.v20090612_1250'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='49336587'/>\r
-        <property name='download.size' value='49336587'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='org.eclipse.update.feature' id='eu.etaxonomy.taxeditor' version='2.0.0.v20090603_1757'>\r
-      <properties size='2'>\r
-        <property name='artifact.size' value='841'/>\r
-        <property name='download.size' value='841'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='eu.etaxonomy.taxeditor.store' version='2.0.0.v20090708-1633'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='704115'/>\r
-        <property name='download.size' value='704115'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='org.eclipse.jface.databinding' version='1.2.1.M20080827-0800a'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='196505'/>\r
-        <property name='download.size' value='196505'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='org.eclipse.ui.navigator.resources' version='3.3.101.M20080910-0800'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='115744'/>\r
-        <property name='download.size' value='115744'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='eu.etaxonomy.taxeditor.application' version='2.0.0.v20090708-1633'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='251258'/>\r
-        <property name='download.size' value='251258'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='eu.etaxonomy.taxeditor.editor' version='2.0.0.v20090603_1756'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='743066'/>\r
-        <property name='download.size' value='743066'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='eu.etaxonomy.taxeditor.store' version='2.0.0.v20090617-1416'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='649523'/>\r
-        <property name='download.size' value='649523'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='org.eclipse.core.net.win32.x86' version='1.0.0.I20080521'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='28449'/>\r
-        <property name='download.size' value='28449'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='org.eclipse.update.feature' id='eu.etaxonomy.taxeditor.feature.dependencies' version='2.0.0.v20090701-1323'>\r
-      <properties size='2'>\r
-        <property name='artifact.size' value='1702'/>\r
-        <property name='download.size' value='1702'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='org.eclipse.equinox.security' version='1.0.1.R34x_v20080721'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='104720'/>\r
-        <property name='download.size' value='104720'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='org.eclipse.update.feature' id='eu.etaxonomy.taxeditor.feature.dependencies' version='2.0.0.v20090708-1713'>\r
-      <properties size='2'>\r
-        <property name='artifact.size' value='1702'/>\r
-        <property name='download.size' value='1702'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='org.eclipse.core.filesystem.macosx' version='1.0.0.v20080604-1400'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='9594'/>\r
-        <property name='download.size' value='9594'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='org.eclipse.ui.win32' version='3.2.100.v20080408-0800'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='23398'/>\r
-        <property name='download.size' value='23398'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='eu.etaxonomy.taxeditor.editor' version='2.0.0.v20090708-1633'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='852196'/>\r
-        <property name='download.size' value='852196'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='org.eclipse.update.feature' id='eu.etaxonomy.taxeditor.feature.dependencies' version='2.0.0.v20090708-1633'>\r
-      <properties size='2'>\r
-        <property name='artifact.size' value='1702'/>\r
-        <property name='download.size' value='1702'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='org.eclipse.jface.text' version='3.4.2.r342_v20081119-0800'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='945619'/>\r
-        <property name='download.size' value='945619'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='org.eclipse.update.feature' id='eu.etaxonomy.taxeditor' version='2.0.0.v20090701-1323'>\r
-      <properties size='2'>\r
-        <property name='artifact.size' value='847'/>\r
-        <property name='download.size' value='847'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='com.ibm.icu' version='3.8.1.v20080530'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='4467363'/>\r
-        <property name='download.size' value='4467363'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='eu.etaxonomy.cdmLibrary' version='2.1.0.v20090708-1452'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='70033490'/>\r
-        <property name='download.size' value='70033490'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='org.eclipse.update.feature' id='eu.etaxonomy.taxeditor' version='2.0.0.v20090708-1633'>\r
-      <properties size='2'>\r
-        <property name='artifact.size' value='844'/>\r
-        <property name='download.size' value='844'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='org.eclipse.update.feature' id='eu.etaxonomy.cdmLibrary' version='2.1.0.v20090625-1925'>\r
-      <properties size='2'>\r
-        <property name='artifact.size' value='0'/>\r
-        <property name='download.size' value='0'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='org.eclipse.equinox.security.win32.x86' version='1.0.0.v20080529-1600'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='21778'/>\r
-        <property name='download.size' value='21778'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-    <artifact classifier='osgi.bundle' id='org.eclipse.core.runtime.compatibility.registry' version='3.2.200.v20080610'>\r
-      <properties size='3'>\r
-        <property name='artifact.size' value='13892'/>\r
-        <property name='download.size' value='13892'/>\r
-        <property name='download.contentType' value='application/zip'/>\r
-      </properties>\r
-    </artifact>\r
-  </artifacts>\r
-</repository>\r
diff --git a/taxeditor-updateSite/content.xml b/taxeditor-updateSite/content.xml
deleted file mode 100644 (file)
index d963065..0000000
+++ /dev/null
@@ -1,6143 +0,0 @@
-<?xml version='1.0' encoding='UTF-8'?>\r
-<?metadataRepository class='org.eclipse.equinox.internal.p2.metadata.repository.LocalMetadataRepository' version='1.0.0'?>\r
-<repository name='file:/Users/nho/Documents/workspace/taxeditor/taxeditor-updateSite/ - metadata' type='org.eclipse.equinox.internal.p2.metadata.repository.LocalMetadataRepository' version='1.0.0'>\r
-  <properties size='2'>\r
-    <property name='p2.compressed' value='false'/>\r
-    <property name='p2.timestamp' value='1247066741777'/>\r
-  </properties>\r
-  <references size='2'>\r
-    <repository url='http://wp5.e-taxonomy.eu/taxeditor/update' type='1' options='0'/>\r
-    <repository url='http://wp5.e-taxonomy.eu/taxeditor/update' type='0' options='0'/>\r
-  </references>\r
-  <units size='135'>\r
-    <unit id='eu.etaxonomy.taxeditor.application' version='2.0.0.v20090603_1756'>\r
-      <update id='eu.etaxonomy.taxeditor.application' range='[0.0.0,2.0.0.v20090603_1756)' severity='0'/>\r
-      <properties size='2'>\r
-        <property name='org.eclipse.equinox.p2.name' value='EDIT Taxonomic Editor'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='EDIT'/>\r
-      </properties>\r
-      <provides size='4'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='eu.etaxonomy.taxeditor.application' version='2.0.0.v20090603_1756'/>\r
-        <provided namespace='osgi.bundle' name='eu.etaxonomy.taxeditor.application' version='2.0.0.v20090603_1756'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor' version='0.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' version='1.0.0'/>\r
-      </provides>\r
-      <requires size='8'>\r
-        <required namespace='osgi.bundle' name='org.eclipse.ui' range='3.4.1'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.ui.ide' range='3.4.1'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.runtime' range='3.4.0'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.resources' range='3.4.1'/>\r
-        <required namespace='osgi.bundle' name='eu.etaxonomy.cdmLibrary' range='2.0.0'/>\r
-        <required namespace='osgi.bundle' name='eu.etaxonomy.taxeditor.store' range='1.0.0'/>\r
-        <required namespace='osgi.bundle' name='eu.etaxonomy.taxeditor.editor' range='1.0.0'/>\r
-        <required namespace='osgi.bundle' name='eu.etaxonomy.taxeditor.navigation' range='1.0.0'/>\r
-      </requires>\r
-      <artifacts size='1'>\r
-        <artifact classifier='osgi.bundle' id='eu.etaxonomy.taxeditor.application' version='2.0.0.v20090603_1756'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='1'>\r
-          <instruction key='manifest'>\r
-            Bundle-ManifestVersion: 2&#xA;Export-Package: eu.etaxonomy.taxeditor&#xA;Bundle-RequiredExecutionEnvironment: J2SE-1.5&#xA;Bundle-Localization: plugin&#xA;Require-Bundle: org.eclipse.ui;bundle-version=&quot;3.4.1&quot;,org.eclipse.ui.ide;bundle-version=&quot;3.4.1&quot;,org.eclipse.core.runtime;bundle-version=&quot;3.4.0&quot;,org.eclipse.core.resources;bundle-version=&quot;3.4.1&quot;,eu.etaxonomy.cdmLibrary;bundle-version=&quot;2.0.0&quot;,eu.etaxonomy.taxeditor.store;bundle-version=&quot;1.0.0&quot;,eu.etaxonomy.taxeditor.editor;bundle-version=&quot;1.0.0&quot;,eu.etaxonomy.taxeditor.navigation;bundle-version=&quot;1.0.0&quot;&#xA;Bundle-Activator: eu.etaxonomy.taxeditor.TaxonomicEditorPlugin&#xA;Bundle-Name: EDIT Taxonomic Editor&#xA;Bundle-Version: 2.0.0.v20090603_1756&#xA;Bundle-Vendor: EDIT&#xA;Bundle-SymbolicName: eu.etaxonomy.taxeditor.application;singleton:=true&#xA;Bundle-ActivationPolicy: lazy&#xA;Manifest-Version: 1.0\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='eu.etaxonomy.taxeditor.feature.dependencies.feature.group' version='2.0.0.v200906021611' singleton='false'>\r
-      <update id='eu.etaxonomy.taxeditor.feature.dependencies.feature.group' range='[0.0.0,2.0.0.v200906021611)' severity='0'/>\r
-      <properties size='4'>\r
-        <property name='org.eclipse.equinox.p2.name' value='Taxeditor Dependencies'/>\r
-        <property name='org.eclipse.equinox.p2.description' value='[Enter Feature Description here.]'/>\r
-        <property name='org.eclipse.equinox.p2.description.url' value='http://www.example.com/description'/>\r
-        <property name='org.eclipse.equinox.p2.type.group' value='true'/>\r
-      </properties>\r
-      <provides size='1'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='eu.etaxonomy.taxeditor.feature.dependencies.feature.group' version='2.0.0.v200906021611'/>\r
-      </provides>\r
-      <requires size='58'>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='com.ibm.icu' range='[3.8.1.v20080530,3.8.1.v20080530]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='javax.servlet' range='[2.4.0.v200806031604,2.4.0.v200806031604]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.ant.core' range='[3.2.0.v20080529,3.2.0.v20080529]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.core.commands' range='[3.4.0.I20080509-2000,3.4.0.I20080509-2000]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.core.contenttype' range='[3.3.0.v20080604-1400,3.3.0.v20080604-1400]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.core.databinding' range='[1.1.1.M20080827-0800b,1.1.1.M20080827-0800b]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.core.databinding.beans' range='[1.1.1.M20080827-0800a,1.1.1.M20080827-0800a]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.core.expressions' range='[3.4.1.r342_v20081203-0800,3.4.1.r342_v20081203-0800]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.core.filebuffers' range='[3.4.0.v20080603-2000,3.4.0.v20080603-2000]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.core.filesystem' range='[1.2.0.v20080604-1400,1.2.0.v20080604-1400]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.core.filesystem.macosx' range='[1.0.0.v20080604-1400,1.0.0.v20080604-1400]'>\r
-          <filter>\r
-            (&amp;(osgi.os=macosx))\r
-          </filter>\r
-        </required>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.core.jobs' range='[3.4.1.R34x_v20081128,3.4.1.R34x_v20081128]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.core.net' range='[1.1.0.I20080604,1.1.0.I20080604]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.core.resources' range='[3.4.2.R34x_v20090126,3.4.2.R34x_v20090126]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.core.resources.compatibility' range='[3.4.0.v20080604-1400,3.4.0.v20080604-1400]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.core.runtime' range='[3.4.0.v20080512,3.4.0.v20080512]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.core.runtime.compatibility.auth' range='[3.2.100.v20070502,3.2.100.v20070502]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.core.runtime.compatibility.registry' range='[3.2.200.v20080610,3.2.200.v20080610]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.core.variables' range='[3.2.100.v20080529-1300,3.2.100.v20080529-1300]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.equinox.app' range='[1.1.0.v20080421-2006,1.1.0.v20080421-2006]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.equinox.common' range='[3.4.0.v20080421-2006,3.4.0.v20080421-2006]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.equinox.preferences' range='[3.2.201.R34x_v20080709,3.2.201.R34x_v20080709]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.equinox.registry' range='[3.4.0.v20080516-0950,3.4.0.v20080516-0950]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.equinox.security' range='[1.0.1.R34x_v20080721,1.0.1.R34x_v20080721]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.equinox.security.macosx' range='[1.0.0.v20080602-2000,1.0.0.v20080602-2000]'>\r
-          <filter>\r
-            (&amp;(osgi.os=macosx))\r
-          </filter>\r
-        </required>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.help' range='[3.3.102.v20081014_34x,3.3.102.v20081014_34x]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.jface' range='[3.4.2.M20090107-0800,3.4.2.M20090107-0800]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.jface.databinding' range='[1.2.1.M20080827-0800a,1.2.1.M20080827-0800a]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.jface.text' range='[3.4.2.r342_v20081119-0800,3.4.2.r342_v20081119-0800]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.osgi' range='[3.4.3.R34x_v20081215-1030,3.4.3.R34x_v20081215-1030]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.osgi.services' range='[3.1.200.v20071203,3.1.200.v20071203]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.pde.source' range='[3.4.0.v20080603,3.4.0.v20080603]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.swt' range='[3.4.2.v3452b,3.4.2.v3452b]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.swt.carbon.macosx' range='[3.4.1.v3452b,3.4.1.v3452b]'>\r
-          <filter>\r
-            (&amp;(osgi.os=macosx)(osgi.ws=carbon))\r
-          </filter>\r
-        </required>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.text' range='[3.4.0.v20080605-1800,3.4.0.v20080605-1800]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.ui' range='[3.4.2.M20090204-0800,3.4.2.M20090204-0800]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.ui.carbon' range='[4.0.0.I20080610-1200,4.0.0.I20080610-1200]'>\r
-          <filter>\r
-            (&amp;(osgi.os=macosx)(osgi.ws=carbon))\r
-          </filter>\r
-        </required>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.ui.editors' range='[3.4.0.v20080603-2000,3.4.0.v20080603-2000]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.ui.forms' range='[3.3.103.v20081027_34x,3.3.103.v20081027_34x]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.ui.ide' range='[3.4.2.M20090127-1700,3.4.2.M20090127-1700]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.ui.navigator' range='[3.3.102.M20090127-1700,3.3.102.M20090127-1700]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.ui.navigator.resources' range='[3.3.101.M20080910-0800,3.3.101.M20080910-0800]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.ui.views' range='[3.3.1.M20081112-0800,3.3.1.M20081112-0800]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.ui.views.properties.tabbed' range='[3.4.2.M20090127-1700,3.4.2.M20090127-1700]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.ui.workbench' range='[3.4.2.M20090127-1700,3.4.2.M20090127-1700]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.ui.workbench.texteditor' range='[3.4.1.r341_v20080827-1100,3.4.1.r341_v20080827-1100]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.update.configurator' range='[3.2.201.R34x_v20080819,3.2.201.R34x_v20080819]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.update.core' range='[3.2.202.R34x_v20081128,3.2.202.R34x_v20081128]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.update.ui' range='[3.2.101.R34x_v20081128,3.2.101.R34x_v20081128]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.junit4' range='[4.3.1,4.3.1]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.update.core.win32' range='0.0.0'>\r
-          <filter>\r
-            (&amp;(osgi.os=win32))\r
-          </filter>\r
-        </required>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.core.filesystem.win32.x86' range='0.0.0'>\r
-          <filter>\r
-            (&amp;(osgi.os=win32)(osgi.arch=x86))\r
-          </filter>\r
-        </required>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.core.net.win32.x86' range='0.0.0'>\r
-          <filter>\r
-            (&amp;(osgi.os=win32)(osgi.arch=x86))\r
-          </filter>\r
-        </required>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.core.resources.win32.x86' range='0.0.0'>\r
-          <filter>\r
-            (&amp;(osgi.os=win32)(osgi.arch=x86))\r
-          </filter>\r
-        </required>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.equinox.security.win32.x86' range='0.0.0'>\r
-          <filter>\r
-            (&amp;(osgi.os=win32)(osgi.arch=x86))\r
-          </filter>\r
-        </required>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.swt.win32.win32.x86' range='0.0.0'>\r
-          <filter>\r
-            (&amp;(osgi.os=win32)(osgi.arch=x86))\r
-          </filter>\r
-        </required>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.ui.win32' range='0.0.0'>\r
-          <filter>\r
-            (&amp;(osgi.os=win32))\r
-          </filter>\r
-        </required>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='eu.etaxonomy.taxeditor.feature.dependencies.feature.jar' range='[2.0.0.v200906021611,2.0.0.v200906021611]'>\r
-          <filter>\r
-            (org.eclipse.update.install.features=true)\r
-          </filter>\r
-        </required>\r
-      </requires>\r
-      <touchpoint id='null' version='0.0.0'/>\r
-      <licenses size='1'>\r
-        <license url='http://www.example.com/license'>\r
-          [Enter License Description here.]\r
-        </license>\r
-      </licenses>\r
-      <copyright url='http://www.example.com/copyright'>\r
-        [Enter Copyright Description here.]\r
-      </copyright>\r
-    </unit>\r
-    <unit id='tooling.osgi.bundle.default' version='1.0.0' singleton='false'>\r
-      <hostRequirements size='1'>\r
-        <required namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' range='0.0.0' multiple='true' greedy='false'/>\r
-      </hostRequirements>\r
-      <properties size='1'>\r
-        <property name='org.eclipse.equinox.p2.type.fragment' value='true'/>\r
-      </properties>\r
-      <provides size='2'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='tooling.osgi.bundle.default' version='1.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.flavor' name='tooling' version='1.0.0'/>\r
-      </provides>\r
-      <requires size='1'>\r
-        <required namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' range='0.0.0' multiple='true' greedy='false'/>\r
-      </requires>\r
-      <touchpoint id='null' version='0.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='4'>\r
-          <instruction key='uninstall'>\r
-            uninstallBundle(bundle:${artifact})\r
-          </instruction>\r
-          <instruction key='configure'>\r
-            setStartLevel(startLevel:4);\r
-          </instruction>\r
-          <instruction key='install'>\r
-            installBundle(bundle:${artifact})\r
-          </instruction>\r
-          <instruction key='unconfigure'>\r
-\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='a.jre' version='1.6.0' singleton='false'>\r
-      <provides size='117'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='a.jre' version='1.6.0'/>\r
-        <provided namespace='java.package' name='javax.accessibility' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.activity' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.crypto' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.crypto.interfaces' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.crypto.spec' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.imageio' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.imageio.event' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.imageio.metadata' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.imageio.plugins.bmp' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.imageio.plugins.jpeg' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.imageio.spi' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.imageio.stream' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.management' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.management.loading' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.management.modelmbean' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.management.monitor' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.management.openmbean' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.management.relation' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.management.remote' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.management.remote.rmi' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.management.timer' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.naming' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.naming.directory' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.naming.event' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.naming.ldap' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.naming.spi' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.net' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.net.ssl' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.print' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.print.attribute' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.print.attribute.standard' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.print.event' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.rmi' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.rmi.CORBA' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.rmi.ssl' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.security.auth' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.security.auth.callback' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.security.auth.kerberos' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.security.auth.login' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.security.auth.spi' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.security.auth.x500' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.security.cert' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.security.sasl' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.sound.midi' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.sound.midi.spi' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.sound.sampled' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.sound.sampled.spi' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.sql' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.sql.rowset' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.sql.rowset.serial' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.sql.rowset.spi' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.swing' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.swing.border' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.swing.colorchooser' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.swing.event' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.swing.filechooser' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.swing.plaf' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.swing.plaf.basic' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.swing.plaf.metal' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.swing.plaf.multi' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.swing.plaf.synth' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.swing.table' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.swing.text' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.swing.text.html' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.swing.text.html.parser' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.swing.text.rtf' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.swing.tree' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.swing.undo' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.transaction' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.transaction.xa' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.xml' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.xml.datatype' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.xml.namespace' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.xml.parsers' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.xml.transform' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.xml.transform.dom' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.xml.transform.sax' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.xml.transform.stream' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.xml.validation' version='0.0.0'/>\r
-        <provided namespace='java.package' name='javax.xml.xpath' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.ietf.jgss' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.omg.CORBA' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.omg.CORBA_2_3' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.omg.CORBA_2_3.portable' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.omg.CORBA.DynAnyPackage' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.omg.CORBA.ORBPackage' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.omg.CORBA.portable' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.omg.CORBA.TypeCodePackage' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.omg.CosNaming' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.omg.CosNaming.NamingContextExtPackage' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.omg.CosNaming.NamingContextPackage' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.omg.Dynamic' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.omg.DynamicAny' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.omg.DynamicAny.DynAnyFactoryPackage' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.omg.DynamicAny.DynAnyPackage' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.omg.IOP' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.omg.IOP.CodecFactoryPackage' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.omg.IOP.CodecPackage' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.omg.Messaging' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.omg.PortableInterceptor' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.omg.PortableInterceptor.ORBInitInfoPackage' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.omg.PortableServer' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.omg.PortableServer.CurrentPackage' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.omg.PortableServer.POAManagerPackage' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.omg.PortableServer.POAPackage' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.omg.PortableServer.portable' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.omg.PortableServer.ServantLocatorPackage' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.omg.SendingContext' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.omg.stub.java.rmi' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.w3c.dom' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.w3c.dom.bootstrap' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.w3c.dom.events' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.w3c.dom.ls' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.xml.sax' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.xml.sax.ext' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.xml.sax.helpers' version='0.0.0'/>\r
-      </provides>\r
-      <touchpoint id='org.eclipse.equinox.p2.native' version='1.0.0'/>\r
-    </unit>\r
-    <unit id='tooling.org.eclipse.update.feature.default' version='1.0.0' singleton='false'>\r
-      <hostRequirements size='1'>\r
-        <required namespace='org.eclipse.equinox.p2.eclipse.type' name='feature' range='0.0.0' optional='true' multiple='true' greedy='false'/>\r
-      </hostRequirements>\r
-      <properties size='1'>\r
-        <property name='org.eclipse.equinox.p2.type.fragment' value='true'/>\r
-      </properties>\r
-      <provides size='2'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='tooling.org.eclipse.update.feature.default' version='1.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.flavor' name='tooling' version='1.0.0'/>\r
-      </provides>\r
-      <requires size='1'>\r
-        <required namespace='org.eclipse.equinox.p2.eclipse.type' name='feature' range='0.0.0' optional='true' multiple='true' greedy='false'/>\r
-      </requires>\r
-      <filter>\r
-        (org.eclipse.update.install.features=true)\r
-      </filter>\r
-      <touchpoint id='null' version='0.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='2'>\r
-          <instruction key='uninstall'>\r
-            uninstallFeature(feature:${artifact},featureId:default,featureVersion:default)\r
-          </instruction>\r
-          <instruction key='install'>\r
-            installFeature(feature:${artifact},featureId:default,featureVersion:default)\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='Taxonomic Editor' version='0.0.0'>\r
-      <properties size='2'>\r
-        <property name='org.eclipse.equinox.p2.name' value='Taxonomic Editor'/>\r
-        <property name='org.eclipse.equinox.p2.type.category' value='true'/>\r
-      </properties>\r
-      <provides size='1'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='Taxonomic Editor' version='0.0.0'/>\r
-      </provides>\r
-      <requires size='1'>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='eu.etaxonomy.taxeditor.feature.group' range='[2.0.0.v20090603_1757,2.0.0.v20090603_1757]'/>\r
-      </requires>\r
-      <touchpoint id='null' version='0.0.0'/>\r
-    </unit>\r
-    <unit id='eu.etaxonomy.taxeditor.store' version='2.0.0.v20090603_1757'>\r
-      <update id='eu.etaxonomy.taxeditor.store' range='[0.0.0,2.0.0.v20090603_1757)' severity='0'/>\r
-      <properties size='2'>\r
-        <property name='org.eclipse.equinox.p2.name' value='EDIT Taxonomic Editor - DataStore Bundle'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='EDIT'/>\r
-      </properties>\r
-      <provides size='14'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='eu.etaxonomy.taxeditor.store' version='2.0.0.v20090603_1757'/>\r
-        <provided namespace='osgi.bundle' name='eu.etaxonomy.taxeditor.store' version='2.0.0.v20090603_1757'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.handler' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.store' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.store.datasource' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.store.datasource.handler' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.store.datasource.view' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.store.datasource.wizard' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.store.internal' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.store.model' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.store.operations' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.store.parser' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.store.preference' version='0.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' version='1.0.0'/>\r
-      </provides>\r
-      <requires size='9'>\r
-        <required namespace='osgi.bundle' name='org.eclipse.ui' range='[3.2.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.runtime' range='[3.2.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.filesystem' range='1.2.0'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.resources' range='3.4.1'/>\r
-        <required namespace='osgi.bundle' name='eu.etaxonomy.cdmLibrary' range='2.1.0'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.ui.editors' range='3.4.0'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.jface.text' range='3.4.1'/>\r
-        <required namespace='java.package' name='junit.framework' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.junit' range='0.0.0'/>\r
-      </requires>\r
-      <artifacts size='1'>\r
-        <artifact classifier='osgi.bundle' id='eu.etaxonomy.taxeditor.store' version='2.0.0.v20090603_1757'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='1'>\r
-          <instruction key='manifest'>\r
-            Bundle-ManifestVersion: 2&#xA;Export-Package: eu.etaxonomy.taxeditor.handler,eu.etaxonomy.taxeditor.store,eu.etaxonomy.taxeditor.store.datasource,eu.etaxonomy.taxeditor.store.datasource.handler,eu.etaxonomy.taxeditor.store.datasource.view,eu.etaxonomy.taxeditor.store.datasource.wizard,eu.etaxonomy.taxeditor.store.internal,eu.etaxonomy.taxeditor.store.model;uses:=&quot;eu.etaxonomy.cdm.model.common,eu.etaxonomy.cdm.model.name,eu.etaxonomy.cdm.model.taxon&quot;,eu.etaxonomy.taxeditor.store.operations,eu.etaxonomy.taxeditor.store.parser,eu.etaxonomy.taxeditor.store.preference&#xA;Bundle-RequiredExecutionEnvironment: J2SE-1.5&#xA;Require-Bundle: org.eclipse.ui;bundle-version=&quot;[3.2.0,4.0.0)&quot;,org.eclipse.core.runtime;bundle-version=&quot;[3.2.0,4.0.0)&quot;,org.eclipse.core.filesystem;bundle-version=&quot;1.2.0&quot;,org.eclipse.core.resources;bundle-version=&quot;3.4.1&quot;,eu.etaxonomy.cdmLibrary;bundle-version=&quot;2.1.0&quot;,org.eclipse.ui.editors;bundle-version=&quot;3.4.0&quot;,org.eclipse.jface.text;bundle-version=&quot;3.4.1&quot;&#xA;Bundle-Activator: eu.etaxonomy.taxeditor.store.internal.TaxeditorStorePlugin&#xA;Bundle-Name: EDIT Taxonomic Editor - DataStore Bundle&#xA;Bundle-Version: 2.0.0.v20090603_1757&#xA;Bundle-Vendor: EDIT&#xA;Bundle-SymbolicName: eu.etaxonomy.taxeditor.store;singleton:=true&#xA;Import-Package: junit.framework,org.junit&#xA;Bundle-ActivationPolicy: lazy&#xA;Manifest-Version: 1.0\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='config.a.jre' version='1.6.0' singleton='false'>\r
-      <hostRequirements size='1'>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='a.jre' range='1.6.0'/>\r
-      </hostRequirements>\r
-      <properties size='1'>\r
-        <property name='org.eclipse.equinox.p2.type.fragment' value='true'/>\r
-      </properties>\r
-      <provides size='1'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='config.a.jre' version='1.6.0'/>\r
-      </provides>\r
-      <requires size='1'>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='a.jre' range='1.6.0'/>\r
-      </requires>\r
-      <touchpoint id='org.eclipse.equinox.p2.native' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='1'>\r
-          <instruction key='install'>\r
-\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='eu.etaxonomy.taxeditor.feature.dependencies.feature.jar' version='2.0.0.v200906021611'>\r
-      <update id='eu.etaxonomy.taxeditor.feature.dependencies.feature.jar' range='[0.0.0,2.0.0.v200906021611)' severity='0'/>\r
-      <properties size='3'>\r
-        <property name='org.eclipse.equinox.p2.name' value='Taxeditor Dependencies'/>\r
-        <property name='org.eclipse.equinox.p2.description' value='[Enter Feature Description here.]'/>\r
-        <property name='org.eclipse.equinox.p2.description.url' value='http://www.example.com/description'/>\r
-      </properties>\r
-      <provides size='3'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='eu.etaxonomy.taxeditor.feature.dependencies.feature.jar' version='2.0.0.v200906021611'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='feature' version='1.0.0'/>\r
-        <provided namespace='org.eclipse.update.feature' name='eu.etaxonomy.taxeditor.feature.dependencies' version='2.0.0.v200906021611'/>\r
-      </provides>\r
-      <filter>\r
-        (org.eclipse.update.install.features=true)\r
-      </filter>\r
-      <artifacts size='1'>\r
-        <artifact classifier='org.eclipse.update.feature' id='eu.etaxonomy.taxeditor.feature.dependencies' version='2.0.0.v200906021611'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='1'>\r
-          <instruction key='zipped'>\r
-            true\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-      <licenses size='1'>\r
-        <license url='http://www.example.com/license'>\r
-          [Enter License Description here.]\r
-        </license>\r
-      </licenses>\r
-      <copyright url='http://www.example.com/copyright'>\r
-        [Enter Copyright Description here.]\r
-      </copyright>\r
-    </unit>\r
-    <unit id='eu.etaxonomy.taxeditor.editor' version='2.0.0.v20090603_1756'>\r
-      <update id='eu.etaxonomy.taxeditor.editor' range='[0.0.0,2.0.0.v20090603_1756)' severity='0'/>\r
-      <properties size='4'>\r
-        <property name='df_LT.Bundle-Vendor.0' value='EDIT'/>\r
-        <property name='df_LT.Bundle-Name.0' value='EDIT Taxonomic Editor - Editor Bundle'/>\r
-        <property name='org.eclipse.equinox.p2.name' value='%Bundle-Name.0'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='%Bundle-Vendor.0'/>\r
-      </properties>\r
-      <provides size='22'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='eu.etaxonomy.taxeditor.editor' version='2.0.0.v20090603_1756'/>\r
-        <provided namespace='osgi.bundle' name='eu.etaxonomy.taxeditor.editor' version='2.0.0.v20090603_1756'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.editor' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.editor.description' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.editor.description.handler' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.editor.handler' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.editor.images' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.editor.images.handler' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.editor.internal' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.editor.name' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.editor.name.handler' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.editor.reference' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.propertysheet' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.propertysheet.description' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.propertysheet.images' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.propertysheet.name' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.propertysheet.namerelations.wizard' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.propertysheet.reference' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.propertysheet.type' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.propertysheet.type.wizard' version='0.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' version='1.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.localization' name='df_LT' version='1.0.0'/>\r
-      </provides>\r
-      <requires size='15'>\r
-        <required namespace='osgi.bundle' name='org.eclipse.ui' range='3.4.1'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.runtime' range='3.4.0'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.databinding' range='1.1.1'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.databinding.beans' range='1.1.1'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.ui.editors' range='3.4.0'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.jface' range='3.4.1'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.jface.databinding' range='1.2.1'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.ui.ide' range='3.4.1'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.resources' range='3.4.1'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.filesystem' range='1.2.0'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.expressions' range='3.4.0'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.ui.forms' range='3.3.101'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.jface.text' range='3.4.1'/>\r
-        <required namespace='osgi.bundle' name='eu.etaxonomy.cdmLibrary' range='2.0.0'/>\r
-        <required namespace='osgi.bundle' name='eu.etaxonomy.taxeditor.store' range='1.0.0'/>\r
-      </requires>\r
-      <artifacts size='1'>\r
-        <artifact classifier='osgi.bundle' id='eu.etaxonomy.taxeditor.editor' version='2.0.0.v20090603_1756'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='1'>\r
-          <instruction key='manifest'>\r
-            Bundle-RequiredExecutionEnvironment: J2SE-1.5&#xA;Bundle-Name: %Bundle-Name.0&#xA;Bundle-Activator: eu.etaxonomy.taxeditor.editor.internal.TaxeditorEditorPlugin&#xA;Manifest-Version: 1.0&#xA;Bundle-Vendor: %Bundle-Vendor.0&#xA;Bundle-ClassPath: .,icons/&#xA;Bundle-ActivationPolicy: lazy&#xA;Bundle-SymbolicName: eu.etaxonomy.taxeditor.editor;singleton:=true&#xA;Bundle-ManifestVersion: 2&#xA;Bundle-Version: 2.0.0.v20090603_1756&#xA;Bundle-Localization: plugin&#xA;Export-Package: eu.etaxonomy.taxeditor.editor,eu.etaxonomy.taxeditor.editor.description,eu.etaxonomy.taxeditor.editor.description.handler,eu.etaxonomy.taxeditor.editor.handler,eu.etaxonomy.taxeditor.editor.images,eu.etaxonomy.taxeditor.editor.images.handler,eu.etaxonomy.taxeditor.editor.internal,eu.etaxonomy.taxeditor.editor.name,eu.etaxonomy.taxeditor.editor.name.handler,eu.etaxonomy.taxeditor.editor.reference,eu.etaxonomy.taxeditor.propertysheet,eu.etaxonomy.taxeditor.propertysheet.description,eu.etaxonomy.taxeditor.propertysheet.images,eu.etaxonomy.taxeditor.propertysheet.name,eu.etaxonomy.taxeditor.propertysheet.namerelations.wizard,eu.etaxonomy.taxeditor.propertysheet.reference,eu.etaxonomy.taxeditor.propertysheet.type,eu.etaxonomy.taxeditor.propertysheet.type.wizard&#xA;Require-Bundle: org.eclipse.ui;bundle-version=&quot;3.4.1&quot;,org.eclipse.core.runtime;bundle-version=&quot;3.4.0&quot;,org.eclipse.core.databinding;bundle-version=&quot;1.1.1&quot;,org.eclipse.core.databinding.beans;bundle-version=&quot;1.1.1&quot;,org.eclipse.ui.editors;bundle-version=&quot;3.4.0&quot;,org.eclipse.jface;bundle-version=&quot;3.4.1&quot;,org.eclipse.jface.databinding;bundle-version=&quot;1.2.1&quot;,org.eclipse.ui.ide;bundle-version=&quot;3.4.1&quot;,org.eclipse.core.resources;bundle-version=&quot;3.4.1&quot;,org.eclipse.core.filesystem;bundle-version=&quot;1.2.0&quot;,org.eclipse.core.expressions;bundle-version=&quot;3.4.0&quot;,org.eclipse.ui.forms;bundle-version=&quot;3.3.101&quot;,org.eclipse.jface.text;bundle-version=&quot;3.4.1&quot;,eu.etaxonomy.cdmLibrary;bundle-version=&quot;2.0.0&quot;,eu.etaxonomy.taxeditor.store;bundle-version=&quot;1.0.0&quot;\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='tooling.source.default' version='1.0.0' singleton='false'>\r
-      <hostRequirements size='1'>\r
-        <required namespace='org.eclipse.equinox.p2.eclipse.type' name='source' range='0.0.0' optional='true' multiple='true' greedy='false'/>\r
-      </hostRequirements>\r
-      <properties size='1'>\r
-        <property name='org.eclipse.equinox.p2.type.fragment' value='true'/>\r
-      </properties>\r
-      <provides size='2'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='tooling.source.default' version='1.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.flavor' name='tooling' version='1.0.0'/>\r
-      </provides>\r
-      <requires size='1'>\r
-        <required namespace='org.eclipse.equinox.p2.eclipse.type' name='source' range='0.0.0' optional='true' multiple='true' greedy='false'/>\r
-      </requires>\r
-      <touchpoint id='null' version='0.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='2'>\r
-          <instruction key='uninstall'>\r
-            removeSourceBundle(bundle:${artifact})\r
-          </instruction>\r
-          <instruction key='install'>\r
-            addSourceBundle(bundle:${artifact})\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='eu.etaxonomy.taxeditor.feature.jar' version='2.0.0.v20090603_1757'>\r
-      <update id='eu.etaxonomy.taxeditor.feature.jar' range='[0.0.0,2.0.0.v20090603_1757)' severity='0'/>\r
-      <properties size='4'>\r
-        <property name='org.eclipse.equinox.p2.name' value='Taxeditor Feature'/>\r
-        <property name='org.eclipse.equinox.p2.description' value='[Enter Feature Description here.]'/>\r
-        <property name='org.eclipse.equinox.p2.description.url' value='http://www.example.com/description'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='EDIT'/>\r
-      </properties>\r
-      <provides size='3'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='eu.etaxonomy.taxeditor.feature.jar' version='2.0.0.v20090603_1757'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='feature' version='1.0.0'/>\r
-        <provided namespace='org.eclipse.update.feature' name='eu.etaxonomy.taxeditor' version='2.0.0.v20090603_1757'/>\r
-      </provides>\r
-      <filter>\r
-        (org.eclipse.update.install.features=true)\r
-      </filter>\r
-      <artifacts size='1'>\r
-        <artifact classifier='org.eclipse.update.feature' id='eu.etaxonomy.taxeditor' version='2.0.0.v20090603_1757'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='1'>\r
-          <instruction key='zipped'>\r
-            true\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-      <licenses size='1'>\r
-        <license url='http://www.example.com/license'>\r
-          [Enter License Description here.]\r
-        </license>\r
-      </licenses>\r
-      <copyright url='http://www.example.com/copyright'>\r
-        [Enter Copyright Description here.]\r
-      </copyright>\r
-    </unit>\r
-    <unit id='eu.etaxonomy.taxeditor.feature.group' version='2.0.0.v20090603_1757' singleton='false'>\r
-      <update id='eu.etaxonomy.taxeditor.feature.group' range='[0.0.0,2.0.0.v20090603_1757)' severity='0'/>\r
-      <properties size='5'>\r
-        <property name='org.eclipse.equinox.p2.name' value='Taxeditor Feature'/>\r
-        <property name='org.eclipse.equinox.p2.description' value='[Enter Feature Description here.]'/>\r
-        <property name='org.eclipse.equinox.p2.description.url' value='http://www.example.com/description'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='EDIT'/>\r
-        <property name='org.eclipse.equinox.p2.type.group' value='true'/>\r
-      </properties>\r
-      <provides size='1'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='eu.etaxonomy.taxeditor.feature.group' version='2.0.0.v20090603_1757'/>\r
-      </provides>\r
-      <requires size='7'>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='eu.etaxonomy.taxeditor.feature.dependencies.feature.group' range='[2.0.0.v200906021611,2.0.0.v200906021611]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='eu.etaxonomy.cdmLibrary.feature.group' range='[2.1.0.v20090603_1459,2.1.0.v20090603_1459]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='eu.etaxonomy.taxeditor.application' range='[2.0.0.v20090603_1756,2.0.0.v20090603_1756]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='eu.etaxonomy.taxeditor.editor' range='[2.0.0.v20090603_1756,2.0.0.v20090603_1756]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='eu.etaxonomy.taxeditor.navigation' range='[2.0.0.v20090603_1757,2.0.0.v20090603_1757]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='eu.etaxonomy.taxeditor.store' range='[2.0.0.v20090603_1757,2.0.0.v20090603_1757]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='eu.etaxonomy.taxeditor.feature.jar' range='[2.0.0.v20090603_1757,2.0.0.v20090603_1757]'>\r
-          <filter>\r
-            (org.eclipse.update.install.features=true)\r
-          </filter>\r
-        </required>\r
-      </requires>\r
-      <touchpoint id='null' version='0.0.0'/>\r
-      <licenses size='1'>\r
-        <license url='http://www.example.com/license'>\r
-          [Enter License Description here.]\r
-        </license>\r
-      </licenses>\r
-      <copyright url='http://www.example.com/copyright'>\r
-        [Enter Copyright Description here.]\r
-      </copyright>\r
-    </unit>\r
-    <unit id='eu.etaxonomy.taxeditor.navigation' version='2.0.0.v20090603_1757'>\r
-      <update id='eu.etaxonomy.taxeditor.navigation' range='[0.0.0,2.0.0.v20090603_1757)' severity='0'/>\r
-      <properties size='2'>\r
-        <property name='org.eclipse.equinox.p2.name' value='EDIT Taxonomic Editor - Navigation Bundle'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='EDIT'/>\r
-      </properties>\r
-      <provides size='8'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='eu.etaxonomy.taxeditor.navigation' version='2.0.0.v20090603_1757'/>\r
-        <provided namespace='osgi.bundle' name='eu.etaxonomy.taxeditor.navigation' version='2.0.0.v20090603_1757'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.navigation' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.navigation.handler' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.navigation.internal' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.navigation.search' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.navigation.taxonomictree' version='0.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' version='1.0.0'/>\r
-      </provides>\r
-      <requires size='13'>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.resources' range='3.4.1'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.runtime' range='3.4.0'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.ui' range='3.4.1'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.ui.navigator' range='3.3.101'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.ui.navigator.resources' range='3.3.101'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.ui.ide' range='3.4.1'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.ui.forms' range='3.3.101'/>\r
-        <required namespace='osgi.bundle' name='eu.etaxonomy.cdmLibrary' range='2.0.0'/>\r
-        <required namespace='osgi.bundle' name='eu.etaxonomy.taxeditor.store' range='1.0.0'/>\r
-        <required namespace='osgi.bundle' name='eu.etaxonomy.taxeditor.editor' range='1.0.0'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.databinding.beans' range='1.1.1'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.databinding' range='1.1.1'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.jface.databinding' range='1.2.1'/>\r
-      </requires>\r
-      <artifacts size='1'>\r
-        <artifact classifier='osgi.bundle' id='eu.etaxonomy.taxeditor.navigation' version='2.0.0.v20090603_1757'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='1'>\r
-          <instruction key='manifest'>\r
-            Bundle-Vendor: EDIT&#xA;Bundle-ManifestVersion: 2&#xA;Bundle-Activator: eu.etaxonomy.taxeditor.navigation.internal.TaxeditorNavigationPlugin&#xA;Bundle-RequiredExecutionEnvironment: J2SE-1.5&#xA;Bundle-Name: EDIT Taxonomic Editor - Navigation Bundle&#xA;Require-Bundle: org.eclipse.core.resources;bundle-version=&quot;3.4.1&quot;,org.eclipse.core.runtime;bundle-version=&quot;3.4.0&quot;,org.eclipse.ui;bundle-version=&quot;3.4.1&quot;,org.eclipse.ui.navigator;bundle-version=&quot;3.3.101&quot;,org.eclipse.ui.navigator.resources;bundle-version=&quot;3.3.101&quot;,org.eclipse.ui.ide;bundle-version=&quot;3.4.1&quot;,org.eclipse.ui.forms;bundle-version=&quot;3.3.101&quot;,eu.etaxonomy.cdmLibrary;bundle-version=&quot;2.0.0&quot;,eu.etaxonomy.taxeditor.store;bundle-version=&quot;1.0.0&quot;,eu.etaxonomy.taxeditor.editor;bundle-version=&quot;1.0.0&quot;,org.eclipse.core.databinding.beans;bundle-version=&quot;1.1.1&quot;,org.eclipse.core.databinding;bundle-version=&quot;1.1.1&quot;,org.eclipse.jface.databinding;bundle-version=&quot;1.2.1&quot;&#xA;Bundle-ActivationPolicy: lazy&#xA;Manifest-Version: 1.0&#xA;Bundle-SymbolicName: eu.etaxonomy.taxeditor.navigation;singleton:=true&#xA;Bundle-Version: 2.0.0.v20090603_1757&#xA;Export-Package: eu.etaxonomy.taxeditor.navigation,eu.etaxonomy.taxeditor.navigation.handler,eu.etaxonomy.taxeditor.navigation.internal,eu.etaxonomy.taxeditor.navigation.search,eu.etaxonomy.taxeditor.navigation.taxonomictree\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='org.eclipse.core.resources.compatibility.translated_host_properties' version='3.4.0.v20080604-1400'>\r
-      <hostRequirements size='1'>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.core.resources' range='[3.4.0,4.0.0)' greedy='false'/>\r
-      </hostRequirements>\r
-      <properties size='1'>\r
-        <property name='org.eclipse.equinox.p2.type.fragment' value='true'/>\r
-      </properties>\r
-      <requires size='1'>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.core.resources' range='[3.4.0,4.0.0)' greedy='false'/>\r
-      </requires>\r
-      <touchpoint id='null' version='0.0.0'/>\r
-    </unit>\r
-    <unit id='org.eclipse.ui.navigator.resources' version='3.3.101.M20080910-0800'>\r
-      <update id='org.eclipse.ui.navigator.resources' range='[0.0.0,3.3.101.M20080910-0800)' severity='0'/>\r
-      <properties size='4'>\r
-        <property name='df_LT.Plugin.name' value='Navigator Workbench Components'/>\r
-        <property name='df_LT.Plugin.providerName' value='Eclipse.org'/>\r
-        <property name='org.eclipse.equinox.p2.name' value='%Plugin.name'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='%Plugin.providerName'/>\r
-      </properties>\r
-      <provides size='9'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.ui.navigator.resources' version='3.3.101.M20080910-0800'/>\r
-        <provided namespace='osgi.bundle' name='org.eclipse.ui.navigator.resources' version='3.3.101.M20080910-0800'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.navigator.resources.actions' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.navigator.resources.plugin' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.navigator.resources.workbench' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.navigator.workingsets' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.navigator.resources' version='0.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' version='1.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.localization' name='df_LT' version='1.0.0'/>\r
-      </provides>\r
-      <requires size='8'>\r
-        <required namespace='osgi.bundle' name='org.eclipse.ui.ide' range='[3.2.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.resources' range='[3.2.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.jface' range='[3.2.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.ui' range='[3.2.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.ui.navigator' range='[3.2.1,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.runtime' range='[3.2.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.ui.views.properties.tabbed' range='[3.2.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.ui.workbench.texteditor' range='[3.2.0,4.0.0)'/>\r
-      </requires>\r
-      <artifacts size='1'>\r
-        <artifact classifier='osgi.bundle' id='org.eclipse.ui.navigator.resources' version='3.3.101.M20080910-0800'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='1'>\r
-          <instruction key='manifest'>\r
-            Bundle-ManifestVersion: 2&#xA;Export-Package: org.eclipse.ui.internal.navigator.resources.actions;x-internal:=true,org.eclipse.ui.internal.navigator.resources.plugin;x-internal:=true,org.eclipse.ui.internal.navigator.resources.workbench;x-internal:=true,org.eclipse.ui.internal.navigator.workingsets;x-internal:=true,org.eclipse.ui.navigator.resources&#xA;Bundle-RequiredExecutionEnvironment: J2SE-1.4&#xA;Bundle-Localization: plugin&#xA;Require-Bundle: org.eclipse.ui.ide;bundle-version=&quot;[3.2.0,4.0.0)&quot;,org.eclipse.core.resources;bundle-version=&quot;[3.2.0,4.0.0)&quot;,org.eclipse.jface;bundle-version=&quot;[3.2.0,4.0.0)&quot;,org.eclipse.ui;bundle-version=&quot;[3.2.0,4.0.0)&quot;,org.eclipse.ui.navigator;bundle-version=&quot;[3.2.1,4.0.0)&quot;,org.eclipse.core.runtime;bundle-version=&quot;[3.2.0,4.0.0)&quot;,org.eclipse.ui.views.properties.tabbed;bundle-version=&quot;[3.2.0,4.0.0)&quot;,org.eclipse.ui.workbench.texteditor;bundle-version=&quot;[3.2.0,4.0.0)&quot;&#xA;Bundle-Activator: org.eclipse.ui.internal.navigator.resources.plugin.WorkbenchNavigatorPlugin&#xA;Bundle-Name: %Plugin.name&#xA;Bundle-Version: 3.3.101.M20080910-0800&#xA;Bundle-Vendor: %Plugin.providerName&#xA;Bundle-SymbolicName: org.eclipse.ui.navigator.resources; singleton:=true&#xA;Bundle-ActivationPolicy: lazy&#xA;Manifest-Version: 1.0\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='org.eclipse.core.runtime.compatibility.registry' version='3.2.200.v20080610' singleton='false'>\r
-      <update id='org.eclipse.core.runtime.compatibility.registry' range='[0.0.0,3.2.200.v20080610)' severity='0'/>\r
-      <properties size='4'>\r
-        <property name='df_LT.fragmentName' value='Eclipse Registry Compatibility Fragment'/>\r
-        <property name='df_LT.providerName' value='Eclipse.org'/>\r
-        <property name='org.eclipse.equinox.p2.name' value='%fragmentName'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='%providerName'/>\r
-      </properties>\r
-      <provides size='5'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.core.runtime.compatibility.registry' version='3.2.200.v20080610'/>\r
-        <provided namespace='osgi.bundle' name='org.eclipse.core.runtime.compatibility.registry' version='3.2.200.v20080610'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' version='1.0.0'/>\r
-        <provided namespace='osgi.fragment' name='org.eclipse.equinox.registry' version='3.2.200.v20080610'/>\r
-        <provided namespace='org.eclipse.equinox.p2.localization' name='df_LT' version='1.0.0'/>\r
-      </provides>\r
-      <requires size='1'>\r
-        <required namespace='osgi.bundle' name='org.eclipse.equinox.registry' range='[3.3.0,3.5.0)'/>\r
-      </requires>\r
-      <artifacts size='1'>\r
-        <artifact classifier='osgi.bundle' id='org.eclipse.core.runtime.compatibility.registry' version='3.2.200.v20080610'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='2'>\r
-          <instruction key='manifest'>\r
-            Bundle-Vendor: %providerName&#xA;Bundle-ManifestVersion: 2&#xA;Bundle-RequiredExecutionEnvironment: CDC-1.0/Foundation-1.0,J2SE-1.3&#xA;Eclipse-PatchFragment: true&#xA;Bundle-Localization: fragment&#xA;Bundle-Name: %fragmentName&#xA;Bundle-ClassPath: runtime_registry_compatibility.jar&#xA;Manifest-Version: 1.0&#xA;Fragment-Host: org.eclipse.equinox.registry;bundle-version=&quot;[3.3.0,3.5.0)&quot;&#xA;Bundle-SymbolicName: org.eclipse.core.runtime.compatibility.registry&#xA;Bundle-Version: 3.2.200.v20080610\r
-          </instruction>\r
-          <instruction key='zipped'>\r
-            true\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='org.eclipse.ui.workbench' version='3.4.2.M20090127-1700'>\r
-      <update id='org.eclipse.ui.workbench' range='[0.0.0,3.4.2.M20090127-1700)' severity='0'/>\r
-      <properties size='4'>\r
-        <property name='df_LT.providerName' value='Eclipse.org'/>\r
-        <property name='df_LT.pluginName' value='Workbench'/>\r
-        <property name='org.eclipse.equinox.p2.name' value='%pluginName'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='%providerName'/>\r
-      </properties>\r
-      <provides size='80'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.ui.workbench' version='3.4.2.M20090127-1700'/>\r
-        <provided namespace='osgi.bundle' name='org.eclipse.ui.workbench' version='3.4.2.M20090127-1700'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.about' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.actions' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.activities' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.application' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.branding' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.browser' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.commands' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.contexts' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.dialogs' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.dnd' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.fieldassist' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.handlers' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.help' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.about' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.actions' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.activities' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.activities.ws' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.application' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.browser' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.commands' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.contexts' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.decorators' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.dialogs' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.dnd' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.editorsupport' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.expressions' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.handlers' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.help' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.intro' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.keys' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.keys.model' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.layout' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.menus' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.misc' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.model' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.operations' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.part' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.preferences' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.presentations' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.presentations.classic' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.presentations.defaultpresentation' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.presentations.util' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.progress' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.provisional.application' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.provisional.presentations' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.quickaccess' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.registry' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.services' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.splash' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.statushandlers' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.testing' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.themes' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.tweaklets' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.util' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.wizards' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.wizards.preferences' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.intro' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.keys' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.menus' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.model' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.operations' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.part' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.plugin' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.preferences' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.presentations' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.progress' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.services' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.splash' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.statushandlers' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.swt' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.testing' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.themes' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.views' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.wizards' version='0.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' version='1.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.localization' name='df_LT' version='1.0.0'/>\r
-      </provides>\r
-      <requires size='11'>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.runtime' range='[3.4.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.help' range='[3.2.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.jface' range='[3.4.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.swt' range='[3.3.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.expressions' range='[3.2.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.jface.databinding' range='[1.1.0,2.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.databinding' range='[1.0.0,2.0.0)'/>\r
-        <required namespace='java.package' name='com.ibm.icu.text' range='0.0.0'/>\r
-        <required namespace='java.package' name='javax.xml.parsers' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.w3c.dom' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.xml.sax' range='0.0.0'/>\r
-      </requires>\r
-      <artifacts size='1'>\r
-        <artifact classifier='osgi.bundle' id='org.eclipse.ui.workbench' version='3.4.2.M20090127-1700'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='1'>\r
-          <instruction key='manifest'>\r
-            Bundle-Name: %pluginName&#xA;Bundle-ClassPath: compatibility.jar,.&#xA;Bundle-Version: 3.4.2.M20090127-1700&#xA;Import-Package: com.ibm.icu.text,javax.xml.parsers,org.w3c.dom,org.xml.sax&#xA;Bundle-Activator: org.eclipse.ui.internal.WorkbenchPlugin&#xA;Bundle-Vendor: %providerName&#xA;Require-Bundle: org.eclipse.core.runtime;bundle-version=&quot;[3.4.0,4.0.0)&quot;,org.eclipse.help;bundle-version=&quot;[3.2.0,4.0.0)&quot;,org.eclipse.jface;bundle-version=&quot;[3.4.0,4.0.0)&quot;,org.eclipse.swt;bundle-version=&quot;[3.3.0,4.0.0)&quot;,org.eclipse.core.expressions;bundle-version=&quot;[3.2.0,4.0.0)&quot;,org.eclipse.jface.databinding;bundle-version=&quot;[1.1.0,2.0.0)&quot;,org.eclipse.core.databinding;bundle-version=&quot;[1.0.0,2.0.0)&quot;&#xA;Export-Package: org.eclipse.ui;ui.workbench=split;mandatory:=&quot;ui.workbench&quot;,org.eclipse.ui.about,org.eclipse.ui.actions;ui.workbench=split;mandatory:=&quot;ui.workbench&quot;,org.eclipse.ui.activities,org.eclipse.ui.application,org.eclipse.ui.branding,org.eclipse.ui.browser;ui.workbench=split;mandatory:=&quot;ui.workbench&quot;,org.eclipse.ui.commands,org.eclipse.ui.contexts,org.eclipse.ui.dialogs;ui.workbench=split;mandatory:=&quot;ui.workbench&quot;,org.eclipse.ui.dnd,org.eclipse.ui.fieldassist,org.eclipse.ui.handlers,org.eclipse.ui.help,org.eclipse.ui.internal;ui.workbench=split;mandatory:=&quot;ui.workbench&quot;; x-friends:=&quot;org.eclipse.ui,  org.eclipse.ui.intro,  org.eclipse.ui.ide,  org.eclipse.ui.presentations.r21&quot;,org.eclipse.ui.internal.about;x-friends:=&quot;org.eclipse.ui&quot;,org.eclipse.ui.internal.actions;x-internal:=true,org.eclipse.ui.internal.activities;x-friends:=&quot;org.eclipse.ui&quot;,org.eclipse.ui.internal.activities.ws;x-internal:=true,org.eclipse.ui.internal.application;x-internal:=true,org.eclipse.ui.internal.browser;ui.workbench=split;mandatory:=&quot;ui.workbench&quot;;x-internal:=true,org.eclipse.ui.internal.commands;x-friends:=&quot;org.eclipse.ui&quot;,org.eclipse.ui.internal.contexts;x-friends:=&quot;org.eclipse.ui&quot;,org.eclipse.ui.internal.decorators;x-friends:=&quot;org.eclipse.ui.ide&quot;,org.eclipse.ui.internal.dialogs;x-internal:=true,org.eclipse.ui.internal.dnd;x-friends:=&quot;org.eclipse.ui.intro,org.eclipse.ui.presentations.r21&quot;,org.eclipse.ui.internal.editorsupport;x-internal:=true,org.eclipse.ui.internal.expressions;x-internal:=true,org.eclipse.ui.internal.handlers;x-friends:=&quot;org.eclipse.ui&quot;,org.eclipse.ui.internal.help;x-internal:=true,org.eclipse.ui.internal.intro;x-internal:=true,org.eclipse.ui.internal.keys;x-internal:=true,org.eclipse.ui.internal.keys.model;x-internal:=true,org.eclipse.ui.internal.layout;x-friends:=&quot;org.eclipse.ui.presentations.r21,org.eclipse.ui.intro&quot;,org.eclipse.ui.internal.menus;x-friends:=&quot;org.eclipse.ui&quot;,org.eclipse.ui.internal.misc;x-internal:=true,org.eclipse.ui.internal.model;x-internal:=true,org.eclipse.ui.internal.operations;x-internal:=true,org.eclipse.ui.internal.part;x-internal:=true,org.eclipse.ui.internal.preferences;x-friends:=&quot;org.eclipse.ui&quot;,org.eclipse.ui.internal.presentations;ui.workbench=split;mandatory:=&quot;ui.workbench&quot;;x-friends:=&quot;org.eclipse.ui.presentations.r21&quot;,org.eclipse.ui.internal.presentations.classic;x-friends:=&quot;org.eclipse.ui&quot;,org.eclipse.ui.internal.presentations.defaultpresentation;x-internal:=true,org.eclipse.ui.internal.presentations.util;x-friends:=&quot;org.eclipse.ui.presentations.r21&quot;,org.eclipse.ui.internal.progress;x-internal:=true,org.eclipse.ui.internal.provisional.application;x-internal:=true,org.eclipse.ui.internal.provisional.presentations;x-internal:=true,org.eclipse.ui.internal.quickaccess;x-friends:=&quot;org.eclipse.ui&quot;,org.eclipse.ui.internal.registry;x-friends:=&quot;org.eclipse.ui&quot;,org.eclipse.ui.internal.services;x-friends:=&quot;org.eclipse.ui&quot;,org.eclipse.ui.internal.splash;x-internal:=true,org.eclipse.ui.internal.statushandlers;x-internal:=true,org.eclipse.ui.internal.testing;x-internal:=true,org.eclipse.ui.internal.themes;x-friends:=&quot;org.eclipse.ui&quot;,org.eclipse.ui.internal.tweaklets;x-internal:=true,org.eclipse.ui.internal.util;x-friends:=&quot;org.eclipse.ui,org.eclipse.ui.presentations.r21,org.eclipse.ui.ide&quot;,org.eclipse.ui.internal.wizards;x-internal:=true,org.eclipse.ui.internal.wizards.preferences;x-internal:=true,org.eclipse.ui.intro,org.eclipse.ui.keys,org.eclipse.ui.menus,org.eclipse.ui.model;ui.workbench=split;mandatory:=&quot;ui.workbench&quot;,org.eclipse.ui.operations,org.eclipse.ui.part;ui.workbench=split;mandatory:=&quot;ui.workbench&quot;,org.eclipse.ui.plugin,org.eclipse.ui.preferences,org.eclipse.ui.presentations,org.eclipse.ui.progress,org.eclipse.ui.services,org.eclipse.ui.splash,org.eclipse.ui.statushandlers,org.eclipse.ui.swt,org.eclipse.ui.testing,org.eclipse.ui.themes,org.eclipse.ui.views,org.eclipse.ui.wizards&#xA;Bundle-SymbolicName: org.eclipse.ui.workbench; singleton:=true&#xA;Manifest-Version: 1.0&#xA;Bundle-ActivationPolicy: lazy&#xA;Bundle-ManifestVersion: 2&#xA;Bundle-RequiredExecutionEnvironment: J2SE-1.4,CDC-1.0/Foundation-1.0,J2SE-1.3&#xA;Bundle-Localization: plugin\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='org.eclipse.core.contenttype' version='3.3.0.v20080604-1400'>\r
-      <update id='org.eclipse.core.contenttype' range='[0.0.0,3.3.0.v20080604-1400)' severity='0'/>\r
-      <properties size='4'>\r
-        <property name='df_LT.providerName' value='Eclipse.org'/>\r
-        <property name='df_LT.pluginName' value='Eclipse Content Mechanism'/>\r
-        <property name='org.eclipse.equinox.p2.name' value='%pluginName'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='%providerName'/>\r
-      </properties>\r
-      <provides size='6'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.core.contenttype' version='3.3.0.v20080604-1400'/>\r
-        <provided namespace='osgi.bundle' name='org.eclipse.core.contenttype' version='3.3.0.v20080604-1400'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.internal.content' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.runtime.content' version='0.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' version='1.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.localization' name='df_LT' version='1.0.0'/>\r
-      </provides>\r
-      <requires size='11'>\r
-        <required namespace='osgi.bundle' name='org.eclipse.equinox.preferences' range='[3.2.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.equinox.registry' range='[3.2.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.equinox.common' range='[3.2.0,4.0.0)'/>\r
-        <required namespace='java.package' name='javax.xml.parsers' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.eclipse.osgi.service.debug' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.eclipse.osgi.util' range='1.0.0'/>\r
-        <required namespace='java.package' name='org.osgi.framework' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.osgi.util.tracker' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.xml.sax' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.xml.sax.ext' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.xml.sax.helpers' range='0.0.0'/>\r
-      </requires>\r
-      <artifacts size='1'>\r
-        <artifact classifier='osgi.bundle' id='org.eclipse.core.contenttype' version='3.3.0.v20080604-1400'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='1'>\r
-          <instruction key='manifest'>\r
-            Bundle-RequiredExecutionEnvironment: J2SE-1.4,CDC-1.0/Foundation-1.0,J2SE-1.3&#xA;Bundle-Name: %pluginName&#xA;Bundle-Activator: org.eclipse.core.internal.content.Activator&#xA;Manifest-Version: 1.0&#xA;Bundle-Vendor: %providerName&#xA;Bundle-SymbolicName: org.eclipse.core.contenttype; singleton:=true&#xA;Import-Package: javax.xml.parsers,org.eclipse.osgi.service.debug,org.eclipse.osgi.util;version=&quot;1.0.0&quot;,org.osgi.framework,org.osgi.util.tracker,org.xml.sax,org.xml.sax.ext,org.xml.sax.helpers&#xA;Bundle-ManifestVersion: 2&#xA;Eclipse-LazyStart: true&#xA;Bundle-Version: 3.3.0.v20080604-1400&#xA;Bundle-Localization: plugin&#xA;Export-Package: org.eclipse.core.internal.content;x-internal:=true,org.eclipse.core.runtime.content&#xA;Require-Bundle: org.eclipse.equinox.preferences;bundle-version=&quot;[3.2.0,4.0.0)&quot;,org.eclipse.equinox.registry;bundle-version=&quot;[3.2.0,4.0.0)&quot;,org.eclipse.equinox.common;bundle-version=&quot;[3.2.0,4.0.0)&quot;\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='org.eclipse.core.runtime.compatibility.registry.translated_host_properties' version='3.2.200.v20080610'>\r
-      <hostRequirements size='1'>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.equinox.registry' range='[3.3.0,3.5.0)' greedy='false'/>\r
-      </hostRequirements>\r
-      <properties size='1'>\r
-        <property name='org.eclipse.equinox.p2.type.fragment' value='true'/>\r
-      </properties>\r
-      <requires size='1'>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.equinox.registry' range='[3.3.0,3.5.0)' greedy='false'/>\r
-      </requires>\r
-      <touchpoint id='null' version='0.0.0'/>\r
-    </unit>\r
-    <unit id='org.eclipse.core.commands' version='3.4.0.I20080509-2000' singleton='false'>\r
-      <update id='org.eclipse.core.commands' range='[0.0.0,3.4.0.I20080509-2000)' severity='0'/>\r
-      <properties size='4'>\r
-        <property name='df_LT.providerName' value='Eclipse.org'/>\r
-        <property name='df_LT.pluginName' value='Commands'/>\r
-        <property name='org.eclipse.equinox.p2.name' value='%pluginName'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='%providerName'/>\r
-      </properties>\r
-      <provides size='11'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.core.commands' version='3.4.0.I20080509-2000'/>\r
-        <provided namespace='osgi.bundle' name='org.eclipse.core.commands' version='3.4.0.I20080509-2000'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.commands' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.commands.common' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.commands.contexts' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.commands.operations' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.commands.util' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.internal.commands.operations' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.internal.commands.util' version='0.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' version='1.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.localization' name='df_LT' version='1.0.0'/>\r
-      </provides>\r
-      <requires size='1'>\r
-        <required namespace='osgi.bundle' name='org.eclipse.equinox.common' range='[3.2.0,4.0.0)'/>\r
-      </requires>\r
-      <artifacts size='1'>\r
-        <artifact classifier='osgi.bundle' id='org.eclipse.core.commands' version='3.4.0.I20080509-2000'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='1'>\r
-          <instruction key='manifest'>\r
-            Bundle-Vendor: %providerName&#xA;Bundle-ManifestVersion: 2&#xA;Bundle-RequiredExecutionEnvironment: CDC-1.0/Foundation-1.0,J2SE-1.3&#xA;Bundle-Localization: plugin&#xA;Bundle-Name: %pluginName&#xA;Require-Bundle: org.eclipse.equinox.common;bundle-version=&quot;[3.2.0,4.0.0)&quot;&#xA;Bundle-ClassPath: .&#xA;Manifest-Version: 1.0&#xA;Bundle-SymbolicName: org.eclipse.core.commands&#xA;Bundle-Version: 3.4.0.I20080509-2000&#xA;Export-Package: org.eclipse.core.commands,org.eclipse.core.commands.common,org.eclipse.core.commands.contexts,org.eclipse.core.commands.operations,org.eclipse.core.commands.util,org.eclipse.core.internal.commands.operations;x-internal:=true,org.eclipse.core.internal.commands.util;x-internal:=true\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='org.eclipse.core.runtime' version='3.4.0.v20080512'>\r
-      <update id='org.eclipse.core.runtime' range='[0.0.0,3.4.0.v20080512)' severity='0'/>\r
-      <properties size='4'>\r
-        <property name='df_LT.providerName' value='Eclipse.org'/>\r
-        <property name='df_LT.pluginName' value='Core Runtime'/>\r
-        <property name='org.eclipse.equinox.p2.name' value='%pluginName'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='%providerName'/>\r
-      </properties>\r
-      <provides size='7'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.core.runtime' version='3.4.0.v20080512'/>\r
-        <provided namespace='osgi.bundle' name='org.eclipse.core.runtime' version='3.4.0.v20080512'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.internal.preferences.legacy' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.internal.runtime' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.runtime' version='3.4.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' version='1.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.localization' name='df_LT' version='1.0.0'/>\r
-      </provides>\r
-      <requires size='9'>\r
-        <required namespace='osgi.bundle' name='org.eclipse.osgi' range='[3.2.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.equinox.common' range='[3.2.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.jobs' range='[3.2.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.equinox.registry' range='[3.4.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.equinox.preferences' range='[3.2.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.contenttype' range='[3.3.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.runtime.compatibility.auth' range='[3.2.0,4.0.0)' optional='true'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.equinox.app' range='[1.0.0,2.0.0)'/>\r
-        <required namespace='java.package' name='org.eclipse.core.internal.runtime.auth' range='0.0.0' optional='true'/>\r
-      </requires>\r
-      <artifacts size='1'>\r
-        <artifact classifier='osgi.bundle' id='org.eclipse.core.runtime' version='3.4.0.v20080512'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='1'>\r
-          <instruction key='manifest'>\r
-            Bundle-RequiredExecutionEnvironment: CDC-1.0/Foundation-1.0,J2SE-1.3&#xA;Bundle-Name: %pluginName&#xA;Bundle-Activator: org.eclipse.core.internal.runtime.PlatformActivator&#xA;Manifest-Version: 1.0&#xA;Bundle-Vendor: %providerName&#xA;Bundle-ActivationPolicy: lazy&#xA;Bundle-SymbolicName: org.eclipse.core.runtime; singleton:=true&#xA;Bundle-ManifestVersion: 2&#xA;DynamicImport-Package: org.eclipse.core.internal.runtime.auth&#xA;Bundle-Version: 3.4.0.v20080512&#xA;Bundle-Localization: plugin&#xA;Export-Package: org.eclipse.core.internal.preferences.legacy;x-internal:=true,org.eclipse.core.internal.runtime;x-friends:=&quot;org.eclipse.core.runtime.compatibility&quot;,org.eclipse.core.runtime;version=&quot;3.4.0&quot;&#xA;Require-Bundle: org.eclipse.osgi;bundle-version=&quot;[3.2.0,4.0.0)&quot;;visibility:=reexport,org.eclipse.equinox.common;bundle-version=&quot;[3.2.0,4.0.0)&quot;;visibility:=reexport,org.eclipse.core.jobs;bundle-version=&quot;[3.2.0,4.0.0)&quot;;visibility:=reexport,org.eclipse.equinox.registry;bundle-version=&quot;[3.4.0,4.0.0)&quot;;visibility:=reexport,org.eclipse.equinox.preferences;bundle-version=&quot;[3.2.0,4.0.0)&quot;;visibility:=reexport,org.eclipse.core.contenttype;bundle-version=&quot;[3.3.0,4.0.0)&quot;;visibility:=reexport,org.eclipse.core.runtime.compatibility.auth;bundle-version=&quot;[3.2.0,4.0.0)&quot;;resolution:=optional,org.eclipse.equinox.app;bundle-version=&quot;[1.0.0,2.0.0)&quot;;visibility:=reexport\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='org.eclipse.update.core' version='3.2.202.R34x_v20081128'>\r
-      <update id='org.eclipse.update.core' range='[0.0.0,3.2.202.R34x_v20081128)' severity='0'/>\r
-      <properties size='4'>\r
-        <property name='df_LT.providerName' value='Eclipse.org'/>\r
-        <property name='df_LT.pluginName' value='Install/Update Core'/>\r
-        <property name='org.eclipse.equinox.p2.name' value='%pluginName'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='%providerName'/>\r
-      </properties>\r
-      <provides size='20'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.update.core' version='3.2.202.R34x_v20081128'/>\r
-        <provided namespace='osgi.bundle' name='org.eclipse.update.core' version='3.2.202.R34x_v20081128'/>\r
-        <provided namespace='java.package' name='org.eclipse.update.configuration' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.update.core' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.update.core.model' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.update.internal.core' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.update.internal.core.connection' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.update.internal.jarprocessor' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.update.internal.mirror' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.update.internal.model' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.update.internal.operations' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.update.internal.provisional' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.update.internal.search' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.update.internal.security' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.update.internal.verifier' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.update.operations' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.update.search' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.update.standalone' version='0.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' version='1.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.localization' name='df_LT' version='1.0.0'/>\r
-      </provides>\r
-      <requires size='7'>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.runtime' range='[3.1.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.update.configurator' range='[3.1.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.net' range='[1.0.0,2.0.0)'/>\r
-        <required namespace='java.package' name='javax.xml.parsers' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.w3c.dom' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.xml.sax' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.xml.sax.helpers' range='0.0.0'/>\r
-      </requires>\r
-      <artifacts size='1'>\r
-        <artifact classifier='osgi.bundle' id='org.eclipse.update.core' version='3.2.202.R34x_v20081128'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='1'>\r
-          <instruction key='manifest'>\r
-            Bundle-RequiredExecutionEnvironment: J2SE-1.4,CDC-1.0/Foundation-1.0,J2SE-1.3&#xA;Bundle-Name: %pluginName&#xA;Bundle-Activator: org.eclipse.update.internal.core.UpdateCore&#xA;Manifest-Version: 1.0&#xA;Bundle-Vendor: %providerName&#xA;Bundle-SymbolicName: org.eclipse.update.core; singleton:=true&#xA;Import-Package: javax.xml.parsers,org.w3c.dom,org.xml.sax,org.xml.sax.helpers&#xA;Bundle-ManifestVersion: 2&#xA;Eclipse-LazyStart: true&#xA;Bundle-Version: 3.2.202.R34x_v20081128&#xA;Bundle-Localization: plugin&#xA;Export-Package: org.eclipse.update.configuration,org.eclipse.update.core,org.eclipse.update.core.model,org.eclipse.update.internal.core;x-friends:=&quot;org.eclipse.update.ui,org.eclipse.update.scheduler,org.eclipse.pde.build&quot;,org.eclipse.update.internal.core.connection;x-internal:=true,org.eclipse.update.internal.jarprocessor;x-friends:=&quot;org.eclipse.pde.build&quot;,org.eclipse.update.internal.mirror;x-internal:=true,org.eclipse.update.internal.model;x-friends:=&quot;org.eclipse.update.ui&quot;,org.eclipse.update.internal.operations;x-friends:=&quot;org.eclipse.update.ui,org.eclipse.update.scheduler&quot;,org.eclipse.update.internal.provisional;x-internal:=true,org.eclipse.update.internal.search;x-friends:=&quot;org.eclipse.update.ui&quot;,org.eclipse.update.internal.security;x-internal:=true,org.eclipse.update.internal.verifier;x-internal:=true,org.eclipse.update.operations,org.eclipse.update.search,org.eclipse.update.standalone&#xA;Require-Bundle: org.eclipse.core.runtime;bundle-version=&quot;[3.1.0,4.0.0)&quot;,org.eclipse.update.configurator;bundle-version=&quot;[3.1.0,4.0.0)&quot;,org.eclipse.core.net;bundle-version=&quot;[1.0.0,2.0.0)&quot;\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='org.eclipse.ui.editors' version='3.4.0.v20080603-2000'>\r
-      <update id='org.eclipse.ui.editors' range='[0.0.0,3.4.0.v20080603-2000)' severity='0'/>\r
-      <properties size='4'>\r
-        <property name='df_LT.providerName' value='Eclipse.org'/>\r
-        <property name='df_LT.pluginName' value='Default Text Editor'/>\r
-        <property name='org.eclipse.equinox.p2.name' value='%pluginName'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='%providerName'/>\r
-      </properties>\r
-      <provides size='10'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.ui.editors' version='3.4.0.v20080603-2000'/>\r
-        <provided namespace='osgi.bundle' name='org.eclipse.ui.editors' version='3.4.0.v20080603-2000'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.editors.text' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.editors.text.templates' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.editors.quickdiff' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.editors.text' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.texteditor' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.texteditor' version='0.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' version='1.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.localization' name='df_LT' version='1.0.0'/>\r
-      </provides>\r
-      <requires size='9'>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.runtime' range='[3.2.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.ui.ide' range='[3.3.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.ui' range='[3.4.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.jface.text' range='[3.4.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.ui.workbench.texteditor' range='[3.4.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.filebuffers' range='[3.4.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.resources' range='[3.2.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.filesystem' range='[1.1.0,2.0.0)'/>\r
-        <required namespace='java.package' name='com.ibm.icu.text' range='0.0.0'/>\r
-      </requires>\r
-      <artifacts size='1'>\r
-        <artifact classifier='osgi.bundle' id='org.eclipse.ui.editors' version='3.4.0.v20080603-2000'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='1'>\r
-          <instruction key='manifest'>\r
-            Bundle-RequiredExecutionEnvironment: J2SE-1.4&#xA;Bundle-Name: %pluginName&#xA;Bundle-Activator: org.eclipse.ui.internal.editors.text.EditorsPlugin&#xA;Manifest-Version: 1.0&#xA;Bundle-Vendor: %providerName&#xA;Bundle-ActivationPolicy: lazy&#xA;Bundle-SymbolicName: org.eclipse.ui.editors; singleton:=true&#xA;Import-Package: com.ibm.icu.text&#xA;Bundle-ManifestVersion: 2&#xA;Bundle-Version: 3.4.0.v20080603-2000&#xA;Bundle-Localization: plugin&#xA;Export-Package: org.eclipse.ui.editors.text,org.eclipse.ui.editors.text.templates,org.eclipse.ui.internal.editors.quickdiff;x-internal:=true,org.eclipse.ui.internal.editors.text;x-internal:=true,org.eclipse.ui.internal.texteditor;x-internal:=true,org.eclipse.ui.texteditor&#xA;Require-Bundle: org.eclipse.core.runtime;bundle-version=&quot;[3.2.0,4.0.0)&quot;,org.eclipse.ui.ide;bundle-version=&quot;[3.3.0,4.0.0)&quot;,org.eclipse.ui;bundle-version=&quot;[3.4.0,4.0.0)&quot;,org.eclipse.jface.text;bundle-version=&quot;[3.4.0,4.0.0)&quot;,org.eclipse.ui.workbench.texteditor;bundle-version=&quot;[3.4.0,4.0.0)&quot;,org.eclipse.core.filebuffers;visibility:=reexport;bundle-version=&quot;[3.4.0,4.0.0)&quot;,org.eclipse.core.resources;bundle-version=&quot;[3.2.0,4.0.0)&quot;,org.eclipse.core.filesystem;bundle-version=&quot;[1.1.0,2.0.0)&quot;\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='org.eclipse.core.filesystem.macosx' version='1.0.0.v20080604-1400'>\r
-      <update id='org.eclipse.core.filesystem.macosx' range='[0.0.0,1.0.0.v20080604-1400)' severity='0'/>\r
-      <properties size='4'>\r
-        <property name='df_LT.fragmentName' value='Core File System for Macintosh'/>\r
-        <property name='df_LT.providerName' value='Eclipse.org'/>\r
-        <property name='org.eclipse.equinox.p2.name' value='%fragmentName'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='%providerName'/>\r
-      </properties>\r
-      <provides size='5'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.core.filesystem.macosx' version='1.0.0.v20080604-1400'/>\r
-        <provided namespace='osgi.bundle' name='org.eclipse.core.filesystem.macosx' version='1.0.0.v20080604-1400'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' version='1.0.0'/>\r
-        <provided namespace='osgi.fragment' name='org.eclipse.core.filesystem' version='1.0.0.v20080604-1400'/>\r
-        <provided namespace='org.eclipse.equinox.p2.localization' name='df_LT' version='1.0.0'/>\r
-      </provides>\r
-      <requires size='1'>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.filesystem' range='[1.0.0,2.0.0)'/>\r
-      </requires>\r
-      <filter>\r
-        (&amp; (osgi.os=macosx) (|(osgi.arch=x86) (osgi.arch=ppc)))\r
-      </filter>\r
-      <artifacts size='1'>\r
-        <artifact classifier='osgi.bundle' id='org.eclipse.core.filesystem.macosx' version='1.0.0.v20080604-1400'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='1'>\r
-          <instruction key='manifest'>\r
-            Bundle-ManifestVersion: 2&#xA;Bundle-Name: %fragmentName&#xA;Bundle-Version: 1.0.0.v20080604-1400&#xA;Fragment-Host: org.eclipse.core.filesystem;bundle-version=&quot;[1.0.0,2.0.0)&quot;&#xA;Eclipse-PlatformFilter: (&amp; (osgi.os=macosx) (|(osgi.arch=x86) (osgi.arch=ppc)))&#xA;Bundle-SymbolicName: org.eclipse.core.filesystem.macosx; singleton:=true&#xA;Bundle-Localization: fragment&#xA;Manifest-Version: 1.0&#xA;Bundle-Vendor: %providerName\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='org.eclipse.help' version='3.3.102.v20081014_34x'>\r
-      <update id='org.eclipse.help' range='[0.0.0,3.3.102.v20081014_34x)' severity='0'/>\r
-      <properties size='4'>\r
-        <property name='df_LT.providerName' value='Eclipse.org'/>\r
-        <property name='df_LT.help_plugin_name' value='Help System Core'/>\r
-        <property name='org.eclipse.equinox.p2.name' value='%help_plugin_name'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='%providerName'/>\r
-      </properties>\r
-      <provides size='13'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.help' version='3.3.102.v20081014_34x'/>\r
-        <provided namespace='osgi.bundle' name='org.eclipse.help' version='3.3.102.v20081014_34x'/>\r
-        <provided namespace='java.package' name='org.eclipse.help' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.help.internal' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.help.internal.context' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.help.internal.dynamic' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.help.internal.entityresolver' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.help.internal.extension' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.help.internal.index' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.help.internal.toc' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.help.internal.util' version='0.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' version='1.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.localization' name='df_LT' version='1.0.0'/>\r
-      </provides>\r
-      <requires size='9'>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.runtime' range='[3.1.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.expressions' range='[3.3.0,4.0.0)'/>\r
-        <required namespace='java.package' name='javax.xml.parsers' range='0.0.0'/>\r
-        <required namespace='java.package' name='javax.xml.transform' range='0.0.0'/>\r
-        <required namespace='java.package' name='javax.xml.transform.dom' range='0.0.0'/>\r
-        <required namespace='java.package' name='javax.xml.transform.stream' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.w3c.dom' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.xml.sax' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.xml.sax.helpers' range='0.0.0'/>\r
-      </requires>\r
-      <artifacts size='1'>\r
-        <artifact classifier='osgi.bundle' id='org.eclipse.help' version='3.3.102.v20081014_34x'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='1'>\r
-          <instruction key='manifest'>\r
-            Bundle-Name: %help_plugin_name&#xA;Bundle-Version: 3.3.102.v20081014_34x&#xA;Eclipse-LazyStart: true&#xA;Import-Package: javax.xml.parsers,javax.xml.transform,javax.xml.transform.dom,javax.xml.transform.stream,org.w3c.dom,org.xml.sax,org.xml.sax.helpers&#xA;Bundle-Activator: org.eclipse.help.internal.HelpPlugin&#xA;Bundle-Vendor: %providerName&#xA;Require-Bundle: org.eclipse.core.runtime;bundle-version=&quot;[3.1.0,4.0.0)&quot;,org.eclipse.core.expressions;bundle-version=&quot;[3.3.0,4.0.0)&quot;;visibility:=reexport&#xA;Export-Package: org.eclipse.help,org.eclipse.help.internal; x-friends:=&quot;org.eclipse.help.base,  org.eclipse.help.ui,  org.eclipse.help.webapp,  org.eclipse.ui.intro,  org.eclipse.ua.tests,  org.eclipse.ui.cheatsheets&quot;,org.eclipse.help.internal.context; x-friends:=&quot;org.eclipse.help.base,  org.eclipse.help.ui,  org.eclipse.ua.tests,  org.eclipse.help.webapp&quot;,org.eclipse.help.internal.dynamic; x-friends:=&quot;org.eclipse.ua.tests,  org.eclipse.help.ui,  org.eclipse.help.base,  org.eclipse.ui.intro,  org.eclipse.help.webapp,  org.eclipse.ui.cheatsheets&quot;,org.eclipse.help.internal.entityresolver; x-friends:=&quot;org.eclipse.help.base,  org.eclipse.help.ui,  org.eclipse.ui.cheatsheets,  org.eclipse.ua.tests&quot;,org.eclipse.help.internal.extension;x-friends:=&quot;org.eclipse.help.webapp,org.eclipse.help.base,org.eclipse.ua.tests&quot;,org.eclipse.help.internal.index; x-friends:=&quot;org.eclipse.help.webapp,  org.eclipse.ua.tests,  org.eclipse.help.ui,  org.eclipse.help.base&quot;,org.eclipse.help.internal.toc; x-friends:=&quot;org.eclipse.help.base,  org.eclipse.help.ui,  org.eclipse.help.webapp,  org.eclipse.ua.tests&quot;,org.eclipse.help.internal.util; x-friends:=&quot;org.eclipse.help.base,  org.eclipse.help.ui,  org.eclipse.help.webapp,  org.eclipse.ua.tests,  org.eclipse.ui.intro.universal&quot;&#xA;Bundle-SymbolicName: org.eclipse.help; singleton:=true&#xA;Manifest-Version: 1.0&#xA;Bundle-ActivationPolicy: lazy&#xA;Bundle-ManifestVersion: 2&#xA;Bundle-RequiredExecutionEnvironment: J2SE-1.4,CDC-1.0/Foundation-1.0,J2SE-1.3&#xA;Bundle-Localization: plugin\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='org.eclipse.jface' version='3.4.2.M20090107-0800' singleton='false'>\r
-      <update id='org.eclipse.jface' range='[0.0.0,3.4.2.M20090107-0800)' severity='0'/>\r
-      <properties size='4'>\r
-        <property name='df_LT.providerName' value='Eclipse.org'/>\r
-        <property name='df_LT.pluginName' value='JFace'/>\r
-        <property name='org.eclipse.equinox.p2.name' value='%pluginName'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='%providerName'/>\r
-      </properties>\r
-      <provides size='31'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.jface' version='3.4.2.M20090107-0800'/>\r
-        <provided namespace='osgi.bundle' name='org.eclipse.jface' version='3.4.2.M20090107-0800'/>\r
-        <provided namespace='java.package' name='org.eclipse.jface' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.jface.action' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.jface.action.images' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.jface.bindings' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.jface.bindings.keys' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.jface.bindings.keys.formatting' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.jface.commands' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.jface.contexts' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.jface.dialogs' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.jface.dialogs.images' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.jface.fieldassist' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.jface.fieldassist.images' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.jface.images' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.jface.internal' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.jface.internal.provisional.action' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.jface.layout' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.jface.menus' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.jface.operation' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.jface.preference' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.jface.preference.images' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.jface.resource' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.jface.util' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.jface.viewers' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.jface.viewers.deferred' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.jface.window' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.jface.wizard' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.jface.wizard.images' version='0.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' version='1.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.localization' name='df_LT' version='1.0.0'/>\r
-      </provides>\r
-      <requires size='7'>\r
-        <required namespace='osgi.bundle' name='org.eclipse.swt' range='[3.4.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.commands' range='[3.4.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.equinox.common' range='[3.2.0,4.0.0)'/>\r
-        <required namespace='java.package' name='javax.xml.parsers' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.osgi.framework' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.w3c.dom' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.xml.sax' range='0.0.0'/>\r
-      </requires>\r
-      <artifacts size='1'>\r
-        <artifact classifier='osgi.bundle' id='org.eclipse.jface' version='3.4.2.M20090107-0800'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='1'>\r
-          <instruction key='manifest'>\r
-            Bundle-Name: %pluginName&#xA;Bundle-ClassPath: .&#xA;Bundle-Version: 3.4.2.M20090107-0800&#xA;Import-Package: javax.xml.parsers,org.osgi.framework,org.w3c.dom,org.xml.sax&#xA;Bundle-Activator: org.eclipse.jface.internal.JFaceActivator&#xA;Bundle-Vendor: %providerName&#xA;Require-Bundle: org.eclipse.swt;bundle-version=&quot;[3.4.0,4.0.0)&quot;;visibility:=reexport,org.eclipse.core.commands;bundle-version=&quot;[3.4.0,4.0.0)&quot;;visibility:=reexport,org.eclipse.equinox.common;bundle-version=&quot;[3.2.0,4.0.0)&quot;&#xA;Export-Package: org.eclipse.jface,org.eclipse.jface.action,org.eclipse.jface.action.images,org.eclipse.jface.bindings,org.eclipse.jface.bindings.keys,org.eclipse.jface.bindings.keys.formatting,org.eclipse.jface.commands,org.eclipse.jface.contexts,org.eclipse.jface.dialogs,org.eclipse.jface.dialogs.images,org.eclipse.jface.fieldassist,org.eclipse.jface.fieldassist.images,org.eclipse.jface.images,org.eclipse.jface.internal;x-friends:=&quot;org.eclipse.ui.workbench&quot;,org.eclipse.jface.internal.provisional.action;x-friends:=&quot;org.eclipse.ui.workbench&quot;,org.eclipse.jface.layout,org.eclipse.jface.menus,org.eclipse.jface.operation,org.eclipse.jface.preference,org.eclipse.jface.preference.images,org.eclipse.jface.resource,org.eclipse.jface.util,org.eclipse.jface.viewers,org.eclipse.jface.viewers.deferred,org.eclipse.jface.window,org.eclipse.jface.wizard,org.eclipse.jface.wizard.images&#xA;Bundle-SymbolicName: org.eclipse.jface&#xA;Manifest-Version: 1.0&#xA;Bundle-ActivationPolicy: lazy&#xA;Bundle-ManifestVersion: 2&#xA;Bundle-RequiredExecutionEnvironment: J2SE-1.4,CDC-1.0/Foundation-1.0,J2SE-1.3&#xA;Bundle-Localization: plugin\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='org.eclipse.ui.navigator' version='3.3.102.M20090127-1700'>\r
-      <update id='org.eclipse.ui.navigator' range='[0.0.0,3.3.102.M20090127-1700)' severity='0'/>\r
-      <properties size='4'>\r
-        <property name='df_LT.Plugin.name' value='Common Navigator View'/>\r
-        <property name='df_LT.Plugin.providerName' value='Eclipse.org'/>\r
-        <property name='org.eclipse.equinox.p2.name' value='%Plugin.name'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='%Plugin.providerName'/>\r
-      </properties>\r
-      <provides size='12'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.ui.navigator' version='3.3.102.M20090127-1700'/>\r
-        <provided namespace='osgi.bundle' name='org.eclipse.ui.navigator' version='3.3.102.M20090127-1700'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.navigator' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.navigator.actions' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.navigator.dnd' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.navigator.extensions' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.navigator.filters' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.navigator.sorters' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.navigator.wizards' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.navigator' version='0.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' version='1.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.localization' name='df_LT' version='1.0.0'/>\r
-      </provides>\r
-      <requires size='5'>\r
-        <required namespace='osgi.bundle' name='org.eclipse.jface' range='[3.2.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.ui.workbench' range='[3.2.1,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.runtime' range='[3.2.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.ui' range='[3.2.1,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.expressions' range='[3.2.0,4.0.0)'/>\r
-      </requires>\r
-      <artifacts size='1'>\r
-        <artifact classifier='osgi.bundle' id='org.eclipse.ui.navigator' version='3.3.102.M20090127-1700'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='1'>\r
-          <instruction key='manifest'>\r
-            Bundle-ManifestVersion: 2&#xA;Export-Package: org.eclipse.ui.internal.navigator;x-friends:=&quot;org.eclipse.ui.navigator.ide,org.eclipse.ui.navigator.resources&quot;,org.eclipse.ui.internal.navigator.actions;x-friends:=&quot;org.eclipse.ui.navigator.ide,org.eclipse.ui.navigator.resources&quot;,org.eclipse.ui.internal.navigator.dnd;x-friends:=&quot;org.eclipse.ui.navigator.ide,org.eclipse.ui.navigator.resources&quot;,org.eclipse.ui.internal.navigator.extensions;x-friends:=&quot;org.eclipse.ui.navigator.ide,org.eclipse.ui.navigator.resources&quot;,org.eclipse.ui.internal.navigator.filters;x-friends:=&quot;org.eclipse.ui.navigator.ide,org.eclipse.ui.navigator.resources,org.eclipse.ui.tests.navigator&quot;,org.eclipse.ui.internal.navigator.sorters;x-internal:=true,org.eclipse.ui.internal.navigator.wizards;x-internal:=true,org.eclipse.ui.navigator&#xA;Bundle-RequiredExecutionEnvironment: J2SE-1.4&#xA;Bundle-Localization: plugin&#xA;Require-Bundle: org.eclipse.jface;bundle-version=&quot;[3.2.0,4.0.0)&quot;,org.eclipse.ui.workbench;bundle-version=&quot;[3.2.1,4.0.0)&quot;,org.eclipse.core.runtime;bundle-version=&quot;[3.2.0,4.0.0)&quot;,org.eclipse.ui;bundle-version=&quot;[3.2.1,4.0.0)&quot;,org.eclipse.core.expressions;bundle-version=&quot;[3.2.0,4.0.0)&quot;&#xA;Bundle-Activator: org.eclipse.ui.internal.navigator.NavigatorPlugin&#xA;Bundle-Name: %Plugin.name&#xA;Bundle-Version: 3.3.102.M20090127-1700&#xA;Bundle-Vendor: %Plugin.providerName&#xA;Bundle-SymbolicName: org.eclipse.ui.navigator; singleton:=true&#xA;Bundle-ActivationPolicy: lazy&#xA;Manifest-Version: 1.0\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='org.eclipse.equinox.simpleconfigurator' version='1.0.0.v20080604'>\r
-      <update id='org.eclipse.equinox.simpleconfigurator' range='[0.0.0,1.0.0.v20080604)' severity='0'/>\r
-      <properties size='4'>\r
-        <property name='df_LT.bundleName' value='Simple Configurator'/>\r
-        <property name='df_LT.providerName' value='Eclipse.org'/>\r
-        <property name='org.eclipse.equinox.p2.name' value='%bundleName'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='%providerName'/>\r
-      </properties>\r
-      <provides size='5'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.equinox.simpleconfigurator' version='1.0.0.v20080604'/>\r
-        <provided namespace='osgi.bundle' name='org.eclipse.equinox.simpleconfigurator' version='1.0.0.v20080604'/>\r
-        <provided namespace='java.package' name='org.eclipse.equinox.internal.provisional.configurator' version='0.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' version='1.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.localization' name='df_LT' version='1.0.0'/>\r
-      </provides>\r
-      <requires size='7'>\r
-        <required namespace='java.package' name='org.eclipse.osgi.framework.console' range='1.0.0' optional='true'/>\r
-        <required namespace='java.package' name='org.eclipse.osgi.service.datalocation' range='1.0.0' optional='true'/>\r
-        <required namespace='java.package' name='org.eclipse.osgi.service.resolver' range='1.2.0' optional='true'/>\r
-        <required namespace='java.package' name='org.osgi.framework' range='1.3.0'/>\r
-        <required namespace='java.package' name='org.osgi.service.packageadmin' range='1.2.0'/>\r
-        <required namespace='java.package' name='org.osgi.service.startlevel' range='1.0.0'/>\r
-        <required namespace='java.package' name='org.osgi.util.tracker' range='1.3.0'/>\r
-      </requires>\r
-      <artifacts size='1'>\r
-        <artifact classifier='osgi.bundle' id='org.eclipse.equinox.simpleconfigurator' version='1.0.0.v20080604'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='1'>\r
-          <instruction key='manifest'>\r
-            Bundle-ManifestVersion: 2&#xA;Export-Package: org.eclipse.equinox.internal.provisional.configurator;x-friends:=&quot;org.eclipse.equinox.p2.reconciler.dropins,org.eclipse.equinox.p2.console,org.eclipse.equinox.p2.ui&quot;&#xA;Bundle-RequiredExecutionEnvironment: CDC-1.1/Foundation-1.1,J2SE-1.4&#xA;Bundle-Localization: plugin&#xA;Bundle-Activator: org.eclipse.equinox.internal.simpleconfigurator.Activator&#xA;Bundle-Name: %bundleName&#xA;Bundle-Version: 1.0.0.v20080604&#xA;Bundle-Vendor: %providerName&#xA;Bundle-SymbolicName: org.eclipse.equinox.simpleconfigurator;singleton:=true&#xA;Import-Package: org.eclipse.osgi.framework.console;version=&quot;1.0.0&quot;;resolution:=optional,org.eclipse.osgi.service.datalocation;version=&quot;1.0.0&quot;;resolution:=optional,org.eclipse.osgi.service.resolver;version=&quot;1.2.0&quot;;resolution:=optional,org.osgi.framework;version=&quot;1.3.0&quot;,org.osgi.service.packageadmin;version=&quot;1.2.0&quot;,org.osgi.service.startlevel;version=&quot;1.0.0&quot;,org.osgi.util.tracker;version=&quot;1.3.0&quot;&#xA;Manifest-Version: 1.0&#xA;Eclipse-LazyStart: true\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='org.eclipse.update.ui' version='3.2.101.R34x_v20081128'>\r
-      <update id='org.eclipse.update.ui' range='[0.0.0,3.2.101.R34x_v20081128)' severity='0'/>\r
-      <properties size='4'>\r
-        <property name='df_LT.providerName' value='Eclipse.org'/>\r
-        <property name='df_LT.pluginName' value='Install/Update UI'/>\r
-        <property name='org.eclipse.equinox.p2.name' value='%pluginName'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='%providerName'/>\r
-      </properties>\r
-      <provides size='13'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.update.ui' version='3.2.101.R34x_v20081128'/>\r
-        <provided namespace='osgi.bundle' name='org.eclipse.update.ui' version='3.2.101.R34x_v20081128'/>\r
-        <provided namespace='java.package' name='org.eclipse.update.internal.ui' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.update.internal.ui.model' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.update.internal.ui.parts' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.update.internal.ui.preferences' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.update.internal.ui.properties' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.update.internal.ui.security' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.update.internal.ui.views' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.update.internal.ui.wizards' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.update.ui' version='0.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' version='1.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.localization' name='df_LT' version='1.0.0'/>\r
-      </provides>\r
-      <requires size='8'>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.runtime' range='[3.1.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.ui' range='[3.2.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.update.core' range='[3.1.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.update.configurator' range='[3.1.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.ui.forms' range='[3.2.0,4.0.0)'/>\r
-        <required namespace='java.package' name='javax.xml.parsers' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.w3c.dom' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.xml.sax' range='0.0.0'/>\r
-      </requires>\r
-      <artifacts size='1'>\r
-        <artifact classifier='osgi.bundle' id='org.eclipse.update.ui' version='3.2.101.R34x_v20081128'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='1'>\r
-          <instruction key='manifest'>\r
-            Bundle-RequiredExecutionEnvironment: J2SE-1.4,CDC-1.0/Foundation-1.0,J2SE-1.3&#xA;Bundle-Name: %pluginName&#xA;Bundle-Activator: org.eclipse.update.internal.ui.UpdateUI&#xA;Manifest-Version: 1.0&#xA;Bundle-Vendor: %providerName&#xA;Bundle-SymbolicName: org.eclipse.update.ui; singleton:=true&#xA;Import-Package: javax.xml.parsers,org.w3c.dom,org.xml.sax&#xA;Bundle-ManifestVersion: 2&#xA;Eclipse-LazyStart: true&#xA;Bundle-Version: 3.2.101.R34x_v20081128&#xA;Bundle-Localization: plugin&#xA;Export-Package: org.eclipse.update.internal.ui;x-friends:=&quot;org.eclipse.update.scheduler&quot;,org.eclipse.update.internal.ui.model;x-internal:=true,org.eclipse.update.internal.ui.parts;x-internal:=true,org.eclipse.update.internal.ui.preferences;x-internal:=true,org.eclipse.update.internal.ui.properties;x-internal:=true,org.eclipse.update.internal.ui.security;x-internal:=true,org.eclipse.update.internal.ui.views;x-internal:=true,org.eclipse.update.internal.ui.wizards;x-friends:=&quot;org.eclipse.update.scheduler&quot;,org.eclipse.update.ui&#xA;Require-Bundle: org.eclipse.core.runtime;bundle-version=&quot;[3.1.0,4.0.0)&quot;,org.eclipse.ui;bundle-version=&quot;[3.2.0,4.0.0)&quot;,org.eclipse.update.core;bundle-version=&quot;[3.1.0,4.0.0)&quot;,org.eclipse.update.configurator;bundle-version=&quot;[3.1.0,4.0.0)&quot;,org.eclipse.ui.forms;bundle-version=&quot;[3.2.0,4.0.0)&quot;\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='org.eclipse.core.resources.compatibility' version='3.4.0.v20080604-1400' singleton='false'>\r
-      <update id='org.eclipse.core.resources.compatibility' range='[0.0.0,3.4.0.v20080604-1400)' severity='0'/>\r
-      <properties size='2'>\r
-        <property name='org.eclipse.equinox.p2.name' value='%compatibilityFragmentName'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='%providerName'/>\r
-      </properties>\r
-      <provides size='8'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.core.resources.compatibility' version='3.4.0.v20080604-1400'/>\r
-        <provided namespace='osgi.bundle' name='org.eclipse.core.resources.compatibility' version='3.4.0.v20080604-1400'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.internal.indexing' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.internal.localstore' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.internal.properties' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.internal.resources' version='0.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' version='1.0.0'/>\r
-        <provided namespace='osgi.fragment' name='org.eclipse.core.resources' version='3.4.0.v20080604-1400'/>\r
-      </provides>\r
-      <requires size='1'>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.resources' range='[3.4.0,4.0.0)'/>\r
-      </requires>\r
-      <artifacts size='1'>\r
-        <artifact classifier='osgi.bundle' id='org.eclipse.core.resources.compatibility' version='3.4.0.v20080604-1400'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='1'>\r
-          <instruction key='manifest'>\r
-            Bundle-ManifestVersion: 2&#xA;Fragment-Host: org.eclipse.core.resources;bundle-version=&quot;[3.4.0,4.0.0)&quot;&#xA;Bundle-RequiredExecutionEnvironment: J2SE-1.4&#xA;Manifest-Version: 1.0&#xA;Bundle-Version: 3.4.0.v20080604-1400&#xA;Export-Package: org.eclipse.core.internal.indexing;x-internal:=true,org.eclipse.core.internal.localstore;x-internal:=true,org.eclipse.core.internal.properties;x-internal:=true,org.eclipse.core.internal.resources;x-internal:=true&#xA;Bundle-SymbolicName: org.eclipse.core.resources.compatibility&#xA;Bundle-Localization: plugin&#xA;Bundle-Name: %compatibilityFragmentName&#xA;Bundle-Vendor: %providerName\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='org.eclipse.ui.views' version='3.3.1.M20081112-0800'>\r
-      <update id='org.eclipse.ui.views' range='[0.0.0,3.3.1.M20081112-0800)' severity='0'/>\r
-      <properties size='4'>\r
-        <property name='df_LT.providerName' value='Eclipse.org'/>\r
-        <property name='df_LT.pluginName' value='Views'/>\r
-        <property name='org.eclipse.equinox.p2.name' value='%pluginName'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='%providerName'/>\r
-      </properties>\r
-      <provides size='9'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.ui.views' version='3.3.1.M20081112-0800'/>\r
-        <provided namespace='osgi.bundle' name='org.eclipse.ui.views' version='3.3.1.M20081112-0800'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.views' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.views.contentoutline' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.views.properties' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.views.contentoutline' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.views.properties' version='0.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' version='1.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.localization' name='df_LT' version='1.0.0'/>\r
-      </provides>\r
-      <requires size='3'>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.runtime' range='[3.2.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.help' range='[3.2.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.ui' range='[3.3.0,4.0.0)'/>\r
-      </requires>\r
-      <artifacts size='1'>\r
-        <artifact classifier='osgi.bundle' id='org.eclipse.ui.views' version='3.3.1.M20081112-0800'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='1'>\r
-          <instruction key='manifest'>\r
-            Bundle-RequiredExecutionEnvironment: J2SE-1.4&#xA;Bundle-Name: %pluginName&#xA;Bundle-Activator: org.eclipse.ui.internal.views.ViewsPlugin&#xA;Manifest-Version: 1.0&#xA;Bundle-Vendor: %providerName&#xA;Bundle-ClassPath: .&#xA;Bundle-ActivationPolicy: lazy&#xA;Bundle-SymbolicName: org.eclipse.ui.views; singleton:=true&#xA;Bundle-ManifestVersion: 2&#xA;Bundle-Version: 3.3.1.M20081112-0800&#xA;Bundle-Localization: plugin&#xA;Export-Package: org.eclipse.ui.internal.views;x-internal:=true,org.eclipse.ui.internal.views.contentoutline;x-internal:=true,org.eclipse.ui.internal.views.properties; ui.views=&quot;split&quot;; mandatory:=&quot;ui.views&quot;; x-internal:=true,org.eclipse.ui.views.contentoutline,org.eclipse.ui.views.properties; ui.views=&quot;split&quot;; mandatory:=&quot;ui.views&quot;&#xA;Require-Bundle: org.eclipse.core.runtime;bundle-version=&quot;[3.2.0,4.0.0)&quot;,org.eclipse.help;bundle-version=&quot;[3.2.0,4.0.0)&quot;,org.eclipse.ui;bundle-version=&quot;[3.3.0,4.0.0)&quot;\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='org.eclipse.swt.carbon.macosx.translated_host_properties' version='3.4.1.v3452b'>\r
-      <hostRequirements size='1'>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.swt' range='[3.0.0,4.0.0)' greedy='false'/>\r
-      </hostRequirements>\r
-      <properties size='1'>\r
-        <property name='org.eclipse.equinox.p2.type.fragment' value='true'/>\r
-      </properties>\r
-      <requires size='1'>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.swt' range='[3.0.0,4.0.0)' greedy='false'/>\r
-      </requires>\r
-      <touchpoint id='null' version='0.0.0'/>\r
-    </unit>\r
-    <unit id='org.eclipse.core.expressions' version='3.4.1.r342_v20081203-0800'>\r
-      <update id='org.eclipse.core.expressions' range='[0.0.0,3.4.1.r342_v20081203-0800)' severity='0'/>\r
-      <properties size='4'>\r
-        <property name='df_LT.providerName' value='Eclipse.org'/>\r
-        <property name='df_LT.pluginName' value='Expression Language'/>\r
-        <property name='org.eclipse.equinox.p2.name' value='%pluginName'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='%providerName'/>\r
-      </properties>\r
-      <provides size='8'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.core.expressions' version='3.4.1.r342_v20081203-0800'/>\r
-        <provided namespace='osgi.bundle' name='org.eclipse.core.expressions' version='3.4.1.r342_v20081203-0800'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.expressions' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.internal.expressions' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.internal.expressions.propertytester' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.internal.expressions.util' version='0.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' version='1.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.localization' name='df_LT' version='1.0.0'/>\r
-      </provides>\r
-      <requires size='2'>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.runtime' range='[3.3.0,4.0.0)'/>\r
-        <required namespace='java.package' name='org.w3c.dom' range='0.0.0'/>\r
-      </requires>\r
-      <artifacts size='1'>\r
-        <artifact classifier='osgi.bundle' id='org.eclipse.core.expressions' version='3.4.1.r342_v20081203-0800'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='1'>\r
-          <instruction key='manifest'>\r
-            Bundle-Name: %pluginName&#xA;Bundle-ClassPath: .&#xA;Bundle-Version: 3.4.1.r342_v20081203-0800&#xA;Import-Package: org.w3c.dom&#xA;Bundle-Activator: org.eclipse.core.internal.expressions.ExpressionPlugin&#xA;Bundle-Vendor: %providerName&#xA;Require-Bundle: org.eclipse.core.runtime;bundle-version=&quot;[3.3.0,4.0.0)&quot;&#xA;Export-Package: org.eclipse.core.expressions,org.eclipse.core.internal.expressions;x-internal:=true,org.eclipse.core.internal.expressions.propertytester;x-internal:=true,org.eclipse.core.internal.expressions.util;x-internal:=true&#xA;Bundle-SymbolicName: org.eclipse.core.expressions; singleton:=true&#xA;Manifest-Version: 1.0&#xA;Bundle-ActivationPolicy: lazy&#xA;Bundle-ManifestVersion: 2&#xA;Bundle-RequiredExecutionEnvironment: J2SE-1.4,CDC-1.0/Foundation-1.0,J2SE-1.3&#xA;Bundle-Localization: plugin\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='org.eclipse.core.variables' version='3.2.100.v20080529-1300'>\r
-      <update id='org.eclipse.core.variables' range='[0.0.0,3.2.100.v20080529-1300)' severity='0'/>\r
-      <properties size='4'>\r
-        <property name='df_LT.providerName' value='Eclipse.org'/>\r
-        <property name='df_LT.pluginName' value='Core Variables'/>\r
-        <property name='org.eclipse.equinox.p2.name' value='%pluginName'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='%providerName'/>\r
-      </properties>\r
-      <provides size='6'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.core.variables' version='3.2.100.v20080529-1300'/>\r
-        <provided namespace='osgi.bundle' name='org.eclipse.core.variables' version='3.2.100.v20080529-1300'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.internal.variables' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.variables' version='0.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' version='1.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.localization' name='df_LT' version='1.0.0'/>\r
-      </provides>\r
-      <requires size='1'>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.runtime' range='[3.3.0,4.0.0)'/>\r
-      </requires>\r
-      <artifacts size='1'>\r
-        <artifact classifier='osgi.bundle' id='org.eclipse.core.variables' version='3.2.100.v20080529-1300'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='1'>\r
-          <instruction key='manifest'>\r
-            Bundle-ManifestVersion: 2&#xA;Export-Package: org.eclipse.core.internal.variables;x-internal:=true,org.eclipse.core.variables&#xA;Bundle-RequiredExecutionEnvironment: J2SE-1.4&#xA;Bundle-Localization: plugin&#xA;Require-Bundle: org.eclipse.core.runtime;bundle-version=&quot;[3.3.0,4.0.0)&quot;&#xA;Bundle-Activator: org.eclipse.core.variables.VariablesPlugin&#xA;Bundle-Name: %pluginName&#xA;Bundle-Version: 3.2.100.v20080529-1300&#xA;Bundle-Vendor: %providerName&#xA;Bundle-SymbolicName: org.eclipse.core.variables; singleton:=true&#xA;Bundle-ActivationPolicy: lazy&#xA;Manifest-Version: 1.0\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='org.eclipse.equinox.preferences' version='3.2.201.R34x_v20080709'>\r
-      <update id='org.eclipse.equinox.preferences' range='[0.0.0,3.2.201.R34x_v20080709)' severity='0'/>\r
-      <properties size='4'>\r
-        <property name='df_LT.providerName' value='Eclipse.org'/>\r
-        <property name='df_LT.pluginName' value='Eclipse Preferences Mechanism'/>\r
-        <property name='org.eclipse.equinox.p2.name' value='%pluginName'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='%providerName'/>\r
-      </properties>\r
-      <provides size='8'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.equinox.preferences' version='3.2.201.R34x_v20080709'/>\r
-        <provided namespace='osgi.bundle' name='org.eclipse.equinox.preferences' version='3.2.201.R34x_v20080709'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.internal.preferences' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.internal.preferences.exchange' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.runtime.preferences' version='3.2.0'/>\r
-        <provided namespace='java.package' name='org.osgi.service.prefs' version='1.1.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' version='1.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.localization' name='df_LT' version='1.0.0'/>\r
-      </provides>\r
-      <requires size='10'>\r
-        <required namespace='osgi.bundle' name='org.eclipse.equinox.common' range='[3.2.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.equinox.registry' range='[3.2.0,4.0.0)' optional='true'/>\r
-        <required namespace='java.package' name='org.eclipse.osgi.framework.log' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.eclipse.osgi.service.datalocation' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.eclipse.osgi.service.debug' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.eclipse.osgi.service.environment' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.eclipse.osgi.util' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.osgi.framework' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.osgi.service.packageadmin' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.osgi.util.tracker' range='0.0.0'/>\r
-      </requires>\r
-      <artifacts size='1'>\r
-        <artifact classifier='osgi.bundle' id='org.eclipse.equinox.preferences' version='3.2.201.R34x_v20080709'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='1'>\r
-          <instruction key='manifest'>\r
-            Bundle-ManifestVersion: 2&#xA;Bundle-RequiredExecutionEnvironment: CDC-1.0/Foundation-1.0,J2SE-1.3&#xA;Bundle-ActivationPolicy: lazy; exclude:=&quot;org.eclipse.core.internal.preferences.exchange&quot;&#xA;Bundle-Name: %pluginName&#xA;Require-Bundle: org.eclipse.equinox.common;bundle-version=&quot;[3.2.0,4.0.0)&quot;,org.eclipse.equinox.registry;bundle-version=&quot;[3.2.0,4.0.0)&quot;;resolution:=optional&#xA;Bundle-Activator: org.eclipse.core.internal.preferences.Activator&#xA;Bundle-Vendor: %providerName&#xA;Manifest-Version: 1.0&#xA;Bundle-Version: 3.2.201.R34x_v20080709&#xA;Bundle-Localization: plugin&#xA;Comment-Header: Both Eclipse-LazyStart and Bundle-ActivationPolicy are specified for compatibility with 3.2&#xA;Export-Package: org.eclipse.core.internal.preferences;x-friends:=&quot;org.eclipse.core.resources,org.eclipse.core.runtime&quot;,org.eclipse.core.internal.preferences.exchange;x-friends:=&quot;org.eclipse.core.runtime&quot;,org.eclipse.core.runtime.preferences;version=&quot;3.2.0&quot;,org.osgi.service.prefs;version=&quot;1.1&quot;&#xA;Bundle-SymbolicName: org.eclipse.equinox.preferences; singleton:=true&#xA;Import-Package: org.eclipse.osgi.framework.log,org.eclipse.osgi.service.datalocation,org.eclipse.osgi.service.debug,org.eclipse.osgi.service.environment,org.eclipse.osgi.util,org.osgi.framework,org.osgi.service.packageadmin,org.osgi.util.tracker&#xA;Eclipse-LazyStart: true; exceptions=&quot;org.eclipse.core.internal.preferences.exchange&quot;\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='org.eclipse.core.jobs' version='3.4.1.R34x_v20081128'>\r
-      <update id='org.eclipse.core.jobs' range='[0.0.0,3.4.1.R34x_v20081128)' severity='0'/>\r
-      <properties size='4'>\r
-        <property name='df_LT.providerName' value='Eclipse.org'/>\r
-        <property name='df_LT.pluginName' value='Eclipse Jobs Mechanism'/>\r
-        <property name='org.eclipse.equinox.p2.name' value='%pluginName'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='%providerName'/>\r
-      </properties>\r
-      <provides size='6'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.core.jobs' version='3.4.1.R34x_v20081128'/>\r
-        <provided namespace='osgi.bundle' name='org.eclipse.core.jobs' version='3.4.1.R34x_v20081128'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.internal.jobs' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.runtime.jobs' version='0.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' version='1.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.localization' name='df_LT' version='1.0.0'/>\r
-      </provides>\r
-      <requires size='6'>\r
-        <required namespace='osgi.bundle' name='org.eclipse.equinox.common' range='[3.2.0,4.0.0)'/>\r
-        <required namespace='java.package' name='org.eclipse.osgi.service.debug' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.eclipse.osgi.util' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.osgi.framework' range='1.3.0'/>\r
-        <required namespace='java.package' name='org.osgi.service.packageadmin' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.osgi.util.tracker' range='0.0.0'/>\r
-      </requires>\r
-      <artifacts size='1'>\r
-        <artifact classifier='osgi.bundle' id='org.eclipse.core.jobs' version='3.4.1.R34x_v20081128'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='1'>\r
-          <instruction key='manifest'>\r
-            Bundle-RequiredExecutionEnvironment: CDC-1.0/Foundation-1.0,J2SE-1.3&#xA;Bundle-Name: %pluginName&#xA;Bundle-Activator: org.eclipse.core.internal.jobs.JobActivator&#xA;Manifest-Version: 1.0&#xA;Bundle-Vendor: %providerName&#xA;Bundle-SymbolicName: org.eclipse.core.jobs; singleton:=true&#xA;Import-Package: org.eclipse.osgi.service.debug,org.eclipse.osgi.util,org.osgi.framework;version=&quot;1.3.0&quot;,org.osgi.service.packageadmin,org.osgi.util.tracker&#xA;Bundle-ManifestVersion: 2&#xA;Eclipse-LazyStart: true&#xA;Bundle-Version: 3.4.1.R34x_v20081128&#xA;Bundle-Localization: plugin&#xA;Export-Package: org.eclipse.core.internal.jobs;x-internal:=true,org.eclipse.core.runtime.jobs&#xA;Require-Bundle: org.eclipse.equinox.common;bundle-version=&quot;[3.2.0,4.0.0)&quot;\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='toolingorg.eclipse.equinox.simpleconfigurator' version='1.0.0.v20080604' singleton='false'>\r
-      <hostRequirements size='2'>\r
-        <required namespace='osgi.bundle' name='org.eclipse.equinox.simpleconfigurator' range='1.0.0.v20080604'/>\r
-        <required namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' range='[1.0.0,2.0.0)' greedy='false'/>\r
-      </hostRequirements>\r
-      <properties size='1'>\r
-        <property name='org.eclipse.equinox.p2.type.fragment' value='true'/>\r
-      </properties>\r
-      <provides size='2'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='toolingorg.eclipse.equinox.simpleconfigurator' version='1.0.0.v20080604'/>\r
-        <provided namespace='org.eclipse.equinox.p2.flavor' name='tooling' version='1.0.0'/>\r
-      </provides>\r
-      <requires size='2'>\r
-        <required namespace='osgi.bundle' name='org.eclipse.equinox.simpleconfigurator' range='1.0.0.v20080604'/>\r
-        <required namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' range='[1.0.0,2.0.0)' greedy='false'/>\r
-      </requires>\r
-      <touchpoint id='null' version='0.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='4'>\r
-          <instruction key='uninstall'>\r
-            uninstallBundle(bundle:${artifact})\r
-          </instruction>\r
-          <instruction key='configure'>\r
-            setStartLevel(startLevel:1);markStarted(started: true);\r
-          </instruction>\r
-          <instruction key='install'>\r
-            installBundle(bundle:${artifact})\r
-          </instruction>\r
-          <instruction key='unconfigure'>\r
-            setStartLevel(startLevel:-1);markStarted(started: false);\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='org.eclipse.ui' version='3.4.2.M20090204-0800'>\r
-      <update id='org.eclipse.ui' range='[0.0.0,3.4.2.M20090204-0800)' severity='0'/>\r
-      <properties size='4'>\r
-        <property name='df_LT.Plugin.name' value='Eclipse UI'/>\r
-        <property name='df_LT.Plugin.providerName' value='Eclipse.org'/>\r
-        <property name='org.eclipse.equinox.p2.name' value='%Plugin.name'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='%Plugin.providerName'/>\r
-      </properties>\r
-      <provides size='5'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.ui' version='3.4.2.M20090204-0800'/>\r
-        <provided namespace='osgi.bundle' name='org.eclipse.ui' version='3.4.2.M20090204-0800'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal' version='0.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' version='1.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.localization' name='df_LT' version='1.0.0'/>\r
-      </provides>\r
-      <requires size='5'>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.runtime' range='[3.2.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.swt' range='[3.3.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.jface' range='[3.4.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.ui.workbench' range='[3.4.2,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.expressions' range='[3.4.0,4.0.0)'/>\r
-      </requires>\r
-      <artifacts size='1'>\r
-        <artifact classifier='osgi.bundle' id='org.eclipse.ui' version='3.4.2.M20090204-0800'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='1'>\r
-          <instruction key='manifest'>\r
-            Bundle-RequiredExecutionEnvironment: CDC-1.0/Foundation-1.0,J2SE-1.3&#xA;Bundle-Name: %Plugin.name&#xA;Bundle-Activator: org.eclipse.ui.internal.UIPlugin&#xA;Manifest-Version: 1.0&#xA;Bundle-Vendor: %Plugin.providerName&#xA;Bundle-ClassPath: .&#xA;Bundle-ActivationPolicy: lazy&#xA;Bundle-SymbolicName: org.eclipse.ui; singleton:=true&#xA;Bundle-ManifestVersion: 2&#xA;Bundle-Version: 3.4.2.M20090204-0800&#xA;Bundle-Localization: plugin&#xA;Export-Package: org.eclipse.ui.internal;x-internal:=true&#xA;Require-Bundle: org.eclipse.core.runtime;bundle-version=&quot;[3.2.0,4.0.0)&quot;,org.eclipse.swt;bundle-version=&quot;[3.3.0,4.0.0)&quot;;visibility:=reexport,org.eclipse.jface;bundle-version=&quot;[3.4.0,4.0.0)&quot;;visibility:=reexport,org.eclipse.ui.workbench;bundle-version=&quot;[3.4.2,4.0.0)&quot;;visibility:=reexport,org.eclipse.core.expressions;bundle-version=&quot;[3.4.0,4.0.0)&quot;\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='org.eclipse.equinox.security.macosx' version='1.0.0.v20080602-2000'>\r
-      <update id='org.eclipse.equinox.security.macosx' range='[0.0.0,1.0.0.v20080602-2000)' severity='0'/>\r
-      <properties size='4'>\r
-        <property name='df_LT.fragmentName' value='OS X Keystore service integration'/>\r
-        <property name='df_LT.providerName' value='Eclipse.org'/>\r
-        <property name='org.eclipse.equinox.p2.name' value='%fragmentName'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='%providerName'/>\r
-      </properties>\r
-      <provides size='7'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.equinox.security.macosx' version='1.0.0.v20080602-2000'/>\r
-        <provided namespace='osgi.bundle' name='org.eclipse.equinox.security.macosx' version='1.0.0.v20080602-2000'/>\r
-        <provided namespace='java.package' name='org.eclipse.equinox.internal.security.osx' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.equinox.internal.security.osx.nls' version='0.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' version='1.0.0'/>\r
-        <provided namespace='osgi.fragment' name='org.eclipse.equinox.security' version='1.0.0.v20080602-2000'/>\r
-        <provided namespace='org.eclipse.equinox.p2.localization' name='df_LT' version='1.0.0'/>\r
-      </provides>\r
-      <requires size='2'>\r
-        <required namespace='osgi.bundle' name='org.eclipse.equinox.security' range='[1.0.0,2.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.swt' range='[3.4.0,4.0.0)' optional='true'/>\r
-      </requires>\r
-      <filter>\r
-        (&amp; (osgi.os=macosx) (|(osgi.arch=x86)(osgi.arch=ppc)) )\r
-      </filter>\r
-      <artifacts size='1'>\r
-        <artifact classifier='osgi.bundle' id='org.eclipse.equinox.security.macosx' version='1.0.0.v20080602-2000'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='1'>\r
-          <instruction key='manifest'>\r
-            Bundle-ManifestVersion: 2&#xA;Export-Package: org.eclipse.equinox.internal.security.osx;x-internal:=true,org.eclipse.equinox.internal.security.osx.nls;x-internal:=true&#xA;Bundle-RequiredExecutionEnvironment: J2SE-1.4&#xA;Bundle-Localization: fragment&#xA;Require-Bundle: org.eclipse.swt;bundle-version=&quot;[3.4.0,4.0.0)&quot;;resolution:=optional&#xA;Eclipse-PlatformFilter: (&amp; (osgi.os=macosx) (|(osgi.arch=x86)(osgi.arch=ppc)) )&#xA;Bundle-Name: %fragmentName&#xA;Bundle-Version: 1.0.0.v20080602-2000&#xA;Bundle-Vendor: %providerName&#xA;Bundle-SymbolicName: org.eclipse.equinox.security.macosx;singleton:=true&#xA;Fragment-Host: org.eclipse.equinox.security;bundle-version=&quot;[1.0.0,2.0.0)&quot;&#xA;Manifest-Version: 1.0\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='org.eclipse.swt.carbon.macosx' version='3.4.1.v3452b'>\r
-      <update id='org.eclipse.swt.carbon.macosx' range='[0.0.0,3.4.1.v3452b)' severity='0'/>\r
-      <properties size='4'>\r
-        <property name='df_LT.fragmentName' value='Standard Widget Toolkit for Mac OS X (Carbon)'/>\r
-        <property name='df_LT.providerName' value='Eclipse.org'/>\r
-        <property name='org.eclipse.equinox.p2.name' value='%fragmentName'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='%providerName'/>\r
-      </properties>\r
-      <provides size='8'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.swt.carbon.macosx' version='3.4.1.v3452b'/>\r
-        <provided namespace='osgi.bundle' name='org.eclipse.swt.carbon.macosx' version='3.4.1.v3452b'/>\r
-        <provided namespace='java.package' name='org.eclipse.swt.internal.carbon' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.swt.internal.cocoa' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.swt.internal.opengl.carbon' version='0.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' version='1.0.0'/>\r
-        <provided namespace='osgi.fragment' name='org.eclipse.swt' version='3.4.1.v3452b'/>\r
-        <provided namespace='org.eclipse.equinox.p2.localization' name='df_LT' version='1.0.0'/>\r
-      </provides>\r
-      <requires size='1'>\r
-        <required namespace='osgi.bundle' name='org.eclipse.swt' range='[3.0.0,4.0.0)'/>\r
-      </requires>\r
-      <filter>\r
-        (&amp; (osgi.ws=carbon) (osgi.os=macosx) (|(osgi.arch=x86)(osgi.arch=ppc)) )\r
-      </filter>\r
-      <artifacts size='1'>\r
-        <artifact classifier='osgi.bundle' id='org.eclipse.swt.carbon.macosx' version='3.4.1.v3452b'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='1'>\r
-          <instruction key='manifest'>\r
-            Bundle-Vendor: %providerName&#xA;Bundle-ManifestVersion: 2&#xA;Bundle-RequiredExecutionEnvironment: CDC-1.0/Foundation-1.0,J2SE-1.3&#xA;Bundle-Localization: fragment&#xA;Bundle-Name: %fragmentName&#xA;Manifest-Version: 1.0&#xA;Fragment-Host: org.eclipse.swt; bundle-version=&quot;[3.0.0,4.0.0)&quot;&#xA;Bundle-SymbolicName: org.eclipse.swt.carbon.macosx; singleton:=true&#xA;Bundle-Version: 3.4.1.v3452b&#xA;Export-Package: org.eclipse.swt.internal.carbon; x-internal:=true,org.eclipse.swt.internal.cocoa; x-internal:=true,org.eclipse.swt.internal.opengl.carbon; x-internal:=true&#xA;Eclipse-PlatformFilter: (&amp; (osgi.ws=carbon) (osgi.os=macosx) (|(osgi.arch=x86)(osgi.arch=ppc)) )\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='org.eclipse.swt' version='3.4.2.v3452b'>\r
-      <update id='org.eclipse.swt' range='[0.0.0,3.4.2.v3452b)' severity='0'/>\r
-      <properties size='4'>\r
-        <property name='df_LT.providerName' value='Eclipse.org'/>\r
-        <property name='df_LT.pluginName' value='Standard Widget Toolkit'/>\r
-        <property name='org.eclipse.equinox.p2.name' value='%pluginName'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='%providerName'/>\r
-      </properties>\r
-      <provides size='20'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.swt' version='3.4.2.v3452b'/>\r
-        <provided namespace='osgi.bundle' name='org.eclipse.swt' version='3.4.2.v3452b'/>\r
-        <provided namespace='java.package' name='org.eclipse.swt' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.swt.accessibility' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.swt.awt' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.swt.browser' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.swt.custom' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.swt.dnd' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.swt.events' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.swt.graphics' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.swt.layout' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.swt.opengl' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.swt.printing' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.swt.program' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.swt.widgets' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.swt.internal' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.swt.internal.image' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.swt.internal.theme' version='0.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' version='1.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.localization' name='df_LT' version='1.0.0'/>\r
-      </provides>\r
-      <requires size='1'>\r
-        <required namespace='java.package' name='org.mozilla.xpcom' range='0.0.0' optional='true'/>\r
-      </requires>\r
-      <artifacts size='1'>\r
-        <artifact classifier='osgi.bundle' id='org.eclipse.swt' version='3.4.2.v3452b'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='1'>\r
-          <instruction key='manifest'>\r
-            Bundle-Vendor: %providerName&#xA;Bundle-ManifestVersion: 2&#xA;Bundle-RequiredExecutionEnvironment: CDC-1.0/Foundation-1.0,J2SE-1.3&#xA;Bundle-Localization: plugin&#xA;Bundle-Name: %pluginName&#xA;Eclipse-ExtensibleAPI: true&#xA;Manifest-Version: 1.0&#xA;DynamicImport-Package: org.mozilla.xpcom&#xA;Bundle-SymbolicName: org.eclipse.swt; singleton:=true&#xA;Bundle-Version: 3.4.2.v3452b&#xA;Export-Package: org.eclipse.swt,org.eclipse.swt.accessibility,org.eclipse.swt.awt,org.eclipse.swt.browser,org.eclipse.swt.custom,org.eclipse.swt.dnd,org.eclipse.swt.events,org.eclipse.swt.graphics,org.eclipse.swt.layout,org.eclipse.swt.opengl,org.eclipse.swt.printing,org.eclipse.swt.program,org.eclipse.swt.widgets,org.eclipse.swt.internal; x-internal:=true,org.eclipse.swt.internal.image; x-internal:=true,org.eclipse.swt.internal.theme; x-internal:=true\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='eu.etaxonomy.cdmLibrary.feature.group' version='2.1.0.v20090603_1459' singleton='false'>\r
-      <update id='eu.etaxonomy.cdmLibrary.feature.group' range='[0.0.0,2.1.0.v20090603_1459)' severity='0'/>\r
-      <properties size='5'>\r
-        <property name='org.eclipse.equinox.p2.name' value='CDM Library'/>\r
-        <property name='org.eclipse.equinox.p2.description' value='cdmLibrary eclipse plugin feature'/>\r
-        <property name='org.eclipse.equinox.p2.description.url' value='http://www.example.com/description'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='EDIT'/>\r
-        <property name='org.eclipse.equinox.p2.type.group' value='true'/>\r
-      </properties>\r
-      <provides size='1'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='eu.etaxonomy.cdmLibrary.feature.group' version='2.1.0.v20090603_1459'/>\r
-      </provides>\r
-      <requires size='2'>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='eu.etaxonomy.cdmLibrary' range='[2.1.0.v20090603_1459,2.1.0.v20090603_1459]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='eu.etaxonomy.cdmLibrary.feature.jar' range='[2.1.0.v20090603_1459,2.1.0.v20090603_1459]'>\r
-          <filter>\r
-            (org.eclipse.update.install.features=true)\r
-          </filter>\r
-        </required>\r
-      </requires>\r
-      <touchpoint id='null' version='0.0.0'/>\r
-      <licenses size='1'>\r
-        <license url='http://www.example.com/license'>\r
-          to be added\r
-        </license>\r
-      </licenses>\r
-      <copyright url='http://www.example.com/copyright'>\r
-        [Enter Copyright Description here.]\r
-      </copyright>\r
-    </unit>\r
-    <unit id='org.eclipse.ui.views.properties.tabbed' version='3.4.2.M20090127-1700'>\r
-      <update id='org.eclipse.ui.views.properties.tabbed' range='[0.0.0,3.4.2.M20090127-1700)' severity='0'/>\r
-      <properties size='4'>\r
-        <property name='df_LT.Plugin.name' value='Tabbed Properties View'/>\r
-        <property name='df_LT.Plugin.providerName' value='Eclipse.org'/>\r
-        <property name='org.eclipse.equinox.p2.name' value='%Plugin.name'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='%Plugin.providerName'/>\r
-      </properties>\r
-      <provides size='8'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.ui.views.properties.tabbed' version='3.4.2.M20090127-1700'/>\r
-        <provided namespace='osgi.bundle' name='org.eclipse.ui.views.properties.tabbed' version='3.4.2.M20090127-1700'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.views.properties.tabbed' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.views.properties.tabbed.l10n' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.views.properties.tabbed.view' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.views.properties.tabbed' version='0.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' version='1.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.localization' name='df_LT' version='1.0.0'/>\r
-      </provides>\r
-      <requires size='5'>\r
-        <required namespace='osgi.bundle' name='org.eclipse.ui.forms' range='[3.3.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.ui.views' range='[3.2.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.ui' range='[3.3.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.runtime' range='[3.2.0,4.0.0)'/>\r
-        <required namespace='java.package' name='com.ibm.icu.text' range='0.0.0'/>\r
-      </requires>\r
-      <artifacts size='1'>\r
-        <artifact classifier='osgi.bundle' id='org.eclipse.ui.views.properties.tabbed' version='3.4.2.M20090127-1700'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='1'>\r
-          <instruction key='manifest'>\r
-            Bundle-RequiredExecutionEnvironment: CDC-1.0/Foundation-1.0,J2SE-1.3&#xA;Bundle-Name: %Plugin.name&#xA;Bundle-Activator: org.eclipse.ui.internal.views.properties.tabbed.TabbedPropertyViewPlugin&#xA;Manifest-Version: 1.0&#xA;Bundle-Vendor: %Plugin.providerName&#xA;Bundle-ActivationPolicy: lazy&#xA;Bundle-SymbolicName: org.eclipse.ui.views.properties.tabbed;singleton:=true&#xA;Import-Package: com.ibm.icu.text&#xA;Bundle-ManifestVersion: 2&#xA;Bundle-Version: 3.4.2.M20090127-1700&#xA;Bundle-Localization: plugin&#xA;Export-Package: org.eclipse.ui.internal.views.properties.tabbed;x-internal:=true,org.eclipse.ui.internal.views.properties.tabbed.l10n;x-internal:=true,org.eclipse.ui.internal.views.properties.tabbed.view;x-friends:=&quot;org.eclipse.ui.tests.views.properties.tabbed&quot;,org.eclipse.ui.views.properties.tabbed&#xA;Require-Bundle: org.eclipse.ui.forms;bundle-version=&quot;[3.3.0,4.0.0)&quot;;visibility:=reexport,org.eclipse.ui.views;bundle-version=&quot;[3.2.0,4.0.0)&quot;;visibility:=reexport,org.eclipse.ui;bundle-version=&quot;[3.3.0,4.0.0)&quot;;visibility:=reexport,org.eclipse.core.runtime;bundle-version=&quot;[3.2.0,4.0.0)&quot;\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='org.eclipse.update.configurator' version='3.2.201.R34x_v20080819'>\r
-      <update id='org.eclipse.update.configurator' range='[0.0.0,3.2.201.R34x_v20080819)' severity='0'/>\r
-      <properties size='4'>\r
-        <property name='df_LT.providerName' value='Eclipse.org'/>\r
-        <property name='df_LT.pluginName' value='Install/Update Configurator'/>\r
-        <property name='org.eclipse.equinox.p2.name' value='%pluginName'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='%providerName'/>\r
-      </properties>\r
-      <provides size='7'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.update.configurator' version='3.2.201.R34x_v20080819'/>\r
-        <provided namespace='osgi.bundle' name='org.eclipse.update.configurator' version='3.2.201.R34x_v20080819'/>\r
-        <provided namespace='java.package' name='org.eclipse.update.configurator' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.update.internal.configurator' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.update.internal.configurator.branding' version='0.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' version='1.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.localization' name='df_LT' version='1.0.0'/>\r
-      </provides>\r
-      <requires size='6'>\r
-        <required namespace='osgi.bundle' name='org.eclipse.equinox.common' range='[3.2.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.osgi' range='[3.2.0,4.0.0)'/>\r
-        <required namespace='java.package' name='javax.xml.parsers' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.w3c.dom' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.xml.sax' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.xml.sax.helpers' range='0.0.0'/>\r
-      </requires>\r
-      <artifacts size='1'>\r
-        <artifact classifier='osgi.bundle' id='org.eclipse.update.configurator' version='3.2.201.R34x_v20080819'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='1'>\r
-          <instruction key='manifest'>\r
-            Bundle-RequiredExecutionEnvironment: J2SE-1.4,CDC-1.0/Foundation-1.0,J2SE-1.3&#xA;Bundle-Name: %pluginName&#xA;Bundle-Activator: org.eclipse.update.internal.configurator.ConfigurationActivator&#xA;Manifest-Version: 1.0&#xA;Bundle-Vendor: %providerName&#xA;Bundle-SymbolicName: org.eclipse.update.configurator; singleton:=true&#xA;Import-Package: javax.xml.parsers,org.w3c.dom,org.xml.sax,org.xml.sax.helpers&#xA;Bundle-ManifestVersion: 2&#xA;Eclipse-LazyStart: true&#xA;Bundle-Version: 3.2.201.R34x_v20080819&#xA;Bundle-Localization: plugin&#xA;Export-Package: org.eclipse.update.configurator,org.eclipse.update.internal.configurator;x-friends:=&quot;org.eclipse.update.core&quot;,org.eclipse.update.internal.configurator.branding;x-friends:=&quot;org.eclipse.update.core&quot;&#xA;Require-Bundle: org.eclipse.equinox.common;bundle-version=&quot;[3.2.0,4.0.0)&quot;,org.eclipse.osgi;bundle-version=&quot;[3.2.0,4.0.0)&quot;\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='org.eclipse.ui.ide' version='3.4.2.M20090127-1700'>\r
-      <update id='org.eclipse.ui.ide' range='[0.0.0,3.4.2.M20090127-1700)' severity='0'/>\r
-      <properties size='4'>\r
-        <property name='df_LT.Plugin.name' value='Eclipse IDE UI'/>\r
-        <property name='df_LT.Plugin.providerName' value='Eclipse.org'/>\r
-        <property name='org.eclipse.equinox.p2.name' value='%Plugin.name'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='%Plugin.providerName'/>\r
-      </properties>\r
-      <provides size='41'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.ui.ide' version='3.4.2.M20090127-1700'/>\r
-        <provided namespace='osgi.bundle' name='org.eclipse.ui.ide' version='3.4.2.M20090127-1700'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.actions' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.dialogs' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.ide' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.ide.dialogs' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.ide.fileSystem' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.ide.undo' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.ide' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.ide.actions' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.ide.commands' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.ide.dialogs' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.ide.filesystem' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.ide.handlers' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.ide.misc' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.ide.model' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.ide.registry' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.ide.undo' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.ide.update' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.views.bookmarkexplorer' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.views.framelist' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.views.markers' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.views.navigator' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.views.properties' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.views.tasklist' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.wizards.datatransfer' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.wizards.newresource' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.model' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.part' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.views.bookmarkexplorer' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.views.framelist' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.views.markers' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.views.markers.internal' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.views.navigator' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.views.properties' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.views.tasklist' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.wizards.datatransfer' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.wizards.newresource' version='0.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' version='1.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.localization' name='df_LT' version='1.0.0'/>\r
-      </provides>\r
-      <requires size='12'>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.resources' range='[3.2.0,4.0.0)' optional='true'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.runtime' range='[3.2.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.filesystem' range='[1.0.0,2.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.help' range='[3.2.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.ui' range='[3.4.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.ui.views' range='[3.2.0,4.0.0)' optional='true'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.update.configurator' range='[3.1.100,4.0.0)' optional='true'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.update.core' range='[3.1.100,4.0.0)' optional='true'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.update.ui' range='[3.1.100,4.0.0)' optional='true'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.jface.text' range='[3.2.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.ui.forms' range='[3.3.0,4.0.0)' optional='true'/>\r
-        <required namespace='java.package' name='com.ibm.icu.text' range='0.0.0'/>\r
-      </requires>\r
-      <artifacts size='1'>\r
-        <artifact classifier='osgi.bundle' id='org.eclipse.ui.ide' version='3.4.2.M20090127-1700'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='1'>\r
-          <instruction key='manifest'>\r
-            Bundle-Name: %Plugin.name&#xA;Bundle-ClassPath: .&#xA;Bundle-Version: 3.4.2.M20090127-1700&#xA;Import-Package: com.ibm.icu.text&#xA;Bundle-Activator: org.eclipse.ui.internal.ide.IDEWorkbenchPlugin&#xA;Bundle-Vendor: %Plugin.providerName&#xA;Require-Bundle: org.eclipse.core.resources;bundle-version=&quot;[3.2.0,4.0.0)&quot;;resolution:=optional,org.eclipse.core.runtime;bundle-version=&quot;[3.2.0,4.0.0)&quot;,org.eclipse.core.filesystem;bundle-version=&quot;[1.0.0,2.0.0)&quot;,org.eclipse.help;bundle-version=&quot;[3.2.0,4.0.0)&quot;,org.eclipse.ui;bundle-version=&quot;[3.4.0,4.0.0)&quot;,org.eclipse.ui.views;bundle-version=&quot;[3.2.0,4.0.0)&quot;;resolution:=optional,org.eclipse.update.configurator;bundle-version=&quot;[3.1.100,4.0.0)&quot;;resolution:=optional,org.eclipse.update.core;bundle-version=&quot;[3.1.100,4.0.0)&quot;;resolution:=optional,org.eclipse.update.ui;bundle-version=&quot;[3.1.100,4.0.0)&quot;;resolution:=optional,org.eclipse.jface.text;bundle-version=&quot;[3.2.0,4.0.0)&quot;,org.eclipse.ui.forms;bundle-version=&quot;[3.3.0,4.0.0)&quot;;resolution:=optional&#xA;Export-Package: org.eclipse.ui,org.eclipse.ui.actions,org.eclipse.ui.dialogs,org.eclipse.ui.ide,org.eclipse.ui.ide.dialogs,org.eclipse.ui.ide.fileSystem,org.eclipse.ui.ide.undo,org.eclipse.ui.internal.ide;x-friends:=&quot;org.eclipse.ui.ide.application&quot;,org.eclipse.ui.internal.ide.actions;x-internal:=true,org.eclipse.ui.internal.ide.commands;x-internal:=true,org.eclipse.ui.internal.ide.dialogs;x-friends:=&quot;org.eclipse.ui.ide.application&quot;,org.eclipse.ui.internal.ide.filesystem;x-internal:=true,org.eclipse.ui.internal.ide.handlers;x-internal:=true,org.eclipse.ui.internal.ide.misc;x-internal:=true,org.eclipse.ui.internal.ide.model;x-friends:=&quot;org.eclipse.ui.ide.application&quot;,org.eclipse.ui.internal.ide.registry;x-internal:=true,org.eclipse.ui.internal.ide.undo;x-friends:=&quot;org.eclipse.ui.ide.application&quot;,org.eclipse.ui.internal.ide.update;x-internal:=true,org.eclipse.ui.internal.views.bookmarkexplorer;x-internal:=true,org.eclipse.ui.internal.views.framelist;x-internal:=true,org.eclipse.ui.internal.views.markers;x-internal:=true,org.eclipse.ui.internal.views.navigator;x-internal:=true,org.eclipse.ui.internal.views.properties;x-internal:=true,org.eclipse.ui.internal.views.tasklist;x-internal:=true,org.eclipse.ui.internal.wizards.datatransfer;x-internal:=true,org.eclipse.ui.internal.wizards.newresource;x-internal:=true,org.eclipse.ui.model,org.eclipse.ui.part,org.eclipse.ui.views.bookmarkexplorer,org.eclipse.ui.views.framelist,org.eclipse.ui.views.markers,org.eclipse.ui.views.markers.internal;x-internal:=true,org.eclipse.ui.views.navigator,org.eclipse.ui.views.properties,org.eclipse.ui.views.tasklist,org.eclipse.ui.wizards.datatransfer,org.eclipse.ui.wizards.newresource&#xA;Bundle-SymbolicName: org.eclipse.ui.ide; singleton:=true&#xA;Manifest-Version: 1.0&#xA;Bundle-ActivationPolicy: lazy&#xA;Bundle-ManifestVersion: 2&#xA;Bundle-RequiredExecutionEnvironment: J2SE-1.4&#xA;Bundle-Localization: plugin\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='org.eclipse.equinox.app' version='1.1.0.v20080421-2006'>\r
-      <update id='org.eclipse.equinox.app' range='[0.0.0,1.1.0.v20080421-2006)' severity='0'/>\r
-      <properties size='4'>\r
-        <property name='df_LT.providerName' value='Eclipse.org'/>\r
-        <property name='df_LT.pluginName' value='Equinox Application Container'/>\r
-        <property name='org.eclipse.equinox.p2.name' value='%pluginName'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='%providerName'/>\r
-      </properties>\r
-      <provides size='7'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.equinox.app' version='1.1.0.v20080421-2006'/>\r
-        <provided namespace='osgi.bundle' name='org.eclipse.equinox.app' version='1.1.0.v20080421-2006'/>\r
-        <provided namespace='java.package' name='org.eclipse.equinox.app' version='1.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.equinox.internal.app' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.osgi.service.application' version='1.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' version='1.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.localization' name='df_LT' version='1.0.0'/>\r
-      </provides>\r
-      <requires size='16'>\r
-        <required namespace='osgi.bundle' name='org.eclipse.equinox.registry' range='[3.4.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.equinox.common' range='[3.2.0,4.0.0)'/>\r
-        <required namespace='java.package' name='org.osgi.service.event' range='1.0.0' optional='true'/>\r
-        <required namespace='java.package' name='org.eclipse.osgi.framework.console' range='0.0.0' optional='true'/>\r
-        <required namespace='java.package' name='org.eclipse.osgi.framework.log' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.eclipse.osgi.service.datalocation' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.eclipse.osgi.service.debug' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.eclipse.osgi.service.environment' range='1.1.0'/>\r
-        <required namespace='java.package' name='org.eclipse.osgi.service.runnable' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.eclipse.osgi.storagemanager' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.eclipse.osgi.util' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.osgi.framework' range='1.3.0'/>\r
-        <required namespace='java.package' name='org.osgi.service.condpermadmin' range='0.0.0' optional='true'/>\r
-        <required namespace='java.package' name='org.osgi.service.event' range='1.0.0' optional='true'/>\r
-        <required namespace='java.package' name='org.osgi.service.packageadmin' range='1.2.0'/>\r
-        <required namespace='java.package' name='org.osgi.util.tracker' range='0.0.0'/>\r
-      </requires>\r
-      <artifacts size='1'>\r
-        <artifact classifier='osgi.bundle' id='org.eclipse.equinox.app' version='1.1.0.v20080421-2006'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='1'>\r
-          <instruction key='manifest'>\r
-            Bundle-Version: 1.1.0.v20080421-2006&#xA;Bundle-ActivationPolicy: lazy&#xA;Eclipse-LazyStart: true&#xA;Export-Package: org.eclipse.equinox.app;version=&quot;1.0&quot;,org.eclipse.equinox.internal.app;x-friends:=&quot;org.eclipse.core.runtime&quot;,org.osgi.service.application;version=&quot;1.0&quot;&#xA;Import-Package: org.eclipse.osgi.framework.console;resolution:=optional,org.eclipse.osgi.framework.log,org.eclipse.osgi.service.datalocation,org.eclipse.osgi.service.debug,org.eclipse.osgi.service.environment; version=&quot;1.1&quot;,org.eclipse.osgi.service.runnable,org.eclipse.osgi.storagemanager,org.eclipse.osgi.util,org.osgi.framework;version=&quot;1.3&quot;,org.osgi.service.condpermadmin; resolution:=optional,org.osgi.service.event;version=&quot;1.0.0&quot;;resolution:=optional,org.osgi.service.packageadmin;version=&quot;1.2&quot;,org.osgi.util.tracker&#xA;Manifest-Version: 1.0&#xA;Bundle-Activator: org.eclipse.equinox.internal.app.Activator&#xA;Comment-Header: Both Eclipse-LazyStart and Bundle-ActivationPolicy are specified for compatibility with 3.2&#xA;Bundle-RequiredExecutionEnvironment: OSGi/Minimum-1.1&#xA;Bundle-Localization: plugin&#xA;Require-Bundle: org.eclipse.equinox.registry;bundle-version=&quot;[3.4.0,4.0.0)&quot;,org.eclipse.equinox.common;bundle-version=&quot;[3.2.0,4.0.0)&quot;&#xA;Bundle-SymbolicName: org.eclipse.equinox.app; singleton:=true&#xA;Comment-DynamicImport: this is only used to allow late binding of the package&#xA;DynamicImport-Package: org.osgi.service.event;version=&quot;1.0.0&quot;&#xA;Bundle-Vendor: %providerName&#xA;Bundle-Name: %pluginName&#xA;Bundle-ManifestVersion: 2\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='org.eclipse.ui.carbon.translated_host_properties' version='4.0.0.I20080610-1200'>\r
-      <hostRequirements size='1'>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.ui' range='[3.2.0,4.0.0)' greedy='false'/>\r
-      </hostRequirements>\r
-      <properties size='1'>\r
-        <property name='org.eclipse.equinox.p2.type.fragment' value='true'/>\r
-      </properties>\r
-      <requires size='1'>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.ui' range='[3.2.0,4.0.0)' greedy='false'/>\r
-      </requires>\r
-      <touchpoint id='null' version='0.0.0'/>\r
-    </unit>\r
-    <unit id='org.eclipse.core.databinding.beans' version='1.1.1.M20080827-0800a' singleton='false'>\r
-      <update id='org.eclipse.core.databinding.beans' range='[0.0.0,1.1.1.M20080827-0800a)' severity='0'/>\r
-      <properties size='4'>\r
-        <property name='df_LT.providerName' value='Eclipse.org'/>\r
-        <property name='df_LT.pluginName' value='JFace Data Binding for JavaBeans'/>\r
-        <property name='org.eclipse.equinox.p2.name' value='%pluginName'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='%providerName'/>\r
-      </properties>\r
-      <provides size='6'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.core.databinding.beans' version='1.1.1.M20080827-0800a'/>\r
-        <provided namespace='osgi.bundle' name='org.eclipse.core.databinding.beans' version='1.1.1.M20080827-0800a'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.databinding.beans' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.internal.databinding.beans' version='0.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' version='1.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.localization' name='df_LT' version='1.0.0'/>\r
-      </provides>\r
-      <requires size='2'>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.databinding' range='[1.0.0,2.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.equinox.common' range='[3.2.0,4.0.0)'/>\r
-      </requires>\r
-      <artifacts size='1'>\r
-        <artifact classifier='osgi.bundle' id='org.eclipse.core.databinding.beans' version='1.1.1.M20080827-0800a'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='1'>\r
-          <instruction key='manifest'>\r
-            Bundle-Vendor: %providerName&#xA;Bundle-ManifestVersion: 2&#xA;Bundle-RequiredExecutionEnvironment: J2SE-1.4&#xA;Bundle-Localization: plugin&#xA;Bundle-Name: %pluginName&#xA;Require-Bundle: org.eclipse.core.databinding;bundle-version=&quot;[1.0.0,2.0.0)&quot;,org.eclipse.equinox.common;bundle-version=&quot;[3.2.0,4.0.0)&quot;&#xA;Bundle-ClassPath: .&#xA;Manifest-Version: 1.0&#xA;Bundle-SymbolicName: org.eclipse.core.databinding.beans&#xA;Bundle-Version: 1.1.1.M20080827-0800a&#xA;Export-Package: org.eclipse.core.databinding.beans,org.eclipse.core.internal.databinding.beans;x-internal:=true\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='org.eclipse.core.filesystem.macosx.translated_host_properties' version='1.0.0.v20080604-1400'>\r
-      <hostRequirements size='1'>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.core.filesystem' range='[1.0.0,2.0.0)' greedy='false'/>\r
-      </hostRequirements>\r
-      <properties size='1'>\r
-        <property name='org.eclipse.equinox.p2.type.fragment' value='true'/>\r
-      </properties>\r
-      <requires size='1'>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.core.filesystem' range='[1.0.0,2.0.0)' greedy='false'/>\r
-      </requires>\r
-      <touchpoint id='null' version='0.0.0'/>\r
-    </unit>\r
-    <unit id='org.eclipse.pde.source' version='3.4.0.v20080603' singleton='false'>\r
-      <update id='org.eclipse.pde.source' range='[0.0.0,3.4.0.v20080603)' severity='0'/>\r
-      <properties size='4'>\r
-        <property name='df_LT.providerName' value='Eclipse.org'/>\r
-        <property name='df_LT.pluginName' value='Eclipse Plug-in Development Environment Developer Resources'/>\r
-        <property name='org.eclipse.equinox.p2.name' value='%pluginName'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='%providerName'/>\r
-      </properties>\r
-      <provides size='4'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.pde.source' version='3.4.0.v20080603'/>\r
-        <provided namespace='osgi.bundle' name='org.eclipse.pde.source' version='3.4.0.v20080603'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='source' version='1.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.localization' name='df_LT' version='1.0.0'/>\r
-      </provides>\r
-      <artifacts size='1'>\r
-        <artifact classifier='osgi.bundle' id='org.eclipse.pde.source' version='3.4.0.v20080603'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='1'>\r
-          <instruction key='manifest'>\r
-            Bundle-ManifestVersion: 2&#xA;Bundle-Version: 3.4.0.v20080603&#xA;Manifest-Version: 1.0&#xA;Bundle-SymbolicName: org.eclipse.pde.source&#xA;Bundle-Name: %pluginName&#xA;Bundle-Localization: plugin&#xA;Bundle-Vendor: %providerName&#xA;Eclipse-SourceBundle: org.eclipse.pde;version=&quot;3.4.0.v20080603&quot;;roots:=&quot;.&quot;\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='org.eclipse.ui.carbon' version='4.0.0.I20080610-1200'>\r
-      <update id='org.eclipse.ui.carbon' range='[0.0.0,4.0.0.I20080610-1200)' severity='0'/>\r
-      <properties size='4'>\r
-        <property name='df_LT.fragmentName' value='Eclipse UI MacOS X Enhancements'/>\r
-        <property name='df_LT.providerName' value='Eclipse.org'/>\r
-        <property name='org.eclipse.equinox.p2.name' value='%fragmentName'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='%providerName'/>\r
-      </properties>\r
-      <provides size='6'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.ui.carbon' version='4.0.0.I20080610-1200'/>\r
-        <provided namespace='osgi.bundle' name='org.eclipse.ui.carbon' version='4.0.0.I20080610-1200'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.carbon' version='0.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' version='1.0.0'/>\r
-        <provided namespace='osgi.fragment' name='org.eclipse.ui' version='4.0.0.I20080610-1200'/>\r
-        <provided namespace='org.eclipse.equinox.p2.localization' name='df_LT' version='1.0.0'/>\r
-      </provides>\r
-      <requires size='1'>\r
-        <required namespace='osgi.bundle' name='org.eclipse.ui' range='[3.2.0,4.0.0)'/>\r
-      </requires>\r
-      <filter>\r
-        (osgi.ws=carbon)\r
-      </filter>\r
-      <artifacts size='1'>\r
-        <artifact classifier='osgi.bundle' id='org.eclipse.ui.carbon' version='4.0.0.I20080610-1200'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='1'>\r
-          <instruction key='manifest'>\r
-            Bundle-Vendor: %providerName&#xA;Bundle-ManifestVersion: 2&#xA;Bundle-RequiredExecutionEnvironment: J2SE-1.4&#xA;Bundle-Localization: fragment-carbon&#xA;Bundle-Name: %fragmentName&#xA;Manifest-Version: 1.0&#xA;Fragment-Host: org.eclipse.ui;bundle-version=&quot;[3.2.0,4.0.0)&quot;&#xA;Bundle-SymbolicName: org.eclipse.ui.carbon; singleton:=true&#xA;Bundle-Version: 4.0.0.I20080610-1200&#xA;Export-Package: org.eclipse.ui.internal.carbon;x-internal:=true;uses:=&quot;org.eclipse.ui&quot;&#xA;Eclipse-PlatformFilter: (osgi.ws=carbon)\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='org.eclipse.equinox.security.macosx.translated_host_properties' version='1.0.0.v20080602-2000'>\r
-      <hostRequirements size='1'>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.equinox.security' range='[1.0.0,2.0.0)' greedy='false'/>\r
-      </hostRequirements>\r
-      <properties size='1'>\r
-        <property name='org.eclipse.equinox.p2.type.fragment' value='true'/>\r
-      </properties>\r
-      <requires size='1'>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.equinox.security' range='[1.0.0,2.0.0)' greedy='false'/>\r
-      </requires>\r
-      <touchpoint id='null' version='0.0.0'/>\r
-    </unit>\r
-    <unit id='org.eclipse.core.runtime.compatibility.auth' version='3.2.100.v20070502' singleton='false'>\r
-      <update id='org.eclipse.core.runtime.compatibility.auth' range='[0.0.0,3.2.100.v20070502)' severity='0'/>\r
-      <properties size='4'>\r
-        <property name='df_LT.providerName' value='Eclipse.org'/>\r
-        <property name='df_LT.pluginName' value='Authorization Compatibility Plug-in'/>\r
-        <property name='org.eclipse.equinox.p2.name' value='%pluginName'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='%providerName'/>\r
-      </properties>\r
-      <provides size='5'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.core.runtime.compatibility.auth' version='3.2.100.v20070502'/>\r
-        <provided namespace='osgi.bundle' name='org.eclipse.core.runtime.compatibility.auth' version='3.2.100.v20070502'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.internal.runtime.auth' version='0.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' version='1.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.localization' name='df_LT' version='1.0.0'/>\r
-      </provides>\r
-      <requires size='6'>\r
-        <required namespace='osgi.bundle' name='org.eclipse.equinox.common' range='[3.2.0,4.0.0)'/>\r
-        <required namespace='java.package' name='org.eclipse.osgi.framework.log' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.eclipse.osgi.service.datalocation' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.eclipse.osgi.util' range='1.0.0'/>\r
-        <required namespace='java.package' name='org.osgi.framework' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.osgi.util.tracker' range='0.0.0'/>\r
-      </requires>\r
-      <artifacts size='1'>\r
-        <artifact classifier='osgi.bundle' id='org.eclipse.core.runtime.compatibility.auth' version='3.2.100.v20070502'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='1'>\r
-          <instruction key='manifest'>\r
-            Bundle-RequiredExecutionEnvironment: CDC-1.0/Foundation-1.0,J2SE-1.3&#xA;Bundle-Name: %pluginName&#xA;Bundle-Activator: org.eclipse.core.internal.runtime.auth.Activator&#xA;Manifest-Version: 1.0&#xA;Bundle-Vendor: %providerName&#xA;Bundle-SymbolicName: org.eclipse.core.runtime.compatibility.auth&#xA;Import-Package: org.eclipse.osgi.framework.log,org.eclipse.osgi.service.datalocation,org.eclipse.osgi.util;version=&quot;1.0.0&quot;,org.osgi.framework,org.osgi.util.tracker&#xA;Bundle-ManifestVersion: 2&#xA;Eclipse-LazyStart: true&#xA;Bundle-Version: 3.2.100.v20070502&#xA;Bundle-Localization: plugin&#xA;Export-Package: org.eclipse.core.internal.runtime.auth;x-friends:=&quot;org.eclipse.core.runtime&quot;&#xA;Require-Bundle: org.eclipse.equinox.common;bundle-version=&quot;[3.2.0,4.0.0)&quot;\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='org.junit4' version='4.3.1' singleton='false'>\r
-      <update id='org.junit4' range='[0.0.0,4.3.1)' severity='0'/>\r
-      <properties size='4'>\r
-        <property name='df_LT.providerName' value='Eclipse.org'/>\r
-        <property name='df_LT.pluginName' value='JUnit Testing Framework Version 4'/>\r
-        <property name='org.eclipse.equinox.p2.name' value='%pluginName'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='%providerName'/>\r
-      </properties>\r
-      <provides size='16'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='org.junit4' version='4.3.1'/>\r
-        <provided namespace='osgi.bundle' name='org.junit4' version='4.3.1'/>\r
-        <provided namespace='java.package' name='junit.extensions' version='4.3.1'/>\r
-        <provided namespace='java.package' name='junit.framework' version='4.3.1'/>\r
-        <provided namespace='java.package' name='junit.runner' version='4.3.1'/>\r
-        <provided namespace='java.package' name='junit.textui' version='4.3.1'/>\r
-        <provided namespace='java.package' name='org.junit' version='4.3.1'/>\r
-        <provided namespace='java.package' name='org.junit.internal' version='4.3.1'/>\r
-        <provided namespace='java.package' name='org.junit.internal.requests' version='4.3.1'/>\r
-        <provided namespace='java.package' name='org.junit.internal.runners' version='4.3.1'/>\r
-        <provided namespace='java.package' name='org.junit.runner' version='4.3.1'/>\r
-        <provided namespace='java.package' name='org.junit.runner.manipulation' version='4.3.1'/>\r
-        <provided namespace='java.package' name='org.junit.runner.notification' version='4.3.1'/>\r
-        <provided namespace='java.package' name='org.junit.runners' version='4.3.1'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' version='1.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.localization' name='df_LT' version='1.0.0'/>\r
-      </provides>\r
-      <artifacts size='1'>\r
-        <artifact classifier='osgi.bundle' id='org.junit4' version='4.3.1'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='2'>\r
-          <instruction key='manifest'>\r
-            Bundle-ManifestVersion: 2&#xA;Bundle-RequiredExecutionEnvironment: J2SE-1.5&#xA;Manifest-Version: 1.0&#xA;Bundle-Version: 4.3.1&#xA;Export-Package: junit.extensions;version=&quot;4.3.1&quot;,junit.framework;version=&quot;4.3.1&quot;,junit.runner;version=&quot;4.3.1&quot;,junit.textui;version=&quot;4.3.1&quot;,org.junit;version=&quot;4.3.1&quot;,org.junit.internal;version=&quot;4.3.1&quot;;x-internal:=true,org.junit.internal.requests;version=&quot;4.3.1&quot;;x-internal:=true,org.junit.internal.runners;version=&quot;4.3.1&quot;;x-internal:=true,org.junit.runner;version=&quot;4.3.1&quot;,org.junit.runner.manipulation;version=&quot;4.3.1&quot;,org.junit.runner.notification;version=&quot;4.3.1&quot;,org.junit.runners;version=&quot;4.3.1&quot;&#xA;Bundle-SymbolicName: org.junit4&#xA;Bundle-Localization: plugin&#xA;Bundle-Name: %pluginName&#xA;Bundle-ClassPath: junit.jar&#xA;Bundle-Vendor: %providerName\r
-          </instruction>\r
-          <instruction key='zipped'>\r
-            true\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='org.eclipse.equinox.common' version='3.4.0.v20080421-2006'>\r
-      <update id='org.eclipse.equinox.common' range='[0.0.0,3.4.0.v20080421-2006)' severity='0'/>\r
-      <properties size='4'>\r
-        <property name='df_LT.providerName' value='Eclipse.org'/>\r
-        <property name='df_LT.pluginName' value='Common Eclipse Runtime'/>\r
-        <property name='org.eclipse.equinox.p2.name' value='%pluginName'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='%providerName'/>\r
-      </properties>\r
-      <provides size='7'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.equinox.common' version='3.4.0.v20080421-2006'/>\r
-        <provided namespace='osgi.bundle' name='org.eclipse.equinox.common' version='3.4.0.v20080421-2006'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.internal.boot' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.internal.runtime' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.runtime' version='3.4.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' version='1.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.localization' name='df_LT' version='1.0.0'/>\r
-      </provides>\r
-      <requires size='10'>\r
-        <required namespace='java.package' name='org.eclipse.osgi.framework.log' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.eclipse.osgi.service.datalocation' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.eclipse.osgi.service.debug' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.eclipse.osgi.service.localization' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.eclipse.osgi.service.urlconversion' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.osgi.service.url' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.eclipse.osgi.util' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.osgi.framework' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.osgi.service.packageadmin' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.osgi.util.tracker' range='0.0.0'/>\r
-      </requires>\r
-      <artifacts size='1'>\r
-        <artifact classifier='osgi.bundle' id='org.eclipse.equinox.common' version='3.4.0.v20080421-2006'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='1'>\r
-          <instruction key='manifest'>\r
-            Bundle-Name: %pluginName&#xA;Bundle-Version: 3.4.0.v20080421-2006&#xA;Eclipse-LazyStart: true&#xA;Import-Package: org.eclipse.osgi.framework.log,org.eclipse.osgi.service.datalocation,org.eclipse.osgi.service.debug,org.eclipse.osgi.service.localization,org.eclipse.osgi.service.urlconversion,org.osgi.service.url,org.eclipse.osgi.util,org.osgi.framework,org.osgi.service.packageadmin,org.osgi.util.tracker&#xA;Bundle-Activator: org.eclipse.core.internal.runtime.Activator&#xA;Bundle-Vendor: %providerName&#xA;Export-Package: org.eclipse.core.internal.boot;x-friends:=&quot;org.eclipse.core.resources,org.eclipse.core.runtime.compatibility,org.eclipse.pde.build&quot;,org.eclipse.core.internal.runtime;common=split;mandatory:=common; x-friends:=&quot;org.eclipse.core.contenttype,  org.eclipse.core.jobs,  org.eclipse.equinox.preferences,  org.eclipse.equinox.registry,  org.eclipse.core.runtime,  org.eclipse.core.runtime.compatibility,  org.eclipse.core.filesystem,  org.eclipse.equinox.security&quot;,org.eclipse.core.runtime;common=split;version=&quot;3.4.0&quot;;mandatory:=common&#xA;Bundle-SymbolicName: org.eclipse.equinox.common; singleton:=true&#xA;Comment-Header: Both Eclipse-LazyStart and Bundle-ActivationPolicy are specified for compatibility with 3.2&#xA;Manifest-Version: 1.0&#xA;Bundle-ActivationPolicy: lazy&#xA;Bundle-ManifestVersion: 2&#xA;Bundle-RequiredExecutionEnvironment: CDC-1.0/Foundation-1.0,J2SE-1.3&#xA;Bundle-Localization: plugin\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='org.eclipse.jface.databinding' version='1.2.1.M20080827-0800a' singleton='false'>\r
-      <update id='org.eclipse.jface.databinding' range='[0.0.0,1.2.1.M20080827-0800a)' severity='0'/>\r
-      <properties size='4'>\r
-        <property name='df_LT.providerName' value='Eclipse.org'/>\r
-        <property name='df_LT.pluginName' value='JFace Data Binding for SWT and JFace'/>\r
-        <property name='org.eclipse.equinox.p2.name' value='%pluginName'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='%providerName'/>\r
-      </properties>\r
-      <provides size='11'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.jface.databinding' version='1.2.1.M20080827-0800a'/>\r
-        <provided namespace='osgi.bundle' name='org.eclipse.jface.databinding' version='1.2.1.M20080827-0800a'/>\r
-        <provided namespace='java.package' name='org.eclipse.jface.databinding.swt' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.jface.databinding.viewers' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.jface.databinding.wizard' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.jface.internal.databinding.provisional.swt' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.jface.internal.databinding.provisional.viewers' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.jface.internal.databinding.swt' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.jface.internal.databinding.viewers' version='0.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' version='1.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.localization' name='df_LT' version='1.0.0'/>\r
-      </provides>\r
-      <requires size='5'>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.databinding' range='[1.0.0,2.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.swt' range='[3.2.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.jface' range='[3.2.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.equinox.common' range='[3.2.0,4.0.0)'/>\r
-        <required namespace='java.package' name='com.ibm.icu.text' range='0.0.0'/>\r
-      </requires>\r
-      <artifacts size='1'>\r
-        <artifact classifier='osgi.bundle' id='org.eclipse.jface.databinding' version='1.2.1.M20080827-0800a'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='1'>\r
-          <instruction key='manifest'>\r
-            Bundle-ManifestVersion: 2&#xA;Export-Package: org.eclipse.jface.databinding.swt,org.eclipse.jface.databinding.viewers,org.eclipse.jface.databinding.wizard,org.eclipse.jface.internal.databinding.provisional.swt;x-internal:=true,org.eclipse.jface.internal.databinding.provisional.viewers;x-internal:=true,org.eclipse.jface.internal.databinding.swt;x-internal:=true,org.eclipse.jface.internal.databinding.viewers;x-internal:=true&#xA;Bundle-RequiredExecutionEnvironment: CDC-1.0/Foundation-1.0,J2SE-1.3&#xA;Bundle-Localization: plugin&#xA;Require-Bundle: org.eclipse.core.databinding;bundle-version=&quot;[1.0.0,2.0.0)&quot;,org.eclipse.swt;bundle-version=&quot;[3.2.0,4.0.0)&quot;,org.eclipse.jface;bundle-version=&quot;[3.2.0,4.0.0)&quot;,org.eclipse.equinox.common;bundle-version=&quot;[3.2.0,4.0.0)&quot;&#xA;Bundle-Name: %pluginName&#xA;Bundle-Version: 1.2.1.M20080827-0800a&#xA;Bundle-Vendor: %providerName&#xA;Bundle-SymbolicName: org.eclipse.jface.databinding&#xA;Import-Package: com.ibm.icu.text&#xA;Manifest-Version: 1.0&#xA;Bundle-ClassPath: .\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='org.eclipse.core.net' version='1.1.0.I20080604'>\r
-      <update id='org.eclipse.core.net' range='[0.0.0,1.1.0.I20080604)' severity='0'/>\r
-      <properties size='4'>\r
-        <property name='df_LT.PLUGIN_NAME' value='Internet Connection Management'/>\r
-        <property name='df_LT.PLUGIN_PROVIDER' value='Eclipse.org'/>\r
-        <property name='org.eclipse.equinox.p2.name' value='%PLUGIN_NAME'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='%PLUGIN_PROVIDER'/>\r
-      </properties>\r
-      <provides size='6'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.core.net' version='1.1.0.I20080604'/>\r
-        <provided namespace='osgi.bundle' name='org.eclipse.core.net' version='1.1.0.I20080604'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.internal.net' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.net.proxy' version='0.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' version='1.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.localization' name='df_LT' version='1.0.0'/>\r
-      </provides>\r
-      <requires size='5'>\r
-        <required namespace='osgi.bundle' name='org.eclipse.equinox.security' range='[1.0.0,2.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.equinox.common' range='3.4.0'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.equinox.preferences' range='3.2.200'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.osgi' range='3.4.0'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.equinox.registry' range='3.4.0'/>\r
-      </requires>\r
-      <artifacts size='1'>\r
-        <artifact classifier='osgi.bundle' id='org.eclipse.core.net' version='1.1.0.I20080604'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='1'>\r
-          <instruction key='manifest'>\r
-            Bundle-ManifestVersion: 2&#xA;Export-Package: org.eclipse.core.internal.net;x-internal:=true,org.eclipse.core.net.proxy&#xA;Bundle-RequiredExecutionEnvironment: J2SE-1.4,CDC-1.0/Foundation-1.0,J2SE-1.3&#xA;Bundle-Localization: plugin&#xA;Require-Bundle: org.eclipse.equinox.security;bundle-version=&quot;[1.0.0,2.0.0)&quot;,org.eclipse.equinox.common;bundle-version=&quot;3.4.0&quot;,org.eclipse.equinox.preferences;bundle-version=&quot;3.2.200&quot;,org.eclipse.osgi;bundle-version=&quot;3.4.0&quot;,org.eclipse.equinox.registry;bundle-version=&quot;3.4.0&quot;&#xA;Bundle-Activator: org.eclipse.core.internal.net.Activator&#xA;Bundle-Name: %PLUGIN_NAME&#xA;Bundle-Version: 1.1.0.I20080604&#xA;Bundle-Vendor: %PLUGIN_PROVIDER&#xA;Bundle-SymbolicName: org.eclipse.core.net;singleton:=true&#xA;Bundle-ActivationPolicy: lazy&#xA;Manifest-Version: 1.0\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='org.eclipse.osgi' version='3.4.3.R34x_v20081215-1030'>\r
-      <update id='org.eclipse.osgi' range='[0.0.0,3.4.3.R34x_v20081215-1030)' severity='0'/>\r
-      <properties size='5'>\r
-        <property name='df_LT.systemBundle' value='OSGi System Bundle'/>\r
-        <property name='df_LT.eclipse.org' value='Eclipse.org'/>\r
-        <property name='org.eclipse.equinox.p2.name' value='%systemBundle'/>\r
-        <property name='org.eclipse.equinox.p2.description' value='%systemBundle'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='%eclipse.org'/>\r
-      </properties>\r
-      <provides size='52'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.osgi' version='3.4.3.R34x_v20081215-1030'/>\r
-        <provided namespace='osgi.bundle' name='org.eclipse.osgi' version='3.4.3.R34x_v20081215-1030'/>\r
-        <provided namespace='java.package' name='org.eclipse.osgi.event' version='1.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.osgi.framework.console' version='1.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.osgi.framework.eventmgr' version='1.1.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.osgi.framework.log' version='1.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.osgi.service.datalocation' version='1.1.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.osgi.service.debug' version='1.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.osgi.service.environment' version='1.1.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.osgi.service.localization' version='1.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.osgi.service.pluginconversion' version='1.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.osgi.service.resolver' version='1.2.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.osgi.service.runnable' version='1.1.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.osgi.service.security' version='1.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.osgi.service.urlconversion' version='1.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.osgi.signedcontent' version='1.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.osgi.storagemanager' version='1.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.osgi.util' version='1.1.0'/>\r
-        <provided namespace='java.package' name='org.osgi.framework' version='1.4.0'/>\r
-        <provided namespace='java.package' name='org.osgi.service.condpermadmin' version='1.0.0'/>\r
-        <provided namespace='java.package' name='org.osgi.service.packageadmin' version='1.2.0'/>\r
-        <provided namespace='java.package' name='org.osgi.service.permissionadmin' version='1.2.0'/>\r
-        <provided namespace='java.package' name='org.osgi.service.startlevel' version='1.1.0'/>\r
-        <provided namespace='java.package' name='org.osgi.service.url' version='1.0.0'/>\r
-        <provided namespace='java.package' name='org.osgi.util.tracker' version='1.3.3'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.runtime.adaptor' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.runtime.internal.adaptor' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.runtime.internal.stats' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.osgi.baseadaptor' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.osgi.baseadaptor.bundlefile' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.osgi.baseadaptor.hooks' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.osgi.baseadaptor.loader' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.osgi.framework.adaptor' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.osgi.framework.debug' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.osgi.framework.internal.core' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.osgi.framework.internal.protocol' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.osgi.framework.internal.protocol.bundleentry' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.osgi.framework.internal.protocol.bundleresource' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.osgi.framework.internal.protocol.reference' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.osgi.framework.internal.reliablefile' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.osgi.framework.launcher' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.osgi.framework.util' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.osgi.internal.baseadaptor' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.osgi.internal.module' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.osgi.internal.profile' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.osgi.internal.resolver' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.osgi.internal.provisional.service.security' version='1.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.osgi.internal.provisional.verifier' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.osgi.internal.service.security' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.osgi.internal.signedcontent' version='0.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' version='1.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.localization' name='df_LT' version='1.0.0'/>\r
-      </provides>\r
-      <artifacts size='1'>\r
-        <artifact classifier='osgi.bundle' id='org.eclipse.osgi' version='3.4.3.R34x_v20081215-1030'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='1'>\r
-          <instruction key='manifest'>\r
-            Bundle-Version: 3.4.3.R34x_v20081215-1030&#xA;Bundle-DocUrl: http://www.eclipse.org&#xA;Bundle-Copyright: %copyright&#xA;Eclipse-ExtensibleAPI: true&#xA;Eclipse-SystemBundle: true&#xA;Export-Package: org.eclipse.osgi.event;version=&quot;1.0&quot;,org.eclipse.osgi.framework.console;version=&quot;1.0&quot;,org.eclipse.osgi.framework.eventmgr;version=&quot;1.1&quot;,org.eclipse.osgi.framework.log;version=&quot;1.0&quot;,org.eclipse.osgi.service.datalocation;version=&quot;1.1&quot;,org.eclipse.osgi.service.debug;version=&quot;1.0&quot;,org.eclipse.osgi.service.environment;version=&quot;1.1&quot;,org.eclipse.osgi.service.localization;version=&quot;1.0&quot;,org.eclipse.osgi.service.pluginconversion;version=&quot;1.0&quot;,org.eclipse.osgi.service.resolver;version=&quot;1.2&quot;,org.eclipse.osgi.service.runnable;version=&quot;1.1&quot;,org.eclipse.osgi.service.security; version=&quot;1.0&quot;,org.eclipse.osgi.service.urlconversion;version=&quot;1.0&quot;,org.eclipse.osgi.signedcontent; version=&quot;1.0&quot;,org.eclipse.osgi.storagemanager;version=&quot;1.0&quot;,org.eclipse.osgi.util;version=&quot;1.1&quot;,org.osgi.framework;version=&quot;1.4&quot;,org.osgi.service.condpermadmin;version=&quot;1.0&quot;,org.osgi.service.packageadmin;version=&quot;1.2&quot;,org.osgi.service.permissionadmin;version=&quot;1.2&quot;,org.osgi.service.startlevel;version=&quot;1.1&quot;,org.osgi.service.url;version=&quot;1.0&quot;,org.osgi.util.tracker;version=&quot;1.3.3&quot;,org.eclipse.core.runtime.adaptor;x-friends:=&quot;org.eclipse.core.runtime&quot;,org.eclipse.core.runtime.internal.adaptor;x-internal:=true,org.eclipse.core.runtime.internal.stats;x-friends:=&quot;org.eclipse.core.runtime&quot;,org.eclipse.osgi.baseadaptor;x-internal:=true,org.eclipse.osgi.baseadaptor.bundlefile;x-internal:=true,org.eclipse.osgi.baseadaptor.hooks;x-internal:=true,org.eclipse.osgi.baseadaptor.loader;x-internal:=true,org.eclipse.osgi.framework.adaptor;x-internal:=true,org.eclipse.osgi.framework.debug;x-internal:=true,org.eclipse.osgi.framework.internal.core;x-internal:=true,org.eclipse.osgi.framework.internal.protocol;x-internal:=true,org.eclipse.osgi.framework.internal.protocol.bundleentry;x-internal:=true,org.eclipse.osgi.framework.internal.protocol.bundleresource;x-internal:=true,org.eclipse.osgi.framework.internal.protocol.reference;x-internal:=true,org.eclipse.osgi.framework.internal.reliablefile;x-internal:=true,org.eclipse.osgi.framework.launcher;x-internal:=true,org.eclipse.osgi.framework.util;x-internal:=true,org.eclipse.osgi.internal.baseadaptor;x-internal:=true,org.eclipse.osgi.internal.module;x-internal:=true,org.eclipse.osgi.internal.profile;x-internal:=true,org.eclipse.osgi.internal.resolver;x-internal:=true,org.eclipse.osgi.internal.provisional.service.security; x-friends:=&quot;org.eclipse.equinox.security.ui&quot;;version=&quot;1.0.0&quot;,org.eclipse.osgi.internal.provisional.verifier;x-friends:=&quot;org.eclipse.update.core,org.eclipse.ui.workbench,org.eclipse.equinox.p2.artifact.repository&quot;,org.eclipse.osgi.internal.service.security;x-friends:=&quot;org.eclipse.equinox.security.ui&quot;,org.eclipse.osgi.internal.signedcontent; x-internal:=true&#xA;Manifest-Version: 1.0&#xA;Bundle-Activator: org.eclipse.osgi.framework.internal.core.SystemBundleActivator&#xA;Bundle-RequiredExecutionEnvironment: J2SE-1.5,OSGi/Minimum-1.1&#xA;Bundle-Localization: systembundle&#xA;Bundle-SymbolicName: org.eclipse.osgi; singleton:=true&#xA;Export-Service: org.osgi.service.packageadmin.PackageAdmin,org.osgi.service.permissionadmin.PermissionAdmin,org.osgi.service.startlevel.StartLevel,org.eclipse.osgi.service.debug.DebugOptions&#xA;Main-Class: org.eclipse.core.runtime.adaptor.EclipseStarter&#xA;Bundle-Description: %systemBundle&#xA;Bundle-Vendor: %eclipse.org&#xA;Bundle-Name: %systemBundle&#xA;Bundle-ManifestVersion: 2\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='org.eclipse.ui.forms' version='3.3.103.v20081027_34x' singleton='false'>\r
-      <update id='org.eclipse.ui.forms' range='[0.0.0,3.3.103.v20081027_34x)' severity='0'/>\r
-      <properties size='4'>\r
-        <property name='df_LT.provider-name' value='Eclipse.org'/>\r
-        <property name='df_LT.name' value='Eclipse Forms'/>\r
-        <property name='org.eclipse.equinox.p2.name' value='%name'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='%provider-name'/>\r
-      </properties>\r
-      <provides size='10'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.ui.forms' version='3.3.103.v20081027_34x'/>\r
-        <provided namespace='osgi.bundle' name='org.eclipse.ui.forms' version='3.3.103.v20081027_34x'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.forms' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.forms.editor' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.forms.events' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.forms.widgets' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.forms' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.forms.widgets' version='0.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' version='1.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.localization' name='df_LT' version='1.0.0'/>\r
-      </provides>\r
-      <requires size='7'>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.runtime' range='[3.1.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.jface' range='[3.2.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.ui' range='[3.2.0,4.0.0)' optional='true'/>\r
-        <required namespace='java.package' name='com.ibm.icu.text' range='0.0.0'/>\r
-        <required namespace='java.package' name='javax.xml.parsers' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.w3c.dom' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.xml.sax' range='0.0.0'/>\r
-      </requires>\r
-      <artifacts size='1'>\r
-        <artifact classifier='osgi.bundle' id='org.eclipse.ui.forms' version='3.3.103.v20081027_34x'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='1'>\r
-          <instruction key='manifest'>\r
-            Bundle-RequiredExecutionEnvironment: J2SE-1.4&#xA;Bundle-Name: %name&#xA;Manifest-Version: 1.0&#xA;Bundle-Vendor: %provider-name&#xA;Bundle-ActivationPolicy: lazy&#xA;Bundle-SymbolicName: org.eclipse.ui.forms&#xA;Import-Package: com.ibm.icu.text,javax.xml.parsers,org.w3c.dom,org.xml.sax&#xA;Bundle-ManifestVersion: 2&#xA;Eclipse-LazyStart: true&#xA;Bundle-Version: 3.3.103.v20081027_34x&#xA;Bundle-Localization: plugin&#xA;Export-Package: org.eclipse.ui.forms,org.eclipse.ui.forms.editor,org.eclipse.ui.forms.events,org.eclipse.ui.forms.widgets,org.eclipse.ui.internal.forms;x-internal:=true,org.eclipse.ui.internal.forms.widgets;x-friends:=&quot;org.eclipse.ui.tests.forms&quot;&#xA;Require-Bundle: org.eclipse.core.runtime;bundle-version=&quot;[3.1.0,4.0.0)&quot;,org.eclipse.jface;bundle-version=&quot;[3.2.0,4.0.0)&quot;,org.eclipse.ui;bundle-version=&quot;[3.2.0,4.0.0)&quot;;resolution:=optional\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='org.eclipse.ant.core' version='3.2.0.v20080529'>\r
-      <update id='org.eclipse.ant.core' range='[0.0.0,3.2.0.v20080529)' severity='0'/>\r
-      <properties size='4'>\r
-        <property name='df_LT.providerName' value='Eclipse.org'/>\r
-        <property name='df_LT.pluginName' value='Ant Build Tool Core'/>\r
-        <property name='org.eclipse.equinox.p2.name' value='%pluginName'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='%providerName'/>\r
-      </properties>\r
-      <provides size='7'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.ant.core' version='3.2.0.v20080529'/>\r
-        <provided namespace='osgi.bundle' name='org.eclipse.ant.core' version='3.2.0.v20080529'/>\r
-        <provided namespace='java.package' name='org.eclipse.ant.core' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ant.internal.core' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ant.internal.core.contentDescriber' version='0.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' version='1.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.localization' name='df_LT' version='1.0.0'/>\r
-      </provides>\r
-      <requires size='2'>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.variables' range='[3.1.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.runtime' range='[3.2.0,4.0.0)'/>\r
-      </requires>\r
-      <artifacts size='1'>\r
-        <artifact classifier='osgi.bundle' id='org.eclipse.ant.core' version='3.2.0.v20080529'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='1'>\r
-          <instruction key='manifest'>\r
-            Bundle-ManifestVersion: 2&#xA;Export-Package: org.eclipse.ant.core,org.eclipse.ant.internal.core;x-friends:=&quot;org.eclipse.ant.ui&quot;,org.eclipse.ant.internal.core.contentDescriber;x-internal:=true&#xA;Bundle-RequiredExecutionEnvironment: J2SE-1.4&#xA;Bundle-Localization: plugin&#xA;Require-Bundle: org.eclipse.core.variables;bundle-version=&quot;[3.1.0,4.0.0)&quot;,org.eclipse.core.runtime;bundle-version=&quot;[3.2.0,4.0.0)&quot;&#xA;Bundle-Activator: org.eclipse.ant.core.AntCorePlugin&#xA;Bundle-Name: %pluginName&#xA;Bundle-Version: 3.2.0.v20080529&#xA;Bundle-Vendor: %providerName&#xA;Bundle-SymbolicName: org.eclipse.ant.core; singleton:=true&#xA;Manifest-Version: 1.0&#xA;Eclipse-LazyStart: true; exceptions=&quot;org.eclipse.ant.internal.core.contentDescriber&quot;\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='org.eclipse.text' version='3.4.0.v20080605-1800' singleton='false'>\r
-      <update id='org.eclipse.text' range='[0.0.0,3.4.0.v20080605-1800)' severity='0'/>\r
-      <properties size='4'>\r
-        <property name='df_LT.providerName' value='Eclipse.org'/>\r
-        <property name='df_LT.pluginName' value='Text'/>\r
-        <property name='org.eclipse.equinox.p2.name' value='%pluginName'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='%providerName'/>\r
-      </properties>\r
-      <provides size='11'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.text' version='3.4.0.v20080605-1800'/>\r
-        <provided namespace='osgi.bundle' name='org.eclipse.text' version='3.4.0.v20080605-1800'/>\r
-        <provided namespace='java.package' name='org.eclipse.jface.text' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.jface.text.link' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.jface.text.projection' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.jface.text.source' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.jface.text.templates' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.text.edits' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.text.undo' version='0.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' version='1.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.localization' name='df_LT' version='1.0.0'/>\r
-      </provides>\r
-      <requires size='4'>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.commands' range='[3.2.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.equinox.common' range='[3.3.0,4.0.0)'/>\r
-        <required namespace='java.package' name='com.ibm.icu.text' range='0.0.0'/>\r
-        <required namespace='java.package' name='com.ibm.icu.util' range='0.0.0'/>\r
-      </requires>\r
-      <artifacts size='1'>\r
-        <artifact classifier='osgi.bundle' id='org.eclipse.text' version='3.4.0.v20080605-1800'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='1'>\r
-          <instruction key='manifest'>\r
-            Bundle-Vendor: %providerName&#xA;Bundle-ManifestVersion: 2&#xA;Bundle-RequiredExecutionEnvironment: J2SE-1.4&#xA;Bundle-Localization: plugin&#xA;Bundle-Name: %pluginName&#xA;Import-Package: com.ibm.icu.text,com.ibm.icu.util&#xA;Require-Bundle: org.eclipse.core.commands;bundle-version=&quot;[3.2.0,4.0.0)&quot;,org.eclipse.equinox.common;bundle-version=&quot;[3.3.0,4.0.0)&quot;&#xA;Manifest-Version: 1.0&#xA;Bundle-SymbolicName: org.eclipse.text&#xA;Bundle-Version: 3.4.0.v20080605-1800&#xA;Export-Package: org.eclipse.jface.text; text=&quot;split&quot;; mandatory:=&quot;text&quot;,org.eclipse.jface.text.link; text=&quot;split&quot;; mandatory:=&quot;text&quot;,org.eclipse.jface.text.projection,org.eclipse.jface.text.source; text=&quot;split&quot;; mandatory:=&quot;text&quot;,org.eclipse.jface.text.templates; text=&quot;split&quot;; mandatory:=&quot;text&quot;,org.eclipse.text.edits,org.eclipse.text.undo\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='org.eclipse.osgi.services' version='3.1.200.v20071203' singleton='false'>\r
-      <update id='org.eclipse.osgi.services' range='[0.0.0,3.1.200.v20071203)' severity='0'/>\r
-      <properties size='7'>\r
-        <property name='df_LT.osgiServices' value='OSGi Release 4.0.1 Services'/>\r
-        <property name='df_LT.osgiServicesDes' value='OSGi Service Platform Release 4.0.1 Service Interfaces and Classes'/>\r
-        <property name='df_LT.eclipse.org' value='Eclipse.org'/>\r
-        <property name='org.eclipse.equinox.p2.name' value='%osgiServices'/>\r
-        <property name='org.eclipse.equinox.p2.description' value='%osgiServicesDes'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='%eclipse.org'/>\r
-        <property name='org.eclipse.equinox.p2.contact' value='www.eclipse.org'/>\r
-      </properties>\r
-      <provides size='16'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.osgi.services' version='3.1.200.v20071203'/>\r
-        <provided namespace='osgi.bundle' name='org.eclipse.osgi.services' version='3.1.200.v20071203'/>\r
-        <provided namespace='java.package' name='org.osgi.service.cm' version='1.2.0'/>\r
-        <provided namespace='java.package' name='org.osgi.service.component' version='1.0.0'/>\r
-        <provided namespace='java.package' name='org.osgi.service.device' version='1.1.0'/>\r
-        <provided namespace='java.package' name='org.osgi.service.event' version='1.1.0'/>\r
-        <provided namespace='java.package' name='org.osgi.service.http' version='1.2.0'/>\r
-        <provided namespace='java.package' name='org.osgi.service.io' version='1.0.0'/>\r
-        <provided namespace='java.package' name='org.osgi.service.log' version='1.3.0'/>\r
-        <provided namespace='java.package' name='org.osgi.service.metatype' version='1.1.0'/>\r
-        <provided namespace='java.package' name='org.osgi.service.provisioning' version='1.1.0'/>\r
-        <provided namespace='java.package' name='org.osgi.service.upnp' version='1.1.0'/>\r
-        <provided namespace='java.package' name='org.osgi.service.useradmin' version='1.1.0'/>\r
-        <provided namespace='java.package' name='org.osgi.service.wireadmin' version='1.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' version='1.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.localization' name='df_LT' version='1.0.0'/>\r
-      </provides>\r
-      <requires size='5'>\r
-        <required namespace='java.package' name='javax.servlet' range='0.0.0' optional='true'/>\r
-        <required namespace='java.package' name='javax.servlet.http' range='0.0.0' optional='true'/>\r
-        <required namespace='java.package' name='org.osgi.framework' range='1.2.0'/>\r
-        <required namespace='java.package' name='javax.servlet' range='0.0.0' optional='true'/>\r
-        <required namespace='java.package' name='javax.servlet.http' range='0.0.0' optional='true'/>\r
-      </requires>\r
-      <artifacts size='1'>\r
-        <artifact classifier='osgi.bundle' id='org.eclipse.osgi.services' version='3.1.200.v20071203'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='1'>\r
-          <instruction key='manifest'>\r
-            Bundle-ManifestVersion: 2&#xA;Bundle-Description: %osgiServicesDes&#xA;Bundle-RequiredExecutionEnvironment: OSGi/Minimum-1.0&#xA;Bundle-Name: %osgiServices&#xA;Bundle-ContactAddress: www.eclipse.org&#xA;Bundle-Vendor: %eclipse.org&#xA;Bundle-Copyright: %copyright&#xA;Bundle-DocUrl: http://www.eclipse.org&#xA;DynamicImport-Package: javax.servlet,javax.servlet.http&#xA;Manifest-Version: 1.0&#xA;Bundle-Version: 3.1.200.v20071203&#xA;Bundle-Localization: plugin&#xA;Export-Package: org.osgi.service.cm; version=&quot;1.2&quot;,org.osgi.service.component; version=&quot;1.0&quot;,org.osgi.service.device; version=&quot;1.1&quot;,org.osgi.service.event; version=&quot;1.1&quot;,org.osgi.service.http; version=&quot;1.2&quot;,org.osgi.service.io; version=&quot;1.0&quot;,org.osgi.service.log; version=&quot;1.3&quot;,org.osgi.service.metatype; version=&quot;1.1&quot;,org.osgi.service.provisioning; version=&quot;1.1&quot;,org.osgi.service.upnp; version=&quot;1.1&quot;,org.osgi.service.useradmin; version=&quot;1.1&quot;,org.osgi.service.wireadmin; version=&quot;1.0&quot;&#xA;Bundle-SymbolicName: org.eclipse.osgi.services&#xA;Import-Package: org.osgi.framework; version=1.2,javax.servlet; resolution:=&quot;optional&quot;,javax.servlet.http; resolution:=&quot;optional&quot;\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='org.eclipse.equinox.security' version='1.0.1.R34x_v20080721'>\r
-      <update id='org.eclipse.equinox.security' range='[0.0.0,1.0.1.R34x_v20080721)' severity='0'/>\r
-      <properties size='4'>\r
-        <property name='df_LT.providerName' value='Eclipse.org'/>\r
-        <property name='df_LT.pluginName' value='Equinox Java Authentication and Authorization Service (JAAS)'/>\r
-        <property name='org.eclipse.equinox.p2.name' value='%pluginName'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='%providerName'/>\r
-      </properties>\r
-      <provides size='16'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.equinox.security' version='1.0.1.R34x_v20080721'/>\r
-        <provided namespace='osgi.bundle' name='org.eclipse.equinox.security' version='1.0.1.R34x_v20080721'/>\r
-        <provided namespace='java.package' name='org.eclipse.equinox.internal.security.auth' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.equinox.internal.security.auth.events' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.equinox.internal.security.auth.ext.loader' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.equinox.internal.security.auth.nls' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.equinox.internal.security.credentials' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.equinox.internal.security.storage' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.equinox.internal.security.storage.friends' version='1.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.equinox.security.auth' version='1.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.equinox.security.auth.credentials' version='1.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.equinox.security.auth.module' version='1.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.equinox.security.storage' version='1.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.equinox.security.storage.provider' version='1.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' version='1.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.localization' name='df_LT' version='1.0.0'/>\r
-      </provides>\r
-      <requires size='18'>\r
-        <required namespace='java.package' name='javax.crypto' range='0.0.0'/>\r
-        <required namespace='java.package' name='javax.crypto.spec' range='0.0.0'/>\r
-        <required namespace='java.package' name='javax.security.auth' range='0.0.0'/>\r
-        <required namespace='java.package' name='javax.security.auth.callback' range='0.0.0'/>\r
-        <required namespace='java.package' name='javax.security.auth.login' range='0.0.0'/>\r
-        <required namespace='java.package' name='javax.security.auth.spi' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.eclipse.core.internal.runtime' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.eclipse.core.runtime' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.eclipse.core.runtime.jobs' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.eclipse.core.runtime.preferences' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.eclipse.osgi.framework.log' range='[1.0.0,2.0.0)'/>\r
-        <required namespace='java.package' name='org.eclipse.osgi.service.datalocation' range='[1.0.0,2.0.0)'/>\r
-        <required namespace='java.package' name='org.eclipse.osgi.service.debug' range='[1.0.0,2.0.0)'/>\r
-        <required namespace='java.package' name='org.eclipse.osgi.service.environment' range='[1.1.0,2.0.0)'/>\r
-        <required namespace='java.package' name='org.eclipse.osgi.util' range='[1.1.0,2.0.0)'/>\r
-        <required namespace='java.package' name='org.osgi.framework' range='[1.4.0,2.0.0)'/>\r
-        <required namespace='java.package' name='org.osgi.service.prefs' range='[1.1.0,2.0.0)'/>\r
-        <required namespace='java.package' name='org.osgi.util.tracker' range='[1.3.3,2.0.0)'/>\r
-      </requires>\r
-      <artifacts size='1'>\r
-        <artifact classifier='osgi.bundle' id='org.eclipse.equinox.security' version='1.0.1.R34x_v20080721'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='1'>\r
-          <instruction key='manifest'>\r
-            Bundle-ManifestVersion: 2&#xA;Export-Package: org.eclipse.equinox.internal.security.auth;x-internal:=true,org.eclipse.equinox.internal.security.auth.events;x-internal:=true,org.eclipse.equinox.internal.security.auth.ext.loader;x-internal:=true,org.eclipse.equinox.internal.security.auth.nls;x-internal:=true,org.eclipse.equinox.internal.security.credentials;x-internal:=true,org.eclipse.equinox.internal.security.storage;x-internal:=true,org.eclipse.equinox.internal.security.storage.friends;version=&quot;1.0.0&quot;;x-friends:=&quot;org.eclipse.equinox.security.ui&quot;,org.eclipse.equinox.security.auth;version=&quot;1.0.0&quot;,org.eclipse.equinox.security.auth.credentials;version=&quot;1.0.0&quot;,org.eclipse.equinox.security.auth.module;version=&quot;1.0.0&quot;,org.eclipse.equinox.security.storage;version=&quot;1.0.0&quot;,org.eclipse.equinox.security.storage.provider;version=&quot;1.0.0&quot;&#xA;Bundle-RequiredExecutionEnvironment: J2SE-1.4&#xA;Bundle-Localization: plugin&#xA;Bundle-Activator: org.eclipse.equinox.internal.security.auth.AuthPlugin&#xA;Bundle-Name: %pluginName&#xA;Bundle-Version: 1.0.1.R34x_v20080721&#xA;Bundle-Vendor: %providerName&#xA;Bundle-SymbolicName: org.eclipse.equinox.security;singleton:=true&#xA;Import-Package: javax.crypto,javax.crypto.spec,javax.security.auth,javax.security.auth.callback,javax.security.auth.login,javax.security.auth.spi,org.eclipse.core.internal.runtime;common=split,org.eclipse.core.runtime;registry=split,org.eclipse.core.runtime.jobs,org.eclipse.core.runtime.preferences,org.eclipse.osgi.framework.log;version=&quot;[1.0.0,2.0.0)&quot;,org.eclipse.osgi.service.datalocation;version=&quot;[1.0.0,2.0.0)&quot;,org.eclipse.osgi.service.debug;version=&quot;[1.0.0,2.0.0)&quot;,org.eclipse.osgi.service.environment;version=&quot;[1.1.0,2.0.0)&quot;,org.eclipse.osgi.util;version=&quot;[1.1.0,2.0.0)&quot;,org.osgi.framework;version=&quot;[1.4.0,2.0.0)&quot;,org.osgi.service.prefs;version=&quot;[1.1.0,2.0.0)&quot;,org.osgi.util.tracker;version=&quot;[1.3.3,2.0.0)&quot;&#xA;Bundle-ActivationPolicy: lazy&#xA;Manifest-Version: 1.0\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='org.eclipse.core.filesystem' version='1.2.0.v20080604-1400'>\r
-      <update id='org.eclipse.core.filesystem' range='[0.0.0,1.2.0.v20080604-1400)' severity='0'/>\r
-      <properties size='4'>\r
-        <property name='df_LT.providerName' value='Eclipse.org'/>\r
-        <property name='df_LT.pluginName' value='Core File Systems'/>\r
-        <property name='org.eclipse.equinox.p2.name' value='%pluginName'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='%providerName'/>\r
-      </properties>\r
-      <provides size='8'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.core.filesystem' version='1.2.0.v20080604-1400'/>\r
-        <provided namespace='osgi.bundle' name='org.eclipse.core.filesystem' version='1.2.0.v20080604-1400'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.filesystem' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.filesystem.provider' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.internal.filesystem' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.internal.filesystem.local' version='0.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' version='1.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.localization' name='df_LT' version='1.0.0'/>\r
-      </provides>\r
-      <requires size='3'>\r
-        <required namespace='osgi.bundle' name='org.eclipse.equinox.common' range='0.0.0'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.equinox.registry' range='0.0.0'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.osgi' range='0.0.0'/>\r
-      </requires>\r
-      <artifacts size='1'>\r
-        <artifact classifier='osgi.bundle' id='org.eclipse.core.filesystem' version='1.2.0.v20080604-1400'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='1'>\r
-          <instruction key='manifest'>\r
-            Bundle-ManifestVersion: 2&#xA;Export-Package: org.eclipse.core.filesystem,org.eclipse.core.filesystem.provider,org.eclipse.core.internal.filesystem;x-internal:=true,org.eclipse.core.internal.filesystem.local;x-internal:=true&#xA;Bundle-RequiredExecutionEnvironment: J2SE-1.4&#xA;Bundle-Localization: plugin&#xA;Require-Bundle: org.eclipse.equinox.common,org.eclipse.equinox.registry,org.eclipse.osgi&#xA;Bundle-Activator: org.eclipse.core.internal.filesystem.Activator&#xA;Bundle-Name: %pluginName&#xA;Bundle-Version: 1.2.0.v20080604-1400&#xA;Bundle-Vendor: %providerName&#xA;Bundle-SymbolicName: org.eclipse.core.filesystem; singleton:=true&#xA;Manifest-Version: 1.0&#xA;Eclipse-LazyStart: true\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='org.eclipse.equinox.registry' version='3.4.0.v20080516-0950'>\r
-      <update id='org.eclipse.equinox.registry' range='[0.0.0,3.4.0.v20080516-0950)' severity='0'/>\r
-      <properties size='4'>\r
-        <property name='df_LT.providerName' value='Eclipse.org'/>\r
-        <property name='df_LT.pluginName' value='Extension Registry Support'/>\r
-        <property name='org.eclipse.equinox.p2.name' value='%pluginName'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='%providerName'/>\r
-      </properties>\r
-      <provides size='11'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.equinox.registry' version='3.4.0.v20080516-0950'/>\r
-        <provided namespace='osgi.bundle' name='org.eclipse.equinox.registry' version='3.4.0.v20080516-0950'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.internal.adapter' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.internal.registry' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.internal.registry.osgi' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.internal.registry.spi' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.runtime' version='3.4.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.runtime.dynamichelpers' version='3.4.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.runtime.spi' version='3.4.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' version='1.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.localization' name='df_LT' version='1.0.0'/>\r
-      </provides>\r
-      <requires size='15'>\r
-        <required namespace='osgi.bundle' name='org.eclipse.equinox.common' range='[3.2.0,4.0.0)'/>\r
-        <required namespace='java.package' name='javax.xml.parsers' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.eclipse.core.runtime.jobs' range='0.0.0' optional='true'/>\r
-        <required namespace='java.package' name='org.eclipse.osgi.framework.console' range='0.0.0' optional='true'/>\r
-        <required namespace='java.package' name='org.eclipse.osgi.service.datalocation' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.eclipse.osgi.service.debug' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.eclipse.osgi.service.environment' range='0.0.0' optional='true'/>\r
-        <required namespace='java.package' name='org.eclipse.osgi.service.resolver' range='0.0.0' optional='true'/>\r
-        <required namespace='java.package' name='org.eclipse.osgi.storagemanager' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.eclipse.osgi.util' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.osgi.framework' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.osgi.service.packageadmin' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.osgi.util.tracker' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.xml.sax' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.xml.sax.helpers' range='0.0.0'/>\r
-      </requires>\r
-      <artifacts size='1'>\r
-        <artifact classifier='osgi.bundle' id='org.eclipse.equinox.registry' version='3.4.0.v20080516-0950'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='1'>\r
-          <instruction key='manifest'>\r
-            Bundle-Version: 3.4.0.v20080516-0950&#xA;Eclipse-ExtensibleAPI: true&#xA;Bundle-ActivationPolicy: lazy&#xA;Eclipse-LazyStart: true&#xA;Export-Package: org.eclipse.core.internal.adapter;x-internal:=true,org.eclipse.core.internal.registry;x-friends:=&quot;org.eclipse.core.runtime&quot;,org.eclipse.core.internal.registry.osgi;x-friends:=&quot;org.eclipse.core.runtime&quot;,org.eclipse.core.internal.registry.spi;x-internal:=true,org.eclipse.core.runtime;registry=split;version=&quot;3.4.0&quot;;mandatory:=registry,org.eclipse.core.runtime.dynamichelpers;version=&quot;3.4.0&quot;,org.eclipse.core.runtime.spi;version=&quot;3.4.0&quot;&#xA;Import-Package: javax.xml.parsers,org.eclipse.core.runtime.jobs;resolution:=optional,org.eclipse.osgi.framework.console;resolution:=optional,org.eclipse.osgi.service.datalocation,org.eclipse.osgi.service.debug,org.eclipse.osgi.service.environment;resolution:=optional,org.eclipse.osgi.service.resolver;resolution:=optional,org.eclipse.osgi.storagemanager,org.eclipse.osgi.util,org.osgi.framework,org.osgi.service.packageadmin,org.osgi.util.tracker,org.xml.sax,org.xml.sax.helpers&#xA;Manifest-Version: 1.0&#xA;Bundle-Activator: org.eclipse.core.internal.registry.osgi.Activator&#xA;Bundle-ClassPath: runtime_registry_compatibility.jar, .&#xA;Comment-Header: Both Eclipse-LazyStart and Bundle-ActivationPolicy are specified for compatibility with 3.2&#xA;Bundle-RequiredExecutionEnvironment: J2SE-1.4,CDC-1.0/Foundation-1.0,J2SE-1.3&#xA;Bundle-Localization: plugin&#xA;Require-Bundle: org.eclipse.equinox.common;bundle-version=&quot;[3.2.0,4.0.0)&quot;&#xA;Bundle-SymbolicName: org.eclipse.equinox.registry;singleton:=true&#xA;Bundle-Vendor: %providerName&#xA;Bundle-Name: %pluginName&#xA;Bundle-ManifestVersion: 2\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='javax.servlet' version='2.4.0.v200806031604' singleton='false'>\r
-      <update id='javax.servlet' range='[0.0.0,2.4.0.v200806031604)' severity='0'/>\r
-      <properties size='4'>\r
-        <property name='df_LT.bundleName' value='Servlet API Bundle'/>\r
-        <property name='df_LT.bundleProvider' value='Eclipse.org'/>\r
-        <property name='org.eclipse.equinox.p2.name' value='%bundleName'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='%bundleProvider'/>\r
-      </properties>\r
-      <provides size='7'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='javax.servlet' version='2.4.0.v200806031604'/>\r
-        <provided namespace='osgi.bundle' name='javax.servlet' version='2.4.0.v200806031604'/>\r
-        <provided namespace='java.package' name='javax.servlet' version='2.4.0'/>\r
-        <provided namespace='java.package' name='javax.servlet.http' version='2.4.0'/>\r
-        <provided namespace='java.package' name='javax.servlet.resources' version='2.4.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' version='1.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.localization' name='df_LT' version='1.0.0'/>\r
-      </provides>\r
-      <artifacts size='1'>\r
-        <artifact classifier='osgi.bundle' id='javax.servlet' version='2.4.0.v200806031604'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='1'>\r
-          <instruction key='manifest'>\r
-            Bundle-ManifestVersion: 2&#xA;Bundle-Name: %bundleName&#xA;Bundle-Version: 2.4.0.v200806031604&#xA;Export-Package: javax.servlet;version=&quot;2.4&quot;,javax.servlet.http;version=&quot;2.4&quot;,javax.servlet.resources;version=&quot;2.4&quot;&#xA;Bundle-RequiredExecutionEnvironment: CDC-1.0/Foundation-1.0,J2SE-1.3&#xA;Bundle-SymbolicName: javax.servlet&#xA;Bundle-Localization: plugin&#xA;Manifest-Version: 1.0&#xA;Bundle-Vendor: %bundleProvider\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='eu.etaxonomy.cdmLibrary' version='2.1.0.v20090603_1459'>\r
-      <update id='eu.etaxonomy.cdmLibrary' range='[0.0.0,2.1.0.v20090603_1459)' severity='0'/>\r
-      <properties size='1'>\r
-        <property name='org.eclipse.equinox.p2.name' value='CDM Library Plug-in'/>\r
-      </properties>\r
-      <provides size='89'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='eu.etaxonomy.cdmLibrary' version='2.1.0.v20090603_1459'/>\r
-        <provided namespace='osgi.bundle' name='eu.etaxonomy.cdmLibrary' version='2.1.0.v20090603_1459'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.cdm' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.cdm.api.application' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.cdm.api.application.eclipse' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.cdm.api.conversation' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.cdm.api.service' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.cdm.api.service.config' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.cdm.api.service.config.impl' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.cdm.api.service.pager' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.cdm.api.service.pager.impl' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.cdm.aspectj' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.cdm.common' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.cdm.database' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.cdm.database.types' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.cdm.datagenerator' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.cdm.ext' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.cdm.hibernate' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.cdm.io.abcd206' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.cdm.io.berlinModel' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.cdm.io.common' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.cdm.io.excel.common' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.cdm.io.excel.distribution' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.cdm.io.excel.taxa' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.cdm.io.jaxb' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.cdm.io.sdd' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.cdm.io.synthesys' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.cdm.io.taxonx' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.cdm.io.tcsxml' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.cdm.jaxb' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.cdm.model.agent' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.cdm.model.common' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.cdm.model.common.init' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.cdm.model.description' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.cdm.model.location' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.cdm.model.media' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.cdm.model.molecular' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.cdm.model.name' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.cdm.model.occurrence' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.cdm.model.reference' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.cdm.model.taxon' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.cdm.model.view' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.cdm.persistence.hibernate' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.cdm.persistence.query' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.cdm.strategy' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.cdm.strategy.cache.agent' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.cdm.strategy.cache.common' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.cdm.strategy.cache.name' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.cdm.strategy.cache.reference' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.cdm.strategy.exceptions' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.cdm.strategy.parser' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.apache.log4j' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.apache.log4j.chainsaw' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.apache.log4j.config' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.apache.log4j.helpers' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.apache.log4j.jdbc' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.apache.log4j.jmx' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.apache.log4j.lf5' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.apache.log4j.lf5.config' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.apache.log4j.lf5.util' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.apache.log4j.lf5.viewer' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.apache.log4j.lf5.viewer.categoryexplorer' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.apache.log4j.lf5.viewer.configure' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.apache.log4j.lf5.viewer.images' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.apache.log4j.net' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.apache.log4j.nt' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.apache.log4j.or' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.apache.log4j.or.jms' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.apache.log4j.or.sax' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.apache.log4j.spi' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.apache.log4j.varia' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.apache.log4j.xml' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.joda.time' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.joda.time.base' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.joda.time.chrono' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.joda.time.convert' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.joda.time.field' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.joda.time.format' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.joda.time.tz' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.springframework.core' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.springframework.core.io' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.springframework.orm.hibernate3' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.springframework.transaction' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.springframework.transaction.annotation' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.springframework.transaction.config' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.springframework.transaction.interceptor' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.springframework.transaction.jta' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.springframework.transaction.support' version='0.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' version='1.0.0'/>\r
-      </provides>\r
-      <requires size='2'>\r
-        <required namespace='osgi.bundle' name='org.eclipse.osgi' range='0.0.0'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.pde.source' range='0.0.0'/>\r
-      </requires>\r
-      <artifacts size='1'>\r
-        <artifact classifier='osgi.bundle' id='eu.etaxonomy.cdmLibrary' version='2.1.0.v20090603_1459'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='2'>\r
-          <instruction key='manifest'>\r
-            Bundle-ManifestVersion: 2&#xA;Bundle-Version: 2.1.0.v20090603_1459&#xA;Export-Package: eu.etaxonomy.cdm,eu.etaxonomy.cdm.api.application,eu.etaxonomy.cdm.api.application.eclipse,eu.etaxonomy.cdm.api.conversation,eu.etaxonomy.cdm.api.service,eu.etaxonomy.cdm.api.service.config,eu.etaxonomy.cdm.api.service.config.impl,eu.etaxonomy.cdm.api.service.pager,eu.etaxonomy.cdm.api.service.pager.impl,eu.etaxonomy.cdm.aspectj,eu.etaxonomy.cdm.common,eu.etaxonomy.cdm.database,eu.etaxonomy.cdm.database.types,eu.etaxonomy.cdm.datagenerator,eu.etaxonomy.cdm.ext,eu.etaxonomy.cdm.hibernate,eu.etaxonomy.cdm.io.abcd206,eu.etaxonomy.cdm.io.berlinModel,eu.etaxonomy.cdm.io.common,eu.etaxonomy.cdm.io.excel.common,eu.etaxonomy.cdm.io.excel.distribution,eu.etaxonomy.cdm.io.excel.taxa,eu.etaxonomy.cdm.io.jaxb,eu.etaxonomy.cdm.io.sdd,eu.etaxonomy.cdm.io.synthesys,eu.etaxonomy.cdm.io.taxonx,eu.etaxonomy.cdm.io.tcsxml,eu.etaxonomy.cdm.jaxb,eu.etaxonomy.cdm.model.agent,eu.etaxonomy.cdm.model.common,eu.etaxonomy.cdm.model.common.init,eu.etaxonomy.cdm.model.description,eu.etaxonomy.cdm.model.location,eu.etaxonomy.cdm.model.media,eu.etaxonomy.cdm.model.molecular,eu.etaxonomy.cdm.model.name,eu.etaxonomy.cdm.model.occurrence,eu.etaxonomy.cdm.model.reference,eu.etaxonomy.cdm.model.taxon,eu.etaxonomy.cdm.model.view,eu.etaxonomy.cdm.persistence.hibernate,eu.etaxonomy.cdm.persistence.query,eu.etaxonomy.cdm.strategy,eu.etaxonomy.cdm.strategy.cache.agent,eu.etaxonomy.cdm.strategy.cache.common,eu.etaxonomy.cdm.strategy.cache.name,eu.etaxonomy.cdm.strategy.cache.reference,eu.etaxonomy.cdm.strategy.exceptions,eu.etaxonomy.cdm.strategy.parser,org.apache.log4j;uses:=&quot;org.apache.log4j.helpers,org.apache.log4j.or,org.apache.log4j.spi&quot;,org.apache.log4j.chainsaw; uses:=&quot;org.apache.log4j,  javax.swing,  javax.swing.table,  org.apache.log4j.spi,  javax.swing.event,  org.xml.sax.helpers,  org.xml.sax&quot;,org.apache.log4j.config;uses:=&quot;org.apache.log4j&quot;,org.apache.log4j.helpers;uses:=&quot;org.apache.log4j,org.apache.log4j.spi&quot;,org.apache.log4j.jdbc;uses:=&quot;org.apache.log4j,org.apache.log4j.spi&quot;,org.apache.log4j.jmx;uses:=&quot;org.apache.log4j,org.apache.log4j.spi,javax.management&quot;,org.apache.log4j.lf5;uses:=&quot;org.apache.log4j.lf5.viewer,org.apache.log4j,org.apache.log4j.spi&quot;,org.apache.log4j.lf5.config,org.apache.log4j.lf5.util;uses:=&quot;org.apache.log4j.lf5.viewer,org.apache.log4j.lf5&quot;,org.apache.log4j.lf5.viewer; uses:=&quot;org.apache.log4j.lf5.util,  org.apache.log4j.lf5.viewer.categoryexplorer,  org.apache.log4j.lf5,  javax.swing,  javax.swing.table,  javax.swing.event,  org.apache.log4j.lf5.viewer.configure&quot;,org.apache.log4j.lf5.viewer.categoryexplorer; uses:=&quot;org.apache.log4j.lf5,  javax.swing.tree,  javax.swing,  javax.swing.table,  javax.swing.event&quot;,org.apache.log4j.lf5.viewer.configure;uses:=&quot;org.apache.log4j.lf5.viewer,javax.swing.tree,org.w3c.dom&quot;,org.apache.log4j.lf5.viewer.images,org.apache.log4j.net; uses:=&quot;javax.naming,  org.apache.log4j.helpers,  org.apache.log4j,  javax.jms,  javax.mail.internet,  org.apache.log4j.spi,  javax.mail&quot;,org.apache.log4j.nt;uses:=&quot;org.apache.log4j,org.apache.log4j.spi&quot;,org.apache.log4j.or;uses:=&quot;org.apache.log4j.spi&quot;,org.apache.log4j.or.jms;uses:=&quot;org.apache.log4j.or&quot;,org.apache.log4j.or.sax;uses:=&quot;org.apache.log4j.or&quot;,org.apache.log4j.spi;uses:=&quot;org.apache.log4j,org.apache.log4j.or&quot;,org.apache.log4j.varia;uses:=&quot;org.apache.log4j,org.apache.log4j.spi&quot;,org.apache.log4j.xml; uses:=&quot;org.apache.log4j.config,  org.apache.log4j.helpers,  org.apache.log4j,  javax.xml.parsers,  org.apache.log4j.spi,  org.w3c.dom,  org.xml.sax&quot;,org.joda.time; uses:=&quot;org.joda.time.base,  org.joda.time.field,  org.joda.time.chrono,  org.joda.time.tz,  org.joda.time.format&quot;,org.joda.time.base;uses:=&quot;org.joda.time,org.joda.time.format&quot;,org.joda.time.chrono;uses:=&quot;org.joda.time.field,org.joda.time&quot;,org.joda.time.convert;uses:=&quot;org.joda.time,org.joda.time.format&quot;,org.joda.time.field;uses:=&quot;org.joda.time&quot;,org.joda.time.format;uses:=&quot;org.joda.time&quot;,org.joda.time.tz;uses:=&quot;org.joda.time&quot;,org.springframework.core,org.springframework.core.io,org.springframework.orm.hibernate3,org.springframework.transaction;uses:=&quot;org.springframework.core&quot;,org.springframework.transaction.annotation,org.springframework.transaction.config,org.springframework.transaction.interceptor,org.springframework.transaction.jta,org.springframework.transaction.support&#xA;Require-Bundle: org.eclipse.osgi,org.eclipse.pde.source&#xA;Manifest-Version: 1.0&#xA;Bundle-SymbolicName: eu.etaxonomy.cdmLibrary;singleton:=true&#xA;Bundle-Name: CDM Library Plug-in&#xA;Bundle-ClassPath: antlr-2.7.6.jar,asm-attrs.jar,asm.jar,cglib-2.1.3.jar,commons-collections-3.2.jar,commons-logging-1.0.4.jar,dom4j-1.6.1.jar,ehcache-1.2.3.jar,ejb3-persistence.jar,hibernate-annotations-3.4.0-SNAPSHOT.jar,hibernate-commons-annotations-3.4.0-SNAPSHOT.jar,hibernate-core-3.4.0-SNAPSHOT.jar,hibernate-envers-3.4.0-SNAPSHOT.jar,hibernate-search-3.1.0.GA.jar,hibernate-tools-3.2.0.ga.jar,slf4j-api-1.5.2.jar,slf4j-log4j12-1.5.2.jar,javassist.jar,jdbc2_0-stdext.jar,jta.jar,junit-4.4.jar,log4j-1.2.14.jar,mysql-connector-java-3.1.14-bin.jar,xml-apis.jar,xercesImpl.jar,hsqldb.jar,jaxb-api.jar,jaxb-impl-2.0.jar,jdom-1.0.jar,msbase-2000.3.jar,mssqlserver-2000.3.jar,msutil-2000.3.jar,opencsv-1.8.jar,jtds-1.2.2.jar,postgresql-8.2-504.jdbc4.jar,aopalliance-1.0.jar,spring-2.5.jar,spring-beans-2.5.jar,spring-context-2.5.jar,spring-core-2.5.jar,spring-jdbc-2.5.jar,spring-orm-2.5.jar,spring-test-2.5.jar,spring-tx-2.5.jar,h2-1.0.73.jar,joda-time-1.5.jar,joda-time-hibernate-1.0.jar,sanselan-0.94-incubator.jar,poi-3.1-FINAL.jar,spring-security-core-2.0.4.jar,aspectjweaver-1.5.4.jar,lucene-core-2.4.0.jar,lucene-spellchecker-2.4.0.jar,lsid-client-1.1.2.jar,lsid-server-1.1.2.jar,wsdl4j-1.6.1.jar,spring-2.5.6.jar,spring-aop-2.5.6.jar,spring-beans-2.5.6.jar,spring-context-2.5.6.jar,spring-core-2.5.6.jar,spring-jdbc-2.5.6.jar,spring-modules-lucene-0.8a.jar,spring-orm-2.5.6.jar,spring-test-2.5.6.jar,spring-web-2.5.6.jar,spring-webmvc-2.5.6.jar,unitils-1.0.jar,jsr250-api-1.0.jar,cdmlib-commons-2.1.jar,cdmlib-ext-2.1.jar,cdmlib-io-2.1.jar,cdmlib-model-2.1.jar,cdmlib-persistence-2.1.jar,cdmlib-services-2.1.jar,cdmlib-persistence-2.1-tests.jar,hibernate-validator-3.1.0.GA.jar,aspectjrt-1.6.3.jar,aspectjweaver-1.6.3.jar,aspectjtools-1.6.3.jar,spring-aspects-2.5.6.jar,spring-agent-2.5.6.jar\r
-          </instruction>\r
-          <instruction key='zipped'>\r
-            true\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='com.ibm.icu' version='3.8.1.v20080530'>\r
-      <update id='com.ibm.icu' range='[0.0.0,3.8.1.v20080530)' severity='0'/>\r
-      <properties size='4'>\r
-        <property name='df_LT.providerName' value='IBM Corporation'/>\r
-        <property name='df_LT.pluginName' value='International Components for Unicode for Java (ICU4J)'/>\r
-        <property name='org.eclipse.equinox.p2.name' value='%pluginName'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='%providerName'/>\r
-      </properties>\r
-      <provides size='15'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='com.ibm.icu' version='3.8.1.v20080530'/>\r
-        <provided namespace='osgi.bundle' name='com.ibm.icu' version='3.8.1.v20080530'/>\r
-        <provided namespace='java.package' name='com.ibm.icu.lang' version='3.8.1'/>\r
-        <provided namespace='java.package' name='com.ibm.icu.math' version='3.8.1'/>\r
-        <provided namespace='java.package' name='com.ibm.icu.text' version='3.8.1'/>\r
-        <provided namespace='java.package' name='com.ibm.icu.util' version='3.8.1'/>\r
-        <provided namespace='java.package' name='com.ibm.icu.impl' version='0.0.0'/>\r
-        <provided namespace='java.package' name='com.ibm.icu.impl.data' version='0.0.0'/>\r
-        <provided namespace='java.package' name='com.ibm.icu.impl.data.icudt38b' version='0.0.0'/>\r
-        <provided namespace='java.package' name='com.ibm.icu.impl.data.icudt38b.brkitr' version='0.0.0'/>\r
-        <provided namespace='java.package' name='com.ibm.icu.impl.data.icudt38b.coll' version='0.0.0'/>\r
-        <provided namespace='java.package' name='com.ibm.icu.impl.data.icudt38b.rbnf' version='0.0.0'/>\r
-        <provided namespace='java.package' name='com.ibm.icu.impl.data.icudt38b.translit' version='0.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' version='1.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.localization' name='df_LT' version='1.0.0'/>\r
-      </provides>\r
-      <artifacts size='1'>\r
-        <artifact classifier='osgi.bundle' id='com.ibm.icu' version='3.8.1.v20080530'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='1'>\r
-          <instruction key='manifest'>\r
-            Bundle-RequiredExecutionEnvironment: CDC-1.0/Foundation-1.0,J2SE-1.3&#xA;Bundle-Name: %pluginName&#xA;Manifest-Version: 1.0&#xA;Bundle-Vendor: %providerName&#xA;Bundle-ClassPath: icu-jse4.jar,icu-data.jar,.&#xA;Bundle-SymbolicName: com.ibm.icu; singleton:=true&#xA;Bundle-ManifestVersion: 2&#xA;Eclipse-LazyStart: true&#xA;Bundle-Version: 3.8.1.v20080530&#xA;Bundle-Localization: plugin&#xA;Bundle-Copyright: Licensed Materials - Property of IBM (C) Copyright IBM Corp. 2000, 2008. All Rights Reserved. IBM is a registered trademark of IBM Corp.&#xA;Eclipse-ExtensibleAPI: true&#xA;Export-Package: com.ibm.icu.lang;version=&quot;3.8.1&quot;,com.ibm.icu.math;version=&quot;3.8.1&quot;,com.ibm.icu.text;version=&quot;3.8.1&quot;,com.ibm.icu.util;version=&quot;3.8.1&quot;,com.ibm.icu.impl;x-internal:=true,com.ibm.icu.impl.data;x-internal:=true,com.ibm.icu.impl.data.icudt38b;x-internal:=true,com.ibm.icu.impl.data.icudt38b.brkitr;x-internal:=true,com.ibm.icu.impl.data.icudt38b.coll;x-internal:=true,com.ibm.icu.impl.data.icudt38b.rbnf;x-internal:=true,com.ibm.icu.impl.data.icudt38b.translit;x-internal:=true\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='org.eclipse.core.filebuffers' version='3.4.0.v20080603-2000'>\r
-      <update id='org.eclipse.core.filebuffers' range='[0.0.0,3.4.0.v20080603-2000)' severity='0'/>\r
-      <properties size='4'>\r
-        <property name='df_LT.providerName' value='Eclipse.org'/>\r
-        <property name='df_LT.pluginName' value='File Buffers'/>\r
-        <property name='org.eclipse.equinox.p2.name' value='%pluginName'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='%providerName'/>\r
-      </properties>\r
-      <provides size='7'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.core.filebuffers' version='3.4.0.v20080603-2000'/>\r
-        <provided namespace='osgi.bundle' name='org.eclipse.core.filebuffers' version='3.4.0.v20080603-2000'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.filebuffers' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.filebuffers.manipulation' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.internal.filebuffers' version='0.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' version='1.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.localization' name='df_LT' version='1.0.0'/>\r
-      </provides>\r
-      <requires size='5'>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.runtime' range='[3.2.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.resources' range='[3.2.0,4.0.0)' optional='true'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.text' range='[3.4.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.filesystem' range='[1.1.0,2.0.0)'/>\r
-        <required namespace='java.package' name='com.ibm.icu.text' range='0.0.0'/>\r
-      </requires>\r
-      <artifacts size='1'>\r
-        <artifact classifier='osgi.bundle' id='org.eclipse.core.filebuffers' version='3.4.0.v20080603-2000'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='1'>\r
-          <instruction key='manifest'>\r
-            Bundle-RequiredExecutionEnvironment: J2SE-1.4&#xA;Bundle-Name: %pluginName&#xA;Bundle-Activator: org.eclipse.core.internal.filebuffers.FileBuffersPlugin&#xA;Manifest-Version: 1.0&#xA;Bundle-Vendor: %providerName&#xA;Bundle-ActivationPolicy: lazy&#xA;Bundle-SymbolicName: org.eclipse.core.filebuffers; singleton:=true&#xA;Import-Package: com.ibm.icu.text&#xA;Bundle-ManifestVersion: 2&#xA;Bundle-Version: 3.4.0.v20080603-2000&#xA;Bundle-Localization: plugin&#xA;Export-Package: org.eclipse.core.filebuffers,org.eclipse.core.filebuffers.manipulation,org.eclipse.core.internal.filebuffers;x-internal:=true&#xA;Require-Bundle: org.eclipse.core.runtime;bundle-version=&quot;[3.2.0,4.0.0)&quot;,org.eclipse.core.resources;bundle-version=&quot;[3.2.0,4.0.0)&quot;;resolution:=optional,org.eclipse.text;bundle-version=&quot;[3.4.0,4.0.0)&quot;,org.eclipse.core.filesystem;bundle-version=&quot;[1.1.0,2.0.0)&quot;\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='org.eclipse.core.resources' version='3.4.2.R34x_v20090126'>\r
-      <update id='org.eclipse.core.resources' range='[0.0.0,3.4.2.R34x_v20090126)' severity='0'/>\r
-      <properties size='4'>\r
-        <property name='df_LT.providerName' value='Eclipse.org'/>\r
-        <property name='df_LT.pluginName' value='Core Resource Management'/>\r
-        <property name='org.eclipse.equinox.p2.name' value='%pluginName'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='%providerName'/>\r
-      </properties>\r
-      <provides size='19'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.core.resources' version='3.4.2.R34x_v20090126'/>\r
-        <provided namespace='osgi.bundle' name='org.eclipse.core.resources' version='3.4.2.R34x_v20090126'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.internal.dtree' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.internal.events' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.internal.localstore' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.internal.properties' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.internal.propertytester' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.internal.refresh' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.internal.resources' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.internal.resources.mapping' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.internal.resources.refresh.win32' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.internal.utils' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.internal.watson' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.resources' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.resources.mapping' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.resources.refresh' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.resources.team' version='0.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' version='1.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.localization' name='df_LT' version='1.0.0'/>\r
-      </provides>\r
-      <requires size='4'>\r
-        <required namespace='osgi.bundle' name='org.eclipse.ant.core' range='[3.1.0,4.0.0)' optional='true'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.expressions' range='[3.1.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.filesystem' range='[1.1.0,2.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.runtime' range='[3.2.0,4.0.0)'/>\r
-      </requires>\r
-      <artifacts size='1'>\r
-        <artifact classifier='osgi.bundle' id='org.eclipse.core.resources' version='3.4.2.R34x_v20090126'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='1'>\r
-          <instruction key='manifest'>\r
-            Bundle-ManifestVersion: 2&#xA;Export-Package: org.eclipse.core.internal.dtree;x-internal:=true,org.eclipse.core.internal.events;x-internal:=true,org.eclipse.core.internal.localstore;x-internal:=true,org.eclipse.core.internal.properties;x-internal:=true,org.eclipse.core.internal.propertytester;x-internal:=true,org.eclipse.core.internal.refresh;x-internal:=true,org.eclipse.core.internal.resources;x-internal:=true,org.eclipse.core.internal.resources.mapping;x-internal:=true,org.eclipse.core.internal.resources.refresh.win32;x-internal:=true,org.eclipse.core.internal.utils;x-internal:=true,org.eclipse.core.internal.watson;x-internal:=true,org.eclipse.core.resources,org.eclipse.core.resources.mapping,org.eclipse.core.resources.refresh,org.eclipse.core.resources.team&#xA;Bundle-RequiredExecutionEnvironment: J2SE-1.4&#xA;Bundle-Localization: plugin&#xA;Require-Bundle: org.eclipse.ant.core;bundle-version=&quot;[3.1.0,4.0.0)&quot;;resolution:=optional,org.eclipse.core.expressions;bundle-version=&quot;[3.1.0,4.0.0)&quot;,org.eclipse.core.filesystem;bundle-version=&quot;[1.1.0,2.0.0)&quot;,org.eclipse.core.runtime;bundle-version=&quot;[3.2.0,4.0.0)&quot;&#xA;Bundle-Activator: org.eclipse.core.resources.ResourcesPlugin&#xA;Bundle-Name: %pluginName&#xA;Bundle-Version: 3.4.2.R34x_v20090126&#xA;Bundle-Vendor: %providerName&#xA;Bundle-SymbolicName: org.eclipse.core.resources; singleton:=true&#xA;Manifest-Version: 1.0&#xA;Eclipse-LazyStart: true\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='org.eclipse.core.databinding' version='1.1.1.M20080827-0800b' singleton='false'>\r
-      <update id='org.eclipse.core.databinding' range='[0.0.0,1.1.1.M20080827-0800b)' severity='0'/>\r
-      <properties size='4'>\r
-        <property name='df_LT.providerName' value='Eclipse.org'/>\r
-        <property name='df_LT.pluginName' value='JFace Data Binding'/>\r
-        <property name='org.eclipse.equinox.p2.name' value='%pluginName'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='%providerName'/>\r
-      </properties>\r
-      <provides size='20'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.core.databinding' version='1.1.1.M20080827-0800b'/>\r
-        <provided namespace='osgi.bundle' name='org.eclipse.core.databinding' version='1.1.1.M20080827-0800b'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.databinding' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.databinding.conversion' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.databinding.observable' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.databinding.observable.list' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.databinding.observable.map' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.databinding.observable.masterdetail' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.databinding.observable.set' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.databinding.observable.value' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.databinding.util' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.databinding.validation' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.internal.databinding' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.internal.databinding.conversion' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.internal.databinding.observable' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.internal.databinding.observable.masterdetail' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.internal.databinding.observable.tree' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.core.internal.databinding.validation' version='0.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' version='1.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.localization' name='df_LT' version='1.0.0'/>\r
-      </provides>\r
-      <requires size='5'>\r
-        <required namespace='osgi.bundle' name='org.eclipse.equinox.common' range='[3.2.0,4.0.0)'/>\r
-        <required namespace='java.package' name='com.ibm.icu.text' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.osgi.framework' range='[1.4.0,2.0.0)' optional='true'/>\r
-        <required namespace='java.package' name='org.osgi.util.tracker' range='[1.3.3,2.0.0)' optional='true'/>\r
-        <required namespace='java.package' name='org.eclipse.osgi.framework.log' range='[1.0.0,2.0.0)' optional='true'/>\r
-      </requires>\r
-      <artifacts size='1'>\r
-        <artifact classifier='osgi.bundle' id='org.eclipse.core.databinding' version='1.1.1.M20080827-0800b'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='1'>\r
-          <instruction key='manifest'>\r
-            Bundle-ManifestVersion: 2&#xA;Bundle-RequiredExecutionEnvironment: CDC-1.1/Foundation-1.1,J2SE-1.4&#xA;Bundle-ActivationPolicy: lazy&#xA;Bundle-Name: %pluginName&#xA;Bundle-ClassPath: .&#xA;Require-Bundle: org.eclipse.equinox.common;bundle-version=&quot;[3.2.0,4.0.0)&quot;&#xA;Bundle-Activator: org.eclipse.core.internal.databinding.Activator&#xA;Bundle-Vendor: %providerName&#xA;Import-Package-Comment: see http://wiki.eclipse.org/&#xA;Manifest-Version: 1.0&#xA;Bundle-Version: 1.1.1.M20080827-0800b&#xA;Bundle-Localization: plugin&#xA;Export-Package: org.eclipse.core.databinding,org.eclipse.core.databinding.conversion;x-internal:=false,org.eclipse.core.databinding.observable,org.eclipse.core.databinding.observable.list;x-internal:=false,org.eclipse.core.databinding.observable.map,org.eclipse.core.databinding.observable.masterdetail,org.eclipse.core.databinding.observable.set;x-internal:=false,org.eclipse.core.databinding.observable.value;x-internal:=false,org.eclipse.core.databinding.util,org.eclipse.core.databinding.validation;x-internal:=false,org.eclipse.core.internal.databinding;x-friends:=&quot;org.eclipse.core.databinding.beans&quot;,org.eclipse.core.internal.databinding.conversion;x-friends:=&quot;org.eclipse.jface.tests.databinding&quot;,org.eclipse.core.internal.databinding.observable;x-internal:=true,org.eclipse.core.internal.databinding.observable.masterdetail;x-friends:=&quot;org.eclipse.jface.tests.databinding&quot;,org.eclipse.core.internal.databinding.observable.tree;x-friends:=&quot;org.eclipse.jface.databinding,org.eclipse.jface.tests.databinding&quot;,org.eclipse.core.internal.databinding.validation;x-friends:=&quot;org.eclipse.jface.tests.databinding&quot;&#xA;Bundle-SymbolicName: org.eclipse.core.databinding&#xA;Import-Package: com.ibm.icu.text,org.osgi.framework;version=&quot;[1.4.0,2.0.0)&quot;;resolution:=optional,org.osgi.util.tracker;version=&quot;[1.3.3,2.0.0)&quot;;resolution:=optional,org.eclipse.osgi.framework.log;version=&quot;[1.0.0,2.0.0)&quot;;resolution:=optional\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='eu.etaxonomy.cdmLibrary.feature.jar' version='2.1.0.v20090603_1459'>\r
-      <update id='eu.etaxonomy.cdmLibrary.feature.jar' range='[0.0.0,2.1.0.v20090603_1459)' severity='0'/>\r
-      <properties size='4'>\r
-        <property name='org.eclipse.equinox.p2.name' value='CDM Library'/>\r
-        <property name='org.eclipse.equinox.p2.description' value='cdmLibrary eclipse plugin feature'/>\r
-        <property name='org.eclipse.equinox.p2.description.url' value='http://www.example.com/description'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='EDIT'/>\r
-      </properties>\r
-      <provides size='3'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='eu.etaxonomy.cdmLibrary.feature.jar' version='2.1.0.v20090603_1459'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='feature' version='1.0.0'/>\r
-        <provided namespace='org.eclipse.update.feature' name='eu.etaxonomy.cdmLibrary' version='2.1.0.v20090603_1459'/>\r
-      </provides>\r
-      <filter>\r
-        (org.eclipse.update.install.features=true)\r
-      </filter>\r
-      <artifacts size='1'>\r
-        <artifact classifier='org.eclipse.update.feature' id='eu.etaxonomy.cdmLibrary' version='2.1.0.v20090603_1459'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='1'>\r
-          <instruction key='zipped'>\r
-            true\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-      <licenses size='1'>\r
-        <license url='http://www.example.com/license'>\r
-          to be added\r
-        </license>\r
-      </licenses>\r
-      <copyright url='http://www.example.com/copyright'>\r
-        [Enter Copyright Description here.]\r
-      </copyright>\r
-    </unit>\r
-    <unit id='Cdm Library' version='0.0.0'>\r
-      <properties size='2'>\r
-        <property name='org.eclipse.equinox.p2.name' value='Cdm Library'/>\r
-        <property name='org.eclipse.equinox.p2.type.category' value='true'/>\r
-      </properties>\r
-      <provides size='1'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='Cdm Library' version='0.0.0'/>\r
-      </provides>\r
-      <requires size='1'>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='eu.etaxonomy.cdmLibrary.feature.group' range='[2.1.0.v20090603_1459,2.1.0.v20090603_1459]'/>\r
-      </requires>\r
-      <touchpoint id='null' version='0.0.0'/>\r
-    </unit>\r
-    <unit id='org.eclipse.jface.text' version='3.4.2.r342_v20081119-0800' singleton='false'>\r
-      <update id='org.eclipse.jface.text' range='[0.0.0,3.4.2.r342_v20081119-0800)' severity='0'/>\r
-      <properties size='4'>\r
-        <property name='df_LT.providerName' value='Eclipse.org'/>\r
-        <property name='df_LT.pluginName' value='JFace Text'/>\r
-        <property name='org.eclipse.equinox.p2.name' value='%pluginName'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='%providerName'/>\r
-      </properties>\r
-      <provides size='27'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.jface.text' version='3.4.2.r342_v20081119-0800'/>\r
-        <provided namespace='osgi.bundle' name='org.eclipse.jface.text' version='3.4.2.r342_v20081119-0800'/>\r
-        <provided namespace='java.package' name='org.eclipse.jface.contentassist' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.jface.contentassist.images' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.jface.internal.text' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.jface.internal.text.html' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.jface.internal.text.link.contentassist' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.jface.internal.text.revisions' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.jface.internal.text.source' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.jface.text' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.jface.text.contentassist' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.jface.text.formatter' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.jface.text.hyperlink' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.jface.text.information' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.jface.text.link' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.jface.text.presentation' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.jface.text.quickassist' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.jface.text.reconciler' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.jface.text.revisions' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.jface.text.rules' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.jface.text.source' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.jface.text.source.projection' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.jface.text.source.projection.images' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.jface.text.templates' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.jface.text.templates.persistence' version='0.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' version='1.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.localization' name='df_LT' version='1.0.0'/>\r
-      </provides>\r
-      <requires size='4'>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.runtime' range='[3.2.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.text' range='[3.4.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.jface' range='[3.4.0,4.0.0)'/>\r
-        <required namespace='java.package' name='com.ibm.icu.text' range='0.0.0'/>\r
-      </requires>\r
-      <artifacts size='1'>\r
-        <artifact classifier='osgi.bundle' id='org.eclipse.jface.text' version='3.4.2.r342_v20081119-0800'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='1'>\r
-          <instruction key='manifest'>\r
-            Bundle-Vendor: %providerName&#xA;Bundle-ManifestVersion: 2&#xA;Bundle-RequiredExecutionEnvironment: J2SE-1.4&#xA;Bundle-Localization: plugin&#xA;Bundle-Name: %pluginName&#xA;Import-Package: com.ibm.icu.text&#xA;Require-Bundle: org.eclipse.core.runtime;bundle-version=&quot;[3.2.0,4.0.0)&quot;,org.eclipse.text;bundle-version=&quot;[3.4.0,4.0.0)&quot;;visibility:=reexport,org.eclipse.jface;bundle-version=&quot;[3.4.0,4.0.0)&quot;&#xA;Manifest-Version: 1.0&#xA;Bundle-SymbolicName: org.eclipse.jface.text&#xA;Bundle-Version: 3.4.2.r342_v20081119-0800&#xA;Export-Package: org.eclipse.jface.contentassist,org.eclipse.jface.contentassist.images,org.eclipse.jface.internal.text;x-internal:=true,org.eclipse.jface.internal.text.html;x-friends:=&quot;org.eclipse.ui.workbench.texteditor, org.eclipse.ui.editors, org.eclipse.jdt.debug.ui, org.eclipse.jdt.ui, org.eclipse.ant.ui, org.eclipse.ltk.ui.refactoring&quot;,org.eclipse.jface.internal.text.link.contentassist;x-internal:=true,org.eclipse.jface.internal.text.revisions;x-internal:=true,org.eclipse.jface.internal.text.source;x-internal:=true,org.eclipse.jface.text,org.eclipse.jface.text.contentassist,org.eclipse.jface.text.formatter,org.eclipse.jface.text.hyperlink,org.eclipse.jface.text.information,org.eclipse.jface.text.link,org.eclipse.jface.text.presentation,org.eclipse.jface.text.quickassist,org.eclipse.jface.text.reconciler,org.eclipse.jface.text.revisions,org.eclipse.jface.text.rules,org.eclipse.jface.text.source,org.eclipse.jface.text.source.projection,org.eclipse.jface.text.source.projection.images,org.eclipse.jface.text.templates,org.eclipse.jface.text.templates.persistence\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='org.eclipse.ui.workbench.texteditor' version='3.4.1.r341_v20080827-1100'>\r
-      <update id='org.eclipse.ui.workbench.texteditor' range='[0.0.0,3.4.1.r341_v20080827-1100)' severity='0'/>\r
-      <properties size='4'>\r
-        <property name='df_LT.providerName' value='Eclipse.org'/>\r
-        <property name='df_LT.pluginName' value='Text Editor Framework'/>\r
-        <property name='org.eclipse.equinox.p2.name' value='%pluginName'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='%providerName'/>\r
-      </properties>\r
-      <provides size='17'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.ui.workbench.texteditor' version='3.4.1.r341_v20080827-1100'/>\r
-        <provided namespace='osgi.bundle' name='org.eclipse.ui.workbench.texteditor' version='3.4.1.r341_v20080827-1100'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.contentassist' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.texteditor' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.texteditor.quickdiff' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.texteditor.quickdiff.compare.equivalence' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.texteditor.quickdiff.compare.rangedifferencer' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.texteditor.rulers' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.internal.texteditor.spelling' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.texteditor' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.texteditor.link' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.texteditor.quickdiff' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.texteditor.rulers' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.texteditor.spelling' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.ui.texteditor.templates' version='0.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' version='1.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.localization' name='df_LT' version='1.0.0'/>\r
-      </provides>\r
-      <requires size='5'>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.runtime' range='[3.2.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.expressions' range='[3.2.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.jface.text' range='[3.4.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.ui' range='[3.4.0,4.0.0)'/>\r
-        <required namespace='java.package' name='com.ibm.icu.text' range='0.0.0'/>\r
-      </requires>\r
-      <artifacts size='1'>\r
-        <artifact classifier='osgi.bundle' id='org.eclipse.ui.workbench.texteditor' version='3.4.1.r341_v20080827-1100'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='1'>\r
-          <instruction key='manifest'>\r
-            Bundle-RequiredExecutionEnvironment: J2SE-1.4&#xA;Bundle-Name: %pluginName&#xA;Bundle-Activator: org.eclipse.ui.internal.texteditor.TextEditorPlugin&#xA;Manifest-Version: 1.0&#xA;Bundle-Vendor: %providerName&#xA;Bundle-ActivationPolicy: lazy&#xA;Bundle-SymbolicName: org.eclipse.ui.workbench.texteditor; singleton:=true&#xA;Import-Package: com.ibm.icu.text&#xA;Bundle-ManifestVersion: 2&#xA;Bundle-Version: 3.4.1.r341_v20080827-1100&#xA;Bundle-Localization: plugin&#xA;Export-Package: org.eclipse.ui.contentassist,org.eclipse.ui.internal.texteditor;x-internal:=true; texteditor=&quot;split&quot;; mandatory:=&quot;texteditor&quot;,org.eclipse.ui.internal.texteditor.quickdiff;x-internal:=true,org.eclipse.ui.internal.texteditor.quickdiff.compare.equivalence;x-internal:=true,org.eclipse.ui.internal.texteditor.quickdiff.compare.rangedifferencer;x-internal:=true,org.eclipse.ui.internal.texteditor.rulers;x-internal:=true,org.eclipse.ui.internal.texteditor.spelling;x-internal:=true,org.eclipse.ui.texteditor; texteditor=&quot;split&quot;; mandatory:=&quot;texteditor&quot;,org.eclipse.ui.texteditor.link,org.eclipse.ui.texteditor.quickdiff,org.eclipse.ui.texteditor.rulers,org.eclipse.ui.texteditor.spelling,org.eclipse.ui.texteditor.templates&#xA;Require-Bundle: org.eclipse.core.runtime;bundle-version=&quot;[3.2.0,4.0.0)&quot;,org.eclipse.core.expressions;bundle-version=&quot;[3.2.0,4.0.0)&quot;,org.eclipse.jface.text;bundle-version=&quot;[3.4.0,4.0.0)&quot;,org.eclipse.ui;bundle-version=&quot;[3.4.0,4.0.0)&quot;\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='eu.etaxonomy.taxeditor.feature.dependencies.feature.group' version='2.0.0.v20090617-1416' singleton='false'>\r
-      <update id='eu.etaxonomy.taxeditor.feature.dependencies.feature.group' range='[0.0.0,2.0.0.v20090617-1416)' severity='0'/>\r
-      <properties size='4'>\r
-        <property name='org.eclipse.equinox.p2.name' value='Taxeditor Dependencies'/>\r
-        <property name='org.eclipse.equinox.p2.description' value='[Enter Feature Description here.]'/>\r
-        <property name='org.eclipse.equinox.p2.description.url' value='http://www.example.com/description'/>\r
-        <property name='org.eclipse.equinox.p2.type.group' value='true'/>\r
-      </properties>\r
-      <provides size='1'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='eu.etaxonomy.taxeditor.feature.dependencies.feature.group' version='2.0.0.v20090617-1416'/>\r
-      </provides>\r
-      <requires size='58'>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='com.ibm.icu' range='[3.8.1.v20080530,3.8.1.v20080530]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='javax.servlet' range='[2.4.0.v200806031604,2.4.0.v200806031604]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.ant.core' range='[3.2.0.v20080529,3.2.0.v20080529]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.core.commands' range='[3.4.0.I20080509-2000,3.4.0.I20080509-2000]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.core.contenttype' range='[3.3.0.v20080604-1400,3.3.0.v20080604-1400]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.core.databinding' range='[1.1.1.M20080827-0800b,1.1.1.M20080827-0800b]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.core.databinding.beans' range='[1.1.1.M20080827-0800a,1.1.1.M20080827-0800a]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.core.expressions' range='[3.4.1.r342_v20081203-0800,3.4.1.r342_v20081203-0800]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.core.filebuffers' range='[3.4.0.v20080603-2000,3.4.0.v20080603-2000]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.core.filesystem' range='[1.2.0.v20080604-1400,1.2.0.v20080604-1400]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.core.filesystem.macosx' range='[1.0.0.v20080604-1400,1.0.0.v20080604-1400]'>\r
-          <filter>\r
-            (&amp;(osgi.os=macosx))\r
-          </filter>\r
-        </required>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.core.jobs' range='[3.4.1.R34x_v20081128,3.4.1.R34x_v20081128]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.core.net' range='[1.1.0.I20080604,1.1.0.I20080604]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.core.resources' range='[3.4.2.R34x_v20090126,3.4.2.R34x_v20090126]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.core.resources.compatibility' range='[3.4.0.v20080604-1400,3.4.0.v20080604-1400]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.core.runtime' range='[3.4.0.v20080512,3.4.0.v20080512]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.core.runtime.compatibility.auth' range='[3.2.100.v20070502,3.2.100.v20070502]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.core.runtime.compatibility.registry' range='[3.2.200.v20080610,3.2.200.v20080610]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.core.variables' range='[3.2.100.v20080529-1300,3.2.100.v20080529-1300]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.equinox.app' range='[1.1.0.v20080421-2006,1.1.0.v20080421-2006]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.equinox.common' range='[3.4.0.v20080421-2006,3.4.0.v20080421-2006]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.equinox.preferences' range='[3.2.201.R34x_v20080709,3.2.201.R34x_v20080709]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.equinox.registry' range='[3.4.0.v20080516-0950,3.4.0.v20080516-0950]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.equinox.security' range='[1.0.1.R34x_v20080721,1.0.1.R34x_v20080721]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.equinox.security.macosx' range='[1.0.0.v20080602-2000,1.0.0.v20080602-2000]'>\r
-          <filter>\r
-            (&amp;(osgi.os=macosx))\r
-          </filter>\r
-        </required>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.help' range='[3.3.102.v20081014_34x,3.3.102.v20081014_34x]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.jface' range='[3.4.2.M20090107-0800,3.4.2.M20090107-0800]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.jface.databinding' range='[1.2.1.M20080827-0800a,1.2.1.M20080827-0800a]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.jface.text' range='[3.4.2.r342_v20081119-0800,3.4.2.r342_v20081119-0800]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.osgi' range='[3.4.3.R34x_v20081215-1030,3.4.3.R34x_v20081215-1030]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.osgi.services' range='[3.1.200.v20071203,3.1.200.v20071203]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.pde.source' range='[3.4.0.v20080603,3.4.0.v20080603]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.swt' range='[3.4.2.v3452b,3.4.2.v3452b]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.swt.carbon.macosx' range='[3.4.1.v3452b,3.4.1.v3452b]'>\r
-          <filter>\r
-            (&amp;(osgi.os=macosx)(osgi.ws=carbon))\r
-          </filter>\r
-        </required>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.text' range='[3.4.0.v20080605-1800,3.4.0.v20080605-1800]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.ui' range='[3.4.2.M20090204-0800,3.4.2.M20090204-0800]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.ui.carbon' range='[4.0.0.I20080610-1200,4.0.0.I20080610-1200]'>\r
-          <filter>\r
-            (&amp;(osgi.os=macosx)(osgi.ws=carbon))\r
-          </filter>\r
-        </required>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.ui.editors' range='[3.4.0.v20080603-2000,3.4.0.v20080603-2000]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.ui.forms' range='[3.3.103.v20081027_34x,3.3.103.v20081027_34x]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.ui.ide' range='[3.4.2.M20090127-1700,3.4.2.M20090127-1700]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.ui.navigator' range='[3.3.102.M20090127-1700,3.3.102.M20090127-1700]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.ui.navigator.resources' range='[3.3.101.M20080910-0800,3.3.101.M20080910-0800]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.ui.views' range='[3.3.1.M20081112-0800,3.3.1.M20081112-0800]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.ui.views.properties.tabbed' range='[3.4.2.M20090127-1700,3.4.2.M20090127-1700]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.ui.workbench' range='[3.4.2.M20090127-1700,3.4.2.M20090127-1700]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.ui.workbench.texteditor' range='[3.4.1.r341_v20080827-1100,3.4.1.r341_v20080827-1100]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.update.configurator' range='[3.2.201.R34x_v20080819,3.2.201.R34x_v20080819]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.update.core' range='[3.2.202.R34x_v20081128,3.2.202.R34x_v20081128]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.update.ui' range='[3.2.101.R34x_v20081128,3.2.101.R34x_v20081128]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.junit4' range='[4.3.1,4.3.1]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.update.core.win32' range='[3.2.100.v20080107,3.2.100.v20080107]'>\r
-          <filter>\r
-            (&amp;(osgi.os=win32))\r
-          </filter>\r
-        </required>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.core.filesystem.win32.x86' range='[1.1.0.v20080604-1400,1.1.0.v20080604-1400]'>\r
-          <filter>\r
-            (&amp;(osgi.os=win32)(osgi.arch=x86))\r
-          </filter>\r
-        </required>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.core.net.win32.x86' range='[1.0.0.I20080521,1.0.0.I20080521]'>\r
-          <filter>\r
-            (&amp;(osgi.os=win32)(osgi.arch=x86))\r
-          </filter>\r
-        </required>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.core.resources.win32.x86' range='[3.4.0.v20071204,3.4.0.v20071204]'>\r
-          <filter>\r
-            (&amp;(osgi.os=win32)(osgi.arch=x86))\r
-          </filter>\r
-        </required>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.equinox.security.win32.x86' range='[1.0.0.v20080529-1600,1.0.0.v20080529-1600]'>\r
-          <filter>\r
-            (&amp;(osgi.os=win32)(osgi.arch=x86))\r
-          </filter>\r
-        </required>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.swt.win32.win32.x86' range='[3.4.1.v3452b,3.4.1.v3452b]'>\r
-          <filter>\r
-            (&amp;(osgi.os=win32)(osgi.arch=x86))\r
-          </filter>\r
-        </required>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.ui.win32' range='[3.2.100.v20080408-0800,3.2.100.v20080408-0800]'>\r
-          <filter>\r
-            (&amp;(osgi.os=win32))\r
-          </filter>\r
-        </required>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='eu.etaxonomy.taxeditor.feature.dependencies.feature.jar' range='[2.0.0.v20090617-1416,2.0.0.v20090617-1416]'>\r
-          <filter>\r
-            (org.eclipse.update.install.features=true)\r
-          </filter>\r
-        </required>\r
-      </requires>\r
-      <touchpoint id='null' version='0.0.0'/>\r
-      <licenses size='1'>\r
-        <license url='http://www.example.com/license'>\r
-          [Enter License Description here.]\r
-        </license>\r
-      </licenses>\r
-      <copyright url='http://www.example.com/copyright'>\r
-        [Enter Copyright Description here.]\r
-      </copyright>\r
-    </unit>\r
-    <unit id='eu.etaxonomy.taxeditor.editor' version='2.0.0.v20090617-1416'>\r
-      <update id='eu.etaxonomy.taxeditor.editor' range='[0.0.0,2.0.0.v20090617-1416)' severity='0'/>\r
-      <properties size='4'>\r
-        <property name='df_LT.Bundle-Vendor.0' value='EDIT'/>\r
-        <property name='df_LT.Bundle-Name.0' value='EDIT Taxonomic Editor - Editor Bundle'/>\r
-        <property name='org.eclipse.equinox.p2.name' value='%Bundle-Name.0'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='%Bundle-Vendor.0'/>\r
-      </properties>\r
-      <provides size='22'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='eu.etaxonomy.taxeditor.editor' version='2.0.0.v20090617-1416'/>\r
-        <provided namespace='osgi.bundle' name='eu.etaxonomy.taxeditor.editor' version='2.0.0.v20090617-1416'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.editor' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.editor.description' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.editor.description.handler' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.editor.handler' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.editor.images' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.editor.images.handler' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.editor.internal' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.editor.name' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.editor.name.handler' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.editor.reference' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.propertysheet' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.propertysheet.description' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.propertysheet.images' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.propertysheet.name' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.propertysheet.namerelations.wizard' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.propertysheet.reference' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.propertysheet.type' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.propertysheet.type.wizard' version='0.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' version='1.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.localization' name='df_LT' version='1.0.0'/>\r
-      </provides>\r
-      <requires size='16'>\r
-        <required namespace='osgi.bundle' name='org.eclipse.ui' range='3.4.1'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.runtime' range='3.4.0'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.databinding' range='1.1.1'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.databinding.beans' range='1.1.1'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.ui.editors' range='3.4.0'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.jface' range='3.4.1'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.jface.databinding' range='1.2.1'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.ui.ide' range='3.4.1'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.resources' range='3.4.1'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.filesystem' range='1.2.0'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.expressions' range='3.4.0'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.ui.forms' range='3.3.101'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.jface.text' range='3.4.1'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.ui.views.properties.tabbed' range='3.4.2'/>\r
-        <required namespace='osgi.bundle' name='eu.etaxonomy.cdmLibrary' range='2.0.0'/>\r
-        <required namespace='osgi.bundle' name='eu.etaxonomy.taxeditor.store' range='1.0.0'/>\r
-      </requires>\r
-      <artifacts size='1'>\r
-        <artifact classifier='osgi.bundle' id='eu.etaxonomy.taxeditor.editor' version='2.0.0.v20090617-1416'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='1'>\r
-          <instruction key='manifest'>\r
-            Bundle-RequiredExecutionEnvironment: J2SE-1.5&#xA;Bundle-Name: %Bundle-Name.0&#xA;Bundle-Activator: eu.etaxonomy.taxeditor.editor.internal.TaxeditorEditorPlugin&#xA;Manifest-Version: 1.0&#xA;Bundle-Vendor: %Bundle-Vendor.0&#xA;Bundle-ClassPath: .,icons/&#xA;Bundle-ActivationPolicy: lazy&#xA;Bundle-SymbolicName: eu.etaxonomy.taxeditor.editor;singleton:=true&#xA;Bundle-ManifestVersion: 2&#xA;Bundle-Version: 2.0.0.v20090617-1416&#xA;Bundle-Localization: plugin&#xA;Export-Package: eu.etaxonomy.taxeditor.editor,eu.etaxonomy.taxeditor.editor.description,eu.etaxonomy.taxeditor.editor.description.handler,eu.etaxonomy.taxeditor.editor.handler,eu.etaxonomy.taxeditor.editor.images,eu.etaxonomy.taxeditor.editor.images.handler,eu.etaxonomy.taxeditor.editor.internal,eu.etaxonomy.taxeditor.editor.name,eu.etaxonomy.taxeditor.editor.name.handler,eu.etaxonomy.taxeditor.editor.reference,eu.etaxonomy.taxeditor.propertysheet,eu.etaxonomy.taxeditor.propertysheet.description,eu.etaxonomy.taxeditor.propertysheet.images,eu.etaxonomy.taxeditor.propertysheet.name,eu.etaxonomy.taxeditor.propertysheet.namerelations.wizard,eu.etaxonomy.taxeditor.propertysheet.reference,eu.etaxonomy.taxeditor.propertysheet.type,eu.etaxonomy.taxeditor.propertysheet.type.wizard&#xA;Require-Bundle: org.eclipse.ui;bundle-version=&quot;3.4.1&quot;,org.eclipse.core.runtime;bundle-version=&quot;3.4.0&quot;,org.eclipse.core.databinding;bundle-version=&quot;1.1.1&quot;,org.eclipse.core.databinding.beans;bundle-version=&quot;1.1.1&quot;,org.eclipse.ui.editors;bundle-version=&quot;3.4.0&quot;,org.eclipse.jface;bundle-version=&quot;3.4.1&quot;,org.eclipse.jface.databinding;bundle-version=&quot;1.2.1&quot;,org.eclipse.ui.ide;bundle-version=&quot;3.4.1&quot;,org.eclipse.core.resources;bundle-version=&quot;3.4.1&quot;,org.eclipse.core.filesystem;bundle-version=&quot;1.2.0&quot;,org.eclipse.core.expressions;bundle-version=&quot;3.4.0&quot;,org.eclipse.ui.forms;bundle-version=&quot;3.3.101&quot;,org.eclipse.jface.text;bundle-version=&quot;3.4.1&quot;,org.eclipse.ui.views.properties.tabbed;bundle-version=&quot;3.4.2&quot;,eu.etaxonomy.cdmLibrary;bundle-version=&quot;2.0.0&quot;,eu.etaxonomy.taxeditor.store;bundle-version=&quot;1.0.0&quot;\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='eu.etaxonomy.taxeditor.navigation' version='2.0.0.v20090617-1416'>\r
-      <update id='eu.etaxonomy.taxeditor.navigation' range='[0.0.0,2.0.0.v20090617-1416)' severity='0'/>\r
-      <properties size='2'>\r
-        <property name='org.eclipse.equinox.p2.name' value='EDIT Taxonomic Editor - Navigation Bundle'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='EDIT'/>\r
-      </properties>\r
-      <provides size='9'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='eu.etaxonomy.taxeditor.navigation' version='2.0.0.v20090617-1416'/>\r
-        <provided namespace='osgi.bundle' name='eu.etaxonomy.taxeditor.navigation' version='2.0.0.v20090617-1416'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.navigation' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.navigation.handler' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.navigation.internal' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.navigation.navigator' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.navigation.search' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.navigation.taxonomictree' version='0.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' version='1.0.0'/>\r
-      </provides>\r
-      <requires size='14'>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.resources' range='3.4.1'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.runtime' range='3.4.0'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.ui' range='3.4.1'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.ui.navigator' range='3.3.101'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.ui.navigator.resources' range='3.3.101'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.ui.ide' range='3.4.1'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.ui.forms' range='3.3.101'/>\r
-        <required namespace='osgi.bundle' name='eu.etaxonomy.cdmLibrary' range='2.1.0'/>\r
-        <required namespace='osgi.bundle' name='eu.etaxonomy.taxeditor.store' range='1.0.0'/>\r
-        <required namespace='osgi.bundle' name='eu.etaxonomy.taxeditor.editor' range='1.0.0'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.databinding.beans' range='1.1.1'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.databinding' range='1.1.1'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.jface.databinding' range='1.2.1'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.expressions' range='0.0.0'/>\r
-      </requires>\r
-      <artifacts size='1'>\r
-        <artifact classifier='osgi.bundle' id='eu.etaxonomy.taxeditor.navigation' version='2.0.0.v20090617-1416'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='1'>\r
-          <instruction key='manifest'>\r
-            Bundle-ManifestVersion: 2&#xA;Require-Bundle: org.eclipse.core.resources;bundle-version=&quot;3.4.1&quot;,org.eclipse.core.runtime;bundle-version=&quot;3.4.0&quot;,org.eclipse.ui;bundle-version=&quot;3.4.1&quot;,org.eclipse.ui.navigator;bundle-version=&quot;3.3.101&quot;,org.eclipse.ui.navigator.resources;bundle-version=&quot;3.3.101&quot;,org.eclipse.ui.ide;bundle-version=&quot;3.4.1&quot;,org.eclipse.ui.forms;bundle-version=&quot;3.3.101&quot;,eu.etaxonomy.cdmLibrary;bundle-version=&quot;2.1.0&quot;,eu.etaxonomy.taxeditor.store;bundle-version=&quot;1.0.0&quot;,eu.etaxonomy.taxeditor.editor;bundle-version=&quot;1.0.0&quot;,org.eclipse.core.databinding.beans;bundle-version=&quot;1.1.1&quot;,org.eclipse.core.databinding;bundle-version=&quot;1.1.1&quot;,org.eclipse.jface.databinding;bundle-version=&quot;1.2.1&quot;,org.eclipse.core.expressions&#xA;Bundle-Activator: eu.etaxonomy.taxeditor.navigation.internal.TaxeditorNavigationPlugin&#xA;Manifest-Version: 1.0&#xA;Bundle-Version: 2.0.0.v20090617-1416&#xA;Export-Package: eu.etaxonomy.taxeditor.navigation,eu.etaxonomy.taxeditor.navigation.handler,eu.etaxonomy.taxeditor.navigation.internal,eu.etaxonomy.taxeditor.navigation.navigator,eu.etaxonomy.taxeditor.navigation.search,eu.etaxonomy.taxeditor.navigation.taxonomictree&#xA;Bundle-SymbolicName: eu.etaxonomy.taxeditor.navigation;singleton:=true&#xA;Bundle-ActivationPolicy: lazy&#xA;Bundle-Name: EDIT Taxonomic Editor - Navigation Bundle&#xA;Bundle-Vendor: EDIT\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='eu.etaxonomy.taxeditor.feature.jar' version='2.0.0.v20090617-1416'>\r
-      <update id='eu.etaxonomy.taxeditor.feature.jar' range='[0.0.0,2.0.0.v20090617-1416)' severity='0'/>\r
-      <properties size='4'>\r
-        <property name='org.eclipse.equinox.p2.name' value='Taxeditor Feature'/>\r
-        <property name='org.eclipse.equinox.p2.description' value='[Enter Feature Description here.]'/>\r
-        <property name='org.eclipse.equinox.p2.description.url' value='http://www.example.com/description'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='EDIT'/>\r
-      </properties>\r
-      <provides size='3'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='eu.etaxonomy.taxeditor.feature.jar' version='2.0.0.v20090617-1416'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='feature' version='1.0.0'/>\r
-        <provided namespace='org.eclipse.update.feature' name='eu.etaxonomy.taxeditor' version='2.0.0.v20090617-1416'/>\r
-      </provides>\r
-      <filter>\r
-        (org.eclipse.update.install.features=true)\r
-      </filter>\r
-      <artifacts size='1'>\r
-        <artifact classifier='org.eclipse.update.feature' id='eu.etaxonomy.taxeditor' version='2.0.0.v20090617-1416'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='1'>\r
-          <instruction key='zipped'>\r
-            true\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-      <licenses size='1'>\r
-        <license url='http://www.example.com/license'>\r
-          [Enter License Description here.]\r
-        </license>\r
-      </licenses>\r
-      <copyright url='http://www.example.com/copyright'>\r
-        [Enter Copyright Description here.]\r
-      </copyright>\r
-    </unit>\r
-    <unit id='eu.etaxonomy.taxeditor.store' version='2.0.0.v20090617-1416'>\r
-      <update id='eu.etaxonomy.taxeditor.store' range='[0.0.0,2.0.0.v20090617-1416)' severity='0'/>\r
-      <properties size='2'>\r
-        <property name='org.eclipse.equinox.p2.name' value='EDIT Taxonomic Editor - DataStore Bundle'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='EDIT'/>\r
-      </properties>\r
-      <provides size='15'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='eu.etaxonomy.taxeditor.store' version='2.0.0.v20090617-1416'/>\r
-        <provided namespace='osgi.bundle' name='eu.etaxonomy.taxeditor.store' version='2.0.0.v20090617-1416'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.datasource' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.datasource.handler' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.datasource.view' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.datasource.wizard' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.dialogs' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.handler' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.model' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.operations' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.parser' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.preference' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.store' version='0.0.0'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor.store.internal' version='0.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' version='1.0.0'/>\r
-      </provides>\r
-      <requires size='9'>\r
-        <required namespace='osgi.bundle' name='org.eclipse.ui' range='[3.2.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.runtime' range='[3.2.0,4.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.filesystem' range='1.2.0'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.resources' range='3.4.1'/>\r
-        <required namespace='osgi.bundle' name='eu.etaxonomy.cdmLibrary' range='2.1.0'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.ui.editors' range='3.4.0'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.jface.text' range='3.4.1'/>\r
-        <required namespace='java.package' name='junit.framework' range='0.0.0'/>\r
-        <required namespace='java.package' name='org.junit' range='0.0.0'/>\r
-      </requires>\r
-      <artifacts size='1'>\r
-        <artifact classifier='osgi.bundle' id='eu.etaxonomy.taxeditor.store' version='2.0.0.v20090617-1416'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='1'>\r
-          <instruction key='manifest'>\r
-            Bundle-ManifestVersion: 2&#xA;Export-Package: eu.etaxonomy.taxeditor.datasource,eu.etaxonomy.taxeditor.datasource.handler,eu.etaxonomy.taxeditor.datasource.view,eu.etaxonomy.taxeditor.datasource.wizard,eu.etaxonomy.taxeditor.dialogs,eu.etaxonomy.taxeditor.handler,eu.etaxonomy.taxeditor.model;uses:=&quot;eu.etaxonomy.cdm.model.common,eu.etaxonomy.cdm.model.name,eu.etaxonomy.cdm.model.taxon&quot;,eu.etaxonomy.taxeditor.operations,eu.etaxonomy.taxeditor.parser,eu.etaxonomy.taxeditor.preference,eu.etaxonomy.taxeditor.store,eu.etaxonomy.taxeditor.store.internal&#xA;Bundle-RequiredExecutionEnvironment: J2SE-1.5&#xA;Require-Bundle: org.eclipse.ui;bundle-version=&quot;[3.2.0,4.0.0)&quot;,org.eclipse.core.runtime;bundle-version=&quot;[3.2.0,4.0.0)&quot;,org.eclipse.core.filesystem;bundle-version=&quot;1.2.0&quot;,org.eclipse.core.resources;bundle-version=&quot;3.4.1&quot;,eu.etaxonomy.cdmLibrary;bundle-version=&quot;2.1.0&quot;,org.eclipse.ui.editors;bundle-version=&quot;3.4.0&quot;,org.eclipse.jface.text;bundle-version=&quot;3.4.1&quot;&#xA;Bundle-Activator: eu.etaxonomy.taxeditor.store.internal.TaxeditorStorePlugin&#xA;Bundle-Name: EDIT Taxonomic Editor - DataStore Bundle&#xA;Bundle-Version: 2.0.0.v20090617-1416&#xA;Bundle-Vendor: EDIT&#xA;Bundle-SymbolicName: eu.etaxonomy.taxeditor.store;singleton:=true&#xA;Import-Package: junit.framework,org.junit&#xA;Bundle-ActivationPolicy: lazy&#xA;Manifest-Version: 1.0\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='eu.etaxonomy.taxeditor.feature.group' version='2.0.0.v20090617-1416' singleton='false'>\r
-      <update id='eu.etaxonomy.taxeditor.feature.group' range='[0.0.0,2.0.0.v20090617-1416)' severity='0'/>\r
-      <properties size='5'>\r
-        <property name='org.eclipse.equinox.p2.name' value='Taxeditor Feature'/>\r
-        <property name='org.eclipse.equinox.p2.description' value='[Enter Feature Description here.]'/>\r
-        <property name='org.eclipse.equinox.p2.description.url' value='http://www.example.com/description'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='EDIT'/>\r
-        <property name='org.eclipse.equinox.p2.type.group' value='true'/>\r
-      </properties>\r
-      <provides size='1'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='eu.etaxonomy.taxeditor.feature.group' version='2.0.0.v20090617-1416'/>\r
-      </provides>\r
-      <requires size='7'>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='eu.etaxonomy.taxeditor.feature.dependencies.feature.group' range='[2.0.0.v20090617-1416,2.0.0.v20090617-1416]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='eu.etaxonomy.cdmLibrary.feature.group' range='[2.1.0.v20090612_1250,2.1.0.v20090612_1250]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='eu.etaxonomy.taxeditor.application' range='[2.0.0.v20090617-1416,2.0.0.v20090617-1416]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='eu.etaxonomy.taxeditor.editor' range='[2.0.0.v20090617-1416,2.0.0.v20090617-1416]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='eu.etaxonomy.taxeditor.navigation' range='[2.0.0.v20090617-1416,2.0.0.v20090617-1416]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='eu.etaxonomy.taxeditor.store' range='[2.0.0.v20090617-1416,2.0.0.v20090617-1416]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='eu.etaxonomy.taxeditor.feature.jar' range='[2.0.0.v20090617-1416,2.0.0.v20090617-1416]'>\r
-          <filter>\r
-            (org.eclipse.update.install.features=true)\r
-          </filter>\r
-        </required>\r
-      </requires>\r
-      <touchpoint id='null' version='0.0.0'/>\r
-      <licenses size='1'>\r
-        <license url='http://www.example.com/license'>\r
-          [Enter License Description here.]\r
-        </license>\r
-      </licenses>\r
-      <copyright url='http://www.example.com/copyright'>\r
-        [Enter Copyright Description here.]\r
-      </copyright>\r
-    </unit>\r
-    <unit id='eu.etaxonomy.taxeditor.application' version='2.0.0.v20090617-1416'>\r
-      <update id='eu.etaxonomy.taxeditor.application' range='[0.0.0,2.0.0.v20090617-1416)' severity='0'/>\r
-      <properties size='2'>\r
-        <property name='org.eclipse.equinox.p2.name' value='EDIT Taxonomic Editor'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='EDIT'/>\r
-      </properties>\r
-      <provides size='4'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='eu.etaxonomy.taxeditor.application' version='2.0.0.v20090617-1416'/>\r
-        <provided namespace='osgi.bundle' name='eu.etaxonomy.taxeditor.application' version='2.0.0.v20090617-1416'/>\r
-        <provided namespace='java.package' name='eu.etaxonomy.taxeditor' version='0.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' version='1.0.0'/>\r
-      </provides>\r
-      <requires size='8'>\r
-        <required namespace='osgi.bundle' name='org.eclipse.ui' range='3.4.1'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.ui.ide' range='3.4.1'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.runtime' range='3.4.0'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.resources' range='3.4.1'/>\r
-        <required namespace='osgi.bundle' name='eu.etaxonomy.cdmLibrary' range='2.1.0'/>\r
-        <required namespace='osgi.bundle' name='eu.etaxonomy.taxeditor.store' range='1.0.0'/>\r
-        <required namespace='osgi.bundle' name='eu.etaxonomy.taxeditor.editor' range='1.0.0'/>\r
-        <required namespace='osgi.bundle' name='eu.etaxonomy.taxeditor.navigation' range='1.0.0'/>\r
-      </requires>\r
-      <artifacts size='1'>\r
-        <artifact classifier='osgi.bundle' id='eu.etaxonomy.taxeditor.application' version='2.0.0.v20090617-1416'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='1'>\r
-          <instruction key='manifest'>\r
-            Bundle-Vendor: EDIT&#xA;Bundle-ManifestVersion: 2&#xA;Bundle-Activator: eu.etaxonomy.taxeditor.TaxonomicEditorPlugin&#xA;Require-Bundle: org.eclipse.ui;bundle-version=&quot;3.4.1&quot;,org.eclipse.ui.ide;bundle-version=&quot;3.4.1&quot;,org.eclipse.core.runtime;bundle-version=&quot;3.4.0&quot;,org.eclipse.core.resources;bundle-version=&quot;3.4.1&quot;,eu.etaxonomy.cdmLibrary;bundle-version=&quot;2.1.0&quot;,eu.etaxonomy.taxeditor.store;bundle-version=&quot;1.0.0&quot;,eu.etaxonomy.taxeditor.editor;bundle-version=&quot;1.0.0&quot;,eu.etaxonomy.taxeditor.navigation;bundle-version=&quot;1.0.0&quot;&#xA;Bundle-Name: EDIT Taxonomic Editor&#xA;Bundle-Localization: plugin&#xA;Bundle-ActivationPolicy: lazy&#xA;Manifest-Version: 1.0&#xA;Bundle-SymbolicName: eu.etaxonomy.taxeditor.application;singleton:=true&#xA;Bundle-Version: 2.0.0.v20090617-1416&#xA;Export-Package: eu.etaxonomy.taxeditor\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='eu.etaxonomy.taxeditor.feature.dependencies.feature.jar' version='2.0.0.v20090617-1416'>\r
-      <update id='eu.etaxonomy.taxeditor.feature.dependencies.feature.jar' range='[0.0.0,2.0.0.v20090617-1416)' severity='0'/>\r
-      <properties size='3'>\r
-        <property name='org.eclipse.equinox.p2.name' value='Taxeditor Dependencies'/>\r
-        <property name='org.eclipse.equinox.p2.description' value='[Enter Feature Description here.]'/>\r
-        <property name='org.eclipse.equinox.p2.description.url' value='http://www.example.com/description'/>\r
-      </properties>\r
-      <provides size='3'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='eu.etaxonomy.taxeditor.feature.dependencies.feature.jar' version='2.0.0.v20090617-1416'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='feature' version='1.0.0'/>\r
-        <provided namespace='org.eclipse.update.feature' name='eu.etaxonomy.taxeditor.feature.dependencies' version='2.0.0.v20090617-1416'/>\r
-      </provides>\r
-      <filter>\r
-        (org.eclipse.update.install.features=true)\r
-      </filter>\r
-      <artifacts size='1'>\r
-        <artifact classifier='org.eclipse.update.feature' id='eu.etaxonomy.taxeditor.feature.dependencies' version='2.0.0.v20090617-1416'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='1'>\r
-          <instruction key='zipped'>\r
-            true\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-      <licenses size='1'>\r
-        <license url='http://www.example.com/license'>\r
-          [Enter License Description here.]\r
-        </license>\r
-      </licenses>\r
-      <copyright url='http://www.example.com/copyright'>\r
-        [Enter Copyright Description here.]\r
-      </copyright>\r
-    </unit>\r
-    <unit id='eu.etaxonomy.cdmLibrary.feature.group' version='2.1.0.v20090612_1250' singleton='false'>\r
-      <update id='eu.etaxonomy.cdmLibrary.feature.group' range='[0.0.0,2.1.0.v20090612_1250)' severity='0'/>\r
-      <properties size='5'>\r
-        <property name='org.eclipse.equinox.p2.name' value='CDM Library'/>\r
-        <property name='org.eclipse.equinox.p2.description' value='cdmLibrary eclipse plugin feature'/>\r
-        <property name='org.eclipse.equinox.p2.description.url' value='http://www.example.com/description'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='EDIT'/>\r
-        <property name='org.eclipse.equinox.p2.type.group' value='true'/>\r
-      </properties>\r
-      <provides size='1'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='eu.etaxonomy.cdmLibrary.feature.group' version='2.1.0.v20090612_1250'/>\r
-      </provides>\r
-      <requires size='2'>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='eu.etaxonomy.cdmLibrary' range='[2.1.0.v20090612_1250,2.1.0.v20090612_1250]'/>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='eu.etaxonomy.cdmLibrary.feature.jar' range='[2.1.0.v20090612_1250,2.1.0.v20090612_1250]'>\r
-          <filter>\r
-            (org.eclipse.update.install.features=true)\r
-          </filter>\r
-        </required>\r
-      </requires>\r
-      <touchpoint id='null' version='0.0.0'/>\r
-      <licenses size='1'>\r
-        <license url='http://www.example.com/license'>\r
-          to be added\r
-        </license>\r
-      </licenses>\r
-      <copyright url='http://www.example.com/copyright'>\r
-        [Enter Copyright Description here.]\r
-      </copyright>\r
-    </unit>\r
-    <unit id='org.eclipse.core.filesystem.win32.x86.translated_host_properties' version='1.1.0.v20080604-1400'>\r
-      <hostRequirements size='1'>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.core.filesystem' range='[1.1.0,2.0.0)' greedy='false'/>\r
-      </hostRequirements>\r
-      <properties size='1'>\r
-        <property name='org.eclipse.equinox.p2.type.fragment' value='true'/>\r
-      </properties>\r
-      <requires size='1'>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.core.filesystem' range='[1.1.0,2.0.0)' greedy='false'/>\r
-      </requires>\r
-      <touchpoint id='null' version='0.0.0'/>\r
-    </unit>\r
-    <unit id='org.eclipse.swt.win32.win32.x86' version='3.4.1.v3452b'>\r
-      <update id='org.eclipse.swt.win32.win32.x86' range='[0.0.0,3.4.1.v3452b)' severity='0'/>\r
-      <properties size='4'>\r
-        <property name='df_LT.fragmentName' value='Standard Widget Toolkit for Windows'/>\r
-        <property name='df_LT.providerName' value='Eclipse.org'/>\r
-        <property name='org.eclipse.equinox.p2.name' value='%fragmentName'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='%providerName'/>\r
-      </properties>\r
-      <provides size='10'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.swt.win32.win32.x86' version='3.4.1.v3452b'/>\r
-        <provided namespace='osgi.bundle' name='org.eclipse.swt.win32.win32.x86' version='3.4.1.v3452b'/>\r
-        <provided namespace='java.package' name='org.eclipse.swt.ole.win32' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.swt.internal.gdip' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.swt.internal.ole.win32' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.swt.internal.win32' version='0.0.0'/>\r
-        <provided namespace='java.package' name='org.eclipse.swt.internal.opengl.win32' version='0.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' version='1.0.0'/>\r
-        <provided namespace='osgi.fragment' name='org.eclipse.swt' version='3.4.1.v3452b'/>\r
-        <provided namespace='org.eclipse.equinox.p2.localization' name='df_LT' version='1.0.0'/>\r
-      </provides>\r
-      <requires size='1'>\r
-        <required namespace='osgi.bundle' name='org.eclipse.swt' range='[3.0.0,4.0.0)'/>\r
-      </requires>\r
-      <filter>\r
-        (&amp; (osgi.ws=win32) (osgi.os=win32) (osgi.arch=x86))\r
-      </filter>\r
-      <artifacts size='1'>\r
-        <artifact classifier='osgi.bundle' id='org.eclipse.swt.win32.win32.x86' version='3.4.1.v3452b'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='1'>\r
-          <instruction key='manifest'>\r
-            Bundle-Vendor: %providerName&#xA;Bundle-ManifestVersion: 2&#xA;Bundle-RequiredExecutionEnvironment: CDC-1.0/Foundation-1.0,J2SE-1.3&#xA;Bundle-Name: %fragmentName&#xA;Bundle-Localization: fragment&#xA;Manifest-Version: 1.0&#xA;Fragment-Host: org.eclipse.swt; bundle-version=&quot;[3.0.0,4.0.0)&quot;&#xA;Bundle-SymbolicName: org.eclipse.swt.win32.win32.x86; singleton:=true&#xA;Bundle-Version: 3.4.1.v3452b&#xA;Export-Package: org.eclipse.swt.ole.win32,org.eclipse.swt.internal.gdip; x-internal:=true,org.eclipse.swt.internal.ole.win32; x-internal:=true,org.eclipse.swt.internal.win32; x-internal:=true,org.eclipse.swt.internal.opengl.win32; x-internal:=true&#xA;Eclipse-PlatformFilter: (&amp; (osgi.ws=win32) (osgi.os=win32) (osgi.arch=x86))\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='org.eclipse.update.core.win32' version='3.2.100.v20080107' singleton='false'>\r
-      <update id='org.eclipse.update.core.win32' range='[0.0.0,3.2.100.v20080107)' severity='0'/>\r
-      <properties size='2'>\r
-        <property name='org.eclipse.equinox.p2.name' value='%fragmentNameWin'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='%providerName'/>\r
-      </properties>\r
-      <provides size='4'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.update.core.win32' version='3.2.100.v20080107'/>\r
-        <provided namespace='osgi.bundle' name='org.eclipse.update.core.win32' version='3.2.100.v20080107'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' version='1.0.0'/>\r
-        <provided namespace='osgi.fragment' name='org.eclipse.update.core' version='3.2.100.v20080107'/>\r
-      </provides>\r
-      <requires size='1'>\r
-        <required namespace='osgi.bundle' name='org.eclipse.update.core' range='[3.0.0,4.0.0)'/>\r
-      </requires>\r
-      <filter>\r
-        (osgi.os=win32)\r
-      </filter>\r
-      <artifacts size='1'>\r
-        <artifact classifier='osgi.bundle' id='org.eclipse.update.core.win32' version='3.2.100.v20080107'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='1'>\r
-          <instruction key='manifest'>\r
-            Bundle-ManifestVersion: 2&#xA;Bundle-Name: %fragmentNameWin&#xA;Bundle-Version: 3.2.100.v20080107&#xA;Fragment-Host: org.eclipse.update.core;bundle-version=&quot;[3.0.0,4.0.0)&quot;&#xA;Eclipse-PlatformFilter: (osgi.os=win32)&#xA;Bundle-SymbolicName: org.eclipse.update.core.win32&#xA;Bundle-Localization: plugin&#xA;Manifest-Version: 1.0&#xA;Bundle-Vendor: %providerName\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='org.eclipse.core.filesystem.win32.x86' version='1.1.0.v20080604-1400'>\r
-      <update id='org.eclipse.core.filesystem.win32.x86' range='[0.0.0,1.1.0.v20080604-1400)' severity='0'/>\r
-      <properties size='4'>\r
-        <property name='df_LT.fragmentName' value='Core File System for Windows'/>\r
-        <property name='df_LT.providerName' value='Eclipse.org'/>\r
-        <property name='org.eclipse.equinox.p2.name' value='%fragmentName'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='%providerName'/>\r
-      </properties>\r
-      <provides size='5'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.core.filesystem.win32.x86' version='1.1.0.v20080604-1400'/>\r
-        <provided namespace='osgi.bundle' name='org.eclipse.core.filesystem.win32.x86' version='1.1.0.v20080604-1400'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' version='1.0.0'/>\r
-        <provided namespace='osgi.fragment' name='org.eclipse.core.filesystem' version='1.1.0.v20080604-1400'/>\r
-        <provided namespace='org.eclipse.equinox.p2.localization' name='df_LT' version='1.0.0'/>\r
-      </provides>\r
-      <requires size='1'>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.filesystem' range='[1.1.0,2.0.0)'/>\r
-      </requires>\r
-      <filter>\r
-        (&amp; (osgi.os=win32) (osgi.arch=x86))\r
-      </filter>\r
-      <artifacts size='1'>\r
-        <artifact classifier='osgi.bundle' id='org.eclipse.core.filesystem.win32.x86' version='1.1.0.v20080604-1400'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='1'>\r
-          <instruction key='manifest'>\r
-            Bundle-ManifestVersion: 2&#xA;Bundle-Name: %fragmentName&#xA;Bundle-Version: 1.1.0.v20080604-1400&#xA;Fragment-Host: org.eclipse.core.filesystem;bundle-version=&quot;[1.1.0,2.0.0)&quot;&#xA;Eclipse-PlatformFilter: (&amp; (osgi.os=win32) (osgi.arch=x86))&#xA;Bundle-SymbolicName: org.eclipse.core.filesystem.win32.x86; singleton:=true&#xA;Bundle-Localization: fragment&#xA;Manifest-Version: 1.0&#xA;Bundle-Vendor: %providerName\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='org.eclipse.equinox.security.win32.x86.translated_host_properties' version='1.0.0.v20080529-1600'>\r
-      <hostRequirements size='1'>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.equinox.security' range='[1.0.0,2.0.0)' greedy='false'/>\r
-      </hostRequirements>\r
-      <properties size='1'>\r
-        <property name='org.eclipse.equinox.p2.type.fragment' value='true'/>\r
-      </properties>\r
-      <requires size='1'>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.equinox.security' range='[1.0.0,2.0.0)' greedy='false'/>\r
-      </requires>\r
-      <touchpoint id='null' version='0.0.0'/>\r
-    </unit>\r
-    <unit id='org.eclipse.ui.win32.translated_host_properties' version='3.2.100.v20080408-0800'>\r
-      <hostRequirements size='1'>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.ui.ide' range='[3.2.0,4.0.0)' greedy='false'/>\r
-      </hostRequirements>\r
-      <properties size='1'>\r
-        <property name='org.eclipse.equinox.p2.type.fragment' value='true'/>\r
-      </properties>\r
-      <requires size='1'>\r
-        <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.ui.ide' range='[3.2.0,4.0.0)' greedy='false'/>\r
-      </requires>\r
-      <touchpoint id='null' version='0.0.0'/>\r
-    </unit>\r
-    <unit id='org.eclipse.core.net.win32.x86' version='1.0.0.I20080521'>\r
-      <update id='org.eclipse.core.net.win32.x86' range='[0.0.0,1.0.0.I20080521)' severity='0'/>\r
-      <properties size='4'>\r
-        <property name='df_LT.fragmentName' value='Proxy for Windows'/>\r
-        <property name='df_LT.providerName' value='Eclipse.org'/>\r
-        <property name='org.eclipse.equinox.p2.name' value='%fragmentName'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='%providerName'/>\r
-      </properties>\r
-      <provides size='5'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.core.net.win32.x86' version='1.0.0.I20080521'/>\r
-        <provided namespace='osgi.bundle' name='org.eclipse.core.net.win32.x86' version='1.0.0.I20080521'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' version='1.0.0'/>\r
-        <provided namespace='osgi.fragment' name='org.eclipse.core.net' version='1.0.0.I20080521'/>\r
-        <provided namespace='org.eclipse.equinox.p2.localization' name='df_LT' version='1.0.0'/>\r
-      </provides>\r
-      <requires size='1'>\r
-        <required namespace='osgi.bundle' name='org.eclipse.core.net' range='1.1.0'/>\r
-      </requires>\r
-      <filter>\r
-        (&amp; (osgi.os=win32) (osgi.arch=x86))\r
-      </filter>\r
-      <artifacts size='1'>\r
-        <artifact classifier='osgi.bundle' id='org.eclipse.core.net.win32.x86' version='1.0.0.I20080521'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='1'>\r
-          <instruction key='manifest'>\r
-            Bundle-ManifestVersion: 2&#xA;Fragment-Host: org.eclipse.core.net;bundle-version=&quot;1.1.0&quot;&#xA;Bundle-RequiredExecutionEnvironment: J2SE-1.4&#xA;Manifest-Version: 1.0&#xA;Bundle-Version: 1.0.0.I20080521&#xA;Eclipse-PlatformFilter: (&amp; (osgi.os=win32) (osgi.arch=x86))&#xA;Bundle-SymbolicName: org.eclipse.core.net.win32.x86;singleton:=true&#xA;Bundle-Localization: fragment&#xA;Bundle-Name: %fragmentName&#xA;Bundle-Vendor: %providerName\r
-          </instruction>\r
-        </instructions>\r
-      </touchpointData>\r
-    </unit>\r
-    <unit id='org.eclipse.equinox.security.win32.x86' version='1.0.0.v20080529-1600'>\r
-      <update id='org.eclipse.equinox.security.win32.x86' range='[0.0.0,1.0.0.v20080529-1600)' severity='0'/>\r
-      <properties size='4'>\r
-        <property name='df_LT.fragmentName' value='Windows Data Protection services integration'/>\r
-        <property name='df_LT.providerName' value='Eclipse.org'/>\r
-        <property name='org.eclipse.equinox.p2.name' value='%fragmentName'/>\r
-        <property name='org.eclipse.equinox.p2.provider' value='%providerName'/>\r
-      </properties>\r
-      <provides size='6'>\r
-        <provided namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.equinox.security.win32.x86' version='1.0.0.v20080529-1600'/>\r
-        <provided namespace='osgi.bundle' name='org.eclipse.equinox.security.win32.x86' version='1.0.0.v20080529-1600'/>\r
-        <provided namespace='java.package' name='org.eclipse.equinox.internal.security.win32' version='0.0.0'/>\r
-        <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' version='1.0.0'/>\r
-        <provided namespace='osgi.fragment' name='org.eclipse.equinox.security' version='1.0.0.v20080529-1600'/>\r
-        <provided namespace='org.eclipse.equinox.p2.localization' name='df_LT' version='1.0.0'/>\r
-      </provides>\r
-      <requires size='2'>\r
-        <required namespace='osgi.bundle' name='org.eclipse.equinox.security' range='[1.0.0,2.0.0)'/>\r
-        <required namespace='osgi.bundle' name='org.eclipse.swt' range='[3.4.0,4.0.0)' optional='true'/>\r
-      </requires>\r
-      <filter>\r
-        (&amp; (osgi.os=win32) (osgi.arch=x86))\r
-      </filter>\r
-      <artifacts size='1'>\r
-        <artifact classifier='osgi.bundle' id='org.eclipse.equinox.security.win32.x86' version='1.0.0.v20080529-1600'/>\r
-      </artifacts>\r
-      <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>\r
-      <touchpointData size='1'>\r
-        <instructions size='1'>\r
-          <instruction key='manifest'>\r
-            Bundle-ManifestVersion: 2&#xA;Export-Package: org.eclipse.equinox.internal.security.win32;x-internal:=true&#xA;Bundle-RequiredExecutionEnvironment: J2SE-1.4&#xA;Bundle-Localization: fragment&#xA;Require-Bundle: org.eclipse.swt;bundle-version=&quot;[3.4.0,4.0.0)&quot;;resolution:=optional&#xA;Eclipse-PlatformFilter: (&amp; (osgi.