Merge branch 'hotfix/5.28.1'
[taxeditor.git] / eu.etaxonomy.taxeditor.cdmlib / pom.xml
1 <?xml version="1.0" encoding="UTF-8"?>
2 <project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
3 xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
4 <parent>
5 <groupId>eu.etaxonomy</groupId>
6 <artifactId>taxeditor-parent</artifactId>
7 <version>5.28.1</version>
8 </parent>
9 <modelVersion>4.0.0</modelVersion>
10 <artifactId>eu.etaxonomy.taxeditor.cdmlib</artifactId>
11 <packaging>eclipse-plugin</packaging>
12 <properties>
13 <jackson.version>2.11.2</jackson.version>
14 <poi.version>4.1.2</poi.version>
15 <hibernate.version>5.1.17.Final</hibernate.version>
16 </properties>
17 <name>CDM Library Dependencies Plugin</name>
18 <description>CDM Library and dependencies as a plugin</description>
19 <build>
20 <pluginManagement>
21 <plugins>
22 <plugin>
23 <groupId>org.apache.maven.plugins</groupId>
24 <artifactId>maven-surefire-plugin</artifactId>
25 <version>2.22.2</version>
26 </plugin>
27 </plugins>
28 </pluginManagement>
29 <plugins>
30 <plugin>
31 <groupId>org.apache.maven.plugins</groupId>
32 <artifactId>maven-dependency-plugin</artifactId>
33 <version>2.4</version>
34 <executions>
35 <execution>
36 <id>copy-dependencies</id>
37 <phase>validate</phase>
38 <goals>
39 <goal>copy-dependencies</goal>
40 </goals>
41 <configuration>
42 <excludeArtifactIds>
43 cdmlib-remote-webapp
44 </excludeArtifactIds>
45 <includeArtifactIds>
46 cdmlib-commons,cdmlib-model,cdmlib-persistence,cdmlib-services,cdmlib-cache,cdmlib-ext,cdmlib-io
47 </includeArtifactIds>
48 <outputDirectory>${basedir}/lib</outputDirectory>
49 <overWriteReleases>true</overWriteReleases>
50 <overWriteSnapshots>true</overWriteSnapshots>
51 <excludeTransitive>true</excludeTransitive>
52 </configuration>
53 </execution>
54 <execution>
55 <id>copy-dependency-jars</id>
56 <phase>validate</phase>
57 <goals>
58 <goal>copy-dependencies</goal>
59 </goals>
60 <configuration>
61 <includeArtifactIds>
62 httpclient,JavaAPIforKml,iiif-apis,commons-beanutils,commons-lang3,commons-lang,commons-codec,
63 commons-imaging,jackson-databind,jackson-annotations,jackson-core,jboss-logging,
64 validation-api,classmate,javax.el-api,slf4j-api,slf4j-log4j12,
65 ehcache,
66 hibernate-validator,
67 spring-context,spring-context-support,spring-aspects,spring-test,spring-beans,
68 spring-tx,spring-web,spring-core,spring-aop,spring-expression,spring-orm,
69 spring-oxm,spring-jdbc,spring-security-config,spring-security-core,
70 aopalliance,aspectjweaver,aspectjrt,
71 hibernate-jpa-2.1-api,javassist,hibernate-commons-annotations,
72 hibernate-core,hibernate-entitymanager,hibernate-envers,antlr,cglib-nodep,
73 xml-apis,lsid-client,jdom,jdom2,
74 poi,poi-ooxml,poi-ooxml-schemas,xmlbeans,commons-collections4,commons-math3,
75 c3p0,mchange-commons-java,
76 opencsv,joda-time,usertype.jodatime,usertype.spi,
77 apache-log4j-extras,
78 h2,mysql-connector-java,postgresql,
79 junit,hamcrest-core,commons-dbcp,commons-pool,
80 jboss-transaction-api_1.2_spec
81 </includeArtifactIds>
82 <outputDirectory>
83 ${basedir}/lib
84 </outputDirectory>
85 <overWriteReleases>true</overWriteReleases>
86 <overWriteSnapshots>true</overWriteSnapshots>
87 <excludeTransitive>true</excludeTransitive>
88 </configuration>
89 </execution>
90 <execution>
91 <id>copy-dependency-jars-transitive</id>
92 <phase>validate</phase>
93 <goals>
94 <goal>copy-dependencies</goal>
95 </goals>
96 <configuration>
97 <includeArtifactIds>
98 httpclient-cache,httpcore,xercesImpl
99 </includeArtifactIds>
100 <outputDirectory>
101 ${basedir}/lib
102 </outputDirectory>
103 <overWriteReleases>true</overWriteReleases>
104 <overWriteSnapshots>true</overWriteSnapshots>
105 <excludeTransitive>false</excludeTransitive>
106 </configuration>
107 </execution>
108 </executions>
109 </plugin>
110 <plugin>
111 <groupId>org.apache.maven.plugins</groupId>
112 <artifactId>maven-antrun-plugin</artifactId>
113 <executions>
114 <execution>
115 <id>update-snapshot-jar-names</id>
116 <phase>validate</phase>
117 <goals>
118 <goal>run</goal>
119 </goals>
120 <configuration>
121 <target>
122 <echo>Update cdmlib jars to SNAPSHOT when build with
123 timestamp
124 </echo>
125 <move todir="./lib">
126 <fileset dir="./lib" />
127 <mapper type="regexp"
128 from="(^cdmlib\-.*\-\d+\.\d+\.\d+\-)[\d.-]+(\.jar)"
129 to="\1SNAPSHOT\2" />
130 </move>
131 <move todir="./lib">
132 <fileset dir="./lib" />
133 <mapper type="regexp"
134 from="(^cdmlib\-.*\-\d+\.\d+\.\d+\-)[\d.-]+(\-sources\.jar)"
135 to="\1SNAPSHOT\2" />
136 </move>
137 </target>
138 </configuration>
139 </execution>
140 <execution>
141 <id>remove-existing-jars</id>
142 <phase>clean</phase>
143 <goals>
144 <goal>run</goal>
145 </goals>
146 <configuration>
147 <target>
148 <echo>Remove all cdmlib jars</echo>
149 <delete>
150 <fileset dir="./lib" includes="cdmlib-*" />
151 </delete>
152 </target>
153 </configuration>
154 </execution>
155 </executions>
156 </plugin>
157 </plugins>
158 </build>
159 <profiles>
160 <profile>
161 <id>copyAllJars</id>
162 <build>
163 <plugins>
164 <plugin>
165 <groupId>org.apache.maven.plugins</groupId>
166 <artifactId>maven-dependency-plugin</artifactId>
167 <version>2.4</version>
168 <executions>
169 <execution>
170 <id>copy-all-dependencies</id>
171 <phase>validate</phase>
172 <goals>
173 <goal>copy-dependencies</goal>
174 </goals>
175 <configuration>
176 <excludeArtifactIds>
177 cdmlib-remote-webapp
178 </excludeArtifactIds>
179 <outputDirectory>${basedir}/lib</outputDirectory>
180 <overWriteReleases>true</overWriteReleases>
181 <overWriteSnapshots>true</overWriteSnapshots>
182 <excludeTransitive>true</excludeTransitive>
183 </configuration>
184 </execution>
185 </executions>
186 </plugin>
187 </plugins>
188 </build>
189 </profile>
190 </profiles>
191 <repositories>
192 <repository>
193 <id>SpringSource Enterprise Bundle Repository - External Bundle
194 Milestones
195 </id>
196 <url>http://repository.springsource.com/maven/bundles/milestone
197 </url>
198 </repository>
199 <repository>
200 <id>SpringSource Enterprise Bundle Repository - SpringSource
201 Bundle
202 Releases
203 </id>
204 <url>http://repository.springsource.com/maven/bundles/release
205 </url>
206 </repository>
207 <repository>
208 <id>SpringSource Enterprise Bundle Repository - External Bundle
209 Releases
210 </id>
211 <url>http://repository.springsource.com/maven/bundles/external
212 </url>
213 </repository>
214 <repository>
215 <id>repository.springsource.release</id>
216 <name>SpringSource GA Repository</name>
217 <url>https://repo.springsource.org/release</url>
218 </repository>
219 </repositories>
220 <dependencies>
221 <dependency>
222 <groupId>eu.etaxonomy</groupId>
223 <artifactId>cdmlib-commons</artifactId>
224 <version>${cdmlib.version}</version>
225 </dependency>
226 <dependency>
227 <groupId>eu.etaxonomy</groupId>
228 <artifactId>cdmlib-model</artifactId>
229 <version>${cdmlib.version}</version>
230 </dependency>
231 <dependency>
232 <groupId>eu.etaxonomy</groupId>
233 <artifactId>cdmlib-persistence</artifactId>
234 <version>${cdmlib.version}</version>
235 </dependency>
236 <dependency>
237 <groupId>eu.etaxonomy</groupId>
238 <artifactId>cdmlib-services</artifactId>
239 <version>${cdmlib.version}</version>
240 </dependency>
241 <dependency>
242 <groupId>eu.etaxonomy</groupId>
243 <artifactId>cdmlib-io</artifactId>
244 <version>${cdmlib.version}</version>
245 </dependency>
246 <dependency>
247 <groupId>eu.etaxonomy</groupId>
248 <artifactId>cdmlib-ext</artifactId>
249 <version>${cdmlib.version}</version>
250 </dependency>
251 <dependency>
252 <groupId>eu.etaxonomy</groupId>
253 <artifactId>cdmlib-cache</artifactId>
254 <version>${cdmlib.version}</version>
255 </dependency>
256 <!-- required -->
257 <dependency>
258 <groupId>net.sf.ehcache</groupId>
259 <artifactId>ehcache</artifactId>
260 <version>2.10.6</version>
261 </dependency>
262
263 <!-- needed, but should try to remove -->
264 <dependency>
265 <!-- see #9205 for how to remove -->
266 <groupId>log4j</groupId>
267 <artifactId>apache-log4j-extras</artifactId>
268 <version>1.2.17</version>
269 </dependency>
270 <dependency>
271 <!-- somehow this is required for logging, covered by tests, but maybe can be removed somehow -->
272 <groupId>org.jboss.spec.javax.transaction</groupId>
273 <artifactId>jboss-transaction-api_1.2_spec</artifactId>
274 <version>1.1.1.Final</version>
275 </dependency>
276
277 <dependency>
278 <groupId>log4j</groupId>
279 <artifactId>log4j</artifactId>
280 <version>1.2.17</version>
281 </dependency>
282 <dependency>
283 <groupId>joda-time</groupId>
284 <artifactId>joda-time</artifactId>
285 <version>2.10.6</version>
286 </dependency>
287 <dependency>
288 <groupId>org.jadira.usertype</groupId>
289 <artifactId>usertype.jodatime</artifactId>
290 <version>2.0.1</version>
291 </dependency>
292 <dependency>
293 <groupId>org.jadira.usertype</groupId>
294 <artifactId>usertype.spi</artifactId>
295 <version>2.0.1</version>
296 </dependency>
297 <dependency>
298 <!-- needed? -->
299 <groupId>org.jdom</groupId>
300 <artifactId>jdom2</artifactId>
301 <version>2.0.6</version>
302 </dependency>
303 <dependency>
304 <!-- needed? -->
305 <groupId>org.jdom</groupId>
306 <artifactId>jdom</artifactId>
307 <version>1.1.3</version>
308 </dependency>
309 <dependency>
310 <groupId>org.springframework</groupId>
311 <artifactId>spring-context</artifactId>
312 <version>4.3.28.RELEASE</version>
313 </dependency>
314 <dependency>
315 <groupId>org.springframework</groupId>
316 <artifactId>spring-context-support</artifactId>
317 <version>4.3.28.RELEASE</version>
318 </dependency>
319 <dependency>
320 <groupId>org.springframework</groupId>
321 <artifactId>spring-aspects</artifactId>
322 <version>4.3.28.RELEASE</version>
323 </dependency>
324 <dependency>
325 <groupId>org.springframework</groupId>
326 <artifactId>spring-test</artifactId>
327 <version>4.3.28.RELEASE</version>
328 </dependency>
329 <dependency>
330 <groupId>org.springframework</groupId>
331 <artifactId>spring-beans</artifactId>
332 <version>4.3.28.RELEASE</version>
333 </dependency>
334 <dependency>
335 <groupId>org.springframework</groupId>
336 <artifactId>spring-tx</artifactId>
337 <version>4.3.28.RELEASE</version>
338 </dependency>
339 <dependency>
340 <groupId>org.springframework</groupId>
341 <artifactId>spring-web</artifactId>
342 <version>4.3.28.RELEASE</version>
343 </dependency>
344 <dependency>
345 <groupId>org.springframework</groupId>
346 <artifactId>spring-core</artifactId>
347 <version>4.3.28.RELEASE</version>
348 </dependency>
349 <dependency>
350 <groupId>org.springframework</groupId>
351 <artifactId>spring-aop</artifactId>
352 <version>4.3.28.RELEASE</version>
353 </dependency>
354 <dependency>
355 <groupId>org.springframework</groupId>
356 <artifactId>spring-expression</artifactId>
357 <version>4.3.28.RELEASE</version>
358 </dependency>
359 <dependency>
360 <groupId>org.springframework</groupId>
361 <artifactId>spring-orm</artifactId>
362 <version>4.3.28.RELEASE</version>
363 </dependency>
364 <dependency>
365 <groupId>org.springframework</groupId>
366 <artifactId>spring-oxm</artifactId>
367 <version>4.3.28.RELEASE</version>
368 </dependency>
369 <dependency>
370 <groupId>org.springframework</groupId>
371 <artifactId>spring-jdbc</artifactId>
372 <version>4.3.28.RELEASE</version>
373 </dependency>
374 <dependency>
375 <groupId>org.springframework.security</groupId>
376 <artifactId>spring-security-core</artifactId>
377 <version>4.2.18.RELEASE</version>
378 </dependency>
379 <dependency>
380 <groupId>org.springframework.security</groupId>
381 <artifactId>spring-security-config</artifactId>
382 <version>4.2.18.RELEASE</version>
383 </dependency>
384 <dependency>
385 <groupId>org.springframework.security</groupId>
386 <artifactId>spring-security-remoting</artifactId>
387 <version>4.2.18.RELEASE</version>
388 </dependency>
389 <dependency>
390 <!-- dependency of spring security core, can be removed after
391 upgrading to spring security 5.x -->
392 <groupId>aopalliance</groupId>
393 <artifactId>aopalliance</artifactId>
394 <version>1.0</version>
395 </dependency>
396
397 <dependency>
398 <groupId>commons-beanutils</groupId>
399 <artifactId>commons-beanutils</artifactId>
400 <version>1.9.4</version>
401 </dependency>
402 <dependency>
403 <groupId>org.apache.commons</groupId>
404 <artifactId>commons-imaging</artifactId>
405 <version>1.0-alpha2</version>
406 </dependency>
407 <dependency>
408 <groupId>net.sf.opencsv</groupId>
409 <artifactId>opencsv</artifactId>
410 <version>2.3</version>
411 </dependency>
412
413 <dependency>
414 <groupId>org.apache.httpcomponents</groupId>
415 <artifactId>httpclient</artifactId>
416 </dependency>
417
418 <dependency>
419 <groupId>org.apache.commons</groupId>
420 <artifactId>commons-lang3</artifactId>
421 <version>3.11</version>
422 </dependency>
423 <dependency>
424 <!-- needed at least in taxeditor.test by BundleLoader; try to move there but test carefully -->
425 <groupId>commons-lang</groupId>
426 <artifactId>commons-lang</artifactId>
427 <version>2.6</version>
428 </dependency>
429
430 <!-- jackson, not sure if really needed -->
431 <dependency>
432 <groupId>com.fasterxml.jackson.core</groupId>
433 <artifactId>jackson-databind</artifactId>
434 <version>${jackson.version}</version>
435 </dependency>
436 <dependency>
437 <groupId>com.fasterxml.jackson.core</groupId>
438 <artifactId>jackson-core</artifactId>
439 <version>${jackson.version}</version>
440 </dependency>
441 <dependency>
442 <groupId>com.fasterxml.jackson.core</groupId>
443 <artifactId>jackson-annotations</artifactId>
444 <version>${jackson.version}</version>
445 </dependency>
446
447 <dependency>
448 <!-- needed? -->
449 <groupId>xerces</groupId>
450 <artifactId>xercesImpl</artifactId>
451 <version>2.12.0</version>
452 </dependency>
453
454 <dependency>
455 <groupId>org.aspectj</groupId>
456 <artifactId>aspectjweaver</artifactId>
457 <version>1.9.6</version>
458 </dependency>
459 <dependency>
460 <groupId>org.aspectj</groupId>
461 <artifactId>aspectjrt</artifactId>
462 <version>1.9.6</version>
463 </dependency>
464 <dependency>
465 <groupId>org.hibernate.javax.persistence</groupId>
466 <artifactId>hibernate-jpa-2.1-api</artifactId>
467 <version>1.0.2.Final</version>
468 </dependency>
469 <dependency>
470 <groupId>org.javassist</groupId>
471 <artifactId>javassist</artifactId>
472 <version>3.27.0-GA</version>
473 </dependency>
474 <dependency>
475 <groupId>org.hibernate.common</groupId>
476 <artifactId>hibernate-commons-annotations</artifactId>
477 <version>5.1.0.Final</version>
478 </dependency>
479 <dependency>
480 <groupId>xml-apis</groupId>
481 <artifactId>xml-apis</artifactId>
482 <version>1.4.01</version>
483 </dependency>
484 <dependency>
485 <groupId>com.ibm.lsid</groupId>
486 <artifactId>lsid-client</artifactId>
487 <version>1.1.2</version>
488 </dependency>
489
490 <!-- poi -->
491 <!-- needed -->
492 <dependency>
493 <groupId>org.apache.poi</groupId>
494 <artifactId>poi</artifactId>
495 <version>${poi.version}</version>
496 </dependency>
497 <dependency>
498 <groupId>org.apache.poi</groupId>
499 <artifactId>poi-ooxml-schemas</artifactId>
500 <version>${poi.version}</version>
501 </dependency>
502 <dependency>
503 <groupId>org.apache.poi</groupId>
504 <artifactId>poi-ooxml</artifactId>
505 <version>${poi.version}</version>
506 </dependency>
507 <dependency>
508 <groupId>org.apache.xmlbeans</groupId>
509 <artifactId>xmlbeans</artifactId>
510 <version>3.1.0</version>
511 </dependency>
512 <dependency>
513 <groupId>org.apache.commons</groupId>
514 <artifactId>commons-collections4</artifactId>
515 <version>4.4</version>
516 </dependency>
517 <dependency>
518 <groupId>org.apache.commons</groupId>
519 <artifactId>commons-math3</artifactId>
520 <version>3.6.1</version>
521 </dependency>
522 <!-- not yet included
523 poi: com.zaxxer:SparseBitSet
524 poi-ooxml commons-compress,curvesapi
525 -->
526 <!-- logging -->
527 <dependency>
528 <!-- needed? -->
529 <groupId>org.jboss.logging</groupId>
530 <artifactId>jboss-logging</artifactId>
531 <version>3.4.1.Final</version>
532 </dependency>
533 <dependency>
534 <groupId>org.slf4j</groupId>
535 <artifactId>slf4j-api</artifactId>
536 <version>1.7.30</version>
537 </dependency>
538 <dependency>
539 <groupId>org.slf4j</groupId>
540 <artifactId>slf4j-log4j12</artifactId>
541 <version>1.7.30</version>
542 </dependency>
543 <!-- slf4j-nop is not needed -->
544
545 <!-- validation, needed? -->
546 <dependency>
547 <groupId>org.hibernate.validator</groupId>
548 <artifactId>hibernate-validator</artifactId>
549 <version>6.1.5.Final</version>
550 </dependency>
551 <dependency>
552 <groupId>com.fasterxml</groupId>
553 <artifactId>classmate</artifactId>
554 <version>1.5.1</version>
555 </dependency>
556 <dependency>
557 <groupId>javax.el</groupId>
558 <artifactId>javax.el-api</artifactId>
559 <version>3.0.0</version>
560 </dependency>
561
562 <dependency>
563 <!-- used in AuthenticatingHttpInvokerRequestExecutor -->
564 <groupId>commons-codec</groupId>
565 <artifactId>commons-codec</artifactId>
566 <version>1.15</version>
567 </dependency>
568
569 <!-- For Unit Tests Start -->
570 <!-- keep junit and its dependency hamcrest here as long as each plugin
571 has its own unit tests and junit is not yet added there in a way
572 that it does not appear in production bundles -->
573 <dependency>
574 <groupId>junit</groupId>
575 <artifactId>junit</artifactId>
576 <version>4.13.1</version>
577 <scope>test</scope>
578 </dependency>
579 <dependency>
580 <groupId>org.hamcrest</groupId>
581 <artifactId>hamcrest-core</artifactId>
582 <version>1.3</version>
583 <!-- <scope>test</scope> -->
584 </dependency>
585
586 <!-- For Unit Tests End -->
587
588 <!-- dbcp and pool needed for H2Local and unitils,
589 move to taxeditor.webapp and taxedtior.test once all db dependencies are moved to webapp-->
590 <dependency>
591 <groupId>commons-dbcp</groupId>
592 <artifactId>commons-dbcp</artifactId>
593 <version>1.4</version>
594 </dependency>
595 <dependency>
596 <groupId>commons-pool</groupId>
597 <artifactId>commons-pool</artifactId>
598 <version>1.6</version>
599 </dependency>
600
601
602 <!-- For Hibernate Mapping Start -->
603 <dependency>
604 <groupId>javax.validation</groupId>
605 <artifactId>validation-api</artifactId>
606 <version>2.0.1.Final</version>
607 </dependency>
608 <!-- For Hibernate Mapping End -->
609
610 <!-- Hibernate -->
611 <!-- still needed because cdmlib-service still uses classes from cdmlib-persistence (e.g. OrderHint),
612 and those load classes from hibernate -->
613 <!-- all other org.hibernate dependencies have been removed already -->
614 <dependency>
615 <groupId>org.hibernate</groupId>
616 <artifactId>hibernate-core</artifactId>
617 <version>${hibernate.version}</version>
618 </dependency>
619 <dependency>
620 <groupId>org.hibernate</groupId>
621 <artifactId>hibernate-entitymanager</artifactId>
622 <version>${hibernate.version}</version>
623 </dependency>
624 <dependency>
625 <groupId>org.hibernate</groupId>
626 <artifactId>hibernate-envers</artifactId>
627 <version>${hibernate.version}</version>
628 </dependency>
629 <dependency>
630 <!-- probably only used by hibernate-core, so remove when removing hibernate-core,
631 probably it can be removed even before -->
632 <groupId>antlr</groupId>
633 <artifactId>antlr</artifactId>
634 <version>2.7.7</version>
635 </dependency>
636 <dependency>
637 <groupId>cglib</groupId>
638 <artifactId>cglib-nodep</artifactId>
639 <version>3.3.0</version>
640 </dependency>
641
642 <!-- KML/IIIF dependencies should not bee needed for the taxeditor, but at current the KMLDocumentBuilder
643 is used in the EditGeoService bean which is needed to display the distribution maps in the editor.
644 -->
645 <dependency>
646 <groupId>de.micromata.jak</groupId>
647 <artifactId>JavaAPIforKml</artifactId>
648 <version>2.2.1</version><!-- must be same version as in cdmlib -->
649 </dependency>
650 <dependency>
651 <groupId>de.digitalcollections.iiif</groupId>
652 <artifactId>iiif-apis</artifactId>
653 <version>0.3.7</version>
654 </dependency>
655
656 <!-- database related, should be moved to local/test when possible -->
657 <!-- only for supporting test button in datasource dialogue, dialogue should be moved to taxeditor.webapp -->
658 <dependency>
659 <groupId>mysql</groupId>
660 <artifactId>mysql-connector-java</artifactId>
661 <version>8.0.21</version>
662 </dependency>
663 <dependency>
664 <groupId>com.h2database</groupId>
665 <artifactId>h2</artifactId>
666 <version>1.4.190</version>
667 </dependency>
668 <dependency>
669 <groupId>org.postgresql</groupId>
670 <artifactId>postgresql</artifactId>
671 <version>42.2.18</version>
672 </dependency>
673
674 <!-- mchange dependencies, needed in datasource view dialog for finish button (ClassName is needed for datasource.xml -->
675 <dependency>
676 <groupId>com.mchange</groupId>
677 <artifactId>c3p0</artifactId>
678 <version>0.9.5.2</version>
679 <!-- <scope>test</scope> -->
680 </dependency>
681 <dependency>
682 <groupId>com.mchange</groupId>
683 <artifactId>mchange-commons-java</artifactId>
684 <!-- mchange-commons-java needs to match the version as defined in the c3p0/pom.xml -->
685 <version>0.2.11</version>
686 </dependency>
687 </dependencies>
688 </project>
689