added some site content
[taxeditor.git] / src / site / fml / troubleshooting.fml
1 <?xml version="1.0" encoding="UTF-8"?>
2 <faqs xmlns="http://maven.apache.org/FML/1.0.1"
3 xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
4 xsi:schemaLocation="http://maven.apache.org/FML/1.0.1 http://maven.apache.org/xsd/fml-1.0.1.xsd"
5 title="Troubleshooting"
6 toplink="true">
7 <part id="general">
8 <title>General</title>
9 <faq id="How_can_I_configure_logging_in_the_editor">
10 <question>How can I configure logging in the editor?</question>
11 <answer>
12 <p>To get log4j to read your own configuration when developing the editor or
13 anything that has to do with cdmLibrary eclipse plugin you have to tell
14 log4j explicitly what configuration it should use. Otherwise it will scan
15 the classpath and use the first log4j.xml/log4j.properties file it finds
16 (which is mostly the log4j.properties in cdmlib-commons as it will be the
17 first one it encounters).</p>
18 <p>Passing the following argument to the Virtual Machine however does the trick:</p>
19 <source>-Dlog4j.configuration=file:///&lt;path to your personal&gt;/log4j.properties</source>
20 <p>If you run into trouble , you can debug log4j's startup sequence by passing
21 another argument to the VM.</p>
22 <source>-Dlog4j.debug</source>
23 </answer>
24 </faq>
25 <faq id="taxeditor_projects_have_errors">
26 <question>All taxeditor projects have errors and it seems like they can't see the cdmlib dependecies.</question>
27 <answer>
28 <p>There are two possible solutions for this problem.</p>
29 <ol>
30 <li><em>cdmlib-plugin</em> does not contain the cdmlib dependencies
31 <p>Please follow the instructions on <a href="./getting-started.html#Initializing_the_cdmlib_plugin">how to initialize the cdmlib-plugin</a></p>
32 </li>
33 <li>Your classpath is outdated
34 <p>Update your classpath by right-clicking any of the <em>taxeditor-*</em> projects and choose <em>PDE Tools -&gt; Update Classpath...</em>. Click &lt;Select All&gt; in the dialog and confirm.</p>
35 </li>
36 </ol>
37 </answer>
38 </faq>
39 <faq id="Launching_the_editor_from_eclipse_is_simply_not_working">
40 <question>Launching the editor from eclipse is simply not working for me.</question>
41 <answer>
42 <p>This could be due to many reasons. Please have a look at the <a href="http://dev.e-taxonomy.eu/trac/wiki/TroubleshootingEditorLaunches">Troubleshooting Editor Launches</a> document on the developers wiki.</p>
43 </answer>
44 </faq>
45 <faq id="No_application_id_has_been_found">
46 <question>I get a "RuntimeException: No application id has been found." preceded by lots of "Missing required bundle" errors when launching my run/debug configuration</question>
47 <answer>
48 <p>Whenever you change something in the plguin dependency hirarchy, i.e. adding, (re)moving, or renaming a dependant plugin your run configuration does not know about that automatically. To solve this:</p>
49 <ul>
50 <li>In eclipse, open the <em>Run Configurations</em> wizard</li>
51 <li>Choose the run configuration in question</li>
52 <li>Select the <em>Plug-ins</em> tab</li>
53 <li>Click <em>Deselect All</em> from the buttons on the right</li>
54 <li>Click <em>Add Required Plug-ins</em></li>
55 <li>Apply your changes</li>
56 </ul>
57 <p>The editor should launch again.</p>
58 </answer>
59 </faq>
60 </part>
61 </faqs>